source: projects/specs/trunk/h/hyperestraier/hyperestraier-vl.spec @ 736

Revision 736, 5.6 KB checked in by inagaki, 14 years ago (diff)

updated: mecab, mecab-ipadic, qdbm, hyperestraier

Line 
1Summary: a full-text search system for communities
2Summary(ja): 全文検索システム
3Name: hyperestraier
4Version: 1.4.13
5Release: 3%{?_dist_release}
6License: LGPL 2.1
7URL: http://hyperestraier.sourceforge.net/index.html
8Group: Applications/Text
9Source0: http://hyperestraier.sourceforge.net/%{name}-%{version}.tar.gz
10Patch0: hyperestraier-1.4.13-perl-vendordir.patch
11
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: qdbm-devel >= 1.8.75
14BuildRequires: zlib-devel >= 1.2.1
15BuildRequires: mecab-devel >= 0.92
16BuildRequires: perl
17Requires: qdbm >= 1.8.75
18Requires: zlib >= 1.2.1
19Requires: mecab >= 0.92
20Requires: mecab-ipadic >= 2.7.0
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25Packager: inagaki
26
27%description
28Hyper Estraier is a full-text search system. You can search lots of documents
29for some documents including specified words. If you run a web site, it is
30useful as your own search engine for pages in your site. Also, it is useful
31as search utilities of mail boxes and file servers.
32
33The characteristic of Hyper Estraier is the following.
34
35    * High performance of search
36    * High scalability of target documents
37    * Perfect recall ratio by N-gram method
38    * High precision by hybrid mechanism of N-gram and morphological analyzer
39    * Phrase search, regular expressions, attribute search, and similarity search
40    * Multilingualism with Unicode
41    * Independent of file format and repository
42    * Intelligent web crawler
43    * Simple and powerful API
44    * Supporting P2P architecture
45
46Hyper Estraier is an open-source software released under the terms of the
47GNU Lesser General Public License. It works on Linux, Windows, Mac OS X,
48and other UNIX-like systems.
49
50%description -l ja
51Hyper Estraierは全文検索システムです。たくさんの文書の中から、特定の語句を含むものを探して、該当するものの一覧を表示することができます。Web サイトを運営している方なら、自分のサイト専用の検索エンジンとして利用することができます。メールボックスやファイルサーバを対象とした検索ツールとして利用することもできます。
52
53Hyper Estraierには、次のような特徴があります。
54
55    * インデックスを使った高速な検索ができます。
56    * 大量の文書のインデックスを短時間で作成できます。
57    * N-gram方式による漏れのない検索ができます。
58    * 形態素解析とN-gramのハイブリッド機構で検索精度を向上させます。
59    * フレーズ検索や正規表現検索や属性検索や類似検索をサポートします。
60    * 世界各国の言語が扱えます。
61    * 対象文書の所在や形式に依存しません。
62    * 賢いWebクローラが付属しています。
63    * ライブラリとして各種製品に組み込めます。
64    * P2P連携機能をサポートします。
65
66Hyper EstraierはGNU Lesser General Public Licenseに基づいて配布されるフリーソフトウェアです。Linux、Windows、Mac OS Xおよびその他のUNIX系OSの上で動作します。
67
68%package devel
69Summary: Header files and libraries for developing apps which will using Hyper Estraier
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72Requires: qdbm-devel >= 1.8.75
73Requires: zlib-devel >= 1.2.1
74
75%description devel
76Header files and libraries for developing apps which will using Hyper Estraier
77
78%package perl
79Summary: Perl module for Hyper Estraier
80Group: Development/Libraries
81Requires: %{name} = %{version}-%{release}
82Requires: perl
83
84%description perl
85Perl module for Hyper Estraier
86
87%prep
88%setup -q
89%patch0 -p1 -b .perlvendordir
90
91%build
92%configure \
93    --enable-stable \
94    --enable-zlib \
95    --enable-mecab
96make
97
98pushd perlnative
99%configure
100make
101popd
102
103%install
104rm -rf %{buildroot}
105%makeinstall DESTDIR=%{buildroot}
106pushd perlnative
107%makeinstall DESTDIR=%{buildroot}
108popd
109
110## delete
111rm -rf %{buildroot}/usr/share/hyperestraier/doc
112rm -rf %{buildroot}/usr/share/hyperestraier/{COPYING,ChangeLog,THANKS}
113
114## for Perl
115perllocalfile=`find %{buildroot} -name perllocal.pod`
116echo "mv $perllocalfile ."
117mv $perllocalfile .
118
119sed -e "s@^%{buildroot}@@g" < %{buildroot}%{perl_vendorarch}/auto/Estraier/.packlist \
120       > .packlist
121mv -f .packlist %{buildroot}%{perl_vendorarch}/auto/Estraier/.packlist
122
123%clean
124rm -rf %{buildroot}
125
126%check
127make check
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%files
134%defattr(-,root,root)
135%doc COPYING ChangeLog README THANKS doc example
136%{_bindir}/estbutler
137%{_bindir}/estcmd
138%{_bindir}/estconfig
139%{_bindir}/estmaster
140%{_bindir}/estwaver
141%{_bindir}/estcall
142%{_bindir}/estload
143%{_bindir}/estmttest
144%{_bindir}/estwolefind
145%{_mandir}/man1/*
146%{_libdir}/*.so.*
147%{_libexecdir}/*
148%{_datadir}/hyperestraier/*.*
149%{_datadir}/hyperestraier/filter
150%{_datadir}/hyperestraier/increm
151%{_datadir}/hyperestraier/locale
152
153%files devel
154%defattr(-,root,root)
155%{_mandir}/man3/estnode.3*
156%{_mandir}/man3/estraier.3*
157%{_libdir}/*.so
158%{_libdir}/*.a
159%{_libdir}/pkgconfig/hyperestraier.pc
160%{_includedir}/*.h
161
162%files perl
163%defattr(-,root,root)
164%doc perllocal.pod
165%{_bindir}/estcmd.pl
166%{perl_vendorarch}/Estraier.pm
167%{perl_vendorarch}/Estraier.pod
168%{perl_vendorarch}/auto/Estraier
169%{_mandir}/man3/Estraier.3pm*
170
171%changelog
172* Mon Mar 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-3
173- rebuilt with new toolchain
174
175* Sun May 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-2
176- added BR: qdbm-devel, zlib-devel to devel package
177
178* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.13-1vl5
179- applied new versioning policy, spec in utf-8
180- built with perl-5.10.0
181
182* Sat Jan 19 2008 IWAI, Masaharu <iwai@alib.jp> 1.4.13-0vl1
183- initial release
Note: See TracBrowser for help on using the repository browser.