source: projects/specs/trunk/h/hyperestraier/hyperestraier-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: a full-text search system for communities
2Summary(ja): 全文検索システム
3Name: hyperestraier
4Version: 1.4.13
5Release: 2%{?_dist_release}
6License: LGPL 2.1
7URL: http://hyperestraier.sourceforge.net/index.html
8Group: Applications/Text
9Source0: http://hyperestraier.sourceforge.net/%{name}-%{version}.tar.gz
10Patch0: hyperestraier-1.4.13-perl-vendordir.patch
11Buildroot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: qdbm-devel >= 1.8.75
13BuildRequires: zlib-devel >= 1.2.1
14BuildRequires: mecab-devel >= 0.92
15BuildRequires: perl
16Requires: qdbm >= 1.8.75
17Requires: zlib >= 1.2.1
18Requires: mecab >= 0.92
19Requires: mecab-ipadic >= 2.7.0
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24Packager: inagaki
25
26%description
27Hyper Estraier is a full-text search system. You can search lots of documents
28for some documents including specified words. If you run a web site, it is
29useful as your own search engine for pages in your site. Also, it is useful
30as search utilities of mail boxes and file servers.
31
32The characteristic of Hyper Estraier is the following.
33
34    * High performance of search
35    * High scalability of target documents
36    * Perfect recall ratio by N-gram method
37    * High precision by hybrid mechanism of N-gram and morphological analyzer
38    * Phrase search, regular expressions, attribute search, and similarity search
39    * Multilingualism with Unicode
40    * Independent of file format and repository
41    * Intelligent web crawler
42    * Simple and powerful API
43    * Supporting P2P architecture
44
45Hyper Estraier is an open-source software released under the terms of the
46GNU Lesser General Public License. It works on Linux, Windows, Mac OS X,
47and other UNIX-like systems.
48
49%description -l ja
50Hyper Estraierは全文検索システムです。たくさんの文書の中から、特定の語句を含むものを探して、該当するものの一覧を表示することができます。Web サイトを運営している方なら、自分のサイト専用の検索エンジンとして利用することができます。メールボックスやファイルサーバを対象とした検索ツールとして利用することもできます。
51
52Hyper Estraierには、次のような特徴があります。
53
54    * インデックスを使った高速な検索ができます。
55    * 大量の文書のインデックスを短時間で作成できます。
56    * N-gram方式による漏れのない検索ができます。
57    * 形態素解析とN-gramのハイブリッド機構で検索精度を向上させます。
58    * フレーズ検索や正規表現検索や属性検索や類似検索をサポートします。
59    * 世界各国の言語が扱えます。
60    * 対象文書の所在や形式に依存しません。
61    * 賢いWebクローラが付属しています。
62    * ライブラリとして各種製品に組み込めます。
63    * P2P連携機能をサポートします。
64
65Hyper EstraierはGNU Lesser General Public Licenseに基づいて配布されるフリーソフトウェアです。Linux、Windows、Mac OS Xおよびその他のUNIX系OSの上で動作します。
66
67%package devel
68Summary: Header files and libraries for developing apps which will using Hyper Estraier
69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: qdbm-devel >= 1.8.75
72Requires: zlib-devel >= 1.2.1
73
74%description devel
75Header files and libraries for developing apps which will using Hyper Estraier
76
77%package perl
78Summary: Perl module for Hyper Estraier
79Group: Development/Libraries
80Requires: %{name} = %{version}-%{release}
81Requires: perl
82
83%description perl
84Perl module for Hyper Estraier
85
86%prep
87%setup -q
88%patch0 -p1 -b .perlvendordir
89
90%build
91%configure --enable-stable --enable-zlib --enable-mecab
92make
93pushd perlnative
94%configure
95make
96popd
97
98%install
99rm -rf %{buildroot}
100%makeinstall DESTDIR=%{buildroot}
101pushd perlnative
102%makeinstall DESTDIR=%{buildroot}
103popd
104
105## delete
106rm -rf %{buildroot}/usr/share/hyperestraier/doc
107rm -rf %{buildroot}/usr/share/hyperestraier/{COPYING,ChangeLog,THANKS}
108
109## for Perl
110perllocalfile=`find %{buildroot} -name perllocal.pod`
111echo "mv $perllocalfile ."
112mv $perllocalfile .
113
114sed -e "s@^%{buildroot}@@g" < %{buildroot}%{perl_vendorarch}/auto/Estraier/.packlist \
115       > .packlist
116mv -f .packlist %{buildroot}%{perl_vendorarch}/auto/Estraier/.packlist
117
118%clean
119rm -rf %{buildroot}
120
121%check
122make check
123
124%post
125/sbin/ldconfig
126
127%postun
128/sbin/ldconfig
129
130%files
131%defattr(-,root,root)
132%doc COPYING ChangeLog README THANKS doc example
133%{_bindir}/estbutler
134%{_bindir}/estcmd
135%{_bindir}/estconfig
136%{_bindir}/estmaster
137%{_bindir}/estwaver
138%{_bindir}/estcall
139%{_bindir}/estload
140%{_bindir}/estmttest
141%{_bindir}/estwolefind
142%{_mandir}/man1/*
143%{_libdir}/*.so.*
144%{_libexecdir}/*
145%{_datadir}/hyperestraier/*.*
146%{_datadir}/hyperestraier/filter
147%{_datadir}/hyperestraier/increm
148%{_datadir}/hyperestraier/locale
149
150%files devel
151%defattr(-,root,root)
152%{_mandir}/man3/estnode.3*
153%{_mandir}/man3/estraier.3*
154%{_libdir}/*.so
155%{_libdir}/*.a
156%{_libdir}/pkgconfig/hyperestraier.pc
157%{_includedir}/*.h
158
159%files perl
160%defattr(-,root,root)
161%doc perllocal.pod
162%{_bindir}/estcmd.pl
163%{perl_vendorarch}/Estraier.pm
164%{perl_vendorarch}/Estraier.pod
165%{perl_vendorarch}/auto/Estraier
166%{_mandir}/man3/Estraier.3pm*
167
168%changelog
169* Sun May 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-2
170- added BR: qdbm-devel, zlib-devel to devel package
171
172* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.13-1vl5
173- applied new versioning policy, spec in utf-8
174- built with perl-5.10.0
175
176* Sat Jan 19 2008 IWAI, Masaharu <iwai@alib.jp> 1.4.13-0vl1
177- initial release
Note: See TracBrowser for help on using the repository browser.