source: projects/specs/trunk/h/hyperestraier/hyperestraier-vl.spec @ 1960

Revision 1960, 6.0 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1Summary: a full-text search system for communities
2Summary(ja): 全文検索システム
3Name: hyperestraier
4Version: 1.4.13
5Release: 5%{?_dist_release}
6License: LGPL 2.1
7URL: http://hyperestraier.sourceforge.net/index.html
8Group: Applications/Text
9Source0: http://hyperestraier.sourceforge.net/%{name}-%{version}.tar.gz
10# extra filters
11Source10: estfxgunzip
12Source11: estfxmantohtml
13Patch0: hyperestraier-1.4.13-perl-vendordir.patch
14
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: qdbm-devel >= 1.8.75
17BuildRequires: zlib-devel >= 1.2.1
18BuildRequires: mecab-devel >= 0.92
19BuildRequires: perl
20Requires: qdbm >= 1.8.75
21Requires: zlib >= 1.2.1
22Requires: mecab >= 0.92
23Requires: mecab-ipadic >= 2.7.0
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28Packager: inagaki
29
30%description
31Hyper Estraier is a full-text search system. You can search lots of documents
32for some documents including specified words. If you run a web site, it is
33useful as your own search engine for pages in your site. Also, it is useful
34as search utilities of mail boxes and file servers.
35
36The characteristic of Hyper Estraier is the following.
37
38    * High performance of search
39    * High scalability of target documents
40    * Perfect recall ratio by N-gram method
41    * High precision by hybrid mechanism of N-gram and morphological analyzer
42    * Phrase search, regular expressions, attribute search, and similarity search
43    * Multilingualism with Unicode
44    * Independent of file format and repository
45    * Intelligent web crawler
46    * Simple and powerful API
47    * Supporting P2P architecture
48
49Hyper Estraier is an open-source software released under the terms of the
50GNU Lesser General Public License. It works on Linux, Windows, Mac OS X,
51and other UNIX-like systems.
52
53%description -l ja
54Hyper Estraierは全文検索システムです。たくさんの文書の中から、特定の語句を含むものを探して、該当するものの一覧を表示することができます。Web サイトを運営している方なら、自分のサイト専用の検索エンジンとして利用することができます。メールボックスやファイルサーバを対象とした検索ツールとして利用することもできます。
55
56Hyper Estraierには、次のような特徴があります。
57
58    * インデックスを使った高速な検索ができます。
59    * 大量の文書のインデックスを短時間で作成できます。
60    * N-gram方式による漏れのない検索ができます。
61    * 形態素解析とN-gramのハイブリッド機構で検索精度を向上させます。
62    * フレーズ検索や正規表現検索や属性検索や類似検索をサポートします。
63    * 世界各国の言語が扱えます。
64    * 対象文書の所在や形式に依存しません。
65    * 賢いWebクローラが付属しています。
66    * ライブラリとして各種製品に組み込めます。
67    * P2P連携機能をサポートします。
68
69Hyper EstraierはGNU Lesser General Public Licenseに基づいて配布されるフリーソフトウェアです。Linux、Windows、Mac OS Xおよびその他のUNIX系OSの上で動作します。
70
71%package devel
72Summary: Header files and libraries for developing apps which will using Hyper Estraier
73Group: Development/Libraries
74Requires: %{name} = %{version}-%{release}
75Requires: qdbm-devel >= 1.8.75
76Requires: zlib-devel >= 1.2.1
77
78%description devel
79Header files and libraries for developing apps which will using Hyper Estraier
80
81%package perl
82Summary: Perl module for Hyper Estraier
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85Requires: perl
86
87%description perl
88Perl module for Hyper Estraier
89
90%prep
91%setup -q
92%patch0 -p1 -b .perlvendordir
93
94%build
95%configure \
96    --enable-stable \
97    --enable-zlib \
98    --enable-mecab
99make
100
101pushd perlnative
102%configure
103make
104popd
105
106%install
107rm -rf %{buildroot}
108%makeinstall DESTDIR=%{buildroot}
109pushd perlnative
110%makeinstall DESTDIR=%{buildroot}
111popd
112
113## delete
114rm -rf %{buildroot}/usr/share/hyperestraier/doc
115rm -rf %{buildroot}/usr/share/hyperestraier/{COPYING,ChangeLog,THANKS}
116
117## install extra filters
118install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/hyperestraier/filter
119install -m755 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/hyperestraier/filter
120
121## for Perl
122perllocalfile=`find %{buildroot} -name perllocal.pod`
123echo "mv $perllocalfile ."
124mv $perllocalfile .
125
126sed -e "s@^%{buildroot}@@g" < %{buildroot}%{perl_vendorarch}/auto/Estraier/.packlist \
127       > .packlist
128mv -f .packlist %{buildroot}%{perl_vendorarch}/auto/Estraier/.packlist
129
130%clean
131rm -rf %{buildroot}
132
133%check
134make check
135
136%post -p /sbin/ldconfig
137
138%postun -p /sbin/ldconfig
139
140%files
141%defattr(-,root,root)
142%doc COPYING ChangeLog README THANKS doc example
143%{_bindir}/estbutler
144%{_bindir}/estcmd
145%{_bindir}/estconfig
146%{_bindir}/estmaster
147%{_bindir}/estwaver
148%{_bindir}/estcall
149%{_bindir}/estload
150%{_bindir}/estmttest
151%{_bindir}/estwolefind
152%{_mandir}/man1/*
153%{_libdir}/*.so.*
154%{_libexecdir}/*
155%{_datadir}/hyperestraier/*.*
156%{_datadir}/hyperestraier/filter
157%{_datadir}/hyperestraier/increm
158%{_datadir}/hyperestraier/locale
159
160%files devel
161%defattr(-,root,root)
162%{_mandir}/man3/estnode.3*
163%{_mandir}/man3/estraier.3*
164%{_libdir}/*.so
165%{_libdir}/*.a
166%{_libdir}/pkgconfig/hyperestraier.pc
167%{_includedir}/*.h
168
169%files perl
170%defattr(-,root,root)
171%doc perllocal.pod
172%{_bindir}/estcmd.pl
173%{perl_vendorarch}/Estraier.pm
174%{perl_vendorarch}/Estraier.pod
175%{perl_vendorarch}/auto/Estraier
176%{_mandir}/man3/Estraier.3pm*
177
178%changelog
179* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 1.4.13-5
180- rebuilt with rpm-4.8.1 for pkg-config
181
182* Tue Apr  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-4
183- added Source10 and 11 for indexing JF, JM
184
185* Mon Mar 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-3
186- rebuilt with new toolchain
187
188* Sun May 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.13-2
189- added BR: qdbm-devel, zlib-devel to devel package
190
191* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.13-1vl5
192- applied new versioning policy, spec in utf-8
193- built with perl-5.10.0
194
195* Sat Jan 19 2008 IWAI, Masaharu <iwai@alib.jp> 1.4.13-0vl1
196- initial release
Note: See TracBrowser for help on using the repository browser.