source: projects/specs/trunk/g/guile/guile-vl.spec @ 7961

Revision 7961, 11.6 KB checked in by Takemikaduchi, 10 years ago (diff)

upgrade toolchain + xserver-1.14.4

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define mver 1.8
3
4Name: guile
5Summary: A GNU implementation of Scheme for application extensibility.
6Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
7Version: 1.8.8
8Release: 1%{?_dist_release}
9
10Group: Development/Languages
11License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
12URL: http://www.gnu.org/software/guile/
13
14Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
15
16# following patchs are imported from fedora-dev
17Patch1: guile-1.8.7-multilib.patch
18Patch2: guile-1.8.7-testsuite.patch
19Patch4: guile-1.8.6-deplibs.patch
20
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
23BuildRequires: gmp-devel readline-devel emacs
24Requires(post): /sbin/install-info
25Requires(preun): /sbin/install-info
26Requires: coreutils
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30Packager:       yasumichi
31
32%description
33GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
34implementation of the Scheme programming language, written in C.  GUILE
35provides a machine-independent execution platform that can be linked in
36as a library during the building of extensible programs.
37
38Install the guile package if you'd like to add extensibility to programs
39that you are developing.
40
41%package devel
42Summary: Libraries and header files for the GUILE extensibility library.
43Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: gmp-devel
47
48%description devel
49The guile-devel package includes the libraries, header files, etc.,
50that you'll need to develop applications that are linked with the
51GUILE extensibility library.
52
53You need to install the guile-devel package if you want to develop
54applications that will be linked to GUILE.  You'll also need to
55install the guile package.
56
57%package -n compat32-%{name}
58Summary: A GNU implementation of Scheme for application extensibility.
59Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
60Group: Development/Languages
61Requires: %{name} = %{version}-%{release}
62
63%description -n compat32-%{name}
64GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
65implementation of the Scheme programming language, written in C.  GUILE
66provides a machine-independent execution platform that can be linked in
67as a library during the building of extensible programs.
68
69Install the guile package if you'd like to add extensibility to programs
70that you are developing.
71
72%package -n compat32-%{name}-devel
73Summary: Libraries and header files for the GUILE extensibility library.
74Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
75Group: Development/Libraries
76Requires: %{name}-devel = %{version}-%{release}
77Requires: compat32-%{name} = %{version}-%{release}
78Requires: compat32-gmp-devel
79
80%description -n compat32-%{name}-devel
81The guile-devel package includes the libraries, header files, etc.,
82that you'll need to develop applications that are linked with the
83GUILE extensibility library.
84
85You need to install the guile-devel package if you want to develop
86applications that will be linked to GUILE.  You'll also need to
87install the guile package.
88
89%prep
90%setup -q
91%patch1 -p1 -b .multilib
92%patch2 -p1 -b .testsuite
93%patch4 -p1 -b .deplibs
94
95%build
96%configure --disable-static --disable-error-on-warning
97
98# Remove RPATH
99sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
100    {,guile-readline/}libtool
101
102make %{?_smp_mflags}
103
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108make DESTDIR=$RPM_BUILD_ROOT install
109
110mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site
111
112rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
113rm -f $RPM_BUILD_ROOT%{_infodir}/dir
114
115# Compress large documentation
116bzip2 NEWS
117
118for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
119    iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
120done
121
122touch $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slibcat
123ln -s ../../slib $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slib
124
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130/sbin/ldconfig
131/sbin/install-info  %{_infodir}/guile.info.gz %{_infodir}/dir
132/sbin/install-info  %{_infodir}/r5rs.info.gz %{_infodir}/dir
133/sbin/install-info  %{_infodir}/goops.info.gz %{_infodir}/dir
134/sbin/install-info  %{_infodir}/guile-tut.info.gz %{_infodir}/dir
135
136%postun -p /sbin/ldconfig
137
138%preun
139if [ "$1" = 0 ]; then
140    /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
141    /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
142    /sbin/install-info --delete %{_infodir}/goops.info.gz %{_infodir}/dir
143    /sbin/install-info --delete %{_infodir}/guile-tut.info.gz %{_infodir}/dir
144fi
145:
146
147%post -n compat32-%{name} -p /sbin/ldconfig
148
149%postun -n compat32-%{name} -p /sbin/ldconfig
150
151%files
152%defattr(-,root,root,-)
153%doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
154%{_bindir}/guile
155%{_bindir}/guile-tools
156%{_libdir}/libguile*.so.*
157%{_libdir}/libguilereadline-*.so
158%{_libdir}/libguile-srfi-srfi-*.so
159%dir %{_datadir}/guile
160%dir %{_datadir}/guile/%{mver}
161%{_datadir}/guile/%{mver}/ice-9
162%{_datadir}/guile/%{mver}/lang
163%{_datadir}/guile/%{mver}/oop
164%{_datadir}/guile/%{mver}/scripts
165%{_datadir}/guile/%{mver}/srfi
166%{_datadir}/guile/%{mver}/guile-procedures.txt
167%ghost %{_datadir}/guile/%{mver}/slibcat
168%ghost %{_datadir}/guile/%{mver}/slib
169%dir %{_datadir}/guile/site
170%dir %{_datadir}/emacs/site-lisp
171%{_datadir}/emacs/site-lisp/*.el
172%{_infodir}/*
173%{_mandir}/man1/guile.1*
174
175%files devel
176%defattr(-,root,root,-)
177%{_bindir}/guile-config
178%{_bindir}/guile-snarf
179%{_datadir}/aclocal/*
180%{_libdir}/libguile.so
181%{_libdir}/pkgconfig/*.pc
182%{_includedir}/guile
183%{_includedir}/libguile
184%{_includedir}/libguile.h
185
186# compat32
187%if %{build_compat32}
188%files -n compat32-%{name}
189%defattr(-,root,root,-)
190%{_libdir}/libguile*.so.*
191%{_libdir}/libguilereadline-*.so
192%{_libdir}/libguile-srfi-srfi-*.so
193
194%files -n compat32-%{name}-devel
195%defattr(-,root,root,-)
196%{_libdir}/libguile.so
197%{_libdir}/pkgconfig/*.pc
198%endif
199
200%changelog
201* Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
202- update to 1.8.8
203- remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
204
205* Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
206- rebuilt with rpm-4.8.1
207- added Patch1, 2, 3, 5 and 6 from Fedora
208
209* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
210- new upstream release.
211- comment out Patch11,12.
212
213* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
214- added Requires: gmp-devel to guile-devel
215
216* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
217- added compat32 package for x86_64 arch support
218
219* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
220- rebuild with libtool-2.2.6a
221
222* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
223- new upstream release
224- import some patches from fedora development
225- drop some old patches
226- update spec based on fedora package
227- spec in utf-8
228
229* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
230- use macro for Release
231
232* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
233- apply new virsioning policy.
234- remove *.la
235
236* Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
237- rebuilt with readline 5.1
238
239* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
240- added Patches from Fedora
241  * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
242  - Fix dynamic linking on 64bit archs (#159971)
243  * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
244  - Moved info files to base package as they are not devel related (#139948)
245  - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
246  - Fixed guile-tools not finding guile lib dir (#142642)
247  - Added some nice tools (#142642)
248  - Removed smp build, seems to be broken atm
249
250* Fri Jan  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
251- new upstream release
252- dropped patch2, 4, 6
253- added BuildPrereq: perl
254
255* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
256- rebuild with new toolchains
257- s/Copyright/License/
258- added srfi libs
259- patch for ppc64 from Fedora package
260
261* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
262- update to 1.6.4
263
264* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
265- rebuild with readline-4.3
266
267* Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
268- based on Rawhide 1.6.0-4
269  - Included s390 as working arch as well, switch to general unknown arch patch
270  - rebuild to fix broken deps
271  - fix continuations.h on ia64
272- new upstream 1.6.3
273
274* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
275- porting for Vine Linux
276- remove 1.3 patches( not required  so that upstream upgrade )
277
278* Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
279- Add version number to prereq for umb-scheme to get the post-install to
280  work properly.
281
282* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
283- Add an Epoch = 1 in case anyone happened to have 1.4 installed.
284
285* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
286- automatic rebuild
287
288* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
289- Back down to 1.3.4.
290- Fix to actually link against the version of libguile in the package.
291
292* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
293- FHS fixups using the %%{makeinstall} macro.
294
295* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
296- fix preun-devel
297- call ldconfig directly in postun
298
299* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
300- rebuild with new readline
301- update to 1.3.4
302
303* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
304- using the same catalog as umb-scheme makes umb-scheme a prereq
305
306* Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
307- readline is needed for %post
308
309* Tue Feb  8 2000 Nalin Dahyabhai <nalin@redhat.com>
310- use the same catalog as umb-scheme
311
312* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
313- fix broken %postun
314
315* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
316- auto rebuild in the new build environment (release 6)
317
318* Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
319- added .ansi patch to fix #endif
320
321* Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
322- add patch for the scm stuff
323
324* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
325- integrate changes from rhcn version (#640)
326
327* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
328- call libtoolize first to get it to compile on the arm
329
330* Sat Jan  9 1999 Todd Larason <jtl@molehill.org>
331- Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
332
333* Fri Jan  1 1999 Todd Larason <jtl@molehill.org>
334- guile-devel does depend on guile
335- remove devel dependancy on m4
336- move guile-snarf from guile to guile-devel
337- Converted to rhcn
338
339* Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
340- update to 1.3.
341- don't strip libguile.so.*.0.0. (but set the execute bits).
342
343* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
344- spec file fixups
345
346* Wed Sep  2 1998 Michael Fulbright <msf@redhat.com>
347- Updated for RH 5.2
348
349* Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
350- Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
351- added slib link
352
353* Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl>          (1.2-3)
354- added %attr(-, root, root) for %doc,
355- in %post, %postun ldconfig runed as parameter "-p",
356- removed /bin/sh from requires,
357- added %description,
358- changes in %files.
359
360* Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl>  (1.2-2)
361- all rewrited for using Buildroot,
362- added %postun,
363- removed making buid logs,
364- removed "--inclededir", added "--enable-dynamic-linking" to configure
365  parameters,
366- added striping shared libs and /usr/bin/guile,
367- added "Requires: /bin/sh" (for guile-snarf) in guile package and
368  "Requires: m4" for guile-devel,
369- added macro %{PACKAGE_VERSION} in "Source:" and %files,
370- added %attr macros in %files.
Note: See TracBrowser for help on using the repository browser.