source: projects/specs/trunk/g/guile/guile-vl.spec @ 12376

Revision 12376, 16.8 KB checked in by tomop, 4 years ago (diff)

updated 19 packages

g-wrap-1.9.15-2

gjs-1.54.3-2

glib2-2.64.2-2

gobject-introspection-1.64.1-1

guile-2.2.7-1

guile20-2.0.14-5

hardinfo-0.5.1-4

llvm-10.0.0-2

libffi-3.3-1

libffi321-3.2.1-1

p11-kit-0.23.20-2

pycairo-1.18.2-1

pygobject-2.28.6-7

pygobject3-3.34.0-1

python-cffi-1.14.0-1

python-2.7.17-1

python3-3.5.9-1

ruby-2.6.6-2

uim-1.8.8-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%global obsolete_ver 2.0.14-3
4
5Name: guile
6Summary: A GNU implementation of Scheme for application extensibility.
7Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
8Version: 2.2.7
9Release: 1%{?_dist_release}
10
11Group: Development/Languages
12License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
13URL: https://www.gnu.org/software/guile/
14
15Source: https://ftp.gnu.org/gnu/guile/guile-%{version}.tar.xz
16
17# following patchs are imported from fedora-dev
18Patch1: guile-multilib.patch
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
22BuildRequires: gmp-devel readline-devel emacs
23BuildRequires: libunistring-devel
24BuildRequires: libffi-devel
25BuildRequires: gc-devel
26Requires(post): /sbin/install-info
27Requires(preun): /sbin/install-info
28Requires: coreutils
29
30Provides: guile = %{version}-%{release}
31Obsoletes: guile < %{obsolete_ver}
32
33Vendor:         Project Vine
34Distribution:   Vine Linux
35Packager:       yasumichi
36
37%global mver %(echo '%{version}' | sed -e 's/\.[0-9]*$//')
38%global majorver %(echo '%{mver}' | sed -e 's/\.[0-9]*$//')
39%global minorver %(echo '%{mver}' | sed -e 's/^[0-9]*\.//')
40%global alt_priority %(printf "%%d%%02d" "%{majorver}" "%{minorver}")
41
42%description
43GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
44implementation of the Scheme programming language, written in C.  GUILE
45provides a machine-independent execution platform that can be linked in
46as a library during the building of extensible programs.
47
48Install the guile package if you'd like to add extensibility to programs
49that you are developing.
50
51
52%package devel
53Summary: Libraries and header files for the GUILE extensibility library.
54Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: gmp-devel
58Requires: gc-devel
59Provides: guile-devel = %{version}-%{release}
60Obsoletes: guile-devel < %{obsolete_ver}
61
62%description devel
63The guile-devel package includes the libraries, header files, etc.,
64that you'll need to develop applications that are linked with the
65GUILE extensibility library.
66
67
68%package -n compat32-%{name}
69Summary: A GNU implementation of Scheme for application extensibility.
70Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
71Group: System Environment/Libraries
72Requires: %{name} = %{version}-%{release}
73Provides: compat32-guile = %{version}-%{release}
74Obsoletes: compat32-guile < %{obsolete_ver}
75
76%description -n compat32-%{name}
77GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
78implementation of the Scheme programming language, written in C.  GUILE
79provides a machine-independent execution platform that can be linked in
80as a library during the building of extensible programs.
81
82Install the guile package if you'd like to add extensibility to programs
83that you are developing.
84
85
86%package -n compat32-%{name}-devel
87Summary: Libraries and header files for the GUILE extensibility library.
88Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
89Group: Development/Libraries
90Requires: %{name}-devel = %{version}-%{release}
91Requires: compat32-%{name} = %{version}-%{release}
92Requires: compat32-gmp-devel
93Requires: compat32-gc-devel
94Provides: compat32-guile-devel = %{version}-%{release}
95Obsoletes: compat32-guile-devel < %{obsolete_ver}
96
97%description -n compat32-%{name}-devel
98The guile-devel package includes the libraries, header files, etc.,
99that you'll need to develop applications that are linked with the
100GUILE extensibility library.
101
102You need to install the guile-devel package if you want to develop
103applications that will be linked to GUILE.  You'll also need to
104install the guile package.
105
106
107%prep
108%setup -q -n guile-%{version}
109%patch1 -p1 -b .multilib
110
111%build
112%configure \
113        --disable-static \
114        --disable-error-on-warning \
115        --program-suffix=%{?mver}
116
117# Remove RPATH
118sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
119    libtool
120
121make %{?_smp_mflags}
122
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127make DESTDIR=$RPM_BUILD_ROOT install
128
129mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site/%{mver}
130
131rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
132rm -f $RPM_BUILD_ROOT%{_infodir}/dir
133
134for i in $(seq 1 10); do
135  mv $RPM_BUILD_ROOT%{_infodir}/guile{,-%{mver}}.info-$i
136  sed -i -e 's/guile\.info/guile-%{mver}.info/' $RPM_BUILD_ROOT%{_infodir}/guile-%{mver}.info-$i
137  sed -i -e 's/\* Guile Reference: (guile)/* Guile %{mver} Reference: (guile-%{mver})/' $RPM_BUILD_ROOT%{_infodir}/guile-%{mver}.info-$i
138done
139mv $RPM_BUILD_ROOT%{_infodir}/guile{,-%{mver}}.info
140sed -i -e 's/guile\.info/guile-%{mver}.info/' $RPM_BUILD_ROOT%{_infodir}/guile-%{mver}.info
141sed -i -e 's/\* Guile Reference: (guile)/* Guile %{mver} Reference: (guile-%{mver})/' $RPM_BUILD_ROOT%{_infodir}/guile-%{mver}.info
142mv $RPM_BUILD_ROOT%{_infodir}/r5rs{,-%{mver}}.info
143mv $RPM_BUILD_ROOT%{_datadir}/aclocal/guile{,-%{mver}}.m4
144
145# Our gdb doesn't support guile yet
146rm -f ${RPM_BUILD_ROOT}%{_libdir}/libguile*gdb.scm
147
148# Compress large documentation
149bzip2 NEWS
150
151for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
152    iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
153done
154
155touch $RPM_BUILD_ROOT%{_datadir}/guile/site/%{mver}/slibcat
156
157# Remove Libtool archive
158rm $RPM_BUILD_ROOT%{_libdir}/guile/%{mver}/extensions/guile-readline.la
159
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164%post
165/sbin/ldconfig
166/sbin/install-info  %{_infodir}/guile-%{mver}.info.gz %{_infodir}/dir
167/sbin/install-info  %{_infodir}/r5rs-%{mver}.info.gz %{_infodir}/dir
168
169if [ $1 -eq 1 ]; then
170    %{_sbindir}/update-alternatives \
171        --install \
172                %{_bindir}/guile \
173                guile \
174                %{_bindir}/guile%{?mver} \
175                %{alt_priority} \
176        --slave \
177                %{_bindir}/guild \
178                guild \
179                %{_bindir}/guild%{?mver} \
180        --slave \
181                %{_bindir}/guile-tools \
182                guile-tools \
183                %{_bindir}/guile-tools%{?mver} \
184        --slave \
185                %{_mandir}/man1/guile.1.gz \
186                guile.1 \
187                %{_mandir}/man1/guile%{?mver}.1.gz
188fi
189
190%triggerpostun -- guile < 2.0.14-3
191if [ ! -e %{_bindir}/guile ]; then
192    rm -f %{_sysconfdir}/alternatives/{guile,guild,guile-tools,guile.1}
193    rm -f %{_sharedstatedir}/rpm/alternatives/{guile,guild,guile-tools,guile.1}
194fi
195%{_sbindir}/update-alternatives \
196        --install \
197                %{_bindir}/guile \
198                guile \
199                %{_bindir}/guile%{?mver} \
200                %{alt_priority} \
201        --slave \
202                %{_bindir}/guild \
203                guild \
204                %{_bindir}/guild%{?mver} \
205        --slave \
206                %{_bindir}/guile-tools \
207                guile-tools \
208                %{_bindir}/guile-tools%{?mver} \
209        --slave \
210                %{_mandir}/man1/guile.1.gz \
211                guile.1 \
212                %{_mandir}/man1/guile%{?mver}.1.gz
213
214%postun -p /sbin/ldconfig
215
216%preun
217if [ "$1" = 0 ]; then
218    /sbin/install-info --delete %{_infodir}/guile-%{mver}.info.gz %{_infodir}/dir
219    /sbin/install-info --delete %{_infodir}/r5rs-%{mver}.info.gz %{_infodir}/dir
220
221    %{_sbindir}/update-alternatives \
222        --remove \
223                guile \
224                %{_bindir}/guile%{?mver}
225fi
226:
227
228%post devel
229if [ $1 -eq 1 -o ! -e %{_libdir}/pkgconfig/guile.pc ]; then
230    %{_sbindir}/update-alternatives \
231        --install \
232                %{_bindir}/guile-config \
233                guile-config \
234                %{_bindir}/guile-config%{?mver} \
235                %{alt_priority} \
236        --slave \
237                %{_bindir}/guile-snarf \
238                guile-snarf \
239                %{_bindir}/guile-snarf%{?mver} \
240        --slave \
241                %{_libdir}/pkgconfig/guile.pc \
242                guile.pc \
243                %{_libdir}/pkgconfig/guile-%{?mver}.pc
244fi
245
246%triggerpostun -- guile-devel < 2.0.14-4
247if [ ! -e %{_bindir}/guile-config ]; then
248    rm -f %{_sysconfdir}/alternatives/{guile-config,guile-snarf,guile.pc}
249    rm -f %{_sharedstatedir}/rpm/alternatives/{guile-config,guile-snarf,guile.pc}
250fi
251%{_sbindir}/update-alternatives \
252        --install \
253                %{_bindir}/guile-config \
254                guile-config \
255                %{_bindir}/guile-config%{?mver} \
256                %{alt_priority} \
257        --slave \
258                %{_bindir}/guile-snarf \
259                guile-snarf \
260                %{_bindir}/guile-snarf%{?mver} \
261        --slave \
262                %{_libdir}/pkgconfig/guile.pc \
263                guile.pc \
264                %{_libdir}/pkgconfig/guile-%{?mver}.pc
265
266%preun devel
267if [ "$1" = 0 ]; then
268    %{_sbindir}/update-alternatives \
269        --remove \
270                guile-config \
271                %{_bindir}/guile-config%{?mver}
272fi
273
274%if %{build_compat32}
275%post -n compat32-%{name} -p /sbin/ldconfig
276
277%postun -n compat32-%{name} -p /sbin/ldconfig
278%endif
279
280
281%files
282%defattr(-,root,root,-)
283%license COPYING*
284%doc AUTHORS ChangeLog HACKING NEWS.bz2 README THANKS
285%{_bindir}/guild%{?mver}
286%{_bindir}/guile%{?mver}
287%{_bindir}/guile-tools%{?mver}
288%{_libdir}/libguile*.so.*
289%dir %{_libdir}/guile
290%dir %{_libdir}/guile/%{mver}
291%{_libdir}/guile/%{mver}/ccache
292%{_libdir}/guile/%{mver}/extensions
293%dir %{_datadir}/guile
294%dir %{_datadir}/guile/%{mver}
295%{_datadir}/guile/%{mver}/*.scm
296%{_datadir}/guile/%{mver}/ice-9
297%{_datadir}/guile/%{mver}/language
298%{_datadir}/guile/%{mver}/oop
299%{_datadir}/guile/%{mver}/rnrs
300%{_datadir}/guile/%{mver}/scripts
301%{_datadir}/guile/%{mver}/srfi
302%{_datadir}/guile/%{mver}/sxml
303%{_datadir}/guile/%{mver}/system
304%{_datadir}/guile/%{mver}/texinfo
305%{_datadir}/guile/%{mver}/web
306%{_datadir}/guile/%{mver}/guile-procedures.txt
307%dir %{_datadir}/guile/site
308%ghost %{_datadir}/guile/site/%{mver}/slibcat
309%{_infodir}/*
310%{_mandir}/man1/guile%{?mver}*
311
312
313%files devel
314%defattr(-,root,root,-)
315%{_bindir}/guile-config%{?mver}
316%{_bindir}/guile-snarf%{?mver}
317%{_datadir}/aclocal/*
318%{_libdir}/libguile-%{mver}.so
319%{_libdir}/pkgconfig/*.pc
320%dir %{_includedir}/guile
321%{_includedir}/guile/%{mver}
322
323
324# compat32
325%if %{build_compat32}
326%files -n compat32-%{name}
327%defattr(-,root,root,-)
328%{_libdir}/libguile*.so.*
329%dir %{_libdir}/guile
330%dir %{_libdir}/guile/%{mver}
331%{_libdir}/guile/%{mver}/ccache
332%{_libdir}/guile/%{mver}/extensions
333
334
335%files -n compat32-%{name}-devel
336%defattr(-,root,root,-)
337%{_libdir}/libguile-%{mver}.so
338%endif
339
340
341%changelog
342* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.7-1
343- new upstream release.
344
345* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-2
346- made guile-devel alternatives-ready.
347
348* Mon Sep 09 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6-1
349- updated to 2.2.6.
350- made alternatives-ready.
351
352* Wed Sep 04 2019 Toshiaki Ara <ara_t@384.jp> 2.0.14-2
353- rebuild with readline-8.0
354
355* Wed Mar 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.14-1
356- update to 2.0.14
357
358* Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.12-1
359- update to 2.0.12
360
361* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.11-2
362- rebuilt with readline 6.3
363
364* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.11-1
365- update to 2.0.11
366- add BuildRequires: libunistring-devel, libffi-devel, gc-devel
367- remove Patch2,4
368
369* Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
370- update to 1.8.8
371- remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
372
373* Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
374- rebuilt with rpm-4.8.1
375- added Patch1, 2, 3, 5 and 6 from Fedora
376
377* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
378- new upstream release.
379- comment out Patch11,12.
380
381* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
382- added Requires: gmp-devel to guile-devel
383
384* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
385- added compat32 package for x86_64 arch support
386
387* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
388- rebuild with libtool-2.2.6a
389
390* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
391- new upstream release
392- import some patches from fedora development
393- drop some old patches
394- update spec based on fedora package
395- spec in utf-8
396
397* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
398- use macro for Release
399
400* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
401- apply new virsioning policy.
402- remove *.la
403
404* Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
405- rebuilt with readline 5.1
406
407* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
408- added Patches from Fedora
409  * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
410  - Fix dynamic linking on 64bit archs (#159971)
411  * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
412  - Moved info files to base package as they are not devel related (#139948)
413  - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
414  - Fixed guile-tools not finding guile lib dir (#142642)
415  - Added some nice tools (#142642)
416  - Removed smp build, seems to be broken atm
417
418* Fri Jan  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
419- new upstream release
420- dropped patch2, 4, 6
421- added BuildPrereq: perl
422
423* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
424- rebuild with new toolchains
425- s/Copyright/License/
426- added srfi libs
427- patch for ppc64 from Fedora package
428
429* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
430- update to 1.6.4
431
432* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
433- rebuild with readline-4.3
434
435* Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
436- based on Rawhide 1.6.0-4
437  - Included s390 as working arch as well, switch to general unknown arch patch
438  - rebuild to fix broken deps
439  - fix continuations.h on ia64
440- new upstream 1.6.3
441
442* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
443- porting for Vine Linux
444- remove 1.3 patches( not required  so that upstream upgrade )
445
446* Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
447- Add version number to prereq for umb-scheme to get the post-install to
448  work properly.
449
450* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
451- Add an Epoch = 1 in case anyone happened to have 1.4 installed.
452
453* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
454- automatic rebuild
455
456* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
457- Back down to 1.3.4.
458- Fix to actually link against the version of libguile in the package.
459
460* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
461- FHS fixups using the %%{makeinstall} macro.
462
463* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
464- fix preun-devel
465- call ldconfig directly in postun
466
467* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
468- rebuild with new readline
469- update to 1.3.4
470
471* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
472- using the same catalog as umb-scheme makes umb-scheme a prereq
473
474* Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
475- readline is needed for %post
476
477* Tue Feb  8 2000 Nalin Dahyabhai <nalin@redhat.com>
478- use the same catalog as umb-scheme
479
480* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
481- fix broken %postun
482
483* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
484- auto rebuild in the new build environment (release 6)
485
486* Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
487- added .ansi patch to fix #endif
488
489* Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
490- add patch for the scm stuff
491
492* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
493- integrate changes from rhcn version (#640)
494
495* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
496- call libtoolize first to get it to compile on the arm
497
498* Sat Jan  9 1999 Todd Larason <jtl@molehill.org>
499- Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
500
501* Fri Jan  1 1999 Todd Larason <jtl@molehill.org>
502- guile-devel does depend on guile
503- remove devel dependancy on m4
504- move guile-snarf from guile to guile-devel
505- Converted to rhcn
506
507* Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
508- update to 1.3.
509- don't strip libguile.so.*.0.0. (but set the execute bits).
510
511* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
512- spec file fixups
513
514* Wed Sep  2 1998 Michael Fulbright <msf@redhat.com>
515- Updated for RH 5.2
516
517* Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
518- Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
519- added slib link
520
521* Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl>          (1.2-3)
522- added %attr(-, root, root) for %doc,
523- in %post, %postun ldconfig runed as parameter "-p",
524- removed /bin/sh from requires,
525- added %description,
526- changes in %files.
527
528* Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl>  (1.2-2)
529- all rewrited for using Buildroot,
530- added %postun,
531- removed making buid logs,
532- removed "--inclededir", added "--enable-dynamic-linking" to configure
533  parameters,
534- added striping shared libs and /usr/bin/guile,
535- added "Requires: /bin/sh" (for guile-snarf) in guile package and
536  "Requires: m4" for guile-devel,
537- added macro %{PACKAGE_VERSION} in "Source:" and %files,
538- added %attr macros in %files.
Note: See TracBrowser for help on using the repository browser.