source: projects/specs/trunk/g/guile/guile-vl.spec @ 9291

Revision 9291, 11.5 KB checked in by Takemikaduchi, 9 years ago (diff)

libdbi-drivers,goffice08,guile18: NEW package
geda-gaf,missile,rrdtool,trackballs,trackballs-music,ulogd,xkeycaps,xorg-x11-jpfonts: rebuild
others: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define mver 2.0
3
4Name: guile
5Summary: A GNU implementation of Scheme for application extensibility.
6Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
7Version: 2.0.11
8Release: 1%{?_dist_release}
9
10Group: Development/Languages
11License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
12URL: http://www.gnu.org/software/guile/
13
14Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
15
16# following patchs are imported from fedora-dev
17Patch1: guile-1.8.7-multilib.patch
18
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
21BuildRequires: gmp-devel readline-devel emacs
22BuildRequires: libunistring-devel
23BuildRequires: libffi-devel
24BuildRequires: gc-devel
25Requires(post): /sbin/install-info
26Requires(preun): /sbin/install-info
27Requires: coreutils
28
29Vendor:         Project Vine
30Distribution:   Vine Linux
31Packager:       yasumichi
32
33%description
34GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
35implementation of the Scheme programming language, written in C.  GUILE
36provides a machine-independent execution platform that can be linked in
37as a library during the building of extensible programs.
38
39Install the guile package if you'd like to add extensibility to programs
40that you are developing.
41
42%package devel
43Summary: Libraries and header files for the GUILE extensibility library.
44Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: gmp-devel
48Requires: gc-devel
49
50%description devel
51The guile-devel package includes the libraries, header files, etc.,
52that you'll need to develop applications that are linked with the
53GUILE extensibility library.
54
55You need to install the guile-devel package if you want to develop
56applications that will be linked to GUILE.  You'll also need to
57install the guile package.
58
59%package -n compat32-%{name}
60Summary: A GNU implementation of Scheme for application extensibility.
61Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
62Group: Development/Languages
63Requires: %{name} = %{version}-%{release}
64
65%description -n compat32-%{name}
66GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
67implementation of the Scheme programming language, written in C.  GUILE
68provides a machine-independent execution platform that can be linked in
69as a library during the building of extensible programs.
70
71Install the guile package if you'd like to add extensibility to programs
72that you are developing.
73
74%package -n compat32-%{name}-devel
75Summary: Libraries and header files for the GUILE extensibility library.
76Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
77Group: Development/Libraries
78Requires: %{name}-devel = %{version}-%{release}
79Requires: compat32-%{name} = %{version}-%{release}
80Requires: compat32-gmp-devel
81Requires: compat32-gc-devel
82
83%description -n compat32-%{name}-devel
84The guile-devel package includes the libraries, header files, etc.,
85that you'll need to develop applications that are linked with the
86GUILE extensibility library.
87
88You need to install the guile-devel package if you want to develop
89applications that will be linked to GUILE.  You'll also need to
90install the guile package.
91
92%prep
93%setup -q
94%patch1 -p1 -b .multilib
95
96%build
97%configure --disable-static --disable-error-on-warning
98
99# Remove RPATH
100sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
101    libtool
102
103make %{?_smp_mflags}
104
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109make DESTDIR=$RPM_BUILD_ROOT install
110
111mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site/%{mver}
112
113rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
114rm -f $RPM_BUILD_ROOT%{_infodir}/dir
115
116# Our gdb doesn't support guile yet
117rm -f ${RPM_BUILD_ROOT}%{_libdir}/libguile*gdb.scm
118
119# Compress large documentation
120bzip2 NEWS
121
122for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
123    iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
124done
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130/sbin/ldconfig
131/sbin/install-info  %{_infodir}/guile.info.gz %{_infodir}/dir
132/sbin/install-info  %{_infodir}/r5rs.info.gz %{_infodir}/dir
133
134%postun -p /sbin/ldconfig
135
136%preun
137if [ "$1" = 0 ]; then
138    /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
139    /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
140fi
141:
142
143%post -n compat32-%{name} -p /sbin/ldconfig
144
145%postun -n compat32-%{name} -p /sbin/ldconfig
146
147%files
148%defattr(-,root,root,-)
149%doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
150%{_bindir}/guild
151%{_bindir}/guile
152%{_bindir}/guile-tools
153%{_libdir}/libguile*.so.*
154%{_libdir}/libguilereadline-*.so
155%dir %{_libdir}/guile/%{mver}
156%{_libdir}/guile/%{mver}/ccache
157%dir %{_datadir}/guile
158%dir %{_datadir}/guile/%{mver}
159%{_datadir}/guile/%{mver}/*.scm
160%{_datadir}/guile/%{mver}/ice-9
161%{_datadir}/guile/%{mver}/language
162%{_datadir}/guile/%{mver}/oop
163%{_datadir}/guile/%{mver}/rnrs
164%{_datadir}/guile/%{mver}/scripts
165%{_datadir}/guile/%{mver}/srfi
166%{_datadir}/guile/%{mver}/sxml
167%{_datadir}/guile/%{mver}/system
168%{_datadir}/guile/%{mver}/texinfo
169%{_datadir}/guile/%{mver}/web
170%{_datadir}/guile/%{mver}/guile-procedures.txt
171%dir %{_datadir}/guile/site
172%{_infodir}/*
173%{_mandir}/man1/guile.1*
174
175%files devel
176%defattr(-,root,root,-)
177%{_bindir}/guile-config
178%{_bindir}/guile-snarf
179%{_datadir}/aclocal/*
180%{_libdir}/libguile-%{mver}.so
181%{_libdir}/pkgconfig/*.pc
182%{_includedir}/guile/%{mver}
183
184# compat32
185%if %{build_compat32}
186%files -n compat32-%{name}
187%defattr(-,root,root,-)
188%{_libdir}/libguile*.so.*
189%{_libdir}/libguilereadline-*.so
190
191%files -n compat32-%{name}-devel
192%defattr(-,root,root,-)
193%{_libdir}/libguile-%{mver}.so
194%endif
195
196%changelog
197* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.11-1
198- update to 2.0.11
199- add BuildRequires: libunistring-devel, libffi-devel, gc-devel
200- remove Patch2,4
201
202* Tue Nov 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.8-1
203- update to 1.8.8
204- remove Patch3,5,6 (guile-1.8.7-ia64jmp.patch)
205
206* Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
207- rebuilt with rpm-4.8.1
208- added Patch1, 2, 3, 5 and 6 from Fedora
209
210* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
211- new upstream release.
212- comment out Patch11,12.
213
214* Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
215- added Requires: gmp-devel to guile-devel
216
217* Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
218- added compat32 package for x86_64 arch support
219
220* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
221- rebuild with libtool-2.2.6a
222
223* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
224- new upstream release
225- import some patches from fedora development
226- drop some old patches
227- update spec based on fedora package
228- spec in utf-8
229
230* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
231- use macro for Release
232
233* Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
234- apply new virsioning policy.
235- remove *.la
236
237* Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
238- rebuilt with readline 5.1
239
240* Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
241- added Patches from Fedora
242  * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
243  - Fix dynamic linking on 64bit archs (#159971)
244  * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
245  - Moved info files to base package as they are not devel related (#139948)
246  - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
247  - Fixed guile-tools not finding guile lib dir (#142642)
248  - Added some nice tools (#142642)
249  - Removed smp build, seems to be broken atm
250
251* Fri Jan  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
252- new upstream release
253- dropped patch2, 4, 6
254- added BuildPrereq: perl
255
256* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
257- rebuild with new toolchains
258- s/Copyright/License/
259- added srfi libs
260- patch for ppc64 from Fedora package
261
262* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
263- update to 1.6.4
264
265* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
266- rebuild with readline-4.3
267
268* Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
269- based on Rawhide 1.6.0-4
270  - Included s390 as working arch as well, switch to general unknown arch patch
271  - rebuild to fix broken deps
272  - fix continuations.h on ia64
273- new upstream 1.6.3
274
275* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
276- porting for Vine Linux
277- remove 1.3 patches( not required  so that upstream upgrade )
278
279* Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
280- Add version number to prereq for umb-scheme to get the post-install to
281  work properly.
282
283* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
284- Add an Epoch = 1 in case anyone happened to have 1.4 installed.
285
286* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
287- automatic rebuild
288
289* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
290- Back down to 1.3.4.
291- Fix to actually link against the version of libguile in the package.
292
293* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
294- FHS fixups using the %%{makeinstall} macro.
295
296* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
297- fix preun-devel
298- call ldconfig directly in postun
299
300* Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
301- rebuild with new readline
302- update to 1.3.4
303
304* Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
305- using the same catalog as umb-scheme makes umb-scheme a prereq
306
307* Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
308- readline is needed for %post
309
310* Tue Feb  8 2000 Nalin Dahyabhai <nalin@redhat.com>
311- use the same catalog as umb-scheme
312
313* Thu Sep  2 1999 Jeff Johnson <jbj@redhat.com>
314- fix broken %postun
315
316* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
317- auto rebuild in the new build environment (release 6)
318
319* Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
320- added .ansi patch to fix #endif
321
322* Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
323- add patch for the scm stuff
324
325* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
326- integrate changes from rhcn version (#640)
327
328* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
329- call libtoolize first to get it to compile on the arm
330
331* Sat Jan  9 1999 Todd Larason <jtl@molehill.org>
332- Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
333
334* Fri Jan  1 1999 Todd Larason <jtl@molehill.org>
335- guile-devel does depend on guile
336- remove devel dependancy on m4
337- move guile-snarf from guile to guile-devel
338- Converted to rhcn
339
340* Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
341- update to 1.3.
342- don't strip libguile.so.*.0.0. (but set the execute bits).
343
344* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
345- spec file fixups
346
347* Wed Sep  2 1998 Michael Fulbright <msf@redhat.com>
348- Updated for RH 5.2
349
350* Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
351- Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
352- added slib link
353
354* Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl>          (1.2-3)
355- added %attr(-, root, root) for %doc,
356- in %post, %postun ldconfig runed as parameter "-p",
357- removed /bin/sh from requires,
358- added %description,
359- changes in %files.
360
361* Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl>  (1.2-2)
362- all rewrited for using Buildroot,
363- added %postun,
364- removed making buid logs,
365- removed "--inclededir", added "--enable-dynamic-linking" to configure
366  parameters,
367- added striping shared libs and /usr/bin/guile,
368- added "Requires: /bin/sh" (for guile-snarf) in guile package and
369  "Requires: m4" for guile-devel,
370- added macro %{PACKAGE_VERSION} in "Source:" and %files,
371- added %attr macros in %files.
Note: See TracBrowser for help on using the repository browser.