source: projects/specs/trunk/g/gtkwave/gtkwave-vl.spec @ 7305

Revision 7305, 14.0 KB checked in by iwaim, 11 years ago (diff)

gtkwave 3.3.31-2vl7

Line 
1Summary:        Waveform Viewer
2Summary(ja):    波形ビューワ
3Name:           gtkwave
4Version:        3.3.31
5Release:        2%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/Engineering
8URL:            http://gtkwave.sourceforge.net/
9Source0:        http://gtkwave.sourceforge.net/gtkwave-%{version}.tar.gz
10Source1:        gtkwave.desktop
11Source2:        gtkwave-16.png
12Source3:        gtkwave-32.png
13Source4:        gtkwave-48.png
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gtk2-devel
17BuildRequires:  bzip2-devel
18BuildRequires:  Judy-devel
19BuildRequires:  xz-devel
20BuildRequires:  zlib-devel
21BuildRequires:  gperf
22BuildRequires:  flex
23BuildRequires:  desktop-file-utils
24
25BuildRequires:  tk
26BuildRequires:  tcl >= 8.4
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30
31%description
32GTKWave is a waveform viewer that can view VCD files produced by most Verilog
33simulation tools, as well as LXT files produced by certain Verilog simulation
34tools.
35
36%prep
37%setup -q
38
39%build
40%configure \
41    --disable-dependency-tracking \
42    --disable-mime-update \
43    --enable-judy
44
45make %{?_smp_mflags}
46
47%install
48%{__rm} -rf %{buildroot}
49make install \
50    DESTDIR=%{buildroot} \
51    pkgdatadir=%{_docdir}/gtkwave-%{version} \
52    INSTALL="%{__install} -p"
53
54# Icons and desktop entry
55/usr/bin/desktop-file-install --vendor "" \
56    --dir %{buildroot}%{_datadir}/applications \
57    %{SOURCE1}
58%{__install} -D -m 644 -p %{SOURCE2} %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
59%{__install} -D -m 644 -p %{SOURCE3} %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
60%{__install} -D -m 644 -p %{SOURCE4} %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
61
62# Include extra docs
63for extradoc in \
64        ANALOG_README.TXT \
65        CHANGELOG.TXT \
66        GNU.TXT \
67        LICENSE.TXT \
68        MIT.TXT \
69        SYSTEMVERILOG_README.TXT
70do
71        %{__install} -p -m 644 ${extradoc} %{buildroot}%{_docdir}/gtkwave-%{version}/
72done
73
74%clean
75%{__rm} -rf %{buildroot}
76
77%post
78touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
79
80%postun
81if [ $1 -eq 0 ] ; then
82        touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
83        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
84fi
85
86%posttrans
87gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
88
89%files
90%defattr(-,root,root,-)
91%doc %{_docdir}/gtkwave-%{version}/
92%{_bindir}/evcd2vcd
93%{_bindir}/fst2vcd
94%{_bindir}/ghwdump
95%{_bindir}/gtkwave
96%{_bindir}/lxt2miner
97%{_bindir}/lxt2vcd
98%{_bindir}/rtlbrowse
99%{_bindir}/shmidcat
100%{_bindir}/twinwave
101%{_bindir}/vcd2fst
102%{_bindir}/vcd2lxt
103%{_bindir}/vcd2lxt2
104%{_bindir}/vcd2vzt
105%{_bindir}/vermin
106%{_bindir}/vzt2vcd
107%{_bindir}/vztminer
108%{_datadir}/applications/gtkwave.desktop
109%{_datadir}/icons/gnome/16x16/mimetypes/*.png
110%{_datadir}/icons/gnome/32x32/mimetypes/*.png
111%{_datadir}/icons/gnome/48x48/mimetypes/*.png
112%{_datadir}/icons/gtkwave_256x256x32.png
113%{_datadir}/icons/gtkwave_files_256x256x32.png
114%{_datadir}/icons/gtkwave_savefiles_256x256x32.png
115%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
116%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
117%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
118%{_datadir}/mime/packages/x-gtkwave-extension-*.xml
119%{_mandir}/man1/evcd2vcd.1*
120%{_mandir}/man1/fst2vcd.1*
121%{_mandir}/man1/ghwdump.1*
122%{_mandir}/man1/gtkwave.1*
123%{_mandir}/man1/lxt2miner.1*
124%{_mandir}/man1/lxt2vcd.1*
125%{_mandir}/man1/rtlbrowse.1*
126%{_mandir}/man1/shmidcat.1*
127%{_mandir}/man1/twinwave.1*
128%{_mandir}/man1/vcd2fst.1*
129%{_mandir}/man1/vcd2lxt.1*
130%{_mandir}/man1/vcd2lxt2.1*
131%{_mandir}/man1/vcd2vzt.1*
132%{_mandir}/man1/vermin.1*
133%{_mandir}/man1/vzt2vcd.1*
134%{_mandir}/man1/vztminer.1*
135%{_mandir}/man5/gtkwaverc.5*
136
137%changelog
138* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 3.3.31-2vl7
139- build with Tcl/Tk 8.5.7-1
140- add Vendor and Distribution tags
141
142* Sat Feb 11 2012 NAKAMURA Kenta <kenta@vinelinux.org> 3.3.31-1
143- update to 3.3.31
144
145* Tue Jun 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-4
146- BR: tk instead of /usr/include/tcl.h /usr/include/tk.h
147  (Thanks to takemikaduchi-san)
148
149* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-3
150- added --disable-xz at Vine Linux 5
151
152* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-2
153- Initial build for Vine Linux
154
155* Sun Jun  6 2010 Paul Howarth <paul@city-fan.org> 3.3.7-1
156- update to 3.3.7 (general bug and compiler warning fixes)
157- -n option not needed in desktop file
158
159* Tue May  4 2010 Paul Howarth <paul@city-fan.org> 3.3.6-1
160- update to 3.3.6 (see CHANGELOG.TXT for details)
161- add desktop file and icons based on Mandriva package
162- BR: desktop-file-utils
163- add scriptlets to update icon cache
164- no longer need to fix permissions of lzma wrapper code
165
166* Sat Mar 20 2010 Paul Howarth <paul@city-fan.org> 3.3.5-1
167- update to 3.3.5 (see CHANGELOG.TXT for details)
168- add Judy-devel buildreq for improved memory usage efficiency
169
170* Mon Mar  8 2010 Paul Howarth <paul@city-fan.org> 3.3.4-1
171- update to 3.3.4 (see CHANGELOG.TXT for details)
172
173* Fri Feb 19 2010 Paul Howarth <paul@city-fan.org> 3.3.3-1
174- update to 3.3.3
175- drop upstreamed dlopen linking patch
176- drop obsolete helper apps mvl2lxt, mvl2vcd, tex2vcd and tla2vcd
177
178* Mon Feb 15 2010 Paul Howarth <paul@city-fan.org> 3.3.2-2
179- fix FTBFS due to missing -ldl linking for dlopen function (#565173)
180
181* Tue Jan  5 2010 Paul Howarth <paul@city-fan.org> 3.3.2-1
182- update to 3.3.2 (speed up operation on networked filesystems)
183
184* Sat Dec 26 2009 Paul Howarth <paul@city-fan.org> 3.3.0-1
185- update to 3.3.0
186- added tk support
187- bundled old liblzma replaced by system xz (add BR: xz-devel)
188- tcl/tk support require Fedora >= 2 or RHEL >= 4 (tcl 8.4)
189
190* Fri Sep  4 2009 Paul Howarth <paul@city-fan.org> 3.2.3-1
191- update to 3.2.3
192- fix permissions in bundled liblzma for debuginfo
193
194* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-3
195- drop patch for #515672, not needed with gcc 4.4.1-4
196
197* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-2
198- add patch to work around #515672 (internal compiler error on PPC)
199
200* Wed Aug  5 2009 Paul Howarth <paul@city-fan.org> 3.2.2-1
201- update to 3.2.2 (new tools evcd2vcd/fst2vcd/vcd2fst)
202- drop print-to-file patch, no longer needed
203
204* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2.1
205- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
206
207* Wed Jul 15 2009 Paul Howarth <paul@city-fan.org> 3.2.1-2
208- add upstream patch for crash on print to file (#511858)
209
210* Tue Apr 14 2009 Paul Howarth <paul@city-fan.org> 3.2.1-1
211- update to 3.2.1
212
213* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 3.2.0-1.1
214- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
215
216* Tue Feb 17 2009 Paul Howarth <paul@city-fan.org> 3.2.0-1
217- update to 3.2.0
218
219* Mon Feb  2 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.2.RC5
220- update to 3.2.0RC5
221
222* Fri Jan 29 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.1.RC4
223- update to 3.2.0RC4 (#481264)
224- new upstream URLs
225- buildreq /usr/include/tcl.h for embedded tcl support
226
227* Thu Aug 21 2008 Paul Howarth <paul@city-fan.org> 3.1.13-1
228- update to 3.1.13
229
230* Mon Jul 14 2008 Paul Howarth <paul@city-fan.org> 3.1.12-1
231- update to 3.1.12
232
233* Thu Jun 19 2008 Paul Howarth <paul@city-fan.org> 3.1.11-1
234- update to 3.1.11
235
236* Thu May 15 2008 Paul Howarth <paul@city-fan.org> 3.1.10-1
237- update to 3.1.10
238
239* Tue Apr 22 2008 Paul Howarth <paul@city-fan.org> 3.1.9-1
240- update to 3.1.9
241
242* Mon Apr  7 2008 Paul Howarth <paul@city-fan.org> 3.1.8-1
243- update to 3.1.8
244
245* Tue Mar 25 2008 Paul Howarth <paul@city-fan.org> 3.1.7-1
246- update to 3.1.7
247
248* Wed Feb 27 2008 Paul Howarth <paul@city-fan.org> 3.1.6-1
249- update to 3.1.6
250
251* Fri Feb  1 2008 Paul Howarth <paul@city-fan.org> 3.1.4-1
252- update to 3.1.4
253
254* Tue Jan 15 2008 Paul Howarth <paul@city-fan.org> 3.1.3-1
255- update to 3.1.3
256
257* Wed Jan  2 2008 Paul Howarth <paul@city-fan.org> 3.1.2-1
258- update to 3.1.2
259
260* Fri Sep 28 2007 Paul Howarth <paul@city-fan.org> 3.1.1-1
261- update to 3.1.1
262
263* Tue Sep  4 2007 Paul Howarth <paul@city-fan.org> 3.1.0-1
264- update to 3.1.0
265
266* Fri Aug 24 2007 Paul Howarth <paul@city-fan.org> 3.0.30-3
267- clarify license as GPL, version 2 or later
268
269* Fri Jul 27 2007 Paul Howarth <paul@city-fan.org> 3.0.30-1
270- update to 3.0.30
271
272* Fri Jun  8 2007 Paul Howarth <paul@city-fan.org> 3.0.29-1
273- update to 3.0.29
274- spec file much-simplified as gtkwave is now fully autotooled
275- try to retain upstream timestamps as far as possible
276- use parallel make
277
278* Tue May  1 2007 Paul Howarth <paul@city-fan.org> 3.0.28-1
279- update to 3.0.28
280- update source URL to master source
281
282* Mon Apr 30 2007 Paul Howarth <paul@city-fan.org> 3.0.27-1
283- update to 3.0.27
284- rename "vertex" to "vermin" to avoid conflict with Vertex 3D Model Assembler
285  (http://wolfpack.twu.net/Vertex/index.html)
286
287* Fri Apr 20 2007 Paul Howarth <paul@city-fan.org> 3.0.26-1
288- update to 3.0.26
289
290* Wed Apr 11 2007 Paul Howarth <paul@city-fan.org> 3.0.25-1
291- update to 3.0.25
292
293* Thu Apr  5 2007 Paul Howarth <paul@city-fan.org> 3.0.24-1
294- update to 3.0.24
295
296* Tue Mar 20 2007 Paul Howarth <paul@city-fan.org> 3.0.23-1
297- update to 3.0.23
298
299* Mon Feb 26 2007 Paul Howarth <paul@city-fan.org> 3.0.22-1
300- update to 3.0.22
301
302* Mon Feb  5 2007 Paul Howarth <paul@city-fan.org> 3.0.21-1
303- update to 3.0.21
304
305* Wed Jan 24 2007 Paul Howarth <paul@city-fan.org> 3.0.20-1
306- update to 3.0.20
307
308* Tue Jan  2 2007 Paul Howarth <paul@city-fan.org> 3.0.19-1
309- update to 3.0.19
310
311* Tue Dec  5 2006 Paul Howarth <paul@city-fan.org> 3.0.18-1
312- update to 3.0.18
313
314* Tue Nov 28 2006 Paul Howarth <paul@city-fan.org> 3.0.17-1
315- update to 3.0.17
316
317* Tue Nov 14 2006 Paul Howarth <paul@city-fan.org> 3.0.16-1
318- update to 3.0.16
319
320* Mon Oct 30 2006 Paul Howarth <paul@city-fan.org> 3.0.15-1
321- update to 3.0.15
322
323* Wed Oct 18 2006 Paul Howarth <paul@city-fan.org> 3.0.14-1
324- update to 3.0.14
325
326* Mon Oct  9 2006 Paul Howarth <paul@city-fan.org> 3.0.13-1
327- update to 3.0.13
328
329* Tue Oct  3 2006 Paul Howarth <paul@city-fan.org> 3.0.12-2
330- rebuilt for unwind info generation, broken in gcc-4.1.1-21
331
332* Fri Sep 22 2006 Paul Howarth <paul@city-fan.org> 3.0.12-1
333- update to 3.0.12
334- create dummy libz/libbz2 Makefile.in files to ensure that config.h gets
335  generated
336
337* Thu Sep 14 2006 Paul Howarth <paul@city-fan.org> 3.0.11-1
338- update to 3.0.11
339
340* Mon Aug 21 2006 Paul Howarth <paul@city-fan.org> 3.0.10-1
341- update to 3.0.10
342
343* Fri Aug 11 2006 Paul Howarth <paul@city-fan.org> 3.0.9-1
344- update to 3.0.9
345- tarball is now .tar.gz rather than .tgz
346
347* Mon Aug  7 2006 Paul Howarth <paul@city-fan.org> 3.0.8-1
348- update to 3.0.8
349- new program and manpage: shmidcat
350
351* Fri Jul 21 2006 Paul Howarth <paul@city-fan.org> 3.0.7-1
352- update to 3.0.7
353- new program and manpage: twinwave
354
355* Mon Jul 17 2006 Paul Howarth <paul@city-fan.org> 3.0.6-1
356- update to 3.0.6
357
358* Wed Jun 28 2006 Paul Howarth <paul@city-fan.org> 3.0.5-1
359- update to 3.0.5
360- new program and manpage: ghwdump
361
362* Fri Jun  2 2006 Paul Howarth <paul@city-fan.org> 3.0.4-1
363- update to 3.0.4
364
365* Tue May 30 2006 Paul Howarth <paul@city-fan.org> 3.0.3-1
366- update to 3.0.3
367
368* Sun May 28 2006 Paul Howarth <paul@city-fan.org> 3.0.2-2
369- adding missing buildreq flex
370
371* Wed May 10 2006 Paul Howarth <paul@city-fan.org> 3.0.2-1
372- update to 3.0.2
373
374* Tue May  9 2006 Paul Howarth <paul@city-fan.org> 3.0.1-1
375- update to 3.0.1
376
377* Tue May  2 2006 Paul Howarth <paul@city-fan.org> 3.0.0-1
378- update to 3.0.0
379- add examples directory as %%doc
380- add new buildreq gperf
381- tweak Makefile.in edits to handle Makefiles under contrib/
382- add new binaries rtlbrowse and vertex
383- add new manpages for rtlbrowse, vertex, and gtkwaverc
384- %%{_mandir} no longer needs to be created manually
385- configure script now accepts --libdir
386
387* Tue Mar  7 2006 Paul Howarth <paul@city-fan.org> 1.3.86-1
388- update to 1.3.86
389
390* Mon Feb 27 2006 Paul Howarth <paul@city-fan.org> 1.3.85-1
391- update to 1.3.85
392
393* Tue Feb 21 2006 Paul Howarth <paul@city-fan.org> 1.3.84-1
394- update to 1.3.84
395- INSTALL now called INSTALL.TXT
396
397* Thu Feb 16 2006 Paul Howarth <paul@city-fan.org> 1.3.83-2
398- rebuild
399
400* Tue Jan 31 2006 Paul Howarth <paul@city-fan.org> 1.3.83-1
401- update to 1.3.83
402
403* Thu Jan 19 2006 Paul Howarth <paul@city-fan.org> 1.3.82-1
404- update to 1.3.82
405
406* Tue Dec 13 2005 Paul Howarth <paul@city-fan.org> 1.3.81-1
407- update to 1.3.81
408
409* Sun Nov 27 2005 Paul Howarth <paul@city-fan.org> 1.3.80-1
410- update to 1.3.80
411
412* Wed Nov 23 2005 Paul Howarth <paul@city-fan.org> 1.3.79-2
413- fix file permissions in debuginfo package
414
415* Mon Nov 21 2005 Paul Howarth <paul@city-fan.org> 1.3.79-1
416- update to 1.3.79
417
418* Wed Nov  9 2005 Paul Howarth <paul@city-fan.org> 1.3.78-1
419- update to 1.3.78
420
421* Tue Nov  8 2005 Paul Howarth <paul@city-fan.org> 1.3.77-1
422- update to 1.3.77
423- GHDL ghw support now included upstream, so remove patches
424
425* Mon Nov  7 2005 Paul Howarth <paul@city-fan.org> 1.3.76-3
426- clean up for Fedora Extras:
427  - don't support GTK1 builds
428  - unconditionally remove buildroot in %%clean and %%install
429  - remove redundant glib2-devel buildreq
430  - add dist tag
431
432* Mon Nov  7 2005 Thomas Sailer <t.sailer@alumni.ethz.ch> - 1.3.76-2
433- add GHDL ghw support
434
435* Thu Oct 27 2005 Paul Howarth <paul@city-fan.org> 1.3.76-1
436- update to 1.3.76
437
438* Thu Oct 13 2005 Paul Howarth <paul@city-fan.org> 1.3.73-1
439- update to 1.3.73
440
441* Mon Oct 10 2005 Paul Howarth <paul@city-fan.org> 1.3.72-1
442- update to 1.3.72
443
444* Fri Oct  7 2005 Paul Howarth <paul@city-fan.org> 1.3.71-1
445- update to 1.3.71
446
447* Thu Sep 15 2005 Paul Howarth <paul@city-fan.org> 1.3.70-1
448- update to 1.3.70
449- new program tla2vcd (with manpage)
450
451* Mon Sep  5 2005 Paul Howarth <paul@city-fan.org> 1.3.69-1
452- update to 1.3.69
453- honour %%{optflags}
454- use system bzip and zlib libraries
455
456* Fri Sep  2 2005 Paul Howarth <paul@city-fan.org> 1.3.68-1
457- update to 1.3.68
458
459* Wed Aug 25 2005 Paul Howarth <paul@city-fan.org> 1.3.67-1
460- update to 1.3.67
461
462* Wed Aug 10 2005 Paul Howarth <paul@city-fan.org> 1.3.64-1
463- update to 1.3.64
464- new programs lxt2miner & vztminer (with manpages)
465
466* Tue Jul 26 2005 Paul Howarth <paul@city-fan.org> 1.3.63-1
467- update to 1.3.63
468
469* Mon Jul 11 2005 Paul Howarth <paul@city-fan.org> 1.3.62-1
470- update to 1.3.62
471
472* Thu Apr 21 2005 Paul Howarth <paul@city-fan.org> 1.3.58-1
473- update to 1.3.58
474- include sample .gtkwaverc in doc area
475- update URL to point to new project home page
476
477* Wed Apr 13 2005 Paul Howarth <paul@city-fan.org> 1.3.57-1
478- update to 1.3.57
479- add support for building with gtk version 1 (build using: --without gtk2)
480
481* Tue Apr 12 2005 Paul Howarth <paul@city-fan.org> 1.3.56-1
482- initial RPM build
Note: See TracBrowser for help on using the repository browser.