source: projects/specs/trunk/g/gtkwave/gtkwave-vl.spec @ 10784

Revision 10784, 14.4 KB checked in by ara_t, 8 years ago (diff)

gauche 0.9.5-1

Line 
1Summary:        Waveform Viewer
2Summary(ja):    波形ビューワ
3Name:           gtkwave
4Version:        3.3.64
5Release:        3%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/Engineering
8URL:            http://gtkwave.sourceforge.net/
9Source0:        http://gtkwave.sourceforge.net/gtkwave-%{version}.tar.gz
10Source1:        gtkwave.desktop
11Source2:        gtkwave-16.png
12Source3:        gtkwave-32.png
13Source4:        gtkwave-48.png
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gtk2-devel
17BuildRequires:  bzip2-devel
18BuildRequires:  Judy-devel
19BuildRequires:  xz-devel
20BuildRequires:  zlib-devel
21BuildRequires:  gperf
22BuildRequires:  flex
23BuildRequires:  desktop-file-utils
24
25BuildRequires:  tk-devel
26BuildRequires:  tcl-devel >= 8.4
27
28Requires:       electronics-menu
29
30Vendor:         Project Vine
31Distribution:   Vine Linux
32
33%description
34GTKWave is a waveform viewer that can view VCD files produced by most Verilog
35simulation tools, as well as LXT files produced by certain Verilog simulation
36tools.
37
38%prep
39%setup -q
40
41%build
42%configure \
43    --disable-dependency-tracking \
44    --disable-mime-update \
45    --enable-judy
46
47make %{?_smp_mflags}
48
49%install
50%{__rm} -rf %{buildroot}
51make install \
52    DESTDIR=%{buildroot} \
53    pkgdatadir=%{_docdir}/gtkwave-%{version} \
54    INSTALL="%{__install} -p"
55
56# Icons and desktop entry
57/usr/bin/desktop-file-install --vendor "" \
58    --dir %{buildroot}%{_datadir}/applications \
59    %{SOURCE1}
60%{__install} -D -m 644 -p %{SOURCE2} %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
61%{__install} -D -m 644 -p %{SOURCE3} %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
62%{__install} -D -m 644 -p %{SOURCE4} %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
63
64# docs_to_include
65rm -rf docs_to_include
66mkdir -p docs_to_include
67mv %{buildroot}%{_docdir}/gtkwave-%{version}/* docs_to_include
68
69%clean
70%{__rm} -rf %{buildroot}
71
72%post
73touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
74
75%postun
76if [ $1 -eq 0 ] ; then
77        touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
78        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
79fi
80
81%posttrans
82gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
83
84%files
85%defattr(-,root,root,-)
86%doc AUTHORS COPYING ChangeLog LICENSE.TXT README
87%doc docs_to_include/*
88%{_bindir}/evcd2vcd
89%{_bindir}/fst2vcd
90%{_bindir}/fstminer
91%{_bindir}/ghwdump
92%{_bindir}/gtkwave
93%{_bindir}/lxt2miner
94%{_bindir}/lxt2vcd
95%{_bindir}/rtlbrowse
96%{_bindir}/shmidcat
97%{_bindir}/twinwave
98%{_bindir}/vcd2fst
99%{_bindir}/vcd2lxt
100%{_bindir}/vcd2lxt2
101%{_bindir}/vcd2vzt
102%{_bindir}/vermin
103%{_bindir}/vzt2vcd
104%{_bindir}/vztminer
105%{_datadir}/applications/gtkwave.desktop
106%{_datadir}/icons/gnome/16x16/mimetypes/*.png
107%{_datadir}/icons/gnome/32x32/mimetypes/*.png
108%{_datadir}/icons/gnome/48x48/mimetypes/*.png
109%{_datadir}/icons/gtkwave_256x256x32.png
110%{_datadir}/icons/gtkwave_files_256x256x32.png
111%{_datadir}/icons/gtkwave_savefiles_256x256x32.png
112%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
113%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
114%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
115%{_datadir}/mime/packages/x-gtkwave-extension-*.xml
116%{_mandir}/man1/evcd2vcd.1*
117%{_mandir}/man1/fst2vcd.1*
118%{_mandir}/man1/fstminer.1*
119%{_mandir}/man1/ghwdump.1*
120%{_mandir}/man1/gtkwave.1*
121%{_mandir}/man1/lxt2miner.1*
122%{_mandir}/man1/lxt2vcd.1*
123%{_mandir}/man1/rtlbrowse.1*
124%{_mandir}/man1/shmidcat.1*
125%{_mandir}/man1/twinwave.1*
126%{_mandir}/man1/vcd2fst.1*
127%{_mandir}/man1/vcd2lxt.1*
128%{_mandir}/man1/vcd2lxt2.1*
129%{_mandir}/man1/vcd2vzt.1*
130%{_mandir}/man1/vermin.1*
131%{_mandir}/man1/vzt2vcd.1*
132%{_mandir}/man1/vztminer.1*
133%{_mandir}/man5/gtkwaverc.5*
134
135%changelog
136* Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> 3.3.64-3
137- rebuild with gcc-5.4.0
138
139* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.64-2
140- rebuild with gcc-5.4.0
141
142* Wed Feb 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.3.64-1
143- updated to 3.3.64
144- used BR: tcl-devel, tk-devel instead of tcl, tk
145- added R: electronics-menu
146
147* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 3.3.31-2vl7
148- build with Tcl/Tk 8.5.7-1
149- add Vendor and Distribution tags
150
151* Sat Feb 11 2012 NAKAMURA Kenta <kenta@vinelinux.org> 3.3.31-1
152- update to 3.3.31
153
154* Tue Jun 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-4
155- BR: tk instead of /usr/include/tcl.h /usr/include/tk.h
156  (Thanks to takemikaduchi-san)
157
158* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-3
159- added --disable-xz at Vine Linux 5
160
161* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-2
162- Initial build for Vine Linux
163
164* Sun Jun  6 2010 Paul Howarth <paul@city-fan.org> 3.3.7-1
165- update to 3.3.7 (general bug and compiler warning fixes)
166- -n option not needed in desktop file
167
168* Tue May  4 2010 Paul Howarth <paul@city-fan.org> 3.3.6-1
169- update to 3.3.6 (see CHANGELOG.TXT for details)
170- add desktop file and icons based on Mandriva package
171- BR: desktop-file-utils
172- add scriptlets to update icon cache
173- no longer need to fix permissions of lzma wrapper code
174
175* Sat Mar 20 2010 Paul Howarth <paul@city-fan.org> 3.3.5-1
176- update to 3.3.5 (see CHANGELOG.TXT for details)
177- add Judy-devel buildreq for improved memory usage efficiency
178
179* Mon Mar  8 2010 Paul Howarth <paul@city-fan.org> 3.3.4-1
180- update to 3.3.4 (see CHANGELOG.TXT for details)
181
182* Fri Feb 19 2010 Paul Howarth <paul@city-fan.org> 3.3.3-1
183- update to 3.3.3
184- drop upstreamed dlopen linking patch
185- drop obsolete helper apps mvl2lxt, mvl2vcd, tex2vcd and tla2vcd
186
187* Mon Feb 15 2010 Paul Howarth <paul@city-fan.org> 3.3.2-2
188- fix FTBFS due to missing -ldl linking for dlopen function (#565173)
189
190* Tue Jan  5 2010 Paul Howarth <paul@city-fan.org> 3.3.2-1
191- update to 3.3.2 (speed up operation on networked filesystems)
192
193* Sat Dec 26 2009 Paul Howarth <paul@city-fan.org> 3.3.0-1
194- update to 3.3.0
195- added tk support
196- bundled old liblzma replaced by system xz (add BR: xz-devel)
197- tcl/tk support require Fedora >= 2 or RHEL >= 4 (tcl 8.4)
198
199* Fri Sep  4 2009 Paul Howarth <paul@city-fan.org> 3.2.3-1
200- update to 3.2.3
201- fix permissions in bundled liblzma for debuginfo
202
203* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-3
204- drop patch for #515672, not needed with gcc 4.4.1-4
205
206* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-2
207- add patch to work around #515672 (internal compiler error on PPC)
208
209* Wed Aug  5 2009 Paul Howarth <paul@city-fan.org> 3.2.2-1
210- update to 3.2.2 (new tools evcd2vcd/fst2vcd/vcd2fst)
211- drop print-to-file patch, no longer needed
212
213* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2.1
214- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
215
216* Wed Jul 15 2009 Paul Howarth <paul@city-fan.org> 3.2.1-2
217- add upstream patch for crash on print to file (#511858)
218
219* Tue Apr 14 2009 Paul Howarth <paul@city-fan.org> 3.2.1-1
220- update to 3.2.1
221
222* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 3.2.0-1.1
223- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
224
225* Tue Feb 17 2009 Paul Howarth <paul@city-fan.org> 3.2.0-1
226- update to 3.2.0
227
228* Mon Feb  2 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.2.RC5
229- update to 3.2.0RC5
230
231* Fri Jan 29 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.1.RC4
232- update to 3.2.0RC4 (#481264)
233- new upstream URLs
234- buildreq /usr/include/tcl.h for embedded tcl support
235
236* Thu Aug 21 2008 Paul Howarth <paul@city-fan.org> 3.1.13-1
237- update to 3.1.13
238
239* Mon Jul 14 2008 Paul Howarth <paul@city-fan.org> 3.1.12-1
240- update to 3.1.12
241
242* Thu Jun 19 2008 Paul Howarth <paul@city-fan.org> 3.1.11-1
243- update to 3.1.11
244
245* Thu May 15 2008 Paul Howarth <paul@city-fan.org> 3.1.10-1
246- update to 3.1.10
247
248* Tue Apr 22 2008 Paul Howarth <paul@city-fan.org> 3.1.9-1
249- update to 3.1.9
250
251* Mon Apr  7 2008 Paul Howarth <paul@city-fan.org> 3.1.8-1
252- update to 3.1.8
253
254* Tue Mar 25 2008 Paul Howarth <paul@city-fan.org> 3.1.7-1
255- update to 3.1.7
256
257* Wed Feb 27 2008 Paul Howarth <paul@city-fan.org> 3.1.6-1
258- update to 3.1.6
259
260* Fri Feb  1 2008 Paul Howarth <paul@city-fan.org> 3.1.4-1
261- update to 3.1.4
262
263* Tue Jan 15 2008 Paul Howarth <paul@city-fan.org> 3.1.3-1
264- update to 3.1.3
265
266* Wed Jan  2 2008 Paul Howarth <paul@city-fan.org> 3.1.2-1
267- update to 3.1.2
268
269* Fri Sep 28 2007 Paul Howarth <paul@city-fan.org> 3.1.1-1
270- update to 3.1.1
271
272* Tue Sep  4 2007 Paul Howarth <paul@city-fan.org> 3.1.0-1
273- update to 3.1.0
274
275* Fri Aug 24 2007 Paul Howarth <paul@city-fan.org> 3.0.30-3
276- clarify license as GPL, version 2 or later
277
278* Fri Jul 27 2007 Paul Howarth <paul@city-fan.org> 3.0.30-1
279- update to 3.0.30
280
281* Fri Jun  8 2007 Paul Howarth <paul@city-fan.org> 3.0.29-1
282- update to 3.0.29
283- spec file much-simplified as gtkwave is now fully autotooled
284- try to retain upstream timestamps as far as possible
285- use parallel make
286
287* Tue May  1 2007 Paul Howarth <paul@city-fan.org> 3.0.28-1
288- update to 3.0.28
289- update source URL to master source
290
291* Mon Apr 30 2007 Paul Howarth <paul@city-fan.org> 3.0.27-1
292- update to 3.0.27
293- rename "vertex" to "vermin" to avoid conflict with Vertex 3D Model Assembler
294  (http://wolfpack.twu.net/Vertex/index.html)
295
296* Fri Apr 20 2007 Paul Howarth <paul@city-fan.org> 3.0.26-1
297- update to 3.0.26
298
299* Wed Apr 11 2007 Paul Howarth <paul@city-fan.org> 3.0.25-1
300- update to 3.0.25
301
302* Thu Apr  5 2007 Paul Howarth <paul@city-fan.org> 3.0.24-1
303- update to 3.0.24
304
305* Tue Mar 20 2007 Paul Howarth <paul@city-fan.org> 3.0.23-1
306- update to 3.0.23
307
308* Mon Feb 26 2007 Paul Howarth <paul@city-fan.org> 3.0.22-1
309- update to 3.0.22
310
311* Mon Feb  5 2007 Paul Howarth <paul@city-fan.org> 3.0.21-1
312- update to 3.0.21
313
314* Wed Jan 24 2007 Paul Howarth <paul@city-fan.org> 3.0.20-1
315- update to 3.0.20
316
317* Tue Jan  2 2007 Paul Howarth <paul@city-fan.org> 3.0.19-1
318- update to 3.0.19
319
320* Tue Dec  5 2006 Paul Howarth <paul@city-fan.org> 3.0.18-1
321- update to 3.0.18
322
323* Tue Nov 28 2006 Paul Howarth <paul@city-fan.org> 3.0.17-1
324- update to 3.0.17
325
326* Tue Nov 14 2006 Paul Howarth <paul@city-fan.org> 3.0.16-1
327- update to 3.0.16
328
329* Mon Oct 30 2006 Paul Howarth <paul@city-fan.org> 3.0.15-1
330- update to 3.0.15
331
332* Wed Oct 18 2006 Paul Howarth <paul@city-fan.org> 3.0.14-1
333- update to 3.0.14
334
335* Mon Oct  9 2006 Paul Howarth <paul@city-fan.org> 3.0.13-1
336- update to 3.0.13
337
338* Tue Oct  3 2006 Paul Howarth <paul@city-fan.org> 3.0.12-2
339- rebuilt for unwind info generation, broken in gcc-4.1.1-21
340
341* Fri Sep 22 2006 Paul Howarth <paul@city-fan.org> 3.0.12-1
342- update to 3.0.12
343- create dummy libz/libbz2 Makefile.in files to ensure that config.h gets
344  generated
345
346* Thu Sep 14 2006 Paul Howarth <paul@city-fan.org> 3.0.11-1
347- update to 3.0.11
348
349* Mon Aug 21 2006 Paul Howarth <paul@city-fan.org> 3.0.10-1
350- update to 3.0.10
351
352* Fri Aug 11 2006 Paul Howarth <paul@city-fan.org> 3.0.9-1
353- update to 3.0.9
354- tarball is now .tar.gz rather than .tgz
355
356* Mon Aug  7 2006 Paul Howarth <paul@city-fan.org> 3.0.8-1
357- update to 3.0.8
358- new program and manpage: shmidcat
359
360* Fri Jul 21 2006 Paul Howarth <paul@city-fan.org> 3.0.7-1
361- update to 3.0.7
362- new program and manpage: twinwave
363
364* Mon Jul 17 2006 Paul Howarth <paul@city-fan.org> 3.0.6-1
365- update to 3.0.6
366
367* Wed Jun 28 2006 Paul Howarth <paul@city-fan.org> 3.0.5-1
368- update to 3.0.5
369- new program and manpage: ghwdump
370
371* Fri Jun  2 2006 Paul Howarth <paul@city-fan.org> 3.0.4-1
372- update to 3.0.4
373
374* Tue May 30 2006 Paul Howarth <paul@city-fan.org> 3.0.3-1
375- update to 3.0.3
376
377* Sun May 28 2006 Paul Howarth <paul@city-fan.org> 3.0.2-2
378- adding missing buildreq flex
379
380* Wed May 10 2006 Paul Howarth <paul@city-fan.org> 3.0.2-1
381- update to 3.0.2
382
383* Tue May  9 2006 Paul Howarth <paul@city-fan.org> 3.0.1-1
384- update to 3.0.1
385
386* Tue May  2 2006 Paul Howarth <paul@city-fan.org> 3.0.0-1
387- update to 3.0.0
388- add examples directory as %%doc
389- add new buildreq gperf
390- tweak Makefile.in edits to handle Makefiles under contrib/
391- add new binaries rtlbrowse and vertex
392- add new manpages for rtlbrowse, vertex, and gtkwaverc
393- %%{_mandir} no longer needs to be created manually
394- configure script now accepts --libdir
395
396* Tue Mar  7 2006 Paul Howarth <paul@city-fan.org> 1.3.86-1
397- update to 1.3.86
398
399* Mon Feb 27 2006 Paul Howarth <paul@city-fan.org> 1.3.85-1
400- update to 1.3.85
401
402* Tue Feb 21 2006 Paul Howarth <paul@city-fan.org> 1.3.84-1
403- update to 1.3.84
404- INSTALL now called INSTALL.TXT
405
406* Thu Feb 16 2006 Paul Howarth <paul@city-fan.org> 1.3.83-2
407- rebuild
408
409* Tue Jan 31 2006 Paul Howarth <paul@city-fan.org> 1.3.83-1
410- update to 1.3.83
411
412* Thu Jan 19 2006 Paul Howarth <paul@city-fan.org> 1.3.82-1
413- update to 1.3.82
414
415* Tue Dec 13 2005 Paul Howarth <paul@city-fan.org> 1.3.81-1
416- update to 1.3.81
417
418* Sun Nov 27 2005 Paul Howarth <paul@city-fan.org> 1.3.80-1
419- update to 1.3.80
420
421* Wed Nov 23 2005 Paul Howarth <paul@city-fan.org> 1.3.79-2
422- fix file permissions in debuginfo package
423
424* Mon Nov 21 2005 Paul Howarth <paul@city-fan.org> 1.3.79-1
425- update to 1.3.79
426
427* Wed Nov  9 2005 Paul Howarth <paul@city-fan.org> 1.3.78-1
428- update to 1.3.78
429
430* Tue Nov  8 2005 Paul Howarth <paul@city-fan.org> 1.3.77-1
431- update to 1.3.77
432- GHDL ghw support now included upstream, so remove patches
433
434* Mon Nov  7 2005 Paul Howarth <paul@city-fan.org> 1.3.76-3
435- clean up for Fedora Extras:
436  - don't support GTK1 builds
437  - unconditionally remove buildroot in %%clean and %%install
438  - remove redundant glib2-devel buildreq
439  - add dist tag
440
441* Mon Nov  7 2005 Thomas Sailer <t.sailer@alumni.ethz.ch> - 1.3.76-2
442- add GHDL ghw support
443
444* Thu Oct 27 2005 Paul Howarth <paul@city-fan.org> 1.3.76-1
445- update to 1.3.76
446
447* Thu Oct 13 2005 Paul Howarth <paul@city-fan.org> 1.3.73-1
448- update to 1.3.73
449
450* Mon Oct 10 2005 Paul Howarth <paul@city-fan.org> 1.3.72-1
451- update to 1.3.72
452
453* Fri Oct  7 2005 Paul Howarth <paul@city-fan.org> 1.3.71-1
454- update to 1.3.71
455
456* Thu Sep 15 2005 Paul Howarth <paul@city-fan.org> 1.3.70-1
457- update to 1.3.70
458- new program tla2vcd (with manpage)
459
460* Mon Sep  5 2005 Paul Howarth <paul@city-fan.org> 1.3.69-1
461- update to 1.3.69
462- honour %%{optflags}
463- use system bzip and zlib libraries
464
465* Fri Sep  2 2005 Paul Howarth <paul@city-fan.org> 1.3.68-1
466- update to 1.3.68
467
468* Wed Aug 25 2005 Paul Howarth <paul@city-fan.org> 1.3.67-1
469- update to 1.3.67
470
471* Wed Aug 10 2005 Paul Howarth <paul@city-fan.org> 1.3.64-1
472- update to 1.3.64
473- new programs lxt2miner & vztminer (with manpages)
474
475* Tue Jul 26 2005 Paul Howarth <paul@city-fan.org> 1.3.63-1
476- update to 1.3.63
477
478* Mon Jul 11 2005 Paul Howarth <paul@city-fan.org> 1.3.62-1
479- update to 1.3.62
480
481* Thu Apr 21 2005 Paul Howarth <paul@city-fan.org> 1.3.58-1
482- update to 1.3.58
483- include sample .gtkwaverc in doc area
484- update URL to point to new project home page
485
486* Wed Apr 13 2005 Paul Howarth <paul@city-fan.org> 1.3.57-1
487- update to 1.3.57
488- add support for building with gtk version 1 (build using: --without gtk2)
489
490* Tue Apr 12 2005 Paul Howarth <paul@city-fan.org> 1.3.56-1
491- initial RPM build
Note: See TracBrowser for help on using the repository browser.