source: projects/specs/trunk/g/gtkwave/gtkwave-vl.spec @ 5619

Revision 5619, 13.9 KB checked in by kenta, 12 years ago (diff)

gtkwave: update to 3.3.31

Line 
1Summary:        Waveform Viewer
2Summary(ja):    波形ビューワ
3Name:           gtkwave
4Version:        3.3.31
5Release:        1%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/Engineering
8URL:            http://gtkwave.sourceforge.net/
9Source0:        http://gtkwave.sourceforge.net/gtkwave-%{version}.tar.gz
10Source1:        gtkwave.desktop
11Source2:        gtkwave-16.png
12Source3:        gtkwave-32.png
13Source4:        gtkwave-48.png
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gtk2-devel
17BuildRequires:  bzip2-devel
18BuildRequires:  Judy-devel
19BuildRequires:  xz-devel
20BuildRequires:  zlib-devel
21BuildRequires:  gperf
22BuildRequires:  flex
23BuildRequires:  desktop-file-utils
24
25BuildRequires:  tk
26BuildRequires:  tcl >= 8.4
27
28%description
29GTKWave is a waveform viewer that can view VCD files produced by most Verilog
30simulation tools, as well as LXT files produced by certain Verilog simulation
31tools.
32
33%prep
34%setup -q
35
36%build
37%configure \
38    --disable-dependency-tracking \
39    --disable-mime-update \
40    --enable-judy
41
42make %{?_smp_mflags}
43
44%install
45%{__rm} -rf %{buildroot}
46make install \
47    DESTDIR=%{buildroot} \
48    pkgdatadir=%{_docdir}/gtkwave-%{version} \
49    INSTALL="%{__install} -p"
50
51# Icons and desktop entry
52/usr/bin/desktop-file-install --vendor "" \
53    --dir %{buildroot}%{_datadir}/applications \
54    %{SOURCE1}
55%{__install} -D -m 644 -p %{SOURCE2} %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
56%{__install} -D -m 644 -p %{SOURCE3} %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
57%{__install} -D -m 644 -p %{SOURCE4} %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
58
59# Include extra docs
60for extradoc in \
61        ANALOG_README.TXT \
62        CHANGELOG.TXT \
63        GNU.TXT \
64        LICENSE.TXT \
65        MIT.TXT \
66        SYSTEMVERILOG_README.TXT
67do
68        %{__install} -p -m 644 ${extradoc} %{buildroot}%{_docdir}/gtkwave-%{version}/
69done
70
71%clean
72%{__rm} -rf %{buildroot}
73
74%post
75touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
76
77%postun
78if [ $1 -eq 0 ] ; then
79        touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
80        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
81fi
82
83%posttrans
84gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
85
86%files
87%defattr(-,root,root,-)
88%doc %{_docdir}/gtkwave-%{version}/
89%{_bindir}/evcd2vcd
90%{_bindir}/fst2vcd
91%{_bindir}/ghwdump
92%{_bindir}/gtkwave
93%{_bindir}/lxt2miner
94%{_bindir}/lxt2vcd
95%{_bindir}/rtlbrowse
96%{_bindir}/shmidcat
97%{_bindir}/twinwave
98%{_bindir}/vcd2fst
99%{_bindir}/vcd2lxt
100%{_bindir}/vcd2lxt2
101%{_bindir}/vcd2vzt
102%{_bindir}/vermin
103%{_bindir}/vzt2vcd
104%{_bindir}/vztminer
105%{_datadir}/applications/gtkwave.desktop
106%{_datadir}/icons/gnome/16x16/mimetypes/*.png
107%{_datadir}/icons/gnome/32x32/mimetypes/*.png
108%{_datadir}/icons/gnome/48x48/mimetypes/*.png
109%{_datadir}/icons/gtkwave_256x256x32.png
110%{_datadir}/icons/gtkwave_files_256x256x32.png
111%{_datadir}/icons/gtkwave_savefiles_256x256x32.png
112%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
113%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
114%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
115%{_datadir}/mime/packages/x-gtkwave-extension-*.xml
116%{_mandir}/man1/evcd2vcd.1*
117%{_mandir}/man1/fst2vcd.1*
118%{_mandir}/man1/ghwdump.1*
119%{_mandir}/man1/gtkwave.1*
120%{_mandir}/man1/lxt2miner.1*
121%{_mandir}/man1/lxt2vcd.1*
122%{_mandir}/man1/rtlbrowse.1*
123%{_mandir}/man1/shmidcat.1*
124%{_mandir}/man1/twinwave.1*
125%{_mandir}/man1/vcd2fst.1*
126%{_mandir}/man1/vcd2lxt.1*
127%{_mandir}/man1/vcd2lxt2.1*
128%{_mandir}/man1/vcd2vzt.1*
129%{_mandir}/man1/vermin.1*
130%{_mandir}/man1/vzt2vcd.1*
131%{_mandir}/man1/vztminer.1*
132%{_mandir}/man5/gtkwaverc.5*
133
134%changelog
135* Sat Feb 11 2012 NAKAMURA Kenta <kenta@vinelinux.org> 3.3.31-1
136- update to 3.3.31
137
138* Tue Jun 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-4
139- BR: tk instead of /usr/include/tcl.h /usr/include/tk.h
140  (Thanks to takemikaduchi-san)
141
142* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-3
143- added --disable-xz at Vine Linux 5
144
145* Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-2
146- Initial build for Vine Linux
147
148* Sun Jun  6 2010 Paul Howarth <paul@city-fan.org> 3.3.7-1
149- update to 3.3.7 (general bug and compiler warning fixes)
150- -n option not needed in desktop file
151
152* Tue May  4 2010 Paul Howarth <paul@city-fan.org> 3.3.6-1
153- update to 3.3.6 (see CHANGELOG.TXT for details)
154- add desktop file and icons based on Mandriva package
155- BR: desktop-file-utils
156- add scriptlets to update icon cache
157- no longer need to fix permissions of lzma wrapper code
158
159* Sat Mar 20 2010 Paul Howarth <paul@city-fan.org> 3.3.5-1
160- update to 3.3.5 (see CHANGELOG.TXT for details)
161- add Judy-devel buildreq for improved memory usage efficiency
162
163* Mon Mar  8 2010 Paul Howarth <paul@city-fan.org> 3.3.4-1
164- update to 3.3.4 (see CHANGELOG.TXT for details)
165
166* Fri Feb 19 2010 Paul Howarth <paul@city-fan.org> 3.3.3-1
167- update to 3.3.3
168- drop upstreamed dlopen linking patch
169- drop obsolete helper apps mvl2lxt, mvl2vcd, tex2vcd and tla2vcd
170
171* Mon Feb 15 2010 Paul Howarth <paul@city-fan.org> 3.3.2-2
172- fix FTBFS due to missing -ldl linking for dlopen function (#565173)
173
174* Tue Jan  5 2010 Paul Howarth <paul@city-fan.org> 3.3.2-1
175- update to 3.3.2 (speed up operation on networked filesystems)
176
177* Sat Dec 26 2009 Paul Howarth <paul@city-fan.org> 3.3.0-1
178- update to 3.3.0
179- added tk support
180- bundled old liblzma replaced by system xz (add BR: xz-devel)
181- tcl/tk support require Fedora >= 2 or RHEL >= 4 (tcl 8.4)
182
183* Fri Sep  4 2009 Paul Howarth <paul@city-fan.org> 3.2.3-1
184- update to 3.2.3
185- fix permissions in bundled liblzma for debuginfo
186
187* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-3
188- drop patch for #515672, not needed with gcc 4.4.1-4
189
190* Thu Aug  6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-2
191- add patch to work around #515672 (internal compiler error on PPC)
192
193* Wed Aug  5 2009 Paul Howarth <paul@city-fan.org> 3.2.2-1
194- update to 3.2.2 (new tools evcd2vcd/fst2vcd/vcd2fst)
195- drop print-to-file patch, no longer needed
196
197* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2.1
198- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
199
200* Wed Jul 15 2009 Paul Howarth <paul@city-fan.org> 3.2.1-2
201- add upstream patch for crash on print to file (#511858)
202
203* Tue Apr 14 2009 Paul Howarth <paul@city-fan.org> 3.2.1-1
204- update to 3.2.1
205
206* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 3.2.0-1.1
207- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
208
209* Tue Feb 17 2009 Paul Howarth <paul@city-fan.org> 3.2.0-1
210- update to 3.2.0
211
212* Mon Feb  2 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.2.RC5
213- update to 3.2.0RC5
214
215* Fri Jan 29 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.1.RC4
216- update to 3.2.0RC4 (#481264)
217- new upstream URLs
218- buildreq /usr/include/tcl.h for embedded tcl support
219
220* Thu Aug 21 2008 Paul Howarth <paul@city-fan.org> 3.1.13-1
221- update to 3.1.13
222
223* Mon Jul 14 2008 Paul Howarth <paul@city-fan.org> 3.1.12-1
224- update to 3.1.12
225
226* Thu Jun 19 2008 Paul Howarth <paul@city-fan.org> 3.1.11-1
227- update to 3.1.11
228
229* Thu May 15 2008 Paul Howarth <paul@city-fan.org> 3.1.10-1
230- update to 3.1.10
231
232* Tue Apr 22 2008 Paul Howarth <paul@city-fan.org> 3.1.9-1
233- update to 3.1.9
234
235* Mon Apr  7 2008 Paul Howarth <paul@city-fan.org> 3.1.8-1
236- update to 3.1.8
237
238* Tue Mar 25 2008 Paul Howarth <paul@city-fan.org> 3.1.7-1
239- update to 3.1.7
240
241* Wed Feb 27 2008 Paul Howarth <paul@city-fan.org> 3.1.6-1
242- update to 3.1.6
243
244* Fri Feb  1 2008 Paul Howarth <paul@city-fan.org> 3.1.4-1
245- update to 3.1.4
246
247* Tue Jan 15 2008 Paul Howarth <paul@city-fan.org> 3.1.3-1
248- update to 3.1.3
249
250* Wed Jan  2 2008 Paul Howarth <paul@city-fan.org> 3.1.2-1
251- update to 3.1.2
252
253* Fri Sep 28 2007 Paul Howarth <paul@city-fan.org> 3.1.1-1
254- update to 3.1.1
255
256* Tue Sep  4 2007 Paul Howarth <paul@city-fan.org> 3.1.0-1
257- update to 3.1.0
258
259* Fri Aug 24 2007 Paul Howarth <paul@city-fan.org> 3.0.30-3
260- clarify license as GPL, version 2 or later
261
262* Fri Jul 27 2007 Paul Howarth <paul@city-fan.org> 3.0.30-1
263- update to 3.0.30
264
265* Fri Jun  8 2007 Paul Howarth <paul@city-fan.org> 3.0.29-1
266- update to 3.0.29
267- spec file much-simplified as gtkwave is now fully autotooled
268- try to retain upstream timestamps as far as possible
269- use parallel make
270
271* Tue May  1 2007 Paul Howarth <paul@city-fan.org> 3.0.28-1
272- update to 3.0.28
273- update source URL to master source
274
275* Mon Apr 30 2007 Paul Howarth <paul@city-fan.org> 3.0.27-1
276- update to 3.0.27
277- rename "vertex" to "vermin" to avoid conflict with Vertex 3D Model Assembler
278  (http://wolfpack.twu.net/Vertex/index.html)
279
280* Fri Apr 20 2007 Paul Howarth <paul@city-fan.org> 3.0.26-1
281- update to 3.0.26
282
283* Wed Apr 11 2007 Paul Howarth <paul@city-fan.org> 3.0.25-1
284- update to 3.0.25
285
286* Thu Apr  5 2007 Paul Howarth <paul@city-fan.org> 3.0.24-1
287- update to 3.0.24
288
289* Tue Mar 20 2007 Paul Howarth <paul@city-fan.org> 3.0.23-1
290- update to 3.0.23
291
292* Mon Feb 26 2007 Paul Howarth <paul@city-fan.org> 3.0.22-1
293- update to 3.0.22
294
295* Mon Feb  5 2007 Paul Howarth <paul@city-fan.org> 3.0.21-1
296- update to 3.0.21
297
298* Wed Jan 24 2007 Paul Howarth <paul@city-fan.org> 3.0.20-1
299- update to 3.0.20
300
301* Tue Jan  2 2007 Paul Howarth <paul@city-fan.org> 3.0.19-1
302- update to 3.0.19
303
304* Tue Dec  5 2006 Paul Howarth <paul@city-fan.org> 3.0.18-1
305- update to 3.0.18
306
307* Tue Nov 28 2006 Paul Howarth <paul@city-fan.org> 3.0.17-1
308- update to 3.0.17
309
310* Tue Nov 14 2006 Paul Howarth <paul@city-fan.org> 3.0.16-1
311- update to 3.0.16
312
313* Mon Oct 30 2006 Paul Howarth <paul@city-fan.org> 3.0.15-1
314- update to 3.0.15
315
316* Wed Oct 18 2006 Paul Howarth <paul@city-fan.org> 3.0.14-1
317- update to 3.0.14
318
319* Mon Oct  9 2006 Paul Howarth <paul@city-fan.org> 3.0.13-1
320- update to 3.0.13
321
322* Tue Oct  3 2006 Paul Howarth <paul@city-fan.org> 3.0.12-2
323- rebuilt for unwind info generation, broken in gcc-4.1.1-21
324
325* Fri Sep 22 2006 Paul Howarth <paul@city-fan.org> 3.0.12-1
326- update to 3.0.12
327- create dummy libz/libbz2 Makefile.in files to ensure that config.h gets
328  generated
329
330* Thu Sep 14 2006 Paul Howarth <paul@city-fan.org> 3.0.11-1
331- update to 3.0.11
332
333* Mon Aug 21 2006 Paul Howarth <paul@city-fan.org> 3.0.10-1
334- update to 3.0.10
335
336* Fri Aug 11 2006 Paul Howarth <paul@city-fan.org> 3.0.9-1
337- update to 3.0.9
338- tarball is now .tar.gz rather than .tgz
339
340* Mon Aug  7 2006 Paul Howarth <paul@city-fan.org> 3.0.8-1
341- update to 3.0.8
342- new program and manpage: shmidcat
343
344* Fri Jul 21 2006 Paul Howarth <paul@city-fan.org> 3.0.7-1
345- update to 3.0.7
346- new program and manpage: twinwave
347
348* Mon Jul 17 2006 Paul Howarth <paul@city-fan.org> 3.0.6-1
349- update to 3.0.6
350
351* Wed Jun 28 2006 Paul Howarth <paul@city-fan.org> 3.0.5-1
352- update to 3.0.5
353- new program and manpage: ghwdump
354
355* Fri Jun  2 2006 Paul Howarth <paul@city-fan.org> 3.0.4-1
356- update to 3.0.4
357
358* Tue May 30 2006 Paul Howarth <paul@city-fan.org> 3.0.3-1
359- update to 3.0.3
360
361* Sun May 28 2006 Paul Howarth <paul@city-fan.org> 3.0.2-2
362- adding missing buildreq flex
363
364* Wed May 10 2006 Paul Howarth <paul@city-fan.org> 3.0.2-1
365- update to 3.0.2
366
367* Tue May  9 2006 Paul Howarth <paul@city-fan.org> 3.0.1-1
368- update to 3.0.1
369
370* Tue May  2 2006 Paul Howarth <paul@city-fan.org> 3.0.0-1
371- update to 3.0.0
372- add examples directory as %%doc
373- add new buildreq gperf
374- tweak Makefile.in edits to handle Makefiles under contrib/
375- add new binaries rtlbrowse and vertex
376- add new manpages for rtlbrowse, vertex, and gtkwaverc
377- %%{_mandir} no longer needs to be created manually
378- configure script now accepts --libdir
379
380* Tue Mar  7 2006 Paul Howarth <paul@city-fan.org> 1.3.86-1
381- update to 1.3.86
382
383* Mon Feb 27 2006 Paul Howarth <paul@city-fan.org> 1.3.85-1
384- update to 1.3.85
385
386* Tue Feb 21 2006 Paul Howarth <paul@city-fan.org> 1.3.84-1
387- update to 1.3.84
388- INSTALL now called INSTALL.TXT
389
390* Thu Feb 16 2006 Paul Howarth <paul@city-fan.org> 1.3.83-2
391- rebuild
392
393* Tue Jan 31 2006 Paul Howarth <paul@city-fan.org> 1.3.83-1
394- update to 1.3.83
395
396* Thu Jan 19 2006 Paul Howarth <paul@city-fan.org> 1.3.82-1
397- update to 1.3.82
398
399* Tue Dec 13 2005 Paul Howarth <paul@city-fan.org> 1.3.81-1
400- update to 1.3.81
401
402* Sun Nov 27 2005 Paul Howarth <paul@city-fan.org> 1.3.80-1
403- update to 1.3.80
404
405* Wed Nov 23 2005 Paul Howarth <paul@city-fan.org> 1.3.79-2
406- fix file permissions in debuginfo package
407
408* Mon Nov 21 2005 Paul Howarth <paul@city-fan.org> 1.3.79-1
409- update to 1.3.79
410
411* Wed Nov  9 2005 Paul Howarth <paul@city-fan.org> 1.3.78-1
412- update to 1.3.78
413
414* Tue Nov  8 2005 Paul Howarth <paul@city-fan.org> 1.3.77-1
415- update to 1.3.77
416- GHDL ghw support now included upstream, so remove patches
417
418* Mon Nov  7 2005 Paul Howarth <paul@city-fan.org> 1.3.76-3
419- clean up for Fedora Extras:
420  - don't support GTK1 builds
421  - unconditionally remove buildroot in %%clean and %%install
422  - remove redundant glib2-devel buildreq
423  - add dist tag
424
425* Mon Nov  7 2005 Thomas Sailer <t.sailer@alumni.ethz.ch> - 1.3.76-2
426- add GHDL ghw support
427
428* Thu Oct 27 2005 Paul Howarth <paul@city-fan.org> 1.3.76-1
429- update to 1.3.76
430
431* Thu Oct 13 2005 Paul Howarth <paul@city-fan.org> 1.3.73-1
432- update to 1.3.73
433
434* Mon Oct 10 2005 Paul Howarth <paul@city-fan.org> 1.3.72-1
435- update to 1.3.72
436
437* Fri Oct  7 2005 Paul Howarth <paul@city-fan.org> 1.3.71-1
438- update to 1.3.71
439
440* Thu Sep 15 2005 Paul Howarth <paul@city-fan.org> 1.3.70-1
441- update to 1.3.70
442- new program tla2vcd (with manpage)
443
444* Mon Sep  5 2005 Paul Howarth <paul@city-fan.org> 1.3.69-1
445- update to 1.3.69
446- honour %%{optflags}
447- use system bzip and zlib libraries
448
449* Fri Sep  2 2005 Paul Howarth <paul@city-fan.org> 1.3.68-1
450- update to 1.3.68
451
452* Wed Aug 25 2005 Paul Howarth <paul@city-fan.org> 1.3.67-1
453- update to 1.3.67
454
455* Wed Aug 10 2005 Paul Howarth <paul@city-fan.org> 1.3.64-1
456- update to 1.3.64
457- new programs lxt2miner & vztminer (with manpages)
458
459* Tue Jul 26 2005 Paul Howarth <paul@city-fan.org> 1.3.63-1
460- update to 1.3.63
461
462* Mon Jul 11 2005 Paul Howarth <paul@city-fan.org> 1.3.62-1
463- update to 1.3.62
464
465* Thu Apr 21 2005 Paul Howarth <paul@city-fan.org> 1.3.58-1
466- update to 1.3.58
467- include sample .gtkwaverc in doc area
468- update URL to point to new project home page
469
470* Wed Apr 13 2005 Paul Howarth <paul@city-fan.org> 1.3.57-1
471- update to 1.3.57
472- add support for building with gtk version 1 (build using: --without gtk2)
473
474* Tue Apr 12 2005 Paul Howarth <paul@city-fan.org> 1.3.56-1
475- initial RPM build
Note: See TracBrowser for help on using the repository browser.