source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 5738

Revision 5738, 15.5 KB checked in by Takemikaduchi, 12 years ago (diff)

python: add configure option
others: new upstream release

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.28.8
5%define _libxml2_ver    2.7.8
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.6
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Summary:        GStreamer streaming media framework runtime.
16Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
17Version:        0.10.36
18Release:        1%{?_dist_release}
19
20Group:          System Environment/Libraries
21License:        LGPL
22URL:            http://gstreamer.freedesktop.org/
23Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  glib2-devel >= %{_glib2_ver}
27BuildRequires:  libxml2-devel >= %{_libxml2_ver}
28BuildRequires:  bison
29BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
30BuildRequires:  flex
31BuildRequires:  ghostscript
32BuildRequires:  check >= %{_check_ver}
33BuildRequires:  python >= %{_python_ver}, python-pyxml
34BuildRequires:  gobject-introspection-devel
35Requires:       glib2 >= %{_glib2_ver}
36Requires:       libxml2 >= %{_libxml2_ver}
37Obsoletes:      gstreamer-tools
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       inagaki, Takemikaduchi
42
43%description
44GStreamer is a streaming-media framework, based on graphs of filters which
45operate on media data. Applications using this library can do anything
46from real-time sound processing to playing videos, and just about anything
47else media-related.  Its plugin-based architecture means that new data
48types or processing capabilities can be added simply by installing new
49plugins.
50
51%package devel
52Summary:        Libraries/header files for GStreamer streaming media framework.
53Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56Requires:       glib2-devel >= %{_glib2_ver}
57Requires:       libxml2-devel >= %{_libxml2_ver}
58
59%description devel
60GStreamer is a streaming-media framework, based on graphs of filters which
61operate on media data. Applications using this library can do anything
62from real-time sound processing to playing videos, and just about anything
63else media-related.  Its plugin-based architecture means that new data
64types or processing capabilities can be added simply by installing new   
65plugins.
66
67This package contains the libraries and includes files necessary to develop
68applications and plugins for GStreamer.
69
70# compat32
71%package -n compat32-%{name}
72Summary:        GStreamer streaming media framework runtime.
73Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
74Group:          System Environment/Libraries
75
76%description -n compat32-%{name}
77GStreamer is a streaming-media framework, based on graphs of filters which
78operate on media data. Applications using this library can do anything
79from real-time sound processing to playing videos, and just about anything
80else media-related.  Its plugin-based architecture means that new data
81types or processing capabilities can be added simply by installing new
82plugins.
83
84%package -n compat32-%{name}-devel
85Summary:        Libraries/header files for GStreamer streaming media framework.
86Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
87Group:          Development/Libraries
88Requires:       compat32-%{name} = %{version}-%{release}
89Requires:       %{name}-devel = %{version}-%{release}
90Requires:       compat32-glib2-devel >= %{_glib2_ver}
91Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
92
93%description -n compat32-%{name}-devel
94GStreamer is a streaming-media framework, based on graphs of filters which
95operate on media data. Applications using this library can do anything
96from real-time sound processing to playing videos, and just about anything
97else media-related.  Its plugin-based architecture means that new data
98types or processing capabilities can be added simply by installing new   
99plugins.
100
101This package contains the libraries and includes files necessary to develop
102applications and plugins for GStreamer.
103
104%prep
105%setup -q
106
107%build
108%configure \
109        --with-package-name='Vine Linux gstreamer package' \
110        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
111        --enable-introspection=yes \
112        --disable-docbook --enable-gtk-doc \
113        --disable-static --disable-examples \
114        --disable-tests --disable-debug
115
116make %{?_smp_mflags}
117
118%install
119[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
120
121make install DESTDIR=$RPM_BUILD_ROOT
122
123mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
124
125rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
126rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
127#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
128
129%find_lang %{po_package}
130
131%clean
132[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post -n compat32-%{name} -p /sbin/ldconfig
139
140%postun -n compat32-%{name} -p /sbin/ldconfig
141
142%files -f %{po_package}.lang
143%defattr(-, root, root)
144%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
145%doc TODO ABOUT-NLS
146%{_bindir}/*
147%dir %{_libdir}/gstreamer-%{major}
148%{_libdir}/gstreamer-%{major}/*.so*
149%{_libdir}/*.so.*
150%{_libdir}/girepository-1.0/*.typelib
151%dir %{_libexecdir}/gstreamer-%{major}
152%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
153%{_mandir}/man1/*
154%dir %{_var}/cache/gstreamer-%{major}
155
156%files devel
157%defattr(-, root, root)
158%dir %{_includedir}/%{name}-%{major}
159%{_includedir}/%{name}-%{major}/*
160#{_libdir}/*.a
161%{_libdir}/*.so
162%{_libdir}/pkgconfig/gstreamer*.pc
163%{_datadir}/aclocal/*.m4
164%{_datadir}/gtk-doc/html/gstreamer-%{major}
165%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
166%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
167%{_datadir}/gir-1.0/*.gir
168
169# compat32
170%if %{build_compat32}
171%files -n compat32-%{name}
172%defattr(-, root, root)
173%dir %{_libdir}/gstreamer-%{major}
174%{_libdir}/gstreamer-%{major}/*.so*
175%{_libdir}/*.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-, root, root)
179#{_libdir}/*.a
180%{_libdir}/*.so
181%{_libdir}/pkgconfig/gstreamer*.pc
182%endif
183
184%changelog
185* Tue Feb 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.36-1
186- new upstream release
187
188* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-1
189- new upstream release
190
191* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
192- new upstream release
193
194* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
195- new upstream release
196
197* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
198- new upstream release
199- add BuildRequires: gobject-introspection-devel
200- add configure option (--enable-introspection=yes)
201- fix %files
202
203* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
204- build with rpm-4.8.1-1 for pkg-config file
205
206* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
207- new upstream release
208
209* Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
210- new upstream release
211
212* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
213- new upstream release
214- used make install instead of %%makeinstall
215
216* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
217- new upstream release
218- built with new toolchain
219
220* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
221- new upstream release
222
223* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
224- new upstream release
225
226* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
227- added compat32 package for x86_64 arch support
228
229* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
230- new upstream release
231- removed static librairies from devel package
232- added Packager tag
233
234* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
235- new upstream release
236- changed Group to System Environment/Libraries
237
238* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
239- new upstream release
240- spec in UTF-8
241
242* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
243- new upstream release
244
245* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
246- new upstream release
247
248* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
249- new upstream release
250
251* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
252- new upstream release
253
254* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
255- new upstream release
256
257* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
258- new upstream release
259
260* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
261- new upstream release
262- add Vendor/Distribution tag
263- add '-with-package-name' option to %%configure
264- use more macros
265
266* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
267- new upstream release
268
269* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
270- new upstream release
271
272* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
273- new upstream release
274
275* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
276- new upstream release
277
278* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
279- new upstream release
280
281* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
282- new upstream release
283
284* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
285- new upstream release
286
287* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
288- new upstream release
289
290* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
291- new upstream release
292
293* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
294- new upstream release
295  - change major to 0.10
296- update URLs
297- update versions: glibc >= 2.8, gtk-doc >= 1.3
298- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
299- remove from BuildRequires: popt, zlib-devel
300- remove obsolete options from %%configure
301- add --enable-gtk-doc to %%configure
302- add gtk-doc/html/gstreamer-* to gstreamer-devel package
303- add RELEASE to %%doc
304- remove REQUIREMENTS DOCBUILDING from %%doc
305- not exec gst-register-%%{major} at %%post
306
307* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
308- new upstream release
309
310* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
311- new upstream release
312
313* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
314- new upstream release
315- removed dependancy related to documentaion build
316
317* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
318- new upstream release
319
320* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
321- new upstream release
322
323* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
324- update alpha-noWerror patch (Patch10)
325
326* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
327- new upstream release
328
329* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
330- new upstream release
331
332* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
333- new upstream release
334
335* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
336- build without -Werror on alpha (Patch10)
337
338* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
339- new upstream release
340
341* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
342- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
343
344* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
345- fix broken %files entries..
346
347* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
348- new upstream release
349
350* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
351- build for Vine Linux
352
353* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
354- Add patch1 to fix C++ plugins on ia64
355
356* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
357- %post -p was wrong
358
359* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
360- explicitly add %{_libdir}/libgstreamer-{major}.so
361- explicitly add %{_libdir}/libgstcontrol-{major}.so
362
363* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
364- bump release
365
366* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
367- move .so files out of -devel
368
369* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
370- new version 0.5.0
371- require docbook-style-xsl
372- add gstreamer-tools package too
373- New patch to use the right docbook prefix.
374
375* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
376- downgrade to a release candidate.  Should work better on other arches
377- build without Werror
378
379* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
380- update to new version.  Remove ExcludeArch
381
382* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
383- excludearch some arches
384
385* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
386- import into CVS and build "officially"
387- use smp_mflags
388- temporarily disable docs build, doesn't seem to work
389
390* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
391- 0.4.2
392
393* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
394- 0.4.1
395
396* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
397- minor cleanups
398
399* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
400- moved header location
401
402* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
403- added popt
404- removed .la
405
406* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
407- added release of gstreamer to req of gstreamer-devel
408- changed location of API docs to be in gtk-doc like other gtk-doc stuff
409- reordered SPEC file
410
411* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
412- moved html docs to gtk-doc standard directory
413
414* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
415- move version defines of glib2 and libxml2 to configure.ac
416- add BuildRequires for these two libs
417
418* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
419- put html docs in canonical place, avoiding %doc erasure
420- added devhelp support, current install of it is hackish
421
422* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
423- Added documentation to build
424
425* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
426- added libgstbasicscheduler
427- renamed libgst to libgstreamer
428
429* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
430- Added configdir parameter as it seems the configdir gets weird otherwise
431
432* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
433- split off gstreamer-editor from core
434- removed gstreamer-gnome-apps
435
436* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
437- Cleaned up the spec file for the gstreamer core/plug-ins split
438- Improve spec file
439
440* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
441- Split of more plugins from the core and put them into their own modules
442- Includes colorspace, xfree and wav
443- Improved package Require lines
444- Added mp3encode (lame based) to the SPEC
445
446* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
447- Thomas merged mpeg plugins into one
448* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
449- More minor cleanups including some fixed descriptions from Andrew Mitchell
450
451* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
452- Added logging to the make statement
453
454* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
455- Updated in preparation for 0.3.0 release
456
457* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
458- Updated for 0.2.1 release
459- Split out the GUI packages into their own RPM
460- added new plugins (FLAC, festival, quicktime etc.)
461
462* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
463- Visualisation plugins bundled out togheter
464- Moved files sections up close to their respective descriptions
465
466* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
467- Split the package into separate RPMS,
468  putting most plugins out by themselves.
469
470* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
471- Updated with change suggestions from Dennis Bjorklund
472
473* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
474- updated to build -devel package as well
475
476* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
477- first draft of spec file
478
Note: See TracBrowser for help on using the repository browser.