source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 8084

Revision 8084, 15.7 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.28.8
5%define _libxml2_ver    2.7.8
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.6
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Summary:        GStreamer streaming media framework runtime.
16Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
17Version:        0.10.36
18Release:        3%{?_dist_release}
19
20Group:          System Environment/Libraries
21License:        LGPL
22URL:            http://gstreamer.freedesktop.org/
23Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  glib2-devel >= %{_glib2_ver}
27BuildRequires:  libxml2-devel >= %{_libxml2_ver}
28BuildRequires:  bison
29BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
30BuildRequires:  flex
31BuildRequires:  ghostscript
32BuildRequires:  check >= %{_check_ver}
33BuildRequires:  python >= %{_python_ver}, python-pyxml
34BuildRequires:  gobject-introspection-devel
35Requires:       glib2 >= %{_glib2_ver}
36Requires:       libxml2 >= %{_libxml2_ver}
37Obsoletes:      gstreamer-tools
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       inagaki, Takemikaduchi
42
43%description
44GStreamer is a streaming-media framework, based on graphs of filters which
45operate on media data. Applications using this library can do anything
46from real-time sound processing to playing videos, and just about anything
47else media-related.  Its plugin-based architecture means that new data
48types or processing capabilities can be added simply by installing new
49plugins.
50
51%package devel
52Summary:        Libraries/header files for GStreamer streaming media framework.
53Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56Requires:       glib2-devel >= %{_glib2_ver}
57Requires:       libxml2-devel >= %{_libxml2_ver}
58
59%description devel
60GStreamer is a streaming-media framework, based on graphs of filters which
61operate on media data. Applications using this library can do anything
62from real-time sound processing to playing videos, and just about anything
63else media-related.  Its plugin-based architecture means that new data
64types or processing capabilities can be added simply by installing new   
65plugins.
66
67This package contains the libraries and includes files necessary to develop
68applications and plugins for GStreamer.
69
70# compat32
71%package -n compat32-%{name}
72Summary:        GStreamer streaming media framework runtime.
73Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
74Group:          System Environment/Libraries
75
76%description -n compat32-%{name}
77GStreamer is a streaming-media framework, based on graphs of filters which
78operate on media data. Applications using this library can do anything
79from real-time sound processing to playing videos, and just about anything
80else media-related.  Its plugin-based architecture means that new data
81types or processing capabilities can be added simply by installing new
82plugins.
83
84%package -n compat32-%{name}-devel
85Summary:        Libraries/header files for GStreamer streaming media framework.
86Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
87Group:          Development/Libraries
88Requires:       compat32-%{name} = %{version}-%{release}
89Requires:       %{name}-devel = %{version}-%{release}
90Requires:       compat32-glib2-devel >= %{_glib2_ver}
91Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
92
93%description -n compat32-%{name}-devel
94GStreamer is a streaming-media framework, based on graphs of filters which
95operate on media data. Applications using this library can do anything
96from real-time sound processing to playing videos, and just about anything
97else media-related.  Its plugin-based architecture means that new data
98types or processing capabilities can be added simply by installing new   
99plugins.
100
101This package contains the libraries and includes files necessary to develop
102applications and plugins for GStreamer.
103
104%prep
105%setup -q
106
107%build
108%configure \
109        --with-package-name='Vine Linux gstreamer package' \
110        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
111        --enable-introspection=yes \
112        --disable-docbook --enable-gtk-doc \
113        --disable-static --disable-examples \
114        --disable-tests --disable-debug
115
116make %{?_smp_mflags}
117
118%install
119[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
120
121make install DESTDIR=$RPM_BUILD_ROOT
122
123mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
124
125rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
126rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
127#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
128
129%find_lang %{po_package}
130
131%clean
132[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post -n compat32-%{name} -p /sbin/ldconfig
139
140%postun -n compat32-%{name} -p /sbin/ldconfig
141
142%files -f %{po_package}.lang
143%defattr(-, root, root)
144%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
145%doc TODO ABOUT-NLS
146%{_bindir}/*
147%dir %{_libdir}/gstreamer-%{major}
148%{_libdir}/gstreamer-%{major}/*.so*
149%{_libdir}/*.so.*
150%{_libdir}/girepository-1.0/*.typelib
151%dir %{_libexecdir}/gstreamer-%{major}
152%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
153%{_mandir}/man1/*
154%dir %{_var}/cache/gstreamer-%{major}
155
156%files devel
157%defattr(-, root, root)
158%dir %{_includedir}/%{name}-%{major}
159%{_includedir}/%{name}-%{major}/*
160#{_libdir}/*.a
161%{_libdir}/*.so
162%{_libdir}/pkgconfig/gstreamer*.pc
163%{_datadir}/aclocal/*.m4
164%{_datadir}/gtk-doc/html/gstreamer-%{major}
165%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
166%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
167%{_datadir}/gir-1.0/*.gir
168
169# compat32
170%if %{build_compat32}
171%files -n compat32-%{name}
172%defattr(-, root, root)
173%dir %{_libdir}/gstreamer-%{major}
174%{_libdir}/gstreamer-%{major}/*.so*
175%{_libdir}/*.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-, root, root)
179%{_libdir}/*.so
180%endif
181
182%changelog
183* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.36-3
184- rebuild with VineSeed environment
185
186* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.36-2
187- remove *.pc from compat32-%{name}-devel
188
189* Tue Feb 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.36-1
190- new upstream release
191
192* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-1
193- new upstream release
194
195* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
196- new upstream release
197
198* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
199- new upstream release
200
201* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
202- new upstream release
203- add BuildRequires: gobject-introspection-devel
204- add configure option (--enable-introspection=yes)
205- fix %files
206
207* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
208- build with rpm-4.8.1-1 for pkg-config file
209
210* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
211- new upstream release
212
213* Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
214- new upstream release
215
216* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
217- new upstream release
218- used make install instead of %%makeinstall
219
220* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
221- new upstream release
222- built with new toolchain
223
224* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
225- new upstream release
226
227* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
228- new upstream release
229
230* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
231- added compat32 package for x86_64 arch support
232
233* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
234- new upstream release
235- removed static librairies from devel package
236- added Packager tag
237
238* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
239- new upstream release
240- changed Group to System Environment/Libraries
241
242* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
243- new upstream release
244- spec in UTF-8
245
246* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
247- new upstream release
248
249* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
250- new upstream release
251
252* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
253- new upstream release
254
255* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
256- new upstream release
257
258* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
259- new upstream release
260
261* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
262- new upstream release
263
264* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
265- new upstream release
266- add Vendor/Distribution tag
267- add '-with-package-name' option to %%configure
268- use more macros
269
270* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
271- new upstream release
272
273* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
274- new upstream release
275
276* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
277- new upstream release
278
279* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
280- new upstream release
281
282* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
283- new upstream release
284
285* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
286- new upstream release
287
288* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
289- new upstream release
290
291* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
292- new upstream release
293
294* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
295- new upstream release
296
297* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
298- new upstream release
299  - change major to 0.10
300- update URLs
301- update versions: glibc >= 2.8, gtk-doc >= 1.3
302- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
303- remove from BuildRequires: popt, zlib-devel
304- remove obsolete options from %%configure
305- add --enable-gtk-doc to %%configure
306- add gtk-doc/html/gstreamer-* to gstreamer-devel package
307- add RELEASE to %%doc
308- remove REQUIREMENTS DOCBUILDING from %%doc
309- not exec gst-register-%%{major} at %%post
310
311* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
312- new upstream release
313
314* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
315- new upstream release
316
317* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
318- new upstream release
319- removed dependancy related to documentaion build
320
321* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
322- new upstream release
323
324* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
325- new upstream release
326
327* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
328- update alpha-noWerror patch (Patch10)
329
330* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
331- new upstream release
332
333* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
334- new upstream release
335
336* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
337- new upstream release
338
339* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
340- build without -Werror on alpha (Patch10)
341
342* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
343- new upstream release
344
345* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
346- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
347
348* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
349- fix broken %files entries..
350
351* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
352- new upstream release
353
354* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
355- build for Vine Linux
356
357* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
358- Add patch1 to fix C++ plugins on ia64
359
360* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
361- %post -p was wrong
362
363* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
364- explicitly add %{_libdir}/libgstreamer-{major}.so
365- explicitly add %{_libdir}/libgstcontrol-{major}.so
366
367* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
368- bump release
369
370* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
371- move .so files out of -devel
372
373* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
374- new version 0.5.0
375- require docbook-style-xsl
376- add gstreamer-tools package too
377- New patch to use the right docbook prefix.
378
379* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
380- downgrade to a release candidate.  Should work better on other arches
381- build without Werror
382
383* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
384- update to new version.  Remove ExcludeArch
385
386* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
387- excludearch some arches
388
389* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
390- import into CVS and build "officially"
391- use smp_mflags
392- temporarily disable docs build, doesn't seem to work
393
394* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
395- 0.4.2
396
397* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
398- 0.4.1
399
400* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
401- minor cleanups
402
403* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
404- moved header location
405
406* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
407- added popt
408- removed .la
409
410* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
411- added release of gstreamer to req of gstreamer-devel
412- changed location of API docs to be in gtk-doc like other gtk-doc stuff
413- reordered SPEC file
414
415* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
416- moved html docs to gtk-doc standard directory
417
418* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
419- move version defines of glib2 and libxml2 to configure.ac
420- add BuildRequires for these two libs
421
422* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
423- put html docs in canonical place, avoiding %doc erasure
424- added devhelp support, current install of it is hackish
425
426* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
427- Added documentation to build
428
429* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
430- added libgstbasicscheduler
431- renamed libgst to libgstreamer
432
433* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
434- Added configdir parameter as it seems the configdir gets weird otherwise
435
436* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
437- split off gstreamer-editor from core
438- removed gstreamer-gnome-apps
439
440* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
441- Cleaned up the spec file for the gstreamer core/plug-ins split
442- Improve spec file
443
444* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
445- Split of more plugins from the core and put them into their own modules
446- Includes colorspace, xfree and wav
447- Improved package Require lines
448- Added mp3encode (lame based) to the SPEC
449
450* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
451- Thomas merged mpeg plugins into one
452* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
453- More minor cleanups including some fixed descriptions from Andrew Mitchell
454
455* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
456- Added logging to the make statement
457
458* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
459- Updated in preparation for 0.3.0 release
460
461* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
462- Updated for 0.2.1 release
463- Split out the GUI packages into their own RPM
464- added new plugins (FLAC, festival, quicktime etc.)
465
466* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
467- Visualisation plugins bundled out togheter
468- Moved files sections up close to their respective descriptions
469
470* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
471- Split the package into separate RPMS,
472  putting most plugins out by themselves.
473
474* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
475- Updated with change suggestions from Dennis Bjorklund
476
477* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
478- updated to build -devel package as well
479
480* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
481- first draft of spec file
482
Note: See TracBrowser for help on using the repository browser.