source: projects/specs/trunk/g/gstreamer/gstreamer-vl.spec @ 6890

Revision 6890, 15.6 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1# keep in sync with the VERSION.  gstreamer can append a .0.1 to CVS snapshots.
2%define major           0.10
3
4%define _glib2_ver      2.28.8
5%define _libxml2_ver    2.7.8
6%define _gtk_doc_ver    1.3
7%define _check_ver      0.9.2
8%define _python_ver     2.6
9
10%define po_package      %{name}-%{major}
11
12%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
13
14Name:           gstreamer
15Summary:        GStreamer streaming media framework runtime.
16Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
17Version:        0.10.36
18Release:        2%{?_dist_release}
19
20Group:          System Environment/Libraries
21License:        LGPL
22URL:            http://gstreamer.freedesktop.org/
23Source:         http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  glib2-devel >= %{_glib2_ver}
27BuildRequires:  libxml2-devel >= %{_libxml2_ver}
28BuildRequires:  bison
29BuildRequires:  gtk-doc >= %{_gtk_doc_ver}
30BuildRequires:  flex
31BuildRequires:  ghostscript
32BuildRequires:  check >= %{_check_ver}
33BuildRequires:  python >= %{_python_ver}, python-pyxml
34BuildRequires:  gobject-introspection-devel
35Requires:       glib2 >= %{_glib2_ver}
36Requires:       libxml2 >= %{_libxml2_ver}
37Obsoletes:      gstreamer-tools
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       inagaki, Takemikaduchi
42
43%description
44GStreamer is a streaming-media framework, based on graphs of filters which
45operate on media data. Applications using this library can do anything
46from real-time sound processing to playing videos, and just about anything
47else media-related.  Its plugin-based architecture means that new data
48types or processing capabilities can be added simply by installing new
49plugins.
50
51%package devel
52Summary:        Libraries/header files for GStreamer streaming media framework.
53Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56Requires:       glib2-devel >= %{_glib2_ver}
57Requires:       libxml2-devel >= %{_libxml2_ver}
58
59%description devel
60GStreamer is a streaming-media framework, based on graphs of filters which
61operate on media data. Applications using this library can do anything
62from real-time sound processing to playing videos, and just about anything
63else media-related.  Its plugin-based architecture means that new data
64types or processing capabilities can be added simply by installing new   
65plugins.
66
67This package contains the libraries and includes files necessary to develop
68applications and plugins for GStreamer.
69
70# compat32
71%package -n compat32-%{name}
72Summary:        GStreamer streaming media framework runtime.
73Summary(ja):    GStreamer ストリーミングメディアフレームワークランタイム
74Group:          System Environment/Libraries
75
76%description -n compat32-%{name}
77GStreamer is a streaming-media framework, based on graphs of filters which
78operate on media data. Applications using this library can do anything
79from real-time sound processing to playing videos, and just about anything
80else media-related.  Its plugin-based architecture means that new data
81types or processing capabilities can be added simply by installing new
82plugins.
83
84%package -n compat32-%{name}-devel
85Summary:        Libraries/header files for GStreamer streaming media framework.
86Summary(ja):    GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
87Group:          Development/Libraries
88Requires:       compat32-%{name} = %{version}-%{release}
89Requires:       %{name}-devel = %{version}-%{release}
90Requires:       compat32-glib2-devel >= %{_glib2_ver}
91Requires:       compat32-libxml2-devel >= %{_libxml2_ver}
92
93%description -n compat32-%{name}-devel
94GStreamer is a streaming-media framework, based on graphs of filters which
95operate on media data. Applications using this library can do anything
96from real-time sound processing to playing videos, and just about anything
97else media-related.  Its plugin-based architecture means that new data
98types or processing capabilities can be added simply by installing new   
99plugins.
100
101This package contains the libraries and includes files necessary to develop
102applications and plugins for GStreamer.
103
104%prep
105%setup -q
106
107%build
108%configure \
109        --with-package-name='Vine Linux gstreamer package' \
110        --with-cachedir=%{_var}/cache/gstreamer-%{major} \
111        --enable-introspection=yes \
112        --disable-docbook --enable-gtk-doc \
113        --disable-static --disable-examples \
114        --disable-tests --disable-debug
115
116make %{?_smp_mflags}
117
118%install
119[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
120
121make install DESTDIR=$RPM_BUILD_ROOT
122
123mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
124
125rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
126rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
127#rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
128
129%find_lang %{po_package}
130
131%clean
132[ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135
136%postun -p /sbin/ldconfig
137
138%post -n compat32-%{name} -p /sbin/ldconfig
139
140%postun -n compat32-%{name} -p /sbin/ldconfig
141
142%files -f %{po_package}.lang
143%defattr(-, root, root)
144%doc AUTHORS ChangeLog COPYING README NEWS RELEASE
145%doc TODO ABOUT-NLS
146%{_bindir}/*
147%dir %{_libdir}/gstreamer-%{major}
148%{_libdir}/gstreamer-%{major}/*.so*
149%{_libdir}/*.so.*
150%{_libdir}/girepository-1.0/*.typelib
151%dir %{_libexecdir}/gstreamer-%{major}
152%{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
153%{_mandir}/man1/*
154%dir %{_var}/cache/gstreamer-%{major}
155
156%files devel
157%defattr(-, root, root)
158%dir %{_includedir}/%{name}-%{major}
159%{_includedir}/%{name}-%{major}/*
160#{_libdir}/*.a
161%{_libdir}/*.so
162%{_libdir}/pkgconfig/gstreamer*.pc
163%{_datadir}/aclocal/*.m4
164%{_datadir}/gtk-doc/html/gstreamer-%{major}
165%{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
166%{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
167%{_datadir}/gir-1.0/*.gir
168
169# compat32
170%if %{build_compat32}
171%files -n compat32-%{name}
172%defattr(-, root, root)
173%dir %{_libdir}/gstreamer-%{major}
174%{_libdir}/gstreamer-%{major}/*.so*
175%{_libdir}/*.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-, root, root)
179#{_libdir}/*.a
180%{_libdir}/*.so
181%{_libdir}/pkgconfig/gstreamer*.pc
182%endif
183
184%changelog
185* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.36-2
186- remove *.pc from compat32-%{name}-devel
187
188* Tue Feb 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.36-1
189- new upstream release
190
191* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-1
192- new upstream release
193
194* Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
195- new upstream release
196
197* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
198- new upstream release
199
200* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
201- new upstream release
202- add BuildRequires: gobject-introspection-devel
203- add configure option (--enable-introspection=yes)
204- fix %files
205
206* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
207- build with rpm-4.8.1-1 for pkg-config file
208
209* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
210- new upstream release
211
212* Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
213- new upstream release
214
215* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
216- new upstream release
217- used make install instead of %%makeinstall
218
219* Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
220- new upstream release
221- built with new toolchain
222
223* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
224- new upstream release
225
226* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
227- new upstream release
228
229* Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
230- added compat32 package for x86_64 arch support
231
232* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
233- new upstream release
234- removed static librairies from devel package
235- added Packager tag
236
237* Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
238- new upstream release
239- changed Group to System Environment/Libraries
240
241* Wed Oct  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
242- new upstream release
243- spec in UTF-8
244
245* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
246- new upstream release
247
248* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
249- new upstream release
250
251* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
252- new upstream release
253
254* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
255- new upstream release
256
257* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
258- new upstream release
259
260* Sat Jun  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
261- new upstream release
262
263* Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
264- new upstream release
265- add Vendor/Distribution tag
266- add '-with-package-name' option to %%configure
267- use more macros
268
269* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
270- new upstream release
271
272* Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
273- new upstream release
274
275* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
276- new upstream release
277
278* Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
279- new upstream release
280
281* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
282- new upstream release
283
284* Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
285- new upstream release
286
287* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
288- new upstream release
289
290* Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
291- new upstream release
292
293* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
294- new upstream release
295
296* Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
297- new upstream release
298  - change major to 0.10
299- update URLs
300- update versions: glibc >= 2.8, gtk-doc >= 1.3
301- add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
302- remove from BuildRequires: popt, zlib-devel
303- remove obsolete options from %%configure
304- add --enable-gtk-doc to %%configure
305- add gtk-doc/html/gstreamer-* to gstreamer-devel package
306- add RELEASE to %%doc
307- remove REQUIREMENTS DOCBUILDING from %%doc
308- not exec gst-register-%%{major} at %%post
309
310* Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
311- new upstream release
312
313* Thu May  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
314- new upstream release
315
316* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
317- new upstream release
318- removed dependancy related to documentaion build
319
320* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
321- new upstream release
322
323* Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
324- new upstream release
325
326* Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
327- update alpha-noWerror patch (Patch10)
328
329* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
330- new upstream release
331
332* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
333- new upstream release
334
335* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
336- new upstream release
337
338* Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
339- build without -Werror on alpha (Patch10)
340
341* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
342- new upstream release
343
344* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
345- merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
346
347* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
348- fix broken %files entries..
349
350* Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
351- new upstream release
352
353* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
354- build for Vine Linux
355
356* Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
357- Add patch1 to fix C++ plugins on ia64
358
359* Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
360- %post -p was wrong
361
362* Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
363- explicitly add %{_libdir}/libgstreamer-{major}.so
364- explicitly add %{_libdir}/libgstcontrol-{major}.so
365
366* Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
367- bump release
368
369* Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
370- move .so files out of -devel
371
372* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
373- new version 0.5.0
374- require docbook-style-xsl
375- add gstreamer-tools package too
376- New patch to use the right docbook prefix.
377
378* Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
379- downgrade to a release candidate.  Should work better on other arches
380- build without Werror
381
382* Mon Dec  9 2002 Jonathan Blandford <jrb@redhat.com>
383- update to new version.  Remove ExcludeArch
384
385* Tue Dec  3 2002 Havoc Pennington <hp@redhat.com>
386- excludearch some arches
387
388* Mon Dec  2 2002 Havoc Pennington <hp@redhat.com>
389- import into CVS and build "officially"
390- use smp_mflags
391- temporarily disable docs build, doesn't seem to work
392
393* Thu Nov  7 2002 Jeremy Katz <katzj@redhat.com>
394- 0.4.2
395
396* Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
397- 0.4.1
398
399* Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
400- minor cleanups
401
402* Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
403- moved header location
404
405* Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
406- added popt
407- removed .la
408
409* Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
410- added release of gstreamer to req of gstreamer-devel
411- changed location of API docs to be in gtk-doc like other gtk-doc stuff
412- reordered SPEC file
413
414* Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
415- moved html docs to gtk-doc standard directory
416
417* Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
418- move version defines of glib2 and libxml2 to configure.ac
419- add BuildRequires for these two libs
420
421* Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
422- put html docs in canonical place, avoiding %doc erasure
423- added devhelp support, current install of it is hackish
424
425* Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
426- Added documentation to build
427
428* Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
429- added libgstbasicscheduler
430- renamed libgst to libgstreamer
431
432* Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
433- Added configdir parameter as it seems the configdir gets weird otherwise
434
435* Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
436- split off gstreamer-editor from core
437- removed gstreamer-gnome-apps
438
439* Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
440- Cleaned up the spec file for the gstreamer core/plug-ins split
441- Improve spec file
442
443* Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
444- Split of more plugins from the core and put them into their own modules
445- Includes colorspace, xfree and wav
446- Improved package Require lines
447- Added mp3encode (lame based) to the SPEC
448
449* Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
450- Thomas merged mpeg plugins into one
451* Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
452- More minor cleanups including some fixed descriptions from Andrew Mitchell
453
454* Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
455- Added logging to the make statement
456
457* Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
458- Updated in preparation for 0.3.0 release
459
460* Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
461- Updated for 0.2.1 release
462- Split out the GUI packages into their own RPM
463- added new plugins (FLAC, festival, quicktime etc.)
464
465* Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
466- Visualisation plugins bundled out togheter
467- Moved files sections up close to their respective descriptions
468
469* Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
470- Split the package into separate RPMS,
471  putting most plugins out by themselves.
472
473* Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
474- Updated with change suggestions from Dennis Bjorklund
475
476* Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
477- updated to build -devel package as well
478
479* Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
480- first draft of spec file
481
Note: See TracBrowser for help on using the repository browser.