source: projects/specs/trunk/g/gsm/gsm-vl.spec @ 9489

Revision 9489, 8.9 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define build_compat32  %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Shared libraries for GSM speech compressor
4
5Name:           gsm
6Version:        1.0.14
7Release:        1%{?_dist_release}
8
9Group:          System Environment/Libraries
10License:        MIT
11URL:            http://www.quut.com/gsm/
12
13Source:         http://www.quut.com/gsm/%{name}-%{version}.tar.gz
14Patch0:         %{name}-makefile.patch
15Patch1:         %{name}-1.0.14-warnings.patch
16Patch2:         %{name}-64bit.patch
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19%define srcver 1.0-pl14
20%define soname 1.0.12
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26Contains runtime shared libraries for libgsm, an implementation of
27the European GSM 06.10 provisional standard for full-rate speech
28transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
29excitation/long term prediction) coding at 13 kbit/s.
30
31GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
32rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
33with typical UNIX applications, our implementation turns frames of 160
3416-bit linear samples into 33-byte frames (1650 Bytes/s).
35The quality of the algorithm is good enough for reliable speaker
36recognition; even music often survives transcoding in recognizable
37form (given the bandwidth limitations of 8 kHz sampling rate).
38
39The interfaces offered are a front end modelled after compress(1), and
40a library API.  Compression and decompression run faster than realtime
41on most SPARCstations.  The implementation has been verified against the
42ETSI standard test patterns.
43
44%package        tools
45Summary:        GSM speech compressor tools
46Group:          Applications/Multimedia
47
48%description    tools
49Contains command line utilities for libgsm, an implementation of
50the European GSM 06.10 provisional standard for full-rate speech
51transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
52excitation/long term prediction) coding at 13 kbit/s.
53
54%package        devel
55Summary:        Header files and development libraries for libgsm
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58
59%description    devel
60Contains header files and development libraries for libgsm, an
61implementation of the European GSM 06.10 provisional standard for
62full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
63(residual pulse excitation/long term prediction) coding at 13 kbit/s.
64
65# compat32
66%package -n compat32-%{name}
67Summary:        Shared libraries for GSM speech compressor
68Group:          System Environment/Libraries
69Requires:       %{name} = %{version}-%{release}
70
71%description -n compat32-%{name}
72Contains runtime shared libraries for libgsm, an implementation of
73the European GSM 06.10 provisional standard for full-rate speech
74transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
75excitation/long term prediction) coding at 13 kbit/s.
76
77GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
78rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
79with typical UNIX applications, our implementation turns frames of 160
8016-bit linear samples into 33-byte frames (1650 Bytes/s).
81The quality of the algorithm is good enough for reliable speaker
82recognition; even music often survives transcoding in recognizable
83form (given the bandwidth limitations of 8 kHz sampling rate).
84
85The interfaces offered are a front end modelled after compress(1), and
86a library API.  Compression and decompression run faster than realtime
87on most SPARCstations.  The implementation has been verified against the
88ETSI standard test patterns.
89
90%package -n compat32-%{name}-devel
91Summary:        Header files and development libraries for libgsm
92Group:          Development/Libraries
93Requires:       compat32-%{name} = %{version}-%{release}
94Requires:       %{name}-devel = %{version}-%{release}
95
96%description -n compat32-%{name}-devel
97Contains header files and development libraries for libgsm, an
98implementation of the European GSM 06.10 provisional standard for
99full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
100(residual pulse excitation/long term prediction) coding at 13 kbit/s.
101
102
103%prep
104%setup -n gsm-%{srcver} -q
105%patch0 -p1 -b .mk
106%patch1 -p1 -b .warn
107%patch2 -p1 -b .64bit
108
109%build
110export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
111make %{?_smp_mflags} all
112
113%install
114rm -rf $RPM_BUILD_ROOT
115
116mkdir -p $RPM_BUILD_ROOT%{_bindir}
117mkdir -p $RPM_BUILD_ROOT%{_includedir}/gsm
118mkdir -p $RPM_BUILD_ROOT%{_libdir}
119mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man1,man3}
120
121make install \
122        INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix} \
123        GSM_INSTALL_INC=$RPM_BUILD_ROOT%{_includedir}/gsm \
124        GSM_INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
125
126cp -p $RPM_BUILD_DIR/gsm-%{srcver}/lib/libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}
127ln -s libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}/libgsm.so.1
128ln -s libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}/libgsm.so
129
130# some apps look for this in /usr/include
131ln -s gsm/gsm.h $RPM_BUILD_ROOT%{_includedir}
132
133rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
134
135
136%check
137# This is to ensure that the patch creates the proper library version.
138[ -f $RPM_BUILD_ROOT%{_libdir}/libgsm.so.%{soname} ]
139make addtst
140
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post -p /sbin/ldconfig
146
147%postun -p /sbin/ldconfig
148
149%post -n compat32-%{name} -p /sbin/ldconfig
150
151%postun -n compat32-%{name} -p /sbin/ldconfig
152
153%files
154%defattr(-,root,root,-)
155%doc ChangeLog COPYRIGHT MACHINES README
156%{_libdir}/libgsm.so.*
157
158%files tools
159%{_bindir}/tcat
160%{_bindir}/toast
161%{_bindir}/untoast
162%{_mandir}/man1/toast.1*
163
164%files devel
165%defattr(-,root,root,-)
166%dir %{_includedir}/gsm
167%{_includedir}/gsm/gsm.h
168%{_includedir}/gsm.h
169%{_libdir}/libgsm.so
170%{_mandir}/man3/*
171
172# compat32
173%if %{build_compat32}
174%files -n compat32-%{name}
175%defattr(-,root,root,-)
176%{_libdir}/libgsm.so.*
177
178%files -n compat32-%{name}-devel
179%defattr(-,root,root,-)
180%{_libdir}/libgsm.so
181%endif
182
183%changelog
184* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.14-1
185- new upstream release
186- update Patch1 (%%{name}-1.0.14-warnings.patch)
187
188* Mon Jul  7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.13-1
189- new upstream release.
190
191* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.12-3
192- create compat32 sub package
193
194* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
195- rebuilt with current VineSeed
196
197* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
198- initial build for Vine Linux
199
200* Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
201- Rebuild for GCC 4.3
202
203* Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
204- install symlinks instead of binaries in -devel
205
206* Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
207- rebuild for BuildID
208- specfile cleanups
209
210* Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
211- fix parallel make
212
213* Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
214- fix some warnings
215- fix 64bit testsuite issue as described at gsm homepage
216- add compatibility header symlink
217- split off binaries into a separate package
218
219* Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
220- Update to Release 1.0 Patchlevel 12.
221- Build with -fPIC not just for non-ix86.
222- Add check section to ensure proper library version.
223- Remove static library.
224
225* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
226- rebuilt for unwind info generation, broken in gcc-4.1.1-21
227
228* Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
229- 1.0.10-11
230- rebuild for FC6
231
232* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
233- switch to new release field
234
235* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
236- add dist
237
238* Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
239- 1.0.10-0.lvn.10: Clean up installation
240
241* Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
242- 1.0.10-0.lvn.9: mv libgsm.a only when needed
243
244* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
245- 1.0.10-0.lvn.8: Use -fPIC on non ix86
246
247* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
248- 1.0.10-0.lvn.7: moved to rpm.livna.org
249
250* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
251- 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
252
253* Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
254- 0:1.0.10-0.fdr.6: remove second makeinstall
255
256* Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
257- 0:1.0.10-0.fdr.5
258- added back epochs, I surrender
259- fix RPM_OPT_FLAGS hackery
260
261* Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
262- 1.0.10-0.fdr.4: remove epoch mentions
263
264* Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
265- 1.0.10-0.fdr.3
266- pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
267- fix group
268- -p'ize ldconfig
269
270* Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
271- 1.0.10-0.fdr.2
272- Fix libgsm.so.* being files instead of symlinks
273
274* Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
275- 0:1.0.10-0.fdr.1: initial RPM release
Note: See TracBrowser for help on using the repository browser.