source: projects/specs/trunk/g/gsm/gsm-vl.spec @ 12358

Revision 12358, 9.5 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

btrfs-progs-5.4.1-1

gsm-1.0.18-1

lzo-2.10-2

libusb1-1.0.23-1

usbutils-012-1

wireless-tools-29-5

zlib-1.2.11-3

Line 
1%define build_compat32  %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Shared libraries for GSM speech compressor
4
5Name:           gsm
6Version:        1.0.18
7Release:        1%{?_dist_release}
8Group:          System Environment/Libraries
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        MIT
13URL:            http://www.quut.com/gsm/
14Source:         http://www.quut.com/gsm/%{name}-%{version}.tar.gz
15Patch0:         gsm-makefile.patch
16Patch1:         gsm-warnings.patch
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19%global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
20%global majorver %(echo %{shortver} | sed -e 's/\.[0-9]*$//')
21%global minorver %(echo %{shortver} | sed -e 's/^[0-9]*\.//')
22%global patchlevel %(echo %{version} | sed -e 's/^[0-9]*\.[0-9]*\.//')
23
24%define srcver %{shortver}-pl%{patchlevel}
25%define soname %{version}
26
27
28%description
29Contains runtime shared libraries for libgsm, an implementation of
30the European GSM 06.10 provisional standard for full-rate speech
31transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
32excitation/long term prediction) coding at 13 kbit/s.
33
34GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
35rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
36with typical UNIX applications, our implementation turns frames of 160
3716-bit linear samples into 33-byte frames (1650 Bytes/s).
38The quality of the algorithm is good enough for reliable speaker
39recognition; even music often survives transcoding in recognizable
40form (given the bandwidth limitations of 8 kHz sampling rate).
41
42The interfaces offered are a front end modelled after compress(1), and
43a library API.  Compression and decompression run faster than realtime
44on most SPARCstations.  The implementation has been verified against the
45ETSI standard test patterns.
46
47%package        tools
48Summary:        GSM speech compressor tools
49Group:          Applications/Multimedia
50
51%description    tools
52Contains command line utilities for libgsm, an implementation of
53the European GSM 06.10 provisional standard for full-rate speech
54transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
55excitation/long term prediction) coding at 13 kbit/s.
56
57%package        devel
58Summary:        Header files and development libraries for libgsm
59Group:          Development/Libraries
60Requires:       %{name} = %{version}-%{release}
61
62%description    devel
63Contains header files and development libraries for libgsm, an
64implementation of the European GSM 06.10 provisional standard for
65full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
66(residual pulse excitation/long term prediction) coding at 13 kbit/s.
67
68# compat32
69%package -n compat32-%{name}
70Summary:        Shared libraries for GSM speech compressor
71Group:          System Environment/Libraries
72Requires:       %{name} = %{version}-%{release}
73
74%description -n compat32-%{name}
75Contains runtime shared libraries for libgsm, an implementation of
76the European GSM 06.10 provisional standard for full-rate speech
77transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
78excitation/long term prediction) coding at 13 kbit/s.
79
80GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
81rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
82with typical UNIX applications, our implementation turns frames of 160
8316-bit linear samples into 33-byte frames (1650 Bytes/s).
84The quality of the algorithm is good enough for reliable speaker
85recognition; even music often survives transcoding in recognizable
86form (given the bandwidth limitations of 8 kHz sampling rate).
87
88The interfaces offered are a front end modelled after compress(1), and
89a library API.  Compression and decompression run faster than realtime
90on most SPARCstations.  The implementation has been verified against the
91ETSI standard test patterns.
92
93%package -n compat32-%{name}-devel
94Summary:        Header files and development libraries for libgsm
95Group:          Development/Libraries
96Requires:       compat32-%{name} = %{version}-%{release}
97Requires:       %{name}-devel = %{version}-%{release}
98
99%description -n compat32-%{name}-devel
100Contains header files and development libraries for libgsm, an
101implementation of the European GSM 06.10 provisional standard for
102full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
103(residual pulse excitation/long term prediction) coding at 13 kbit/s.
104
105
106%prep
107%setup -n gsm-%{srcver} -q
108%autopatch -p1
109
110perl -pi -e 's/^CCFLAGS .*$/CCFLAGS = -c %{optflags} -DNeedFunctionPrototypes=1 -Wall -Wno-comment -D_XOPEN_SOURCE=700 -D_REENTRANT -fPIC/' Makefile
111
112sed -i \
113        -e 's/@MAJORVER@/%{majorver}/' \
114        -e 's/@MINORVER@/%{minorver}/' \
115        -e 's/@PATCHLEVEL@/%{patchlevel}/' \
116        -e 's/@SOVERSION@/%{soname}/' \
117        Makefile
118
119
120%build
121make %{?_smp_mflags} all
122
123%install
124rm -rf %{buildroot}
125
126mkdir -p %{buildroot}%{_bindir}
127mkdir -p %{buildroot}%{_includedir}/gsm
128mkdir -p %{buildroot}%{_libdir}
129mkdir -p %{buildroot}%{_mandir}/{man1,man3}
130
131make install \
132        INSTALL_ROOT=%{buildroot}%{_prefix} \
133        GSM_INSTALL_INC=%{buildroot}%{_includedir}/gsm \
134        GSM_INSTALL_LIB=%{buildroot}%{_libdir}
135
136# some apps look for this in /usr/include
137ln -s gsm/gsm.h %{buildroot}%{_includedir}
138
139echo ".so toast.1" > %{buildroot}%{_mandir}/man1/tcat.1
140echo ".so toast.1" > %{buildroot}%{_mandir}/man1/untoast.1
141
142
143%check
144# This is to ensure that the patch creates the proper library version.
145[ -f %{buildroot}%{_libdir}/libgsm.so.%{version} ]
146export LDFLAGS="%{?__global_ldflags}"
147make addtst
148
149
150%clean
151rm -rf %{buildroot}
152
153%post -p /sbin/ldconfig
154
155%postun -p /sbin/ldconfig
156
157%post -n compat32-%{name} -p /sbin/ldconfig
158
159%postun -n compat32-%{name} -p /sbin/ldconfig
160
161%files
162%defattr(-,root,root,-)
163%license COPYRIGHT
164%doc ChangeLog MACHINES README
165%{_libdir}/libgsm.so.*
166
167%files tools
168%{_bindir}/tcat
169%{_bindir}/toast
170%{_bindir}/untoast
171%{_mandir}/man1/toast.1*
172%{_mandir}/man1/tcat.1.gz
173%{_mandir}/man1/untoast.1.gz
174
175%files devel
176%defattr(-,root,root,-)
177%dir %{_includedir}/gsm
178%{_includedir}/gsm/gsm.h
179%{_includedir}/gsm.h
180%{_libdir}/libgsm.so
181%{_mandir}/man3/*
182
183# compat32
184%if %{build_compat32}
185%files -n compat32-%{name}
186%defattr(-,root,root,-)
187%{_libdir}/libgsm.so.*
188
189%files -n compat32-%{name}-devel
190%defattr(-,root,root,-)
191%{_libdir}/libgsm.so
192%endif
193
194%changelog
195* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-1
196- new upstream release.
197- updated  Patch0 and 1.
198- dropped Patch2.
199
200* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.14-1
201- new upstream release
202- update Patch1 (%%{name}-1.0.14-warnings.patch)
203
204* Mon Jul  7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.13-1
205- new upstream release.
206
207* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.12-3
208- create compat32 sub package
209
210* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
211- rebuilt with current VineSeed
212
213* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
214- initial build for Vine Linux
215
216* Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
217- Rebuild for GCC 4.3
218
219* Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
220- install symlinks instead of binaries in -devel
221
222* Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
223- rebuild for BuildID
224- specfile cleanups
225
226* Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
227- fix parallel make
228
229* Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
230- fix some warnings
231- fix 64bit testsuite issue as described at gsm homepage
232- add compatibility header symlink
233- split off binaries into a separate package
234
235* Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
236- Update to Release 1.0 Patchlevel 12.
237- Build with -fPIC not just for non-ix86.
238- Add check section to ensure proper library version.
239- Remove static library.
240
241* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
242- rebuilt for unwind info generation, broken in gcc-4.1.1-21
243
244* Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
245- 1.0.10-11
246- rebuild for FC6
247
248* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
249- switch to new release field
250
251* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
252- add dist
253
254* Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
255- 1.0.10-0.lvn.10: Clean up installation
256
257* Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
258- 1.0.10-0.lvn.9: mv libgsm.a only when needed
259
260* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
261- 1.0.10-0.lvn.8: Use -fPIC on non ix86
262
263* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
264- 1.0.10-0.lvn.7: moved to rpm.livna.org
265
266* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
267- 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
268
269* Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
270- 0:1.0.10-0.fdr.6: remove second makeinstall
271
272* Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
273- 0:1.0.10-0.fdr.5
274- added back epochs, I surrender
275- fix RPM_OPT_FLAGS hackery
276
277* Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
278- 1.0.10-0.fdr.4: remove epoch mentions
279
280* Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
281- 1.0.10-0.fdr.3
282- pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
283- fix group
284- -p'ize ldconfig
285
286* Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
287- 1.0.10-0.fdr.2
288- Fix libgsm.so.* being files instead of symlinks
289
290* Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
291- 0:1.0.10-0.fdr.1: initial RPM release
Note: See TracBrowser for help on using the repository browser.