source: projects/specs/trunk/g/gsm/gsm-vl.spec @ 8755

Revision 8755, 8.7 KB checked in by tomop, 10 years ago (diff)

gsm-1.0.13-1

Line 
1%define build_compat32  %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        Shared libraries for GSM speech compressor
4
5Name:           gsm
6Version:        1.0.13
7Release:        1%{?_dist_release}
8
9Group:          System Environment/Libraries
10License:        MIT
11URL:            http://www.quut.com/gsm/
12
13Source:         http://www.quut.com/gsm/%{name}-%{version}.tar.gz
14Patch0:         %{name}-makefile.patch
15Patch1:         %{name}-warnings.patch
16Patch2:         %{name}-64bit.patch
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19%define srcver 1.0-pl13
20%define soname 1.0.12
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26Contains runtime shared libraries for libgsm, an implementation of
27the European GSM 06.10 provisional standard for full-rate speech
28transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
29excitation/long term prediction) coding at 13 kbit/s.
30
31GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
32rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
33with typical UNIX applications, our implementation turns frames of 160
3416-bit linear samples into 33-byte frames (1650 Bytes/s).
35The quality of the algorithm is good enough for reliable speaker
36recognition; even music often survives transcoding in recognizable
37form (given the bandwidth limitations of 8 kHz sampling rate).
38
39The interfaces offered are a front end modelled after compress(1), and
40a library API.  Compression and decompression run faster than realtime
41on most SPARCstations.  The implementation has been verified against the
42ETSI standard test patterns.
43
44%package        tools
45Summary:        GSM speech compressor tools
46Group:          Applications/Multimedia
47
48%description    tools
49Contains command line utilities for libgsm, an implementation of
50the European GSM 06.10 provisional standard for full-rate speech
51transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
52excitation/long term prediction) coding at 13 kbit/s.
53
54%package        devel
55Summary:        Header files and development libraries for libgsm
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58
59%description    devel
60Contains header files and development libraries for libgsm, an
61implementation of the European GSM 06.10 provisional standard for
62full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
63(residual pulse excitation/long term prediction) coding at 13 kbit/s.
64
65# compat32
66%package -n compat32-%{name}
67Summary:        Shared libraries for GSM speech compressor
68Group:          System Environment/Libraries
69Requires:       %{name} = %{version}-%{release}
70
71%description -n compat32-%{name}
72Contains runtime shared libraries for libgsm, an implementation of
73the European GSM 06.10 provisional standard for full-rate speech
74transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
75excitation/long term prediction) coding at 13 kbit/s.
76
77GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
78rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
79with typical UNIX applications, our implementation turns frames of 160
8016-bit linear samples into 33-byte frames (1650 Bytes/s).
81The quality of the algorithm is good enough for reliable speaker
82recognition; even music often survives transcoding in recognizable
83form (given the bandwidth limitations of 8 kHz sampling rate).
84
85The interfaces offered are a front end modelled after compress(1), and
86a library API.  Compression and decompression run faster than realtime
87on most SPARCstations.  The implementation has been verified against the
88ETSI standard test patterns.
89
90%package -n compat32-%{name}-devel
91Summary:        Header files and development libraries for libgsm
92Group:          Development/Libraries
93Requires:       %{name}-devel = %{version}-%{release}
94
95%description -n compat32-%{name}-devel
96Contains header files and development libraries for libgsm, an
97implementation of the European GSM 06.10 provisional standard for
98full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
99(residual pulse excitation/long term prediction) coding at 13 kbit/s.
100
101
102%prep
103%setup -n gsm-%{srcver} -q
104%patch0 -p1 -b .mk
105%patch1 -p1 -b .warn
106%patch2 -p1 -b .64bit
107
108%build
109export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
110make %{?_smp_mflags} all
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115mkdir -p $RPM_BUILD_ROOT%{_bindir}
116mkdir -p $RPM_BUILD_ROOT%{_includedir}/gsm
117mkdir -p $RPM_BUILD_ROOT%{_libdir}
118mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man1,man3}
119
120make install \
121        INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix} \
122        GSM_INSTALL_INC=$RPM_BUILD_ROOT%{_includedir}/gsm \
123        GSM_INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
124
125cp -p $RPM_BUILD_DIR/gsm-%{srcver}/lib/libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}
126ln -s libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}/libgsm.so.1
127ln -s libgsm.so.%{soname} $RPM_BUILD_ROOT%{_libdir}/libgsm.so
128
129# some apps look for this in /usr/include
130ln -s gsm/gsm.h $RPM_BUILD_ROOT%{_includedir}
131
132rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
133
134
135%check
136# This is to ensure that the patch creates the proper library version.
137[ -f $RPM_BUILD_ROOT%{_libdir}/libgsm.so.%{soname} ]
138make addtst
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%post -p /sbin/ldconfig
145
146%postun -p /sbin/ldconfig
147
148%post -n compat32-%{name} -p /sbin/ldconfig
149
150%postun -n compat32-%{name} -p /sbin/ldconfig
151
152%files
153%defattr(-,root,root,-)
154%doc ChangeLog COPYRIGHT MACHINES README
155%{_libdir}/libgsm.so.*
156
157%files tools
158%{_bindir}/tcat
159%{_bindir}/toast
160%{_bindir}/untoast
161%{_mandir}/man1/toast.1*
162
163%files devel
164%defattr(-,root,root,-)
165%dir %{_includedir}/gsm
166%{_includedir}/gsm/gsm.h
167%{_includedir}/gsm.h
168%{_libdir}/libgsm.so
169%{_mandir}/man3/*
170
171# compat32
172%if %{build_compat32}
173%files -n compat32-%{name}
174%defattr(-,root,root,-)
175%{_libdir}/libgsm.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-,root,root,-)
179%{_libdir}/libgsm.so
180%endif
181
182%changelog
183* Mon Jul  7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.13-1
184- new upstream release.
185
186* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.12-3
187- create compat32 sub package
188
189* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
190- rebuilt with current VineSeed
191
192* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
193- initial build for Vine Linux
194
195* Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
196- Rebuild for GCC 4.3
197
198* Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
199- install symlinks instead of binaries in -devel
200
201* Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
202- rebuild for BuildID
203- specfile cleanups
204
205* Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
206- fix parallel make
207
208* Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
209- fix some warnings
210- fix 64bit testsuite issue as described at gsm homepage
211- add compatibility header symlink
212- split off binaries into a separate package
213
214* Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
215- Update to Release 1.0 Patchlevel 12.
216- Build with -fPIC not just for non-ix86.
217- Add check section to ensure proper library version.
218- Remove static library.
219
220* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
221- rebuilt for unwind info generation, broken in gcc-4.1.1-21
222
223* Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
224- 1.0.10-11
225- rebuild for FC6
226
227* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
228- switch to new release field
229
230* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
231- add dist
232
233* Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
234- 1.0.10-0.lvn.10: Clean up installation
235
236* Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
237- 1.0.10-0.lvn.9: mv libgsm.a only when needed
238
239* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
240- 1.0.10-0.lvn.8: Use -fPIC on non ix86
241
242* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
243- 1.0.10-0.lvn.7: moved to rpm.livna.org
244
245* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
246- 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
247
248* Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
249- 0:1.0.10-0.fdr.6: remove second makeinstall
250
251* Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
252- 0:1.0.10-0.fdr.5
253- added back epochs, I surrender
254- fix RPM_OPT_FLAGS hackery
255
256* Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
257- 1.0.10-0.fdr.4: remove epoch mentions
258
259* Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
260- 1.0.10-0.fdr.3
261- pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
262- fix group
263- -p'ize ldconfig
264
265* Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
266- 1.0.10-0.fdr.2
267- Fix libgsm.so.* being files instead of symlinks
268
269* Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
270- 0:1.0.10-0.fdr.1: initial RPM release
Note: See TracBrowser for help on using the repository browser.