source: projects/specs/trunk/g/gsm/gsm-vl.spec @ 4616

Revision 4616, 8.7 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

RevLine 
[4616]1%define build_compat32  %{?_with_compat32:1}%{!?_with_compat32:0}
2
[521]3Summary:        Shared libraries for GSM speech compressor
4
5Name:           gsm
6Version:        1.0.12
[3495]7Release:        2%{?_dist_release}
[521]8
9Group:          System Environment/Libraries
10License:        MIT
11URL:            http://kbs.cs.tu-berlin.de/~jutta/toast.html
[3495]12
[521]13Source:         http://kbs.cs.tu-berlin.de/~jutta/gsm/%{name}-%{version}.tar.gz
14Patch0:         %{name}-makefile.patch
15Patch1:         %{name}-warnings.patch
16Patch2:         %{name}-64bit.patch
[3495]17BuildRoot: %{_tmppath}/%{name}-%{version}-root
[521]18
19%define srcver 1.0-pl12
20
[4616]21Vendor: Project Vine
22Distribution: Vine Linux
23
[521]24%description
25Contains runtime shared libraries for libgsm, an implementation of
26the European GSM 06.10 provisional standard for full-rate speech
27transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
28excitation/long term prediction) coding at 13 kbit/s.
29
30GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
31rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
32with typical UNIX applications, our implementation turns frames of 160
3316-bit linear samples into 33-byte frames (1650 Bytes/s).
34The quality of the algorithm is good enough for reliable speaker
35recognition; even music often survives transcoding in recognizable
36form (given the bandwidth limitations of 8 kHz sampling rate).
37
38The interfaces offered are a front end modelled after compress(1), and
39a library API.  Compression and decompression run faster than realtime
40on most SPARCstations.  The implementation has been verified against the
41ETSI standard test patterns.
42
43%package        tools
44Summary:        GSM speech compressor tools
45Group:          Applications/Multimedia
46
47%description    tools
48Contains command line utilities for libgsm, an implementation of
49the European GSM 06.10 provisional standard for full-rate speech
50transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
51excitation/long term prediction) coding at 13 kbit/s.
52
53%package        devel
54Summary:        Header files and development libraries for libgsm
55Group:          Development/Libraries
56Requires:       %{name} = %{version}-%{release}
57
58%description    devel
59Contains header files and development libraries for libgsm, an
60implementation of the European GSM 06.10 provisional standard for
61full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
62(residual pulse excitation/long term prediction) coding at 13 kbit/s.
63
[4616]64# compat32
65%package -n compat32-%{name}
66Summary:        Shared libraries for GSM speech compressor
67Group:          System Environment/Libraries
68Requires:       %{name} = %{version}-%{release}
69
70%description -n compat32-%{name}
71Contains runtime shared libraries for libgsm, an implementation of
72the European GSM 06.10 provisional standard for full-rate speech
73transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
74excitation/long term prediction) coding at 13 kbit/s.
75
76GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
77rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
78with typical UNIX applications, our implementation turns frames of 160
7916-bit linear samples into 33-byte frames (1650 Bytes/s).
80The quality of the algorithm is good enough for reliable speaker
81recognition; even music often survives transcoding in recognizable
82form (given the bandwidth limitations of 8 kHz sampling rate).
83
84The interfaces offered are a front end modelled after compress(1), and
85a library API.  Compression and decompression run faster than realtime
86on most SPARCstations.  The implementation has been verified against the
87ETSI standard test patterns.
88
89%package -n compat32-%{name}-devel
90Summary:        Header files and development libraries for libgsm
91Group:          Development/Libraries
92Requires:       %{name}-devel = %{version}-%{release}
93
94%description -n compat32-%{name}-devel
95Contains header files and development libraries for libgsm, an
96implementation of the European GSM 06.10 provisional standard for
97full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
98(residual pulse excitation/long term prediction) coding at 13 kbit/s.
99
100
[521]101%prep
102%setup -n gsm-%{srcver} -q
103%patch0 -p1 -b .mk
104%patch1 -p1 -b .warn
105%patch2 -p1 -b .64bit
106
107%build
108export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
109make %{?_smp_mflags} all
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114mkdir -p $RPM_BUILD_ROOT%{_bindir}
115mkdir -p $RPM_BUILD_ROOT%{_includedir}/gsm
116mkdir -p $RPM_BUILD_ROOT%{_libdir}
117mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man1,man3}
118
119make install \
120        INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix} \
121        GSM_INSTALL_INC=$RPM_BUILD_ROOT%{_includedir}/gsm \
122        GSM_INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
123
124cp -p $RPM_BUILD_DIR/gsm-%{srcver}/lib/libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}
125ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so.1
126ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so
127
128# some apps look for this in /usr/include
129ln -s gsm/gsm.h $RPM_BUILD_ROOT%{_includedir}
130
131rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
132
133
134%check
135# This is to ensure that the patch creates the proper library version.
136[ -f $RPM_BUILD_ROOT%{_libdir}/libgsm.so.%{version} ]
137make addtst
138
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post -p /sbin/ldconfig
144
145%postun -p /sbin/ldconfig
146
[4616]147%post -n compat32-%{name} -p /sbin/ldconfig
148
149%postun -n compat32-%{name} -p /sbin/ldconfig
150
[521]151%files
152%defattr(-,root,root,-)
153%doc ChangeLog COPYRIGHT MACHINES README
154%{_libdir}/libgsm.so.*
155
156%files tools
157%{_bindir}/tcat
158%{_bindir}/toast
159%{_bindir}/untoast
160%{_mandir}/man1/toast.1*
161
162%files devel
163%defattr(-,root,root,-)
164%dir %{_includedir}/gsm
165%{_includedir}/gsm/gsm.h
166%{_includedir}/gsm.h
167%{_libdir}/libgsm.so
168%{_mandir}/man3/*
169
[4616]170# compat32
171%if %{build_compat32}
172%files -n compat32-%{name}
173%defattr(-,root,root,-)
174%{_libdir}/libgsm.so.*
175
176%files -n compat32-%{name}-devel
177%defattr(-,root,root,-)
178%{_libdir}/libgsm.so
179%endif
180
[521]181%changelog
[4616]182* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.12-3
183- create compat32 sub package
184
[3495]185* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
186- rebuilt with current VineSeed
187
[521]188* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
189- initial build for Vine Linux
190
191* Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
192- Rebuild for GCC 4.3
193
194* Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
195- install symlinks instead of binaries in -devel
196
197* Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
198- rebuild for BuildID
199- specfile cleanups
200
201* Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
202- fix parallel make
203
204* Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
205- fix some warnings
206- fix 64bit testsuite issue as described at gsm homepage
207- add compatibility header symlink
208- split off binaries into a separate package
209
210* Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
211- Update to Release 1.0 Patchlevel 12.
212- Build with -fPIC not just for non-ix86.
213- Add check section to ensure proper library version.
214- Remove static library.
215
216* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
217- rebuilt for unwind info generation, broken in gcc-4.1.1-21
218
219* Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
220- 1.0.10-11
221- rebuild for FC6
222
223* Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
224- switch to new release field
225
226* Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
227- add dist
228
229* Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
230- 1.0.10-0.lvn.10: Clean up installation
231
232* Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
233- 1.0.10-0.lvn.9: mv libgsm.a only when needed
234
235* Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
236- 1.0.10-0.lvn.8: Use -fPIC on non ix86
237
238* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
239- 1.0.10-0.lvn.7: moved to rpm.livna.org
240
241* Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
242- 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
243
244* Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
245- 0:1.0.10-0.fdr.6: remove second makeinstall
246
247* Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
248- 0:1.0.10-0.fdr.5
249- added back epochs, I surrender
250- fix RPM_OPT_FLAGS hackery
251
252* Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
253- 1.0.10-0.fdr.4: remove epoch mentions
254
255* Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
256- 1.0.10-0.fdr.3
257- pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
258- fix group
259- -p'ize ldconfig
260
261* Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
262- 1.0.10-0.fdr.2
263- Fix libgsm.so.* being files instead of symlinks
264
265* Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
266- 0:1.0.10-0.fdr.1: initial RPM release
Note: See TracBrowser for help on using the repository browser.