source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 8760

Revision 8760, 9.1 KB checked in by daisuke, 10 years ago (diff)

graphviz: update to 2.38.0

Line 
1Name:           graphviz
2Summary:        Graph Visualization Tools
3Summary(ja):    グラフ可視化ツール
4Version:        2.38.0
5Release:        1%{?_dist_release}
6Group:          Applications/Graphics
7License:        CPL
8URL:            http://www.graphviz.org/
9
10Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires:  bison
15BuildRequires:  cairo-devel
16BuildRequires:  expat-devel
17BuildRequires:  flex
18BuildRequires:  fontconfig-devel
19BuildRequires:  freetype2-devel
20BuildRequires:  gd-devel
21BuildRequires:  gtk2-devel
22BuildRequires:  guile-devel
23BuildRequires:  libjpeg-turbo-devel
24BuildRequires:  libpng-devel
25BuildRequires:  libSM-devel
26BuildRequires:  libtool-ltdl-devel >= 2.2.6a
27BuildRequires:  libXaw-devel
28BuildRequires:  libXext-devel
29BuildRequires:  librsvg2-devel
30BuildRequires:  m4
31BuildRequires:  perl
32BuildRequires:  python-devel
33BuildRequires:  ruby-devel
34BuildRequires:  swig
35BuildRequires:  tcl >= 8.4
36BuildRequires:  tk >= 8.4
37BuildRequires:  zlib-devel
38Requires:       urw-fonts
39
40# only for this release
41BuildConflicts: graphviz-devel
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       daisuke
46
47%description
48A collection of tools and tcl packages for the manipulation and layout
49of graphs (as in nodes and edges, not as in barcharts).
50
51%package devel
52Group:          Development/Libraries
53Summary:        Development tools for version %{version} of %{name}
54Requires:       %{name} = %{version}
55
56%description devel
57The %{name}-devel package contains the header files
58and man3 pages necessary for developing programs
59using version %{version} of the %{name} libraries.
60
61%package doc
62Summary: PDF and HTML documents for graphviz
63Group:   Applications/Documentation
64
65%description doc
66Provides some additional PDF and HTML documentation for graphviz.
67
68%package guile
69Group:          Applications/Graphics
70Summary:        Guile extension for graphviz
71Requires:       %{name} = %{version}-%{release}, guile
72
73%description guile
74Guile extension for graphviz.
75
76%package perl
77Group:    Applications/Graphics
78Summary:  Perl extension for graphviz
79Requires: %{name} = %{version}-%{release}
80Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
81
82%description perl
83Perl extension for graphviz.
84
85%package python
86Group:    Applications/Graphics
87Summary:  Python extension for graphviz
88Requires: %{name} = %{version}-%{release}
89Requires: python
90
91%description python
92Python extension for graphviz.
93
94%package ruby
95Group:    Applications/Multimedia
96Summary:  Ruby extension for graphviz
97Requires: %{name} = %{version}-%{release}
98Requires: ruby
99
100%description ruby
101Ruby extension for graphviz.
102
103%package tcl
104Group:    Applications/Graphics
105Summary:  Tcl extension & tools for graphviz
106Requires: tcl >= 8.4, tk >= 8.4
107Requires: %{name} = %{version}
108
109%description tcl
110Various tcl packages (extensions) for the graphviz tools.
111
112
113%prep
114%setup -q
115
116# using archdir instead of sitearchdir for Vine
117sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
118
119%build
120# Rewrite config_ruby.rb to work with Ruby 1.9
121sed -i 's|expand(|expand(Config::|' config/config_ruby.rb
122sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
123export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
124
125# XXX ix86 only used to have -ffast-math, let's use everywhere
126%{expand: %%define optflags %{optflags} -ffast-math}
127
128%configure \
129    --with-x \
130    --disable-static \
131    --with-mylibgd \
132    --with-ipsepcola \
133    --with-pangocairo \
134    --with-gdk-pixbuf \
135    --without-mylibgd \
136    --without-ming \
137    --disable-sharp \
138    --enable-guile \
139    --enable-io \
140    --disable-java \
141    --disable-lua \
142    --disable-ocaml \
143    --enable-perl \
144    --disable-php \
145    --enable-python \
146    --disable-r \
147    --enable-ruby \
148    --enable-tcl
149
150make %{?_smp_mflags}
151
152%install
153rm -rf $RPM_BUILD_ROOT __doc
154make DESTDIR=$RPM_BUILD_ROOT \
155    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
156    pkgconfigdir=%{_libdir}/pkgconfig \
157    install
158
159find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
160chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
161cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
162rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
168%post
169/sbin/ldconfig
170%{_bindir}/dot -c
171
172# if there is no dot after everything else is done, then remove config
173%postun
174if [ $1 -eq 0 ]; then
175    rm -f %{_libdir}/graphviz/config || :
176fi
177/sbin/ldconfig
178
179
180%files
181%defattr(-,root,root)
182%doc AUTHORS COPYING ChangeLog NEWS README
183%{_bindir}/*
184%dir %{_datadir}/%{name}
185%{_datadir}/%{name}/gvpr
186%{_datadir}/%{name}/lefty
187%{_mandir}/man1/*
188%{_mandir}/man7/*
189%dir %{_libdir}/%{name}
190%{_libdir}/*.so.*
191%{_libdir}/%{name}/*.so.*
192%exclude %{_libdir}/graphviz/*/*
193
194%files devel
195%defattr(-,root,root)
196%{_includedir}/%{name}
197%{_libdir}/*.so
198%{_libdir}/%{name}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_datadir}/%{name}/graphs
201%{_mandir}/man3/*.3.gz
202
203%files doc
204%defattr(-,root,root,-)
205%doc __doc/*
206
207%files guile
208%defattr(-,root,root,-)
209%{_libdir}/graphviz/guile/
210%{_mandir}/man3/gv.3guile*
211
212%files perl
213%defattr(-,root,root,-)
214%{_libdir}/graphviz/perl/
215%{perl_vendorarch}/*
216%{_mandir}/man3/gv.3perl*
217
218%files python
219%defattr(-,root,root,-)
220%{_libdir}/graphviz/python/
221%{_libdir}/python*/*
222%{_mandir}/man3/gv.3python*
223
224%files ruby
225%defattr(-,root,root,-)
226%{_libdir}/graphviz/ruby/
227%{_libdir}/*ruby*/*
228%{_mandir}/man3/gv.3ruby*
229
230%files tcl
231%defattr(-,root,root)
232%{_libdir}/%{name}/tcl/*
233%{_libdir}/tcl*/*
234%{_datadir}/%{name}/demo
235# hack to include gv.3tcl only if available
236#  always includes tcldot.3tcl, gdtclft.3tcl
237%{_mandir}/man3/*.3tcl*
238%{_mandir}/man3/tkspline.3tk*
239
240
241%changelog
242* Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
243- update to 2.38.0
244
245* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
246- new upstream release
247
248* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
249- rebuilt with gd-2.1.0.
250
251* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
252- new upstream release
253
254* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
255- build with Tcl/Tk 8.5.7-1
256- stop running autoreconf
257- add Vendor and Distribution tags
258
259* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
260- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
261  - rewrite config_ruby.rb to build with ruby-1.9.3
262  - add search path for ruby/config.h to CPPFLAGS for configure
263
264* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
265- new upstream release
266- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
267- add BuildRequires: librsvg2-devel
268
269* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
270- add Patch10 to avoid build failure on ppc
271
272* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
273- new upstream release
274- built with rpm-4.8.1
275- split doc, guile, perl, python, ruby subpackage
276
277* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
278- rebuild with libtool-2.2.6a
279
280* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
281- new upstream release
282
283* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
284- rebuild with libXaw.so.7 (libXaw-1.0.5)
285
286* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
287- new upstream release
288
289* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
290- new upstream release
291- build with expat-2.0.1
292- add man7
293
294* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
295- rebuild with tcl/tk-8.4.16
296
297* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
298- new upstream release
299- add BuildPrereq: swig
300- delete BuildPrereq: gd-progs gd-devel
301- add --with-mylibgd and --disable-FEATURE to configure option
302- update %%files
303
304* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
305- added BuildPrereq: ruby-devel
306
307* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
308- new upstream release
309- add BuildPrereq: libtool-ltdl-devel
310- move pkgconfig files to %%{_libdir}/pkgconfig
311- add --disable-rpath --disable-static to configure option
312- add %%post to every package
313
314* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
315- new upstream release
316- BuildPrereq: tcl >= 8.4, tk >= 8.4
317- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
318- update %%files
319- remove lines about Vine2.6
320- change License to CPL
321
322* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
323- source upgrade
324- remove patch0 and commented lines
325
326* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
327- build for VineSeed
328
329* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
330- source upgrade
331- change spec to build both VineSeed and Vine2.5/2.6
332- add BuildPrereq: expat-devel and Requires: libexpat
333- add patch0 to build against freetype2-2.1.7
334- stop using autogen.sh script
335- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
336- add graphviz-tcl package (VineSeed)
337
338* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
339- rebuild for new Vine
340
341* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
342- import from offical site (src.rpm)
343
Note: See TracBrowser for help on using the repository browser.