source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 8188

Revision 8188, 9.0 KB checked in by kenta, 10 years ago (diff)
  • graphviz
    • new upstream release
Line 
1Name:           graphviz
2Summary:        Graph Visualization Tools
3Version:        2.36.0
4Release:        1%{?_dist_release}
5Group:          Applications/Graphics
6License:        CPL
7URL:            http://www.graphviz.org/
8
9Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  bison
14BuildRequires:  cairo-devel
15BuildRequires:  expat-devel
16BuildRequires:  flex
17BuildRequires:  fontconfig-devel
18BuildRequires:  freetype2-devel
19BuildRequires:  gd-devel
20BuildRequires:  gtk2-devel
21BuildRequires:  guile-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libpng-devel
24BuildRequires:  libSM-devel
25BuildRequires:  libtool-ltdl-devel >= 2.2.6a
26BuildRequires:  libXaw-devel
27BuildRequires:  libXext-devel
28BuildRequires:  librsvg2-devel
29BuildRequires:  m4
30BuildRequires:  perl
31BuildRequires:  python-devel
32BuildRequires:  ruby-devel
33BuildRequires:  swig
34BuildRequires:  tcl >= 8.4
35BuildRequires:  tk >= 8.4
36BuildRequires:  zlib-devel
37Requires:       urw-fonts
38
39# only for this release
40BuildConflicts: graphviz-devel
41
42Vendor:         Project Vine
43Distribution:   Vine Linux
44
45%description
46A collection of tools and tcl packages for the manipulation and layout
47of graphs (as in nodes and edges, not as in barcharts).
48
49%package devel
50Group:          Development/Libraries
51Summary:        Development tools for version %{version} of %{name}
52Requires:       %{name} = %{version}
53
54%description devel
55The %{name}-devel package contains the header files
56and man3 pages necessary for developing programs
57using version %{version} of the %{name} libraries.
58
59%package doc
60Summary: PDF and HTML documents for graphviz
61Group:   Applications/Documentation
62
63%description doc
64Provides some additional PDF and HTML documentation for graphviz.
65
66%package guile
67Group:          Applications/Graphics
68Summary:        Guile extension for graphviz
69Requires:       %{name} = %{version}-%{release}, guile
70
71%description guile
72Guile extension for graphviz.
73
74%package perl
75Group:    Applications/Graphics
76Summary:  Perl extension for graphviz
77Requires: %{name} = %{version}-%{release}
78Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
79
80%description perl
81Perl extension for graphviz.
82
83%package python
84Group:    Applications/Graphics
85Summary:  Python extension for graphviz
86Requires: %{name} = %{version}-%{release}
87Requires: python
88
89%description python
90Python extension for graphviz.
91
92%package ruby
93Group:    Applications/Multimedia
94Summary:  Ruby extension for graphviz
95Requires: %{name} = %{version}-%{release}
96Requires: ruby
97
98%description ruby
99Ruby extension for graphviz.
100
101%package tcl
102Group:    Applications/Graphics
103Summary:  Tcl extension & tools for graphviz
104Requires: tcl >= 8.4, tk >= 8.4
105Requires: %{name} = %{version}
106
107%description tcl
108Various tcl packages (extensions) for the graphviz tools.
109
110
111%prep
112%setup -q
113
114# using archdir instead of sitearchdir for Vine
115sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
116
117%build
118# Rewrite config_ruby.rb to work with Ruby 1.9
119sed -i 's|expand(|expand(Config::|' config/config_ruby.rb
120sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
121export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
122
123# XXX ix86 only used to have -ffast-math, let's use everywhere
124%{expand: %%define optflags %{optflags} -ffast-math}
125
126%configure \
127    --with-x \
128    --disable-static \
129    --with-mylibgd \
130    --with-ipsepcola \
131    --with-pangocairo \
132    --with-gdk-pixbuf \
133    --without-mylibgd \
134    --without-ming \
135    --disable-sharp \
136    --enable-guile \
137    --enable-io \
138    --disable-java \
139    --disable-lua \
140    --disable-ocaml \
141    --enable-perl \
142    --disable-php \
143    --enable-python \
144    --disable-r \
145    --enable-ruby \
146    --enable-tcl
147
148make %{?_smp_mflags}
149
150%install
151rm -rf $RPM_BUILD_ROOT __doc
152make DESTDIR=$RPM_BUILD_ROOT \
153    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
154    pkgconfigdir=%{_libdir}/pkgconfig \
155    install
156
157find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
158chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
159cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
160rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
166%post
167/sbin/ldconfig
168%{_bindir}/dot -c
169
170# if there is no dot after everything else is done, then remove config
171%postun
172if [ $1 -eq 0 ]; then
173    rm -f %{_libdir}/graphviz/config || :
174fi
175/sbin/ldconfig
176
177
178%files
179%defattr(-,root,root)
180%doc AUTHORS COPYING ChangeLog NEWS README
181%{_bindir}/*
182%dir %{_datadir}/%{name}
183%{_datadir}/%{name}/gvpr
184%{_datadir}/%{name}/lefty
185%{_mandir}/man1/*
186%{_mandir}/man7/*
187%dir %{_libdir}/%{name}
188%{_libdir}/*.so.*
189%{_libdir}/%{name}/*.so.*
190%exclude %{_libdir}/graphviz/*/*
191
192%files devel
193%defattr(-,root,root)
194%{_includedir}/%{name}
195%{_libdir}/*.so
196%{_libdir}/%{name}/*.so
197%{_libdir}/pkgconfig/*.pc
198%{_datadir}/%{name}/graphs
199%{_mandir}/man3/*.3.gz
200
201%files doc
202%defattr(-,root,root,-)
203%doc __doc/*
204
205%files guile
206%defattr(-,root,root,-)
207%{_libdir}/graphviz/guile/
208%{_mandir}/man3/gv.3guile*
209
210%files perl
211%defattr(-,root,root,-)
212%{_libdir}/graphviz/perl/
213%{perl_vendorarch}/*
214%{_mandir}/man3/gv.3perl*
215
216%files python
217%defattr(-,root,root,-)
218%{_libdir}/graphviz/python/
219%{_libdir}/python*/*
220%{_mandir}/man3/gv.3python*
221
222%files ruby
223%defattr(-,root,root,-)
224%{_libdir}/graphviz/ruby/
225%{_libdir}/*ruby*/*
226%{_mandir}/man3/gv.3ruby*
227
228%files tcl
229%defattr(-,root,root)
230%{_libdir}/%{name}/tcl/*
231%{_libdir}/tcl*/*
232%{_datadir}/%{name}/demo
233# hack to include gv.3tcl only if available
234#  always includes tcldot.3tcl, gdtclft.3tcl
235%{_mandir}/man3/*.3tcl*
236%{_mandir}/man3/tkspline.3tk*
237
238
239%changelog
240* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
241- new upstream release
242
243* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
244- rebuilt with gd-2.1.0.
245
246* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
247- new upstream release
248
249* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
250- build with Tcl/Tk 8.5.7-1
251- stop running autoreconf
252- add Vendor and Distribution tags
253
254* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
255- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
256  - rewrite config_ruby.rb to build with ruby-1.9.3
257  - add search path for ruby/config.h to CPPFLAGS for configure
258
259* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
260- new upstream release
261- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
262- add BuildRequires: librsvg2-devel
263
264* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
265- add Patch10 to avoid build failure on ppc
266
267* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
268- new upstream release
269- built with rpm-4.8.1
270- split doc, guile, perl, python, ruby subpackage
271
272* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
273- rebuild with libtool-2.2.6a
274
275* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
276- new upstream release
277
278* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
279- rebuild with libXaw.so.7 (libXaw-1.0.5)
280
281* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
282- new upstream release
283
284* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
285- new upstream release
286- build with expat-2.0.1
287- add man7
288
289* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
290- rebuild with tcl/tk-8.4.16
291
292* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
293- new upstream release
294- add BuildPrereq: swig
295- delete BuildPrereq: gd-progs gd-devel
296- add --with-mylibgd and --disable-FEATURE to configure option
297- update %%files
298
299* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
300- added BuildPrereq: ruby-devel
301
302* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
303- new upstream release
304- add BuildPrereq: libtool-ltdl-devel
305- move pkgconfig files to %%{_libdir}/pkgconfig
306- add --disable-rpath --disable-static to configure option
307- add %%post to every package
308
309* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
310- new upstream release
311- BuildPrereq: tcl >= 8.4, tk >= 8.4
312- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
313- update %%files
314- remove lines about Vine2.6
315- change License to CPL
316
317* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
318- source upgrade
319- remove patch0 and commented lines
320
321* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
322- build for VineSeed
323
324* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
325- source upgrade
326- change spec to build both VineSeed and Vine2.5/2.6
327- add BuildPrereq: expat-devel and Requires: libexpat
328- add patch0 to build against freetype2-2.1.7
329- stop using autogen.sh script
330- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
331- add graphviz-tcl package (VineSeed)
332
333* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
334- rebuild for new Vine
335
336* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
337- import from offical site (src.rpm)
338
Note: See TracBrowser for help on using the repository browser.