source: projects/specs/trunk/g/graphviz/graphviz-vl.spec @ 12474

Revision 12474, 11.1 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

brotli-1.0.7-5

graphviz-2.44.1-1

llvm-10.0.1-1

libplist-2.2.0-2

libpwquality-1.4.2-2

python-nose-1.3.7-2

Line 
1%define _unpackaged_files_terminate_build 1
2
3Summary:        Graph Visualization Tools
4Summary(ja):    グラフ可視化ツール
5Name:           graphviz
6Version:        2.44.1
7Release:        1%{?_dist_release}
8Group:          graphics
9Vendor:         Project Vine
10Distribution:   Vine Linux
11Packager:       daisuke
12
13License:        EPL
14URL:            http://www.graphviz.org/
15Source0:        https://www2.graphviz.org/Packages/stable/portable_source/%{name}-%{version}.tar.gz
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  bison
19BuildRequires:  cairo-devel
20BuildRequires:  expat-devel
21BuildRequires:  flex
22BuildRequires:  fontconfig-devel
23BuildRequires:  freetype2-devel
24BuildRequires:  gd-devel
25BuildRequires:  ghostscript
26BuildRequires:  gmp-devel
27BuildRequires:  gtk2-devel
28BuildRequires:  guile-devel
29BuildRequires:  libjpeg-turbo-devel
30BuildRequires:  libpng-devel
31BuildRequires:  libSM-devel
32BuildRequires:  libtool-ltdl-devel >= 2.2.6a
33BuildRequires:  libXaw-devel
34BuildRequires:  libXext-devel
35BuildRequires:  librsvg2-devel
36BuildRequires:  lua-devel
37BuildRequires:  m4
38BuildRequires:  perl
39BuildRequires:  python-devel
40BuildRequires:  python2-rpm-macros
41BuildRequires:  python3-devel
42BuildRequires:  python3-rpm-macros
43BuildRequires:  python3-setuptools
44BuildRequires:  ruby-devel
45BuildRequires:  swig
46BuildRequires:  tcl-devel >= 8.4
47BuildRequires:  tk-devel >= 8.4
48BuildRequires:  zlib-devel
49Requires:       urw-fonts
50
51# only for this release
52# BuildConflicts: graphviz-devel
53
54%description
55A collection of tools and tcl packages for the manipulation and layout
56of graphs (as in nodes and edges, not as in barcharts).
57
58
59%package devel
60Summary:        Development tools for version %{version} of %{name}
61Group:          programming
62Requires:       %{name} = %{version}
63
64%description devel
65The %{name}-devel package contains the header files
66and man3 pages necessary for developing programs
67using version %{version} of the %{name} libraries.
68
69
70%package doc
71Summary: PDF and HTML documents for graphviz
72Group:   documentation
73
74%description doc
75Provides some additional PDF and HTML documentation for graphviz.
76
77
78%package guile
79Summary:        Guile extension for graphviz
80Group:          programming
81Requires:       %{name} = %{version}-%{release}, guile
82
83%description guile
84Guile extension for graphviz.
85
86
87%package lua
88Summary:        Lua extension for graphviz
89Group:          programming
90Requires:       %{name} = %{version}-%{release}, lua
91
92%description lua
93Lua extension for graphviz.
94
95
96%package perl
97Summary:  Perl extension for graphviz
98Group:          programming
99Requires: %{name} = %{version}-%{release}
100Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
101
102%description perl
103Perl extension for graphviz.
104
105
106%package python
107Summary:  Python extension for graphviz
108Group:          programming
109Requires: %{name} = %{version}-%{release}
110Requires: python
111
112%description python
113Python extension for graphviz.
114
115
116%package python3
117Summary:  Python3 extension for graphviz
118Group:          programming
119Requires: %{name} = %{version}-%{release}
120Requires: python3
121
122%description python3
123Python3 extension for graphviz.
124
125
126%package ruby
127Summary:  Ruby extension for graphviz
128Group:          programming
129Requires: %{name} = %{version}-%{release}
130Requires: ruby
131
132%description ruby
133Ruby extension for graphviz.
134
135
136%package tcl
137Summary:  Tcl extension & tools for graphviz
138Group:          programming
139Requires: tcl >= 8.4, tk >= 8.4
140Requires: %{name} = %{version}
141
142%description tcl
143Various tcl packages (extensions) for the graphviz tools.
144
145
146%prep
147%setup -q -n graphviz-%{version}
148# Attempt to fix rpmlint warnings about executable sources
149find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
150
151
152%build
153./autogen.sh
154
155# using archdir instead of sitearchdir for Vine
156sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
157# Rewrite config_ruby.rb to work with Ruby 2.1
158sed -i 's|expand(|expand(RbConfig::|' config/config_ruby.rb
159sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
160
161# get the path to search for ruby/config.h to CPPFLAGS, so that configure can find it
162export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
163# XXX ix86 only used to have -ffast-math, let's use everywhere
164%{expand: %%define optflags %{optflags} -ffast-math}
165
166%configure \
167    --with-x \
168    --disable-static \
169    --with-mylibgd \
170    --with-ipsepcola \
171    --with-pangocairo \
172    --with-gdk-pixbuf \
173    --without-mylibgd \
174    --without-ming \
175    --without-qt \
176    --disable-sharp \
177    --enable-guile \
178    --disable-java \
179    --enable-lua \
180    --disable-ocaml \
181    --enable-perl \
182    --disable-php \
183    --enable-python \
184    --enable-python3 \
185    --disable-r \
186    --enable-ruby \
187    --enable-swig \
188    --enable-tcl \
189    --with-visio
190
191make %{?_smp_mflags}
192
193
194%install
195rm -rf $RPM_BUILD_ROOT __doc
196make DESTDIR=$RPM_BUILD_ROOT \
197    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
198    pkgconfigdir=%{_libdir}/pkgconfig \
199    install
200
201find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
202chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
203cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
204rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
205
206rm -rf %{buildroot}%{_libdir}/graphviz/python2
207
208
209%clean
210rm -rf $RPM_BUILD_ROOT
211
212
213# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
214%post
215/sbin/ldconfig
216%{_bindir}/dot -c
217
218# if there is no dot after everything else is done, then remove config
219%postun
220if [ $1 -eq 0 ]; then
221    rm -f %{_libdir}/graphviz/config || :
222fi
223/sbin/ldconfig
224
225
226%files
227%defattr(-,root,root)
228%license COPYING
229%doc AUTHORS ChangeLog NEWS README
230%{_bindir}/*
231%dir %{_datadir}/%{name}
232%{_datadir}/%{name}/gvpr
233%{_datadir}/%{name}/lefty
234%{_mandir}/man1/*
235%{_mandir}/man7/*
236%dir %{_libdir}/%{name}
237%{_libdir}/*.so.*
238%{_libdir}/%{name}/*.so.*
239%exclude %{_libdir}/graphviz/*/*
240
241%files devel
242%defattr(-,root,root)
243%{_includedir}/%{name}
244%{_libdir}/*.so
245%{_libdir}/%{name}/*.so
246%{_libdir}/pkgconfig/*.pc
247%{_datadir}/%{name}/graphs
248%{_mandir}/man3/*.3.gz
249
250%files doc
251%defattr(-,root,root,-)
252%doc __doc/*
253
254%files guile
255%defattr(-,root,root,-)
256%{_libdir}/graphviz/guile/
257%{_mandir}/man3/gv.3guile*
258
259%files lua
260%defattr(-,root,root,-)
261%{_libdir}/graphviz/lua/
262%{_libdir}/lua*/*
263%{_mandir}/man3/gv.3lua*
264
265%files perl
266%defattr(-,root,root,-)
267%{_libdir}/graphviz/perl/
268%{perl_vendorarch}/*
269%{_mandir}/man3/gv.3perl*
270
271%files python
272%defattr(-,root,root,-)
273%{_libdir}/graphviz/python/
274%{_libdir}/python2*/*
275
276%files python3
277%defattr(-,root,root,-)
278%{_libdir}/graphviz/python3/
279%{_libdir}/python3*/*
280%{_mandir}/man3/gv.3python*
281
282%files ruby
283%defattr(-,root,root,-)
284%{_libdir}/graphviz/ruby/
285%{_libdir}/*ruby*/*
286%{_mandir}/man3/gv.3ruby*
287
288%files tcl
289%defattr(-,root,root)
290%{_libdir}/%{name}/tcl/*
291%{_libdir}/tcl*/*
292%{_datadir}/%{name}/demo
293# hack to include gv.3tcl only if available
294#  always includes tcldot.3tcl, gdtclft.3tcl
295%{_mandir}/man3/*.3tcl*
296
297
298%changelog
299* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.44.1-1
300- new upstream release.
301
302* Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.2-1
303- built with ruby-2.6.5.
304- added python3 support.
305- dropped Patch0.
306- imported Patch0-2 from rawhide.
307
308* Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-2
309- rebuilt with guile-2.2.
310
311* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.1-1
312- updated to 2.40.1.
313- dropped all patches.
314- imported Patch0 from rawhide.
315
316* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-4
317- rebuild with gcc-5.4.0
318
319* Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.0-3
320- rebuild with ruby-2.2.3
321
322* Sun Mar 15 2015 Ryoichi INAGAKI <ryo1@toki.waaseda.jp> 2.38.0-2
323- added Patch0-5 from Fedora
324- rebuilt with guile 2.0.11
325- changed BR: tcl-devel, tk-devel instead of tcl, tk
326- added lua subpackage
327
328* Sat Jun 28 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.38.0-1
329- update to 2.38.0
330
331* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 2.36.0-1
332- new upstream release
333
334* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-2
335- rebuilt with gd-2.1.0.
336
337* Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
338- new upstream release
339
340* Mon Jan  7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
341- build with Tcl/Tk 8.5.7-1
342- stop running autoreconf
343- add Vendor and Distribution tags
344
345* Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
346- re-enable ruby binding, which is accidentally disabled in 2.28.0-1
347  - rewrite config_ruby.rb to build with ruby-1.9.3
348  - add search path for ruby/config.h to CPPFLAGS for configure
349
350* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
351- new upstream release
352- remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
353- add BuildRequires: librsvg2-devel
354
355* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
356- add Patch10 to avoid build failure on ppc
357
358* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
359- new upstream release
360- built with rpm-4.8.1
361- split doc, guile, perl, python, ruby subpackage
362
363* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
364- rebuild with libtool-2.2.6a
365
366* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
367- new upstream release
368
369* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
370- rebuild with libXaw.so.7 (libXaw-1.0.5)
371
372* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
373- new upstream release
374
375* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
376- new upstream release
377- build with expat-2.0.1
378- add man7
379
380* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
381- rebuild with tcl/tk-8.4.16
382
383* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
384- new upstream release
385- add BuildPrereq: swig
386- delete BuildPrereq: gd-progs gd-devel
387- add --with-mylibgd and --disable-FEATURE to configure option
388- update %%files
389
390* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
391- added BuildPrereq: ruby-devel
392
393* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
394- new upstream release
395- add BuildPrereq: libtool-ltdl-devel
396- move pkgconfig files to %%{_libdir}/pkgconfig
397- add --disable-rpath --disable-static to configure option
398- add %%post to every package
399
400* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
401- new upstream release
402- BuildPrereq: tcl >= 8.4, tk >= 8.4
403- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
404- update %%files
405- remove lines about Vine2.6
406- change License to CPL
407
408* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
409- source upgrade
410- remove patch0 and commented lines
411
412* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
413- build for VineSeed
414
415* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
416- source upgrade
417- change spec to build both VineSeed and Vine2.5/2.6
418- add BuildPrereq: expat-devel and Requires: libexpat
419- add patch0 to build against freetype2-2.1.7
420- stop using autogen.sh script
421- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
422- add graphviz-tcl package (VineSeed)
423
424* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
425- rebuild for new Vine
426
427* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
428- import from offical site (src.rpm)
429
Note: See TracBrowser for help on using the repository browser.