source: projects/specs/trunk/g/gnash/gnash-vl.spec @ 7658

Revision 7658, 16.6 KB checked in by daisuke, 11 years ago (diff)

gnash: update to 0.8.10

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# ghelp/omf/scrollkeeper support
4# not working as of version 0.8.7
5%define scrollkeeper 0
6
7# kde and klash support
8%define kde_support 0
9
10Name:           gnash
11Version:        0.8.10
12Release:        1%{?_dist_release}
13Summary:        GNU flash movie player
14
15Group:          Applications/Multimedia
16License:        GPLv3+
17URL:            http://www.gnu.org/software/gnash/
18Source0:        http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
19
20Patch0:         %{name}-%{version}-add-unistd-header.patch
21Patch1:         %{name}-%{version}-integer-overflow.patch
22
23# register KComponentData properly in KDE 4 KPart
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  libxml2-devel libpng-devel libjpeg-devel libogg-devel
27BuildRequires:  libboost-devel curl-devel freetype-devel fontconfig-devel
28BuildRequires:  libboost-date-time libboost-serialization libboost-thread
29BuildRequires:  SDL-devel
30BuildRequires:  agg-devel
31BuildRequires:  python-devel
32BuildRequires:  libXv-devel
33%if %{kde_support}
34#BuildRequires:  kde-filesystem
35BuildRequires:  kdelibs-devel
36%endif
37BuildRequires:  gtkglext-devel
38BuildRequires:  docbook2X
39#BuildRequires:  %{_bindir}/docbook2pdf
40BuildRequires:  gstreamer-devel >= 0.10%
41BuildRequires:  gstreamer-plugins-base-devel >= 0.10
42%if %{scrollkeeper}
43BuildRequires:  scrollkeeper
44%endif
45BuildRequires:  giflib-devel
46BuildRequires:  gettext
47BuildRequires:  desktop-file-utils
48BuildRequires:  speex-devel
49BuildRequires:  gstreamer-plugins-base-devel
50BuildRequires:  pygtk2-devel
51BuildRequires:  libtool-ltdl-devel
52BuildRequires:  dejagnu
53BuildRequires:  GConf2-devel
54BuildRequires:  xulrunner-devel
55BuildRequires:  autoconf automake libtool
56BuildRequires:  libboost-devel
57BuildRequires:  libboost-program-options
58BuildRequires:  libboost-iostreams
59BuildRequires:  mesa-libGLU-devel
60BuildRequires:  libXmu-devel
61
62%if %{scrollkeeper}
63Requires(post): scrollkeeper
64Requires(postun): scrollkeeper
65%endif
66Requires(post): /sbin/ldconfig
67Requires(postun): /sbin/ldconfig
68Requires(post): /sbin/install-info
69Requires(preun): /sbin/install-info
70
71%description
72Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
73supports SWF v7, with better SWF v8 and v9 support under heavy development.
74Gnash includes initial parser support for SWF v8 and v9. Not all
75ActionScript 2 classes are implemented yet, but all of the most heavily
76used ones are. Many ActionScript 2 classes are partially implemented;
77there is support for all of the commonly used methods of each
78class.
79
80%package plugin
81Summary:   Web-client flash movie player plugin
82Requires:  %{name} = %{version}-%{release}
83# this doesn't prevent wrong dependencies, in case a package
84# provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
85# and another unrelated webbrowser is installed, like w3m-el.
86# Moreover konqueror could provide webclient some day
87#Requires:  %{_libdir}/mozilla/plugins webclient
88Requires:  webclient
89Group:     Applications/Internet
90
91%description plugin
92The gnash flash movie player plugin for firefox or mozilla.
93
94%if %{kde_support}
95%package klash
96Summary:   Konqueror flash movie player plugin
97Requires:  %{name} = %{version}-%{release}
98Group:     Applications/Multimedia
99
100%description klash
101The gnash flash movie player plugin for Konqueror.
102
103%endif
104
105%package cygnal
106Summary:   Streaming media server
107Requires:  %{name} = %{version}-%{release}
108Group:     Applications/Multimedia
109
110%description cygnal
111Cygnal is a streaming media server that's Flash aware.
112
113%package devel
114Summary:   Gnash header files
115Requires:  %{name} = %{version}-%{release}
116Group:     Development/Libraries
117
118%description devel
119Gnash header files can be used to write external Gnash extensions or to embed
120the Gnash GTK+ widget into a C/C++ application.
121
122%package -n python-gnash
123Summary:   Gnash Python bindings
124Requires:  %{name} = %{version}-%{release}
125Group:     Applications/Multimedia
126
127%description -n python-gnash
128Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
129application.
130
131%prep
132%setup -q
133%patch0 -p1 -b .unistd-header
134%patch1 -p1 -b .integer-overflow
135autoreconf -if
136
137%build
138%configure --disable-static \
139  --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
140  --enable-docbook --enable-ghelp --enable-media=GST \
141  --disable-dependency-tracking --disable-rpath \
142  --disable-testsuite \
143  --without-swfdec-testsuite \
144  --without-ming \
145  --enable-cygnal \
146  --enable-sdkinstall \
147  --enable-python \
148%if %{kde_support}
149  --enable-gui=gtk,kde4,sdl,fb \
150  --with-kde4-prefix=%{_kde4_prefix} \
151  --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
152  --with-kde4-incl=%{_kde4_includedir} \
153%else
154  --enable-gui=gtk,sdl,fb \
155%endif
156  --enable-renderer=all \
157  --with-plugins-install=system \
158  --disable-jemalloc \
159  --enable-doublebuf \
160  --htmldir=%{_datadir}/gnash/html
161
162%if %{kde_support}
163# make sure the Qt 4 moc etc. tools are found
164export PATH=%{_qt4_prefix}/bin:$PATH
165#doesn't work currently: %%{?_smp_mflags}
166# override KDE4_LIBS because configure doesn't detect it properly
167make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
168%else
169#doesn't work currently: %%{?_smp_mflags}
170make
171%endif
172
173%install
174rm -rf $RPM_BUILD_ROOT
175make install install-plugins \
176 DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
177%if %{kde_support}
178 KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
179 KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
180 KDE4_CONFIGDIR=%{_kde4_configdir} \
181 KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
182%endif
183
184rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
185
186%if %{kde_support}
187# KDE 4 doesn't need the .la file anymore, thankfully
188rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
189%endif
190
191rm -f $RPM_BUILD_ROOT%{_infodir}/dir
192
193%find_lang %{name}
194
195%clean
196rm -rf $RPM_BUILD_ROOT
197
198
199%post
200/sbin/ldconfig
201%if %{scrollkeeper}
202scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
203%endif
204/sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
205/sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
206
207update-desktop-database &> /dev/null || :
208
209touch --no-create %{_datadir}/icons/hicolor
210if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
211  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
212fi
213
214
215%preun
216if [ $1 = 0 ]; then
217    /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
218    /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
219fi
220
221%postun
222/sbin/ldconfig
223%if %{scrollkeeper}
224scrollkeeper-update -q || :
225%endif
226
227update-desktop-database &> /dev/null || :
228
229touch --no-create %{_datadir}/icons/hicolor
230if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
231  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
232fi
233
234
235%files -f %{name}.lang
236%defattr(-,root,root,-)
237%doc README AUTHORS COPYING NEWS
238%config(noreplace) %{_sysconfdir}/gnashpluginrc
239%config(noreplace) %{_sysconfdir}/gnashrc
240%{_bindir}/fb-gnash
241%{_bindir}/gtk-gnash
242%{_bindir}/gnash-gtk-launcher
243%{_bindir}/rtmpget
244%{_bindir}/sdl-gnash
245%{_bindir}/gnash
246%{_bindir}/gprocessor
247%{_bindir}/findmicrophones
248%{_bindir}/findwebcams
249%dir %{_libdir}/gnash
250%{_libdir}/gnash/*.so*
251%{_mandir}/man1/gnash.1*
252%{_mandir}/man1/gprocessor.1*
253%{_mandir}/man1/findmicrophones.1*
254%{_mandir}/man1/findwebcams.1*
255%{_mandir}/man1/gtk-gnash.1*
256%{_mandir}/man1/gnash-gtk-launcher.1*
257%{_mandir}/man1/fb-gnash.1*
258%{_mandir}/man1/sdl-gnash.1*
259%{_mandir}/man1/rtmpget.1*
260%{_infodir}/gnash*
261%{_datadir}/gnash/
262%{_datadir}/icons/hicolor/32x32/apps/*.xpm
263%{_datadir}/applications/*.desktop
264
265%files plugin
266%defattr(-,root,root,-)
267%{_libdir}/mozilla/plugins/libgnashplugin.so
268
269%if %{kde_support}
270%files klash
271%defattr(-,root,root,-)
272%{_kde4_bindir}/kde4-gnash
273%{_kde4_libdir}/kde4/libklashpart.so
274%{_kde4_appsdir}/klash/
275%{_kde4_datadir}/kde4/services/klash_part.desktop
276%{_mandir}/man1/kde4-gnash.1*
277%endif
278
279%files cygnal
280%defattr(-,root,root,-)
281%config(noreplace) %{_sysconfdir}/cygnalrc
282%{_bindir}/cygnal
283%{_bindir}/flvdumper
284%{_bindir}/soldumper
285%{_mandir}/man1/cygnal.1*
286%{_mandir}/man1/flvdumper.1*
287%{_mandir}/man1/soldumper.1*
288%dir %{_libdir}/cygnal
289%{_libdir}/cygnal/plugins/*.so*
290
291%files devel
292%defattr(-,root,root,-)
293%{_includedir}/gnash/
294%{_libdir}/pkgconfig/gnash.pc
295
296%files -n python-gnash
297%defattr(-,root,root,-)
298%{python_sitearch}/gtk-2.0/*
299
300%changelog
301* Mon Apr 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.10-1
302- update to 0.8.10
303
304* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-5
305- rebuild with python-2.7.2
306
307* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-4
308- add BuildRequires: python-devel, libXv-devel
309
310* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
311- rebuilt with libboost-1.45.0
312
313* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
314- rebuilt with rpm-4.8.1 for pkg-config
315
316* Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
317- initial build for Vine Linux: based Fedora 0.8.7-1.fc14
318
319* Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
320- update to 0.8.7
321- make scrollkeeper a conditional (still disabled as it's not working)
322- drop gnash-0.8.3-manual.patch, should no longer be needed
323- drop gnash-0.8.6-python-install-dir.patch, fixed upstream
324
325* Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
326- delete bundled libltdl stuff to make sure it's not used
327
328* Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
329- don't build libltdlc.a
330
331* Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
332- --without-included-ltdl (CVE-2009-3736)
333
334* Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
335- Rebuild for new Boost (1.41.0)
336
337* Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
338- Add missing Epoch to Requires
339
340* Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
341- Install icon to the correct place (#551621)
342
343* Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
344- One more try at using the correct dir
345
346* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
347- Patch was reversed
348
349* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
350- Patch Makefile.in, not Makefile.am
351
352* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
353- Pick up python modules from the right dir
354
355* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
356- Install python modules in the right dir
357
358* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
359- Add cygnal plugins
360
361* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
362- Update to 0.8.6, increase epoch.
363
364* Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
365- update to HEAD
366
367* Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
368- update to HEAD
369
370* Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
371- don't package headers in -widget, only in -devel (no duplicate files)
372- own %%{_includedir}/gnash/ in -devel
373- add missing %%defattr for -devel and -widget
374- make -devel and -widget require the main package (with exact VR)
375- fix -devel group and description
376- rename gnash-widget to python-gnash as per the naming guidelines
377
378* Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
379- use %%{_includedir}, not %%{_prefix}/include
380
381* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
382- Install the python module in the sitearch dir
383
384* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
385- One more 64bit fix
386
387* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
388- Fix the packaging in 64bits
389
390* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
391- upload the .swf file
392
393* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
394- merge upstream changes into the spec
395
396* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
397- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
398
399* Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
400- rebuild for new Boost
401
402* Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
403- explicitly link the KlashPart against the libraries it uses
404
405* Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
406- add missing speex-devel and gstreamer-plugins-base-devel BR
407 
408* Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
409- update to 0.8.5
410- remove use_kde3_executable_hack
411- remove autoreconf
412
413* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
414- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
415
416* Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
417- rebuild for new boost
418
419* Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
420- add missing portions of KDE 4 port from upstream kde4 branch
421
422* Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
423- add 3 more patches from bero to fix the KDE 4 viewer executable
424- disable use_kde3_executable hack
425
426* Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
427- add a desktop file
428
429* Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
430- update KDE 4 patch (undo the backporting and use original patch)
431- patch to make autoreconf work
432- add missing BR giflib-devel, gettext
433- omit unrecognized --with-qtdir
434
435* Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
436- update to 0.8.4
437
438* Sat Oct  4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
439- use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
440  so it can easily be disabled or removed once the KDE 4 executable is fixed)
441
442* Sat Oct  4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
443- register KComponentData properly in KDE 4 KPart
444
445* Fri Oct  3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
446- KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
447
448* Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
449- include %%_libdir/gnash directory
450
451* Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
452- add glib in the link, thanks Daniel Drake (#452767)
453
454* Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
455- update to 0.8.3
456
457* Wed Apr  9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
458- ship libklashpart (#441601)
459
460* Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
461- don't ship libltdl.so.3 (#436725)
462
463* Fri Mar  7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
464- update to 0.8.2
465
466* Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
467- add patch from Martin Stransky to fix wrapped plugin #281061
468
469* Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
470- info files are empty, don't install them
471
472* Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
473- omf/scrollkeeper doc is broken, remove it
474
475* Fri Sep  7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
476- better documentation generation
477
478* Wed Sep  5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
479- update to 0.8.1
480- agg is now the default renderer
481
482* Fri Aug  3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
483- rebuild for boost soname change
484
485* Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
486- update to 0.8.0
487
488* Wed May  9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
489- fix CVE-2007-2500 (fix 239213)
490
491* Mon Nov  6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
492- update for 0.7.2 release.
493
494* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
495 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
496
497* Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
498- plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
499  temporarily, but there is no better solution yet) #207613
500
501* Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
502- add defattr for klash
503- add warnings in the description about stability
504
505* Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
506- remove superfluous buildrequires autoconf
507- rename last patch to gnash-plugin-tempfile-dir.patch
508- add README.fedora to plugin to explain tmpdirs
509
510* Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
511- source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
512- add plugin-tempfile-dir.patch for plugin to use a safe tempdir
513
514* Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
515- buildrequire autotools (Michael Knox)
516
517* Fri Jun  2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
518- add gnash-continue_on_info_install_error.patch to avoid
519- buildrequire libXmu-devel
520
521* Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
522- configure with --disable-rpath
523- buildrequire docbook2X
524- remove devel files
525
526* Sun May  7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
527- update to 0.7.1 alpha release
528
529* Sat Apr  22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
530- install the info file. Various tweaks for my system based on
531Patrice's latest patch,
532
533* Fri Feb  3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
534- initial packaging
Note: See TracBrowser for help on using the repository browser.