source: projects/specs/trunk/g/gnash/gnash-vl.spec @ 5701

Revision 5701, 18.1 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# ghelp/omf/scrollkeeper support
4# not working as of version 0.8.7
5%define scrollkeeper 0
6
7# kde and klash support
8%define kde_support 0
9
10Name:           gnash
11Version:        0.8.7
12Release:        5%{?_dist_release}
13Summary:        GNU flash movie player
14
15Group:          Applications/Multimedia
16License:        GPLv3+
17URL:            http://www.gnu.org/software/gnash/
18Source0:        http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
19Source1:        http://www.getgnash.org/gnash-splash.swf
20Source2:        gnash.desktop
21
22# register KComponentData properly in KDE 4 KPart
23Patch0:         gnash-0.8.3-fix-kde4-port.patch
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  libxml2-devel libpng-devel libjpeg-devel libogg-devel
27BuildRequires:  libboost-devel curl-devel freetype-devel fontconfig-devel
28BuildRequires:  libboost-date-time libboost-serialization libboost-thread
29BuildRequires:  SDL-devel
30BuildRequires:  agg-devel
31BuildRequires:  python-devel
32BuildRequires:  libXv-devel
33%if %{kde_support}
34#BuildRequires:  kde-filesystem
35BuildRequires:  kdelibs-devel
36%endif
37BuildRequires:  gtkglext-devel
38BuildRequires:  docbook2X
39#BuildRequires:  %{_bindir}/docbook2pdf
40BuildRequires:  gstreamer-devel >= 0.10%
41BuildRequires:  gstreamer-plugins-base-devel >= 0.10
42%if %{scrollkeeper}
43BuildRequires:  scrollkeeper
44%endif
45BuildRequires:  giflib-devel
46BuildRequires:  gettext
47BuildRequires:  desktop-file-utils
48BuildRequires:  speex-devel
49BuildRequires:  gstreamer-plugins-base-devel
50BuildRequires:  pygtk2-devel
51BuildRequires:  libtool-ltdl-devel
52BuildRequires:  dejagnu
53
54%if %{scrollkeeper}
55Requires(post): scrollkeeper
56Requires(postun): scrollkeeper
57%endif
58Requires(post): /sbin/ldconfig
59Requires(postun): /sbin/ldconfig
60Requires(post): /sbin/install-info
61Requires(preun): /sbin/install-info
62
63%description
64Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
65supports SWF v7, with better SWF v8 and v9 support under heavy development.
66Gnash includes initial parser support for SWF v8 and v9. Not all
67ActionScript 2 classes are implemented yet, but all of the most heavily
68used ones are. Many ActionScript 2 classes are partially implemented;
69there is support for all of the commonly used methods of each
70class.
71
72%package plugin
73Summary:   Web-client flash movie player plugin
74Requires:  %{name} = %{version}-%{release}
75# this doesn't prevent wrong dependencies, in case a package
76# provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
77# and another unrelated webbrowser is installed, like w3m-el.
78# Moreover konqueror could provide webclient some day
79#Requires:  %{_libdir}/mozilla/plugins webclient
80Requires:  webclient
81Group:     Applications/Internet
82
83%description plugin
84The gnash flash movie player plugin for firefox or mozilla.
85
86%if %{kde_support}
87%package klash
88Summary:   Konqueror flash movie player plugin
89Requires:  %{name} = %{version}-%{release}
90Group:     Applications/Multimedia
91
92%description klash
93The gnash flash movie player plugin for Konqueror.
94
95%endif
96
97%package cygnal
98Summary:   Streaming media server
99Requires:  %{name} = %{version}-%{release}
100Group:     Applications/Multimedia
101
102%description cygnal
103Cygnal is a streaming media server that's Flash aware.
104
105%package devel
106Summary:   Gnash header files
107Requires:  %{name} = %{version}-%{release}
108Group:     Development/Libraries
109
110%description devel
111Gnash header files can be used to write external Gnash extensions or to embed
112the Gnash GTK+ widget into a C/C++ application.
113
114%package -n python-gnash
115Summary:   Gnash Python bindings
116Requires:  %{name} = %{version}-%{release}
117Group:     Applications/Multimedia
118
119%description -n python-gnash
120Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
121application.
122
123%prep
124%setup -q
125%patch0 -p1 -b .fix-kde4
126%if %{kde_support}
127# Hack as autoreconf breaks build
128sed -i -e 's!kapp.h!kapplication.h!g' configure
129sed -i -e 's!libkdeui.la!libkdeui.so!g' configure
130# Currently kde4-gnash (from kde4 branch) links against various KDE libraries,
131# but only needs Qt -- remove the superfluous linkage
132sed -i -e 's!\$(KDE4_LIBS)!!g' gui/Makefile.in
133%endif
134# we don't want any builtin ltdl built, configure wants always either
135# ltdl-install or ltdl-convenience, hack that out
136sed -i -e 's/test x"\${enable_ltdl_convenience-no}" != xno/false/g' configure
137# and don't build the loader part of libltdl either
138sed -i -e 's/\$(LT_DLLOADERS)//g' libltdl/Makefile.in
139# link to the system libltdl instead of the bundled one
140# this is hardcoded in the makefiles, so --without-included-ltdl doesn't help
141sed -i -e 's!\$(top_builddir)/libltdl/libltdlc.la!-lltdl!g' \
142  */Makefile.in */*/Makefile.in
143# delete bundled libltdl stuff to make sure it's not used
144rm -f libltdl/*.[ch] libltdl/*/*.[ch]
145
146iconv -f latin1 -t utf8 < AUTHORS > AUTHORS.utf8
147touch -r AUTHORS AUTHORS.utf8
148mv AUTHORS.utf8 AUTHORS
149
150%build
151%configure --disable-static --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
152  --enable-docbook --enable-ghelp --enable-media=GST \
153  --disable-dependency-tracking --disable-rpath \
154  --enable-cygnal \
155  --enable-sdkinstall \
156  --enable-python \
157%if %{kde_support}
158  --enable-gui=gtk,kde4,sdl,fb \
159  --with-kde4-prefix=%{_kde4_prefix} \
160  --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
161  --with-kde4-incl=%{_kde4_includedir} \
162%else
163  --enable-gui=gtk,sdl,fb \
164%endif
165  --without-included-ltdl
166
167%if %{kde_support}
168# make sure the Qt 4 moc etc. tools are found
169export PATH=%{_qt4_prefix}/bin:$PATH
170#doesn't work currently: %%{?_smp_mflags}
171# override KDE4_LIBS because configure doesn't detect it properly
172make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
173%else
174#doesn't work currently: %%{?_smp_mflags}
175make
176%endif
177
178%install
179rm -rf $RPM_BUILD_ROOT
180make install install-plugins \
181 DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
182%if %{kde_support}
183 KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
184 KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
185 KDE4_CONFIGDIR=%{_kde4_configdir} \
186 KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
187%endif
188
189rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
190
191%if %{kde_support}
192# KDE 4 doesn't need the .la file anymore, thankfully
193rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
194%endif
195
196rm -f $RPM_BUILD_ROOT%{_infodir}/dir
197
198rm -rf __dist_docs
199mkdir __dist_docs
200mv $RPM_BUILD_ROOT%{_datadir}/doc/gnash/* __dist_docs/
201rmdir $RPM_BUILD_ROOT%{_datadir}/doc/gnash
202
203cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/gnash/
204
205mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
206# a wrapper to avoid gnash erroring out if there is no argument.
207# Instead open gnash-splash.swf.
208# this should not be needed in the next version.
209# FIXME: Do we still need this with 0.8.7?
210cat > $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper << EOF
211#! /bin/sh
212if [ "z\$1" = 'z' ]; then
213 gnash %{_datadir}/gnash/gnash-splash.swf
214else
215 gnash "\$@"
216fi
217EOF
218
219chmod a+x $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper
220
221sed -e 's;/usr/libexec;%{_libexecdir};' %{SOURCE2} > gnash.desktop
222mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
223desktop-file-install --vendor="fedora" \
224 --dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
225 gnash.desktop
226
227mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
228cp -p ./gui/images/GnashG.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
229
230%find_lang %{name}
231
232%clean
233rm -rf $RPM_BUILD_ROOT
234
235
236%post
237/sbin/ldconfig
238%if %{scrollkeeper}
239scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
240%endif
241/sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
242/sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
243
244update-desktop-database &> /dev/null || :
245
246touch --no-create %{_datadir}/icons/hicolor
247if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
248  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
249fi
250
251
252%preun
253if [ $1 = 0 ]; then
254    /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
255    /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
256fi
257
258%postun
259/sbin/ldconfig
260%if %{scrollkeeper}
261scrollkeeper-update -q || :
262%endif
263
264update-desktop-database &> /dev/null || :
265
266touch --no-create %{_datadir}/icons/hicolor
267if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
268  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
269fi
270
271
272%files -f %{name}.lang
273%defattr(-,root,root,-)
274%doc README AUTHORS COPYING NEWS
275%doc __dist_docs/*
276%config(noreplace) %{_sysconfdir}/gnashpluginrc
277%config(noreplace) %{_sysconfdir}/gnashrc
278%{_bindir}/dumpshm
279%{_bindir}/fb-gnash
280%{_bindir}/flvdumper
281%{_bindir}/gtk-gnash
282%{_bindir}/sdl-gnash
283%{_bindir}/soldumper
284%{_bindir}/gnash
285%{_bindir}/gprocessor
286%{_bindir}/findmicrophones
287%{_bindir}/findwebcams
288%dir %{_libdir}/gnash
289%{_libdir}/gnash/*.so*
290%{_mandir}/man1/gnash.1*
291%{_mandir}/man1/dumpshm.1*
292%{_mandir}/man1/gprocessor.1*
293%{_mandir}/man1/soldumper.1*
294%{_mandir}/man1/flvdumper.1*
295%{_mandir}/man1/findmicrophones.1*
296%{_mandir}/man1/findwebcams.1*
297%{_mandir}/man1/gtk-gnash.1*
298%{_infodir}/gnash*
299%{_datadir}/gnash/
300%{_datadir}/icons/hicolor/32x32/apps/*.png
301%{_datadir}/applications/*.desktop
302%{_libexecdir}/gnash-wrapper
303%if %{scrollkeeper}
304%{_datadir}/omf/gnash/
305%endif
306
307%files plugin
308%defattr(-,root,root,-)
309%{_libdir}/mozilla/plugins/libgnashplugin.so
310
311%if %{kde_support}
312%files klash
313%defattr(-,root,root,-)
314%{_kde4_bindir}/kde4-gnash
315%{_kde4_libdir}/kde4/libklashpart.so
316%{_kde4_appsdir}/klash/
317%{_kde4_datadir}/kde4/services/klash_part.desktop
318%{_mandir}/man1/kde4-gnash.1*
319%endif
320
321%files cygnal
322%defattr(-,root,root,-)
323%config(noreplace) %{_sysconfdir}/cygnalrc
324%{_bindir}/cygnal
325%{_mandir}/man1/cygnal.1*
326%{_mandir}/man1/rtmpget.1*
327%dir %{_libdir}/cygnal
328%{_libdir}/cygnal/plugins/*.so*
329
330%files devel
331%defattr(-,root,root,-)
332%{_includedir}/gnash/
333%{_libdir}/pkgconfig/gnash.pc
334
335%files -n python-gnash
336%defattr(-,root,root,-)
337%{python_sitearch}/gtk-2.0/*
338
339%changelog
340* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-5
341- rebuild with python-2.7.2
342
343* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-4
344- add BuildRequires: python-devel, libXv-devel
345
346* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
347- rebuilt with libboost-1.45.0
348
349* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
350- rebuilt with rpm-4.8.1 for pkg-config
351
352* Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
353- initial build for Vine Linux: based Fedora 0.8.7-1.fc14
354
355* Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
356- update to 0.8.7
357- make scrollkeeper a conditional (still disabled as it's not working)
358- drop gnash-0.8.3-manual.patch, should no longer be needed
359- drop gnash-0.8.6-python-install-dir.patch, fixed upstream
360
361* Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
362- delete bundled libltdl stuff to make sure it's not used
363
364* Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
365- don't build libltdlc.a
366
367* Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
368- --without-included-ltdl (CVE-2009-3736)
369
370* Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
371- Rebuild for new Boost (1.41.0)
372
373* Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
374- Add missing Epoch to Requires
375
376* Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
377- Install icon to the correct place (#551621)
378
379* Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
380- One more try at using the correct dir
381
382* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
383- Patch was reversed
384
385* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
386- Patch Makefile.in, not Makefile.am
387
388* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
389- Pick up python modules from the right dir
390
391* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
392- Install python modules in the right dir
393
394* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
395- Add cygnal plugins
396
397* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
398- Update to 0.8.6, increase epoch.
399
400* Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
401- update to HEAD
402
403* Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
404- update to HEAD
405
406* Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
407- don't package headers in -widget, only in -devel (no duplicate files)
408- own %%{_includedir}/gnash/ in -devel
409- add missing %%defattr for -devel and -widget
410- make -devel and -widget require the main package (with exact VR)
411- fix -devel group and description
412- rename gnash-widget to python-gnash as per the naming guidelines
413
414* Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
415- use %%{_includedir}, not %%{_prefix}/include
416
417* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
418- Install the python module in the sitearch dir
419
420* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
421- One more 64bit fix
422
423* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
424- Fix the packaging in 64bits
425
426* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
427- upload the .swf file
428
429* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
430- merge upstream changes into the spec
431
432* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
433- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
434
435* Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
436- rebuild for new Boost
437
438* Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
439- explicitly link the KlashPart against the libraries it uses
440
441* Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
442- add missing speex-devel and gstreamer-plugins-base-devel BR
443 
444* Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
445- update to 0.8.5
446- remove use_kde3_executable_hack
447- remove autoreconf
448
449* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
450- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
451
452* Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
453- rebuild for new boost
454
455* Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
456- add missing portions of KDE 4 port from upstream kde4 branch
457
458* Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
459- add 3 more patches from bero to fix the KDE 4 viewer executable
460- disable use_kde3_executable hack
461
462* Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
463- add a desktop file
464
465* Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
466- update KDE 4 patch (undo the backporting and use original patch)
467- patch to make autoreconf work
468- add missing BR giflib-devel, gettext
469- omit unrecognized --with-qtdir
470
471* Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
472- update to 0.8.4
473
474* Thu Oct  4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
475- use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
476  so it can easily be disabled or removed once the KDE 4 executable is fixed)
477
478* Thu Oct  4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
479- register KComponentData properly in KDE 4 KPart
480
481* Wed Oct  3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
482- KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
483
484* Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
485- include %%_libdir/gnash directory
486
487* Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
488- add glib in the link, thanks Daniel Drake (#452767)
489
490* Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
491- update to 0.8.3
492
493* Wed Apr  9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
494- ship libklashpart (#441601)
495
496* Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
497- don't ship libltdl.so.3 (#436725)
498
499* Fri Mar  7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
500- update to 0.8.2
501
502* Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
503- add patch from Martin Stransky to fix wrapped plugin #281061
504
505* Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
506- info files are empty, don't install them
507
508* Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
509- omf/scrollkeeper doc is broken, remove it
510
511* Fri Sep  7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
512- better documentation generation
513
514* Wed Sep  5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
515- update to 0.8.1
516- agg is now the default renderer
517
518* Fri Aug  3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
519- rebuild for boost soname change
520
521* Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
522- update to 0.8.0
523
524* Wed May  9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
525- fix CVE-2007-2500 (fix 239213)
526
527* Sat Nov  6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
528- update for 0.7.2 release.
529
530* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
531 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
532
533* Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
534- plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
535  temporarily, but there is no better solution yet) #207613
536
537* Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
538- add defattr for klash
539- add warnings in the description about stability
540
541* Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
542- remove superfluous buildrequires autoconf
543- rename last patch to gnash-plugin-tempfile-dir.patch
544- add README.fedora to plugin to explain tmpdirs
545
546* Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
547- source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
548- add plugin-tempfile-dir.patch for plugin to use a safe tempdir
549
550* Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
551- buildrequire autotools (Michael Knox)
552
553* Fri Jun  2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
554- add gnash-continue_on_info_install_error.patch to avoid
555- buildrequire libXmu-devel
556
557* Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
558- configure with --disable-rpath
559- buildrequire docbook2X
560- remove devel files
561
562* Sun May  7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
563- update to 0.7.1 alpha release
564
565* Sat Apr  22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
566- install the info file. Various tweaks for my system based on
567Patrice's latest patch,
568
569* Fri Feb  3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
570- initial packaging
Note: See TracBrowser for help on using the repository browser.