source: projects/specs/trunk/g/git/git-vl.spec @ 10812

Revision 10812, 25.7 KB checked in by ara_t, 8 years ago (diff)

update to 2.10.2

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:    git
8Version: 2.10.2
9Release: 1%{?_dist_release}
10Summary: Core git tools
11Summary(ja): Core git ツール
12License:  GPLv2
13Group:    Development/Tools
14URL:      http://git-scm.com/
15Source0:  https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
16Source1:  vine-default-git.el
17Source2:  git.xinetd
18Source3:  git.conf.httpd
19Source4:  gitweb.conf.in
20Source10: %{name}-install.sh
21Source11: %{name}-remove.sh
22Source12: git-init.el
23Patch0:   git-1.5-gitweb-home-link.patch
24
25# Security
26# none
27
28BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel
29BuildRequires:  expat-devel, gettext, asciidoc
30BuildRequires:  pcre-devel
31BuildRequires:  xmlto
32BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
33
34Requires:       perl-Git = %{version}-%{release}
35Requires:       zlib
36Provides:       git-core = %{version}-%{release}
37Obsoletes:      git-core <= 1.5.4.3
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       iwaim
42
43%description
44Git is a fast, scalable, distributed revision control system with an
45unusually rich command set that provides both high-level operations
46and full access to internals.
47
48The git rpm installs the core tools with minimal dependencies.  To
49install all git packages, including tools for integrating with other
50SCMs, install the git-all meta-package.
51
52%package all
53Summary:        Meta-package to pull in all git tools
54Summary(ja):    すべての git ツール
55Group:          Development/Tools
56Requires:       git = %{version}-%{release}
57Requires:       git-svn = %{version}-%{release}
58Requires:       git-cvs = %{version}-%{release}
59%if "%{?_dist_release}" != "vl4" && %{with arch}
60Requires:       git-arch = %{version}-%{release}
61%endif
62Requires:       git-email = %{version}-%{release}
63Requires:       gitk = %{version}-%{release}
64Requires:       git-gui = %{version}-%{release}
65Requires:       perl-Git = %{version}-%{release}
66Requires:       emacs-git = %{version}-%{release}
67Requires:       git-contrib = %{version}-%{release}
68Obsoletes:      git <= 1.5.4.3
69
70%description all
71Git is a fast, scalable, distributed revision control system with an
72unusually rich command set that provides both high-level operations
73and full access to internals.
74
75This is a dummy package which brings in all subpackages.
76
77%package daemon
78Summary:        Git protocol daemon
79Summary(ja):    Git プロトコルデーモン
80Group:          Development/Tools
81Requires:       git = %{version}-%{release}
82%description daemon
83The git daemon for supporting git:// access to git repositories
84
85%package -n gitweb
86Summary:        Simple web interface to git repositories
87Summary(ja):    git リポジトリへのシンプルな Web インタフェース
88Group:          Development/Tools
89Requires:       git = %{version}-%{release}
90
91%description -n gitweb
92Simple web interface to track changes in git repositories
93
94
95%package svn
96Summary:        Git tools for importing Subversion repositories
97Summary(ja):    Subversion リポジトリを git へインポートするためのツール
98Group:          Development/Tools
99Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
100Requires:       perl(SVN::Core)
101%description svn
102Git tools for importing Subversion repositories.
103
104%package cvs
105Summary:        Git tools for importing CVS repositories
106Summary(ja):    CVS リポジトリを git へインポートするためのツール
107Group:          Development/Tools
108Requires:       git = %{version}-%{release}, cvs, cvsps
109%description cvs
110Git tools for importing CVS repositories.
111
112%package contrib
113Summary:        Git contrib tools
114Group:          Development/Tools
115Requires:       git = %{version}-%{release}
116%description contrib
117Git contrib tools
118
119%if "%{?_dist_release}" != "vl4" && %{with arch}
120%package arch
121Summary:        Git tools for importing Arch repositories
122Summary(ja):    Arch リポジトリを git へインポートするためのツール
123Group:          Development/Tools
124Requires:       git = %{version}-%{release}, tla
125%description arch
126Git tools for importing Arch repositories.
127%endif
128
129%package email
130Summary:        Git tools for sending email
131Summary(ja):    Eメールを送るための git ツール
132Group:          Development/Tools
133Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
134%description email
135Git tools for sending email.
136
137%package gui
138Summary:        Git GUI tool
139Summary(ja):    Git の GUI ツール
140Group:          Development/Tools
141Requires:       git = %{version}-%{release}, tk
142%description gui
143Git GUI tool.
144
145%package -n gitk
146Summary:        Git revision tree visualiser
147Summary(ja):    Git リビジョンツリー可視化ツール
148Group:          Development/Tools
149Requires:       git = %{version}-%{release}, tk
150%description -n gitk
151Git revision tree visualiser.
152
153%package -n perl-Git
154Summary:        Perl interface to Git
155Summary(ja):    Git の perl インタフェース
156Group:          Development/Libraries
157Requires:       git = %{version}-%{release}, perl(Error)
158%if "%{?_dist_release}" == "vl4"
159Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
160%else
161Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
162%endif
163#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
164
165%description -n perl-Git
166Perl interface to Git.
167
168%package -n emacs-git
169Summary:       Git version control system support for Emacs
170Summary(ja):   Emacs の Git サポート
171Group:         Applications/Editors
172Requires:      git = %{version}-%{release}, emacsen-common
173
174%description -n emacs-git
175%{summary}.
176
177%package devel
178Summary:        Header files for git-core
179Summary(ja):    git-core 用ヘッダファイル
180Group:          Development/Libraries
181
182%description devel
183Header files for git-core.
184
185%prep
186%setup -q
187%patch0 -p1
188
189# for pcre-8.12
190%if %{?_dist_release} == "vl6"
191%{__perl} -pi -e "s|#include <pcre.h>|#include <pcre/pcre.h>|" grep.h
192%endif
193
194%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
195
196# Filter bogus perl requires
197cat << \EOF > %{name}-req
198#!/bin/sh
199%{__perl_requires} $* |\
200sed -e '/perl(packed-refs)/d'
201EOF
202
203%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
204chmod +x %{__perl_requires}
205
206%build
207make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
208     ETC_GITCONFIG=/etc/gitconfig \
209     USE_LIBPCRE=1 \
210     GITWEB_PROJECTROOT=/var/lib/git \
211     gitwebdir=/var/www/git \
212     prefix=%{_prefix} all %{!?_without_docs: doc}
213
214%install
215rm -rf $RPM_BUILD_ROOT
216make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
217     prefix=%{_prefix} mandir=%{_mandir} \
218     ETC_GITCONFIG=/etc/gitconfig \
219     USE_LIBPCRE=1 \
220     NO_PYTHON=1 \
221     GITWEB_PROJECTROOT=/var/lib/git \
222     gitwebdir=/var/www/git \
223     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
224
225# perl-Git
226# Error.pm provide by perl-Error package
227rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
228
229# emacs-git
230mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
231#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
232#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
233mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
234mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
235
236# install el files
237install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
238
239# install vine-default file
240install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
241
242# install  script( bytecompile el and install elc , remove )
243
244%_installemacsenscript git %{SOURCE10}
245
246%_removeemacsenscript  git %{SOURCE11}
247
248mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
249mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
250install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
251perl -p \
252     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
253     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
254     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
255
256## for gitweb sub package
257mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
258install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
259sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
260    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
261
262find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
263find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
264find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
265
266(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
267(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
268%if %{!?_without_docs:1}0
269(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
270%else
271rm -rf $RPM_BUILD_ROOT%{_mandir}
272%endif
273mkdir -p $RPM_BUILD_ROOT/srv/git
274
275mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
276install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
277
278install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
279
280# header files and lib
281install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
282install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
283install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
284install libgit.a $RPM_BUILD_ROOT%{_libdir}
285install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
286
287%find_lang %{name}
288
289%clean
290rm -rf $RPM_BUILD_ROOT
291
292%post -n emacs-git
293
294# bytecompile and install
295
296if [ "$1" = 2 ]; then
297
298%_emacsenPackageRemove git
299
300fi
301
302%_addemacsenlist git
303
304%_emacsenPackageInstall git
305
306%preun -n emacs-git
307
308if [ "$1" = 0 ]; then
309
310%_emacsenPackageRemove git
311
312%_removeemacsenlist git
313
314fi
315
316
317%files -f bin-man-doc-files -f %{name}.lang
318%defattr(-,root,root)
319%{_bindir}/git
320%{_bindir}/git-receive-pack
321%{_bindir}/git-upload-archive
322%{_bindir}/git-upload-pack
323%{_bindir}/git-shell
324%{_datadir}/git-core/
325%doc README.md COPYING Documentation/*.txt contrib/hooks
326%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
327%{!?_without_docs: %doc Documentation/howto Documentation/technical}
328%{_sysconfdir}/bash_completion.d
329
330
331%files svn
332%defattr(-,root,root)
333%{_libexecdir}/git-core/*svn*
334%doc Documentation/*svn*.txt
335%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
336%{!?_without_docs: %doc Documentation/*svn*.html }
337
338%files cvs
339%defattr(-,root,root)
340%doc Documentation/*git-cvs*.txt
341%{_bindir}/git-cvsserver
342%{_libexecdir}/git-core/*cvs*
343%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
344%{!?_without_docs: %doc Documentation/*git-cvs*.html }
345
346%files contrib
347%defattr(-,root,root)
348%doc contrib/diff-highlight/README.diff-highlight
349%{_bindir}/diff-highlight
350
351%if "%{?_dist_release}" != "vl4" && %{with arch}
352%files arch
353%defattr(-,root,root)
354%doc Documentation/git-archimport.txt
355%{_libexecdir}/git-core/git-archimport
356%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
357%{!?_without_docs: %doc Documentation/git-archimport.html }
358%endif
359
360%files email
361%defattr(-,root,root)
362%doc Documentation/*email*.txt
363%{_libexecdir}/git-core/*email*
364%{!?_without_docs: %{_mandir}/man1/*email*.1*}
365%{!?_without_docs: %doc Documentation/*email*.html }
366
367%files gui
368%defattr(-,root,root)
369%{_libexecdir}/git-core/git-gui*
370%{_libexecdir}/git-core/git-citool
371%{_datadir}/git-gui/
372%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
373%{!?_without_docs: %doc Documentation/git-gui.html}
374%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
375%{!?_without_docs: %doc Documentation/git-citool.html}
376
377%files -n gitk
378%defattr(-,root,root)
379%doc Documentation/*gitk*.txt
380%{_bindir}/gitk
381%{_datadir}/gitk
382%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
383%{!?_without_docs: %doc Documentation/*gitk*.html }
384
385%files -n perl-Git -f perl-files
386%defattr(-,root,root)
387
388%files -n emacs-git
389%defattr(-,root,root)
390%{_datadir}/emacs/site-lisp/git
391#%{_libdir}/emacsen-common/packages/install/git
392#%{_libdir}/emacsen-common/packages/remove/git
393%{emacsen_pkgdir}/install/git
394%{emacsen_pkgdir}/remove/git
395
396%files daemon
397%defattr(-,root,root)
398%{_var}/lib/git
399%{_libexecdir}/git-core/git-daemon
400%config(noreplace)%{_sysconfdir}/xinetd.d/git
401/srv/git
402
403%files -n gitweb
404%defattr(-,root,root)
405%doc gitweb/README
406/var/www/git/
407%config(noreplace)%{_sysconfdir}/gitweb.conf
408%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
409
410%files devel
411%defattr(644,root,root,755)
412%{_includedir}/git
413%{_libdir}/libgit.a
414%{_libdir}/libgit_xdiff.a
415
416
417%files all
418# No files for you!
419
420%changelog
421* Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
422- update to 2.10.2
423- fix build error using pcre-8.12 (Vine6)
424
425* Sun May  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
426- update to 2.8.2.
427
428* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
429- update to 2.6.6.
430
431* Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
432- update to 2.6.4
433- add locale files
434
435* Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
436- update to 2.2.1
437
438* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
439- build with Perl 5.16
440
441* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
442- update to 2.0.1
443- add "%%bcond_with arch": no create git-arch sub package by default
444
445* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
446- update to 1.9.2
447
448* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
449- update to 1.8.5.2
450
451* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
452- update to 1.8.4.4
453- new sub package: contrib
454
455* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
456- new upstream release
457
458* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
459- new upstream release
460
461* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
462- new upstream release
463
464* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
465- new upstream release
466
467* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
468- new upstream release
469
470* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
471- new upstream release
472
473* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
474- new upstream release
475- enable libpcre support, add BR: pcre-devel
476- add /etc/gitweb.conf
477- add /var/lib/git for PROJECTROOT
478
479* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
480- new upstream release
481
482* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
483- new upstream release
484
485* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
486- new upstream release
487
488* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
489- new upstream release
490
491* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
492- build with perl 5.12.3
493
494* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
495- new upstream release
496- build with openssl 1.0.0c for VineSeed
497
498* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
499- new upstream release: include security fix: CVE-2010-3906
500
501* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
502- new upstream release
503- drop CVE-2010-2542 patch (Patch100): upstream fixed
504- apply vine-default
505 - rename Source1: git-init.el -> vine-default-git.el
506 - add new git-init.el file (Source12)
507 - update git-install.sh
508- update %%build and %%install section for gitweb subpackage
509- add README in gitweb subpackage
510
511* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
512- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
513
514* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
515- new upstream release
516- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
517- disable building of unused python remote helper libs
518
519* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
520- new upstream release with security fix
521- drop patch10 (included in new release)
522
523* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
524- new upstream release
525- add patch10 git daemon extra arg parsing fix
526
527* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
528- fix install script for Emacs Lisp: <BTS:VineLinux:685>
529 - update git-install.sh (Source10) using contributed patch
530
531* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
532- new upstream release
533
534* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
535- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
536- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
537- fix summary and description in daemon sub package
538
539* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
540- drop Error.pm: provide by perl-Error package
541
542* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
543- new upstream relase
544- update URL tag
545- add Requires: perl(SVN::Core) for svn subpackage
546
547* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
548- add git-shell in git package
549- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
550
551* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
552- added BuildRequires: xmlto
553
554* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
555- new upstream release
556- add devel subpackage (see [wishes:0165])
557
558* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
559- new upstream release
560
561* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
562- new upstream release
563
564* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
565- new upstream release
566
567* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
568- use %%emacsen_pkgdir macro
569
570* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
571- new upstream release
572
573* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
574- initial build for Vine Linux
575
576* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
577- git-1.5.6.4
578
579* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
580- git-1.5.6
581
582* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
583- use tar.bz2 instead of tar.gz
584
585* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
586- git-1.5.5.3
587
588* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
589- git-1.5.5.2
590
591* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
592- git-1.5.5.1
593
594* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
595- git-1.5.5
596
597* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
598- Remove the last two requires on git-core.
599
600* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
601- Remove a patch that's already upstream.
602
603* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
604- git-1.5.4.5
605
606* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
607- Own /etc/bash_completion.d in case bash-completion isn't installed.
608
609* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
610- Include the sample hooks from contrib/hooks as docs (bug 321151).
611- Install the bash completion script from contrib (bug 433255).
612- Include the html docs in the 'core' package again (bug 434271).
613
614* Wed Mar 19 2008 James Bowes 1.5.4.4-2
615- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
616
617* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
618- git-1.5.4.4
619
620* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
621- rebuild for new perl (again)
622
623* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
624- Do not silently overwrite /etc/httpd/conf.d/git.conf
625
626* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
627- git-1.5.4.3
628- Include Kristian Høgsberg's changes to rename git-core to
629  git and git to git-all.
630
631* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
632- git-1.5.4.2
633
634* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
635- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
636  gitweb rss feeds point be commitdiffs instead of commit
637
638* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
639- git-1.5.4.1
640
641* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
642- rebuild for new perl
643
644* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
645- Add BuidRequires on gettext.
646
647* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
648- git-1.5.4
649
650* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
651- git-1.5.3.8
652
653* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
654- Have git metapackage require explicit versions (bug 247214)
655
656* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
657- git-1.5.3.7
658
659* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
660- git-1.5.3.6
661- git-core requires perl(Error) (bug 367861)
662- git-svn requires perl(Term:ReadKey) (bug 261361)
663- git-email requires perl-Git (bug 333061)
664
665* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
666- git-Perl requires Error package
667
668* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
669- git-1.5.3.4
670
671* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
672- git-1.5.3.3
673
674* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
675- git-1.5.3.2
676
677* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
678- Include git-gui and git-citool docs
679
680* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
681- git-1.5.3.1-1
682
683* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
684- git-1.5.2.5-1
685
686* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
687- git-1.5.2.4-1
688
689* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
690- Add git-daemon and gitweb packages
691
692* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
693- Add emacs-git package (#235431)
694
695* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
696- git-1.5.2.2
697
698* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
699- git-1.5.2.1
700
701* Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
702- Added lib files for git-gui
703- Added Documentation/technical (As needed by Git Users Manual)
704
705* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
706- Added howto files
707
708* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
709- git-1.5.0.6
710
711* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
712- git-1.5.0.5
713
714* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
715- git-1.5.0.3
716
717* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
718- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
719
720* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
721- git-1.5.0.2
722
723* Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
724- Update core package description (Git isn't as stupid as it used to be)
725
726* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
727- Add git-gui and git-citool.
728
729* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
730- no need to install manpages executable (bz 216790)
731- use bytes for git-cvsserver
732
733* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
734- git-1.4.4.2
735
736* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
737- rebuild against the new curl
738
739* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
740- git-1.4.2.4
741
742* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
743- git-1.4.2.3
744
745* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
746- git-1.4.2.1
747
748* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
749- git-1.4.2
750
751* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
752- git-1.4.1
753
754* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
755- git-1.4.0
756
757* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
758- git-1.3.3
759- enable git-email building, prereqs have been relaxed
760
761* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
762- git-1.3.2
763
764* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
765- git-1.3.1
766
767* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
768- git-1.3.0
769
770* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
771- git-1.2.6
772
773* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
774- git-1.2.5
775
776* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
777- git-1.2.4
778
779* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
780- git-1.2.3
781
782* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
783- git-1.2.2
784
785* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
786- git-1.2.1
787
788* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
789- git-1.2.0
790
791* Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
792- git-1.1.6
793
794* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
795- git-1.1.4
796
797* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
798- git-1.1.2
799
800* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
801- git-1.1.1
802
803* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
804- Update to latest git-1.1.0 (drop git-email for now)
805- Now creates multiple packages:
806-        git-core, git-svn, git-cvs, git-arch, gitk
807
808* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
809- Change subpackage names to git-<name> instead of git-core-<name>
810- Create empty root package which brings in all subpackages
811- Rename git-tk -> gitk
812
813* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
814- zlib dependency fix
815- Minor cleanups from split
816- Move arch import to separate package as well
817
818* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
819- Move programs with non-standard dependencies (svn, cvs, email)
820  into separate packages
821
822* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
823- parallelize build
824- COPTS -> CFLAGS
825
826* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
827- update to 0.99.6
828
829* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
830- Linus noticed that less is required, added to the dependencies
831
832* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
833- Updated dependencies
834- Don't assume manpages are gzipped
835
836* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
837- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
838- use RPM_OPT_FLAGS in spec file, drop patch0
839
840* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
841- use dist tag to differentiate between branches
842- use rpm optflags by default (patch0)
843- own %{_datadir}/git-core/
844
845* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
846- update spec file to fix Buildroot, Requires, and drop Vendor
847
848* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
849- Redid the description
850- Cut overlong make line, loosened changelog a bit
851- I think Junio (or perhaps OSDL?) should be vendor...
852
853* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
854- Add the man pages, and the --without docs build option
855
856* Thu Jul 7 2005 Chris Wright <chris@osdl.org>
857- initial git spec file
Note: See TracBrowser for help on using the repository browser.