source: projects/specs/trunk/g/git/git-vl.spec @ 12559

Revision 12559, 27.6 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

git-2.30.1-1

imake-1.0.8-1

irqbalance-1.7.0-1

meson-0.57.1-1

vine-rpm-macros-4-1

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:           git
8Version:        2.30.1
9Release:        1%{?_dist_release}
10Summary:        Core git tools
11Summary(ja):    Core git ツール
12Group:          programming
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       iwaim
16
17License:        GPLv2
18URL:            http://git-scm.com/
19Source0:        https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
20Source1:        vine-default-git.el
21Source2:        git.xinetd
22Source3:        git.conf.httpd
23Source4:        gitweb.conf.in
24Source10:       %{name}-install.sh
25Source11:       %{name}-remove.sh
26Source12:       git-init.el
27Patch0:         git-1.5-gitweb-home-link.patch
28Patch1000:      git-curl-disable-http2.patch
29       
30# Security
31# none
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel
36BuildRequires:  expat-devel, gettext, asciidoc
37BuildRequires:  pcre-devel
38BuildRequires:  xmlto
39
40# git-credential-gnome-keyring
41BuildRequires:  glib2-devel libgnome-keyring-devel
42
43Requires:       perl-Git = %{version}-%{release}
44Requires:       zlib
45Provides:       git-core = %{version}-%{release}
46Obsoletes:      git-core <= 1.5.4.3
47
48%description
49Git is a fast, scalable, distributed revision control system with an
50unusually rich command set that provides both high-level operations
51and full access to internals.
52
53The git rpm installs the core tools with minimal dependencies.  To
54install all git packages, including tools for integrating with other
55SCMs, install the git-all meta-package.
56
57
58%package all
59Summary:        Meta-package to pull in all git tools
60Summary(ja):    すべての git ツール
61Group:          programming
62Requires:       git = %{version}-%{release}
63Requires:       git-svn = %{version}-%{release}
64Requires:       git-cvs = %{version}-%{release}
65%if %{with arch}
66Requires:       git-arch = %{version}-%{release}
67%endif
68Requires:       git-email = %{version}-%{release}
69Requires:       gitk = %{version}-%{release}
70Requires:       git-gui = %{version}-%{release}
71Requires:       perl-Git = %{version}-%{release}
72Requires:       emacs-git = %{version}-%{release}
73Requires:       git-contrib = %{version}-%{release}
74Obsoletes:      git <= 1.5.4.3
75
76%description all
77Git is a fast, scalable, distributed revision control system with an
78unusually rich command set that provides both high-level operations
79and full access to internals.
80
81This is a dummy package which brings in all subpackages.
82
83%package daemon
84Summary:        Git protocol daemon
85Summary(ja):    Git プロトコルデーモン
86Group:          programming,servers
87Requires:       git = %{version}-%{release}
88%description daemon
89The git daemon for supporting git:// access to git repositories
90
91
92%package -n gitweb
93Summary:        Simple web interface to git repositories
94Summary(ja):    git リポジトリへのシンプルな Web インタフェース
95Group:          programming,servers
96Requires:       git = %{version}-%{release}
97
98%description -n gitweb
99Simple web interface to track changes in git repositories
100
101
102%package svn
103Summary:        Git tools for importing Subversion repositories
104Summary(ja):    Subversion リポジトリを git へインポートするためのツール
105Group:          programming
106Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
107Requires:       perl(SVN::Core)
108%description svn
109Git tools for importing Subversion repositories.
110
111
112%package cvs
113Summary:        Git tools for importing CVS repositories
114Summary(ja):    CVS リポジトリを git へインポートするためのツール
115Group:          programming
116Requires:       git = %{version}-%{release}, cvs, cvsps
117%description cvs
118Git tools for importing CVS repositories.
119
120
121%package contrib
122Summary:        Git contrib tools
123Group:          programming
124Requires:       git = %{version}-%{release}
125%description contrib
126Git contrib tools
127
128
129%if %{with arch}
130%package arch
131Summary:        Git tools for importing Arch repositories
132Summary(ja):    Arch リポジトリを git へインポートするためのツール
133Group:          programming
134Requires:       git = %{version}-%{release}, tla
135%description arch
136Git tools for importing Arch repositories.
137%endif
138
139%package email
140Summary:        Git tools for sending email
141Summary(ja):    Eメールを送るための git ツール
142Group:          programming
143Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
144%description email
145Git tools for sending email.
146
147
148%package gui
149Summary:        Git GUI tool
150Summary(ja):    Git の GUI ツール
151Group:          programming
152Requires:       git = %{version}-%{release}, tk
153%description gui
154Git GUI tool.
155
156
157%package -n gitk
158Summary:        Git revision tree visualiser
159Summary(ja):    Git リビジョンツリー可視化ツール
160Group:          programming
161Requires:       git = %{version}-%{release}, tk
162%description -n gitk
163Git revision tree visualiser.
164
165
166%package -n perl-Git
167Summary:        Perl interface to Git
168Summary(ja):    Git の perl インタフェース
169Group:          programming
170Requires:       git = %{version}-%{release}, perl(Error), perl-MailTools
171Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
172#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
173
174%description -n perl-Git
175Perl interface to Git.
176
177
178%package -n emacs-git
179Summary:        Git version control system support for Emacs
180Summary(ja):    Emacs の Git サポート
181Group:          programming
182Requires:       git = %{version}-%{release}, emacsen-common
183
184%description -n emacs-git
185%{summary}.
186
187
188%package devel
189Summary:        Header files for git-core
190Summary(ja):    git-core 用ヘッダファイル
191Group:          programming
192
193%description devel
194Header files for git-core.
195
196
197%debug_package
198
199
200%prep
201%setup -q
202%patch0 -p1
203%patch1000 -p1
204
205%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
206
207# Filter bogus perl requires
208cat << \EOF > %{name}-req
209#!/bin/sh
210%{__perl_requires} $* |\
211sed -e '/perl(packed-refs)/d'
212EOF
213
214%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
215chmod +x %{__perl_requires}
216
217
218%build
219make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
220     ETC_GITCONFIG=/etc/gitconfig \
221     USE_LIBPCRE1=1 \
222     GITWEB_PROJECTROOT=/var/lib/git \
223     gitwebdir=/var/www/git \
224     prefix=%{_prefix} all %{!?_without_docs: doc}
225
226pushd contrib/diff-highlight
227make diff-highlight
228popd
229
230
231%install
232rm -rf $RPM_BUILD_ROOT
233make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
234     prefix=%{_prefix} mandir=%{_mandir} \
235     perllibdir=%{perl_vendorlib} \
236     ETC_GITCONFIG=/etc/gitconfig \
237     USE_LIBPCRE1=1 \
238     NO_PYTHON=1 \
239     GITWEB_PROJECTROOT=/var/lib/git \
240     gitwebdir=/var/www/git \
241     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
242
243pushd contrib/credential/gnome-keyring
244make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
245popd
246
247# arch
248%if %{without arch}
249rm -f Documentation/git-archimport.txt
250rm -f %{buildroot}%{_libexecdir}/git-core/git-archimport
251rm -f %{buildroot}%{_mandir}/man1/git-archimport.1*
252rm -f %{buildroot}/Documentation/git-archimport.html
253%endif
254
255# perl-Git
256rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/FromCPAN
257
258# emacs-git
259mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
260#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
261#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
262mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
263mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
264
265# install el files
266install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
267
268# install vine-default file
269install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
270
271# install  script( bytecompile el and install elc , remove )
272
273%_installemacsenscript git %{SOURCE10}
274%_removeemacsenscript  git %{SOURCE11}
275
276mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
277mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
278install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
279perl -p \
280     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
281     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
282     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
283
284## for gitweb sub package
285mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
286install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
287sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
288    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
289
290find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
291find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
292find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
293
294(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
295(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
296%if %{!?_without_docs:1}0
297(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
298%else
299rm -rf $RPM_BUILD_ROOT%{_mandir}
300%endif
301mkdir -p $RPM_BUILD_ROOT/srv/git
302
303mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
304install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
305
306install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
307
308# header files and lib
309install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
310install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
311install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
312install -m0755 -d $RPM_BUILD_ROOT%{_libdir}
313install libgit.a $RPM_BUILD_ROOT%{_libdir}/
314install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
315
316# git-credential-gnome-keyring
317pushd contrib/credential/gnome-keyring
318%__install -m0755 git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libexecdir}/git-core
319popd
320
321%find_lang %{name}
322
323
324%clean
325rm -rf $RPM_BUILD_ROOT
326
327
328%post -n emacs-git
329
330# bytecompile and install
331if [ "$1" = 2 ]; then
332%_emacsenPackageRemove git
333fi
334%_addemacsenlist git
335%_emacsenPackageInstall git
336
337%preun -n emacs-git
338if [ "$1" = 0 ]; then
339%_emacsenPackageRemove git
340%_removeemacsenlist git
341fi
342
343
344%files -f bin-man-doc-files -f %{name}.lang
345%defattr(-,root,root)
346%{_bindir}/git
347%{_bindir}/git-receive-pack
348%{_bindir}/git-upload-archive
349%{_bindir}/git-upload-pack
350%{_bindir}/git-shell
351%{_datadir}/git-core/
352%exclude %{_libexecdir}/git-core/git-credential-gnome-keyring
353%license COPYING
354%doc README.md Documentation/*.txt contrib/hooks
355%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
356%{!?_without_docs: %doc Documentation/howto Documentation/technical}
357%{_sysconfdir}/bash_completion.d
358
359
360%files svn
361%defattr(-,root,root)
362%{_libexecdir}/git-core/*svn*
363%doc Documentation/*svn*.txt
364%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
365%{!?_without_docs: %doc Documentation/*svn*.html }
366
367%files cvs
368%defattr(-,root,root)
369%doc Documentation/*git-cvs*.txt
370%{_bindir}/git-cvsserver
371%{_libexecdir}/git-core/*cvs*
372%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
373%{!?_without_docs: %doc Documentation/*git-cvs*.html }
374
375%files contrib
376%defattr(-,root,root)
377%doc contrib/diff-highlight/README.diff-highlight
378%{_bindir}/diff-highlight
379%{_libexecdir}/git-core/git-credential-gnome-keyring
380
381%if %{with arch}
382%files arch
383%defattr(-,root,root)
384%doc Documentation/git-archimport.txt
385%{_libexecdir}/git-core/git-archimport
386%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
387%{!?_without_docs: %doc Documentation/git-archimport.html }
388%endif
389
390%files email
391%defattr(-,root,root)
392%doc Documentation/*email*.txt
393%{_libexecdir}/git-core/*email*
394%{!?_without_docs: %{_mandir}/man1/*email*.1*}
395%{!?_without_docs: %doc Documentation/*email*.html }
396
397%files gui
398%defattr(-,root,root)
399%{_libexecdir}/git-core/git-gui*
400%{_libexecdir}/git-core/git-citool
401%{_datadir}/git-gui/
402%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
403%{!?_without_docs: %doc Documentation/git-gui.html}
404%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
405%{!?_without_docs: %doc Documentation/git-citool.html}
406
407%files -n gitk
408%defattr(-,root,root)
409%doc Documentation/*gitk*.txt
410%{_bindir}/gitk
411%{_datadir}/gitk
412%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
413%{!?_without_docs: %doc Documentation/*gitk*.html }
414
415%files -n perl-Git -f perl-files
416%defattr(-,root,root)
417
418%files -n emacs-git
419%defattr(-,root,root)
420%{_datadir}/emacs/site-lisp/git
421#%{_libdir}/emacsen-common/packages/install/git
422#%{_libdir}/emacsen-common/packages/remove/git
423%{emacsen_pkgdir}/install/git
424%{emacsen_pkgdir}/remove/git
425
426%files daemon
427%defattr(-,root,root)
428%{_var}/lib/git
429%{_libexecdir}/git-core/git-daemon
430%config(noreplace)%{_sysconfdir}/xinetd.d/git
431/srv/git
432
433%files -n gitweb
434%defattr(-,root,root)
435%doc gitweb/README
436/var/www/git/
437%config(noreplace)%{_sysconfdir}/gitweb.conf
438%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
439
440%files devel
441%defattr(644,root,root,755)
442%{_includedir}/git
443%{_libdir}/libgit.a
444%{_libdir}/libgit_xdiff.a
445
446%files all
447# No files for you!
448
449
450%changelog
451* Mon Mar 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.30.1-1
452- updated to 2.30.1.
453
454* Fri May 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.26.2-1
455- updated to 2.26.2.
456
457* Mon Apr 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.26.1-1
458- updated to 2.26.1.
459
460* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.24.1-1
461- updated to 2.24.1.
462
463* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.21.0-1
464- updated to 2.21.0.
465- rebuilt with perl-5.26.
466
467* Mon Nov 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.19.1-2
468- added Patch1000 to disable HTTP/2.
469
470* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.19.1-1
471- updated to 2.19.1.
472
473* Wed Jan 17 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 2.15.1-1
474- update to 2.15.1
475
476* Tue Aug 15 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.14.1-1
477- update to 2.14.1
478
479* Sun Jul  9 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.2-1
480- update to 2.13.2
481
482* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.0-1
483- update to 2.13.0
484
485* Sun Mar 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.12.0-1
486- update to 2.12.0
487
488* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.1-1
489- update to 2.11.1
490
491* Tue Dec 20 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.0-1
492- update to 2.11.0
493
494* Fri Nov 18 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.10.2-2
495- include git-credential-gnome-keyring in contrib subpackage
496
497* Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
498- update to 2.10.2
499- fix build error using pcre-8.12 (Vine6)
500
501* Sun May  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
502- update to 2.8.2.
503
504* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
505- update to 2.6.6.
506
507* Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
508- update to 2.6.4
509- add locale files
510
511* Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
512- update to 2.2.1
513
514* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
515- build with Perl 5.16
516
517* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
518- update to 2.0.1
519- add "%%bcond_with arch": no create git-arch sub package by default
520
521* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
522- update to 1.9.2
523
524* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
525- update to 1.8.5.2
526
527* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
528- update to 1.8.4.4
529- new sub package: contrib
530
531* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
532- new upstream release
533
534* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
535- new upstream release
536
537* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
538- new upstream release
539
540* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
541- new upstream release
542
543* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
544- new upstream release
545
546* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
547- new upstream release
548
549* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
550- new upstream release
551- enable libpcre support, add BR: pcre-devel
552- add /etc/gitweb.conf
553- add /var/lib/git for PROJECTROOT
554
555* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
556- new upstream release
557
558* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
559- new upstream release
560
561* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
562- new upstream release
563
564* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
565- new upstream release
566
567* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
568- build with perl 5.12.3
569
570* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
571- new upstream release
572- build with openssl 1.0.0c for VineSeed
573
574* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
575- new upstream release: include security fix: CVE-2010-3906
576
577* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
578- new upstream release
579- drop CVE-2010-2542 patch (Patch100): upstream fixed
580- apply vine-default
581 - rename Source1: git-init.el -> vine-default-git.el
582 - add new git-init.el file (Source12)
583 - update git-install.sh
584- update %%build and %%install section for gitweb subpackage
585- add README in gitweb subpackage
586
587* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
588- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
589
590* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
591- new upstream release
592- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
593- disable building of unused python remote helper libs
594
595* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
596- new upstream release with security fix
597- drop patch10 (included in new release)
598
599* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
600- new upstream release
601- add patch10 git daemon extra arg parsing fix
602
603* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
604- fix install script for Emacs Lisp: <BTS:VineLinux:685>
605 - update git-install.sh (Source10) using contributed patch
606
607* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
608- new upstream release
609
610* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
611- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
612- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
613- fix summary and description in daemon sub package
614
615* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
616- drop Error.pm: provide by perl-Error package
617
618* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
619- new upstream relase
620- update URL tag
621- add Requires: perl(SVN::Core) for svn subpackage
622
623* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
624- add git-shell in git package
625- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
626
627* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
628- added BuildRequires: xmlto
629
630* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
631- new upstream release
632- add devel subpackage (see [wishes:0165])
633
634* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
635- new upstream release
636
637* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
638- new upstream release
639
640* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
641- new upstream release
642
643* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
644- use %%emacsen_pkgdir macro
645
646* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
647- new upstream release
648
649* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
650- initial build for Vine Linux
651
652* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
653- git-1.5.6.4
654
655* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
656- git-1.5.6
657
658* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
659- use tar.bz2 instead of tar.gz
660
661* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
662- git-1.5.5.3
663
664* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
665- git-1.5.5.2
666
667* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
668- git-1.5.5.1
669
670* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
671- git-1.5.5
672
673* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
674- Remove the last two requires on git-core.
675
676* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
677- Remove a patch that's already upstream.
678
679* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
680- git-1.5.4.5
681
682* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
683- Own /etc/bash_completion.d in case bash-completion isn't installed.
684
685* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
686- Include the sample hooks from contrib/hooks as docs (bug 321151).
687- Install the bash completion script from contrib (bug 433255).
688- Include the html docs in the 'core' package again (bug 434271).
689
690* Wed Mar 19 2008 James Bowes 1.5.4.4-2
691- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
692
693* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
694- git-1.5.4.4
695
696* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
697- rebuild for new perl (again)
698
699* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
700- Do not silently overwrite /etc/httpd/conf.d/git.conf
701
702* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
703- git-1.5.4.3
704- Include Kristian Høgsberg's changes to rename git-core to
705  git and git to git-all.
706
707* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
708- git-1.5.4.2
709
710* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
711- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
712  gitweb rss feeds point be commitdiffs instead of commit
713
714* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
715- git-1.5.4.1
716
717* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
718- rebuild for new perl
719
720* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
721- Add BuidRequires on gettext.
722
723* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
724- git-1.5.4
725
726* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
727- git-1.5.3.8
728
729* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
730- Have git metapackage require explicit versions (bug 247214)
731
732* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
733- git-1.5.3.7
734
735* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
736- git-1.5.3.6
737- git-core requires perl(Error) (bug 367861)
738- git-svn requires perl(Term:ReadKey) (bug 261361)
739- git-email requires perl-Git (bug 333061)
740
741* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
742- git-Perl requires Error package
743
744* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
745- git-1.5.3.4
746
747* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
748- git-1.5.3.3
749
750* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
751- git-1.5.3.2
752
753* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
754- Include git-gui and git-citool docs
755
756* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
757- git-1.5.3.1-1
758
759* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
760- git-1.5.2.5-1
761
762* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
763- git-1.5.2.4-1
764
765* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
766- Add git-daemon and gitweb packages
767
768* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
769- Add emacs-git package (#235431)
770
771* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
772- git-1.5.2.2
773
774* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
775- git-1.5.2.1
776
777* Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
778- Added lib files for git-gui
779- Added Documentation/technical (As needed by Git Users Manual)
780
781* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
782- Added howto files
783
784* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
785- git-1.5.0.6
786
787* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
788- git-1.5.0.5
789
790* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
791- git-1.5.0.3
792
793* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
794- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
795
796* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
797- git-1.5.0.2
798
799* Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
800- Update core package description (Git isn't as stupid as it used to be)
801
802* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
803- Add git-gui and git-citool.
804
805* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
806- no need to install manpages executable (bz 216790)
807- use bytes for git-cvsserver
808
809* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
810- git-1.4.4.2
811
812* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
813- rebuild against the new curl
814
815* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
816- git-1.4.2.4
817
818* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
819- git-1.4.2.3
820
821* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
822- git-1.4.2.1
823
824* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
825- git-1.4.2
826
827* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
828- git-1.4.1
829
830* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
831- git-1.4.0
832
833* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
834- git-1.3.3
835- enable git-email building, prereqs have been relaxed
836
837* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
838- git-1.3.2
839
840* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
841- git-1.3.1
842
843* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
844- git-1.3.0
845
846* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
847- git-1.2.6
848
849* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
850- git-1.2.5
851
852* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
853- git-1.2.4
854
855* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
856- git-1.2.3
857
858* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
859- git-1.2.2
860
861* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
862- git-1.2.1
863
864* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
865- git-1.2.0
866
867* Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
868- git-1.1.6
869
870* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
871- git-1.1.4
872
873* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
874- git-1.1.2
875
876* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
877- git-1.1.1
878
879* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
880- Update to latest git-1.1.0 (drop git-email for now)
881- Now creates multiple packages:
882-        git-core, git-svn, git-cvs, git-arch, gitk
883
884* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
885- Change subpackage names to git-<name> instead of git-core-<name>
886- Create empty root package which brings in all subpackages
887- Rename git-tk -> gitk
888
889* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
890- zlib dependency fix
891- Minor cleanups from split
892- Move arch import to separate package as well
893
894* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
895- Move programs with non-standard dependencies (svn, cvs, email)
896  into separate packages
897
898* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
899- parallelize build
900- COPTS -> CFLAGS
901
902* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
903- update to 0.99.6
904
905* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
906- Linus noticed that less is required, added to the dependencies
907
908* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
909- Updated dependencies
910- Don't assume manpages are gzipped
911
912* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
913- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
914- use RPM_OPT_FLAGS in spec file, drop patch0
915
916* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
917- use dist tag to differentiate between branches
918- use rpm optflags by default (patch0)
919- own %{_datadir}/git-core/
920
921* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
922- update spec file to fix Buildroot, Requires, and drop Vendor
923
924* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
925- Redid the description
926- Cut overlong make line, loosened changelog a bit
927- I think Junio (or perhaps OSDL?) should be vendor...
928
929* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
930- Add the man pages, and the --without docs build option
931
932* Thu Jul 7 2005 Chris Wright <chris@osdl.org>
933- initial git spec file
Note: See TracBrowser for help on using the repository browser.