source: projects/specs/trunk/g/git/git-vl.spec @ 10248

Revision 10248, 25.4 KB checked in by tomop, 8 years ago (diff)

git-2.8.2-1

Line 
1%bcond_with arch
2
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4%define emacsen_pkgdir /usr/lib/emacsen-common/packages
5
6# Pass --without docs to rpmbuild if you don't want the documentation
7Name:           git
8Version:        2.8.2
9Release:        1%{?_dist_release}
10Summary:        Core git tools
11Summary(ja):    Core git ツール
12License:        GPLv2
13Group:          Development/Tools
14URL:            http://git-scm.com/
15Source0:        https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
16Source1:        vine-default-git.el
17Source2:        git.xinetd
18Source3:        git.conf.httpd
19Source4:        gitweb.conf.in
20Source10:       %{name}-install.sh
21Source11:       %{name}-remove.sh
22Source12:       git-init.el
23Patch0:         git-1.5-gitweb-home-link.patch
24
25# Security
26# none
27
28BuildRequires:  zlib-devel >= 1.2, openssl-devel, curl-devel
29BuildRequires:  expat-devel, gettext, asciidoc
30BuildRequires:  pcre-devel
31BuildRequires:  xmlto
32BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
33
34Requires:       perl-Git = %{version}-%{release}
35Requires:       zlib
36Provides:       git-core = %{version}-%{release}
37Obsoletes:      git-core <= 1.5.4.3
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       iwaim
42
43%description
44Git is a fast, scalable, distributed revision control system with an
45unusually rich command set that provides both high-level operations
46and full access to internals.
47
48The git rpm installs the core tools with minimal dependencies.  To
49install all git packages, including tools for integrating with other
50SCMs, install the git-all meta-package.
51
52%package all
53Summary:        Meta-package to pull in all git tools
54Summary(ja):    すべての git ツール
55Group:          Development/Tools
56Requires:       git = %{version}-%{release}
57Requires:       git-svn = %{version}-%{release}
58Requires:       git-cvs = %{version}-%{release}
59%if "%{?_dist_release}" != "vl4" && %{with arch}
60Requires:       git-arch = %{version}-%{release}
61%endif
62Requires:       git-email = %{version}-%{release}
63Requires:       gitk = %{version}-%{release}
64Requires:       git-gui = %{version}-%{release}
65Requires:       perl-Git = %{version}-%{release}
66Requires:       emacs-git = %{version}-%{release}
67Requires:       git-contrib = %{version}-%{release}
68Obsoletes:      git <= 1.5.4.3
69
70%description all
71Git is a fast, scalable, distributed revision control system with an
72unusually rich command set that provides both high-level operations
73and full access to internals.
74
75This is a dummy package which brings in all subpackages.
76
77%package daemon
78Summary:        Git protocol daemon
79Summary(ja):    Git プロトコルデーモン
80Group:          Development/Tools
81Requires:       git = %{version}-%{release}
82%description daemon
83The git daemon for supporting git:// access to git repositories
84
85%package -n gitweb
86Summary:        Simple web interface to git repositories
87Summary(ja):    git リポジトリへのシンプルな Web インタフェース
88Group:          Development/Tools
89Requires:       git = %{version}-%{release}
90
91%description -n gitweb
92Simple web interface to track changes in git repositories
93
94
95%package svn
96Summary:        Git tools for importing Subversion repositories
97Summary(ja):    Subversion リポジトリを git へインポートするためのツール
98Group:          Development/Tools
99Requires:       git = %{version}-%{release}, subversion, perl(Term::ReadKey)
100Requires:       perl(SVN::Core)
101%description svn
102Git tools for importing Subversion repositories.
103
104%package cvs
105Summary:        Git tools for importing CVS repositories
106Summary(ja):    CVS リポジトリを git へインポートするためのツール
107Group:          Development/Tools
108Requires:       git = %{version}-%{release}, cvs, cvsps
109%description cvs
110Git tools for importing CVS repositories.
111
112%package contrib
113Summary:        Git contrib tools
114Group:          Development/Tools
115Requires:       git = %{version}-%{release}
116%description contrib
117Git contrib tools
118
119%if "%{?_dist_release}" != "vl4" && %{with arch}
120%package arch
121Summary:        Git tools for importing Arch repositories
122Summary(ja):    Arch リポジトリを git へインポートするためのツール
123Group:          Development/Tools
124Requires:       git = %{version}-%{release}, tla
125%description arch
126Git tools for importing Arch repositories.
127%endif
128
129%package email
130Summary:        Git tools for sending email
131Summary(ja):    Eメールを送るための git ツール
132Group:          Development/Tools
133Requires:       git = %{version}-%{release}, perl-Git = %{version}-%{release}
134%description email
135Git tools for sending email.
136
137%package gui
138Summary:        Git GUI tool
139Summary(ja):    Git の GUI ツール
140Group:          Development/Tools
141Requires:       git = %{version}-%{release}, tk
142%description gui
143Git GUI tool.
144
145%package -n gitk
146Summary:        Git revision tree visualiser
147Summary(ja):    Git リビジョンツリー可視化ツール
148Group:          Development/Tools
149Requires:       git = %{version}-%{release}, tk
150%description -n gitk
151Git revision tree visualiser.
152
153%package -n perl-Git
154Summary:        Perl interface to Git
155Summary(ja):    Git の perl インタフェース
156Group:          Development/Libraries
157Requires:       git = %{version}-%{release}, perl(Error)
158%if "%{?_dist_release}" == "vl4"
159Requires:       perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
160%else
161Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
162%endif
163#BuildRequires:  perl(Error), perl(ExtUtils::MakeMaker)
164
165%description -n perl-Git
166Perl interface to Git.
167
168%package -n emacs-git
169Summary:       Git version control system support for Emacs
170Summary(ja):   Emacs の Git サポート
171Group:         Applications/Editors
172Requires:      git = %{version}-%{release}, emacsen-common
173
174%description -n emacs-git
175%{summary}.
176
177%package devel
178Summary:        Header files for git-core
179Summary(ja):    git-core 用ヘッダファイル
180Group:          Development/Libraries
181
182%description devel
183Header files for git-core.
184
185%prep
186%setup -q
187%patch0 -p1
188%__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
189
190# Filter bogus perl requires
191cat << \EOF > %{name}-req
192#!/bin/sh
193%{__perl_requires} $* |\
194sed -e '/perl(packed-refs)/d'
195EOF
196
197%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
198chmod +x %{__perl_requires}
199
200%build
201make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
202     ETC_GITCONFIG=/etc/gitconfig \
203     USE_LIBPCRE=1 \
204     GITWEB_PROJECTROOT=/var/lib/git \
205     gitwebdir=/var/www/git \
206     prefix=%{_prefix} all %{!?_without_docs: doc}
207
208%install
209rm -rf $RPM_BUILD_ROOT
210make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
211     prefix=%{_prefix} mandir=%{_mandir} \
212     ETC_GITCONFIG=/etc/gitconfig \
213     USE_LIBPCRE=1 \
214     NO_PYTHON=1 \
215     GITWEB_PROJECTROOT=/var/lib/git \
216     gitwebdir=/var/www/git \
217     INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
218
219# perl-Git
220# Error.pm provide by perl-Error package
221rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
222
223# emacs-git
224mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
225#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
226#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
227mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
228mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
229
230# install el files
231install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
232
233# install vine-default file
234install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
235
236# install  script( bytecompile el and install elc , remove )
237
238%_installemacsenscript git %{SOURCE10}
239
240%_removeemacsenscript  git %{SOURCE11}
241
242mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
243mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
244install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
245perl -p \
246     -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
247     -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
248     %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
249
250## for gitweb sub package
251mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
252install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
253sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
254    %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
255
256find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
257find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
258find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
259
260(find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@)               > bin-man-doc-files
261(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
262%if %{!?_without_docs:1}0
263(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
264%else
265rm -rf $RPM_BUILD_ROOT%{_mandir}
266%endif
267mkdir -p $RPM_BUILD_ROOT/srv/git
268
269mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
270install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
271
272install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
273
274# header files and lib
275install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
276install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
277install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
278install libgit.a $RPM_BUILD_ROOT%{_libdir}
279install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
280
281%find_lang %{name}
282
283%clean
284rm -rf $RPM_BUILD_ROOT
285
286%post -n emacs-git
287
288# bytecompile and install
289
290if [ "$1" = 2 ]; then
291
292%_emacsenPackageRemove git
293
294fi
295
296%_addemacsenlist git
297
298%_emacsenPackageInstall git
299
300%preun -n emacs-git
301
302if [ "$1" = 0 ]; then
303
304%_emacsenPackageRemove git
305
306%_removeemacsenlist git
307
308fi
309
310
311%files -f bin-man-doc-files -f %{name}.lang
312%defattr(-,root,root)
313%{_bindir}/git
314%{_bindir}/git-receive-pack
315%{_bindir}/git-upload-archive
316%{_bindir}/git-upload-pack
317%{_bindir}/git-shell
318%{_datadir}/git-core/
319%doc README COPYING Documentation/*.txt contrib/hooks
320%{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
321%{!?_without_docs: %doc Documentation/howto Documentation/technical}
322%{_sysconfdir}/bash_completion.d
323
324
325%files svn
326%defattr(-,root,root)
327%{_libexecdir}/git-core/*svn*
328%doc Documentation/*svn*.txt
329%{!?_without_docs: %{_mandir}/man1/*svn*.1*}
330%{!?_without_docs: %doc Documentation/*svn*.html }
331
332%files cvs
333%defattr(-,root,root)
334%doc Documentation/*git-cvs*.txt
335%{_bindir}/git-cvsserver
336%{_libexecdir}/git-core/*cvs*
337%{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
338%{!?_without_docs: %doc Documentation/*git-cvs*.html }
339
340%files contrib
341%defattr(-,root,root)
342%doc contrib/diff-highlight/README.diff-highlight
343%{_bindir}/diff-highlight
344
345%if "%{?_dist_release}" != "vl4" && %{with arch}
346%files arch
347%defattr(-,root,root)
348%doc Documentation/git-archimport.txt
349%{_libexecdir}/git-core/git-archimport
350%{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
351%{!?_without_docs: %doc Documentation/git-archimport.html }
352%endif
353
354%files email
355%defattr(-,root,root)
356%doc Documentation/*email*.txt
357%{_libexecdir}/git-core/*email*
358%{!?_without_docs: %{_mandir}/man1/*email*.1*}
359%{!?_without_docs: %doc Documentation/*email*.html }
360
361%files gui
362%defattr(-,root,root)
363%{_libexecdir}/git-core/git-gui*
364%{_libexecdir}/git-core/git-citool
365%{_datadir}/git-gui/
366%{!?_without_docs: %{_mandir}/man1/git-gui.1*}
367%{!?_without_docs: %doc Documentation/git-gui.html}
368%{!?_without_docs: %{_mandir}/man1/git-citool.1*}
369%{!?_without_docs: %doc Documentation/git-citool.html}
370
371%files -n gitk
372%defattr(-,root,root)
373%doc Documentation/*gitk*.txt
374%{_bindir}/gitk
375%{_datadir}/gitk
376%{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
377%{!?_without_docs: %doc Documentation/*gitk*.html }
378
379%files -n perl-Git -f perl-files
380%defattr(-,root,root)
381
382%files -n emacs-git
383%defattr(-,root,root)
384%{_datadir}/emacs/site-lisp/git
385#%{_libdir}/emacsen-common/packages/install/git
386#%{_libdir}/emacsen-common/packages/remove/git
387%{emacsen_pkgdir}/install/git
388%{emacsen_pkgdir}/remove/git
389
390%files daemon
391%defattr(-,root,root)
392%{_var}/lib/git
393%{_libexecdir}/git-core/git-daemon
394%config(noreplace)%{_sysconfdir}/xinetd.d/git
395/srv/git
396
397%files -n gitweb
398%defattr(-,root,root)
399%doc gitweb/README
400/var/www/git/
401%config(noreplace)%{_sysconfdir}/gitweb.conf
402%config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
403
404%files devel
405%defattr(644,root,root,755)
406%{_includedir}/git
407%{_libdir}/libgit.a
408%{_libdir}/libgit_xdiff.a
409
410
411%files all
412# No files for you!
413
414%changelog
415* Sun May  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
416- update to 2.8.2.
417
418* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
419- update to 2.6.6.
420
421* Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
422- update to 2.6.4
423- add locale files
424
425* Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
426- update to 2.2.1
427
428* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
429- build with Perl 5.16
430
431* Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
432- update to 2.0.1
433- add "%%bcond_with arch": no create git-arch sub package by default
434
435* Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
436- update to 1.9.2
437
438* Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
439- update to 1.8.5.2
440
441* Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
442- update to 1.8.4.4
443- new sub package: contrib
444
445* Fri Feb  8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
446- new upstream release
447
448* Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
449- new upstream release
450
451* Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
452- new upstream release
453
454* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
455- new upstream release
456
457* Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
458- new upstream release
459
460* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
461- new upstream release
462
463* Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
464- new upstream release
465- enable libpcre support, add BR: pcre-devel
466- add /etc/gitweb.conf
467- add /var/lib/git for PROJECTROOT
468
469* Mon Sep  3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
470- new upstream release
471
472* Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
473- new upstream release
474
475* Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
476- new upstream release
477
478* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
479- new upstream release
480
481* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
482- build with perl 5.12.3
483
484* Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
485- new upstream release
486- build with openssl 1.0.0c for VineSeed
487
488* Sat Jan  1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
489- new upstream release: include security fix: CVE-2010-3906
490
491* Fri Oct  1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
492- new upstream release
493- drop CVE-2010-2542 patch (Patch100): upstream fixed
494- apply vine-default
495 - rename Source1: git-init.el -> vine-default-git.el
496 - add new git-init.el file (Source12)
497 - update git-install.sh
498- update %%build and %%install section for gitweb subpackage
499- add README in gitweb subpackage
500
501* Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
502- add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
503
504* Wed Jun  9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
505- new upstream release
506- fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
507- disable building of unused python remote helper libs
508
509* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
510- new upstream release with security fix
511- drop patch10 (included in new release)
512
513* Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
514- new upstream release
515- add patch10 git daemon extra arg parsing fix
516
517* Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
518- fix install script for Emacs Lisp: <BTS:VineLinux:685>
519 - update git-install.sh (Source10) using contributed patch
520
521* Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
522- new upstream release
523
524* Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
525- delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
526- spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
527- fix summary and description in daemon sub package
528
529* Sun Feb  1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
530- drop Error.pm: provide by perl-Error package
531
532* Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
533- new upstream relase
534- update URL tag
535- add Requires: perl(SVN::Core) for svn subpackage
536
537* Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
538- add git-shell in git package
539- do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
540
541* Mon Jan  5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
542- added BuildRequires: xmlto
543
544* Mon Jan  5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
545- new upstream release
546- add devel subpackage (see [wishes:0165])
547
548* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
549- new upstream release
550
551* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
552- new upstream release
553
554* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
555- new upstream release
556
557* Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
558- use %%emacsen_pkgdir macro
559
560* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
561- new upstream release
562
563* Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.5.6.4-1
564- initial build for Vine Linux
565
566* Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
567- git-1.5.6.4
568
569* Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
570- git-1.5.6
571
572* Tue Jun  3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
573- use tar.bz2 instead of tar.gz
574
575* Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
576- git-1.5.5.3
577
578* Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
579- git-1.5.5.2
580
581* Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
582- git-1.5.5.1
583
584* Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
585- git-1.5.5
586
587* Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
588- Remove the last two requires on git-core.
589
590* Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
591- Remove a patch that's already upstream.
592
593* Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
594- git-1.5.4.5
595
596* Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
597- Own /etc/bash_completion.d in case bash-completion isn't installed.
598
599* Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
600- Include the sample hooks from contrib/hooks as docs (bug 321151).
601- Install the bash completion script from contrib (bug 433255).
602- Include the html docs in the 'core' package again (bug 434271).
603
604* Wed Mar 19 2008 James Bowes 1.5.4.4-2
605- Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
606
607* Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
608- git-1.5.4.4
609
610* Mon Mar  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
611- rebuild for new perl (again)
612
613* Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
614- Do not silently overwrite /etc/httpd/conf.d/git.conf
615
616* Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
617- git-1.5.4.3
618- Include Kristian Høgsberg's changes to rename git-core to
619  git and git to git-all.
620
621* Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
622- git-1.5.4.2
623
624* Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
625- Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
626  gitweb rss feeds point be commitdiffs instead of commit
627
628* Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
629- git-1.5.4.1
630
631* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
632- rebuild for new perl
633
634* Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
635- Add BuidRequires on gettext.
636
637* Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
638- git-1.5.4
639
640* Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
641- git-1.5.3.8
642
643* Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
644- Have git metapackage require explicit versions (bug 247214)
645
646* Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
647- git-1.5.3.7
648
649* Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
650- git-1.5.3.6
651- git-core requires perl(Error) (bug 367861)
652- git-svn requires perl(Term:ReadKey) (bug 261361)
653- git-email requires perl-Git (bug 333061)
654
655* Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
656- git-Perl requires Error package
657
658* Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
659- git-1.5.3.4
660
661* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
662- git-1.5.3.3
663
664* Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
665- git-1.5.3.2
666
667* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
668- Include git-gui and git-citool docs
669
670* Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
671- git-1.5.3.1-1
672
673* Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
674- git-1.5.2.5-1
675
676* Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
677- git-1.5.2.4-1
678
679* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
680- Add git-daemon and gitweb packages
681
682* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
683- Add emacs-git package (#235431)
684
685* Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
686- git-1.5.2.2
687
688* Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
689- git-1.5.2.1
690
691* Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
692- Added lib files for git-gui
693- Added Documentation/technical (As needed by Git Users Manual)
694
695* Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
696- Added howto files
697
698* Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
699- git-1.5.0.6
700
701* Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
702- git-1.5.0.5
703
704* Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
705- git-1.5.0.3
706
707* Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
708- BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
709
710* Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
711- git-1.5.0.2
712
713* Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
714- Update core package description (Git isn't as stupid as it used to be)
715
716* Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
717- Add git-gui and git-citool.
718
719* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
720- no need to install manpages executable (bz 216790)
721- use bytes for git-cvsserver
722
723* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
724- git-1.4.4.2
725
726* Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
727- rebuild against the new curl
728
729* Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
730- git-1.4.2.4
731
732* Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
733- git-1.4.2.3
734
735* Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
736- git-1.4.2.1
737
738* Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
739- git-1.4.2
740
741* Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
742- git-1.4.1
743
744* Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
745- git-1.4.0
746
747* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
748- git-1.3.3
749- enable git-email building, prereqs have been relaxed
750
751* Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
752- git-1.3.2
753
754* Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
755- git-1.3.1
756
757* Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
758- git-1.3.0
759
760* Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
761- git-1.2.6
762
763* Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
764- git-1.2.5
765
766* Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
767- git-1.2.4
768
769* Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
770- git-1.2.3
771
772* Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
773- git-1.2.2
774
775* Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
776- git-1.2.1
777
778* Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
779- git-1.2.0
780
781* Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
782- git-1.1.6
783
784* Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
785- git-1.1.4
786
787* Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
788- git-1.1.2
789
790* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
791- git-1.1.1
792
793* Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
794- Update to latest git-1.1.0 (drop git-email for now)
795- Now creates multiple packages:
796-        git-core, git-svn, git-cvs, git-arch, gitk
797
798* Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
799- Change subpackage names to git-<name> instead of git-core-<name>
800- Create empty root package which brings in all subpackages
801- Rename git-tk -> gitk
802
803* Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
804- zlib dependency fix
805- Minor cleanups from split
806- Move arch import to separate package as well
807
808* Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
809- Move programs with non-standard dependencies (svn, cvs, email)
810  into separate packages
811
812* Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
813- parallelize build
814- COPTS -> CFLAGS
815
816* Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
817- update to 0.99.6
818
819* Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
820- Linus noticed that less is required, added to the dependencies
821
822* Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
823- Updated dependencies
824- Don't assume manpages are gzipped
825
826* Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
827- drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
828- use RPM_OPT_FLAGS in spec file, drop patch0
829
830* Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
831- use dist tag to differentiate between branches
832- use rpm optflags by default (patch0)
833- own %{_datadir}/git-core/
834
835* Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
836- update spec file to fix Buildroot, Requires, and drop Vendor
837
838* Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
839- Redid the description
840- Cut overlong make line, loosened changelog a bit
841- I think Junio (or perhaps OSDL?) should be vendor...
842
843* Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
844- Add the man pages, and the --without docs build option
845
846* Thu Jul 7 2005 Chris Wright <chris@osdl.org>
847- initial git spec file
Note: See TracBrowser for help on using the repository browser.