source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 521

Revision 521, 12.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 7.0.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12Requires: install-info
13#Prereq: /sbin/install-info
14
15%description
16GDB, the GNU debugger, allows you to debug programs written in C, C++,
17and other languages, by executing them in a controlled fashion and
18printing their data.
19
20%description -l ja
21GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
22使うツールです.プログラムの実行を制御し,データを出力することができます.
23
24%prep
25%setup -q
26
27%build
28export CFLAGS="$RPM_OPT_FLAGS"
29rm -fr dejagnu tcl expect
30./configure \
31        --prefix=%{_prefix} \
32        --sysconfdir=%{_sysconfdir} \
33        --mandir=%{_mandir} \
34    --infodir=%{_infodir} \
35        %{_target_platform}
36
37make
38make info
39cp gdb/NEWS .
40
41%install
42rm -rf $RPM_BUILD_ROOT
43%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
44
45# install the gcore script in /usr/bin
46install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
47
48# The above is broken, do this for now:
49#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
50#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
51
52# These are part of binutils
53#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
54#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
55rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
56rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
57rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
58rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
59rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
60rm -rf $RPM_BUILD_ROOT%{_includedir}
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%post
67[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
68[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
69[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
70[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
71[ -f %{_infodir}/gdbint.info ]         && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
72[ -f %{_infodir}/gdbint.info.gz ]      && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
73[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
74[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
75
76
77%preun
78if [ $1 = 0 ]; then
79        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
80        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
81        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
82        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
83        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
84        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
85        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
86        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
87fi
88
89
90%files
91%defattr(-,root,root)
92%doc COPYING COPYING.LIB README NEWS
93%{_bindir}/*
94%{_mandir}/*/*
95%{_datadir}/gdb/syscalls
96%{_infodir}/annotate.info*
97%{_infodir}/gdb.info*
98%{_infodir}/gdbint.info*
99%{_infodir}/stabs.info*
100%exclude %{_infodir}/dir
101## don't include the files in include, they are part of binutils
102#%{_includedir}/*
103#%{_infodir}/bfd.info*
104#%{_infodir}/configure.info*
105#%{_infodir}/standard.info*
106#%{_libdir}/*
107#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
108#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
109
110
111%changelog
112* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
113- updated gdb to 7.0.1
114- rebuilt with new environment
115
116* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
117- applied new versioning policy, spec in utf-8
118
119* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
120- rebuild with expat-2.0.1
121- add BuildRequires: expat-devel
122
123* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
124- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
125
126* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
127- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
128
129* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
130- new upstream release
131
132* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
133- new upstream release
134
135* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
136- new upstream release
137
138* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
139- Oops, spec was written in Shift-JIS. Fixed.
140
141* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
142- based on 5.2.1-4 from Rawhide and built for Vine Linux
143
144* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
145- added mainframe patch from developerworks
146
147* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
148- Add changelogs to the previous patch
149
150* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
151- Add some patches from Elena Zannoni <ezannoni@redhat.com>
152
153* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
154- 5.2.1
155
156* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
157- compile on mainframe
158
159* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
160- Rebuild
161
162* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
163- Rebuild
164
165* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
166- 5.2
167
168* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
169- 5.1.92. Hopefully identical to 5.2 final
170
171* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
172- 5.1.91. 5.2 expected in a week
173
174* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
175- Update to current
176
177* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
178- Update to current
179
180* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
181- Update to current
182
183* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
184- Update to current
185
186* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
187- Update to current 5.2 branch
188
189* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
190- 5.1.1
191- add URL
192
193* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
194- automated rebuild
195
196* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
197- Fix some thread+fpu problems
198
199* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
200- 5.1
201
202* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
203- 5.0.94. Almost there....
204
205* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
206- Add patch from jakub@redhat.com to improve handling of DWARF
207
208* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
209- 5.0.93
210- handle missing info pages in post/pre scripts
211
212* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
213- 5.0.92
214
215* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
216- New snapshot
217- Use the 5.0.91 versioning from the snapshot
218
219* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
220- New snapshot
221
222* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
223- New snapshot
224
225* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
226- New snapshot
227
228* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
229- Don't buildrequire compat-glibc (#51690)
230
231* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
232- New snapshot, from the stable branch eventually leading to gdb 5.1
233
234* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
235- s/Copyright/License/
236- Add texinfo to BuildRequires
237
238* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
239- New snapshot
240
241* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
242- New snapshot
243- Add ncurses-devel to buildprereq
244- Remove perl from buildprereq, as gdb changed the way
245  version strings are generated
246
247* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
248- New snapshot
249
250* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
251- New snapshot - this had thread fixes for curing #39070
252- New way of specifying version
253
254* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
255- New tarball
256- Kevin's patch is now part of gdb
257
258* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
259- Add patch from kevinb@redhat.com to fix floating point + thread
260  problem (#24310)
261- remove old workarounds
262- new snapshot
263
264* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
265- New snapshot
266
267* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
268- on ia64, there are no old headers :)
269
270* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
271- build with old headers, new compiler
272
273* Wed Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
274- new snapshot
275
276* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
277- new snapshot which should fix some more IA64 problems (#29151)
278- remove IA64 patch, it's now integrated
279
280* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
281- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
282- use perl instead of patch for fixing the version string
283
284* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
285- don't use kgcc anymore
286- mark it as our own version
287- new snapshot
288
289* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
290- Link with ncurses 5.x even though we're using kgcc.
291  No need to drag in requirements on ncurses4 (Bug #24445)
292
293* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
294- new snapshot
295
296* Thu Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
297- new snapshot
298
299* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
300- new snapshot
301- new alpha patch - it now compiles everywhere. Finally.
302
303* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
304- new snapshot
305
306* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
307- new CVS snapshot
308- disable the patches
309- don't use %%configure, as it confuses the autoconf script
310- enable SPARC, disable Alpha
311
312
313* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
314- added patch from GDB team for C++ symbol handling
315
316* Mon Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
317- upgrade to CVS snapshot
318- excludearch SPARC, build on IA61
319
320* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
321- rebuild
322
323* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
324- automatic rebuild
325
326* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
327- rebuild
328
329* Fri Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
330- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
331  and %%{_tmppath}
332- the install scripts  for info are broken(they don't care about
333  you specify in the installstep), work around that.
334- don't build for IA64
335
336* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
337- upgraded to 5.0 - dump all patches. Reapply later if needed.
338- added the NEWS file to the %%doc files
339- don't delete files which doesn't get installed (readline, texinfo)
340- let build system handle stripping and gzipping
341- don't delete libmmalloc
342- apply patch from jakub@redhat.com to make it build on SPARC
343
344* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
345- rebuilt against new ncurses
346
347* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
348- rebuild for sparc baud rates > 38400.
349
350* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
351- fix core file handling on i386 with glibc 2.1.3 headers
352
353* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
354- fix reading registers from core on sparc.
355- hack around build problems on i386 with glibc 2.1.3 headers
356
357* Thu Oct 7 1999 Jim Kingdon
358- List files to install in /usr/info specifically (so we don't pick up
359things like info.info from GDB snapshots).
360
361* Thu Oct 7 1999 Jim Kingdon
362- Update GDB to 19991004 snapshot.  This eliminates the need for the
363sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
364
365* Mon Aug 23 1999 Jim Kingdon
366- Omit readline manpage.
367
368* Tue Aug 7 1999 Jim Kingdon
369- Remove H.J. Lu's patches (they had been commented out).
370- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
371from code fusion CD-ROM).
372
373* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
374- merge H.J. Lu's patches into 4.18.
375
376* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
377- updated the kern22 patch with stuff from davem
378
379* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
380- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
381
382* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
383- auto rebuild in the new build environment (release 3)
384
385* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
386- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.