source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 12525

Revision 12525, 14.3 KB checked in by tomop, 3 years ago (diff)

updated 10 packages

binutils-2.36.1-1

elfutils-0.183-1

gcc-10.2.1-1

gdb-10.1-1

glibc-2.33-1

isl-0.23-1

libtirpc-1.3.1-1

libtool-2.4.6-7

libxcrypt-4.4.17-1

valgrind-3.16.1-2

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 10.1
5Release: 1%{?_dist_release}
6Group: programming
7Vendor: Project Vine
8Distribution: Vine Linux
9
10License: GPL
11URL: https://www.gnu.org/software/gdb/
12Source: https://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
16BuildRequires: python3-devel python3-rpm-macros
17BuildRequires: zlib-devel
18Requires: install-info
19
20%description
21GDB, the GNU debugger, allows you to debug programs written in C, C++,
22and other languages, by executing them in a controlled fashion and
23printing their data.
24
25%description -l ja
26GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
27使うツールです.プログラムの実行を制御し,データを出力することができます.
28
29
30%debug_package
31
32
33%prep
34%setup -q
35
36
37%build
38export CFLAGS="$RPM_OPT_FLAGS"
39rm -fr dejagnu tcl expect
40mkdir -p build
41cd build
42../configure \
43        --prefix=%{_prefix} \
44        --sysconfdir=%{_sysconfdir} \
45        --mandir=%{_mandir} \
46    --infodir=%{_infodir} \
47    --with-python=%{__python3} \
48        %{_target_platform}
49
50make %{?_smp_mflags}
51make %{?_smp_mflags} info
52
53
54%install
55rm -rf $RPM_BUILD_ROOT
56cd build
57%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
58
59# The above is broken, do this for now:
60#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
61#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
62
63# These are part of binutils
64#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
65#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
66rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
67rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
68rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
69rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
70rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
71rm -rf $RPM_BUILD_ROOT%{_includedir}
72
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77
78%post
79[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
80[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
81[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
82[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
83[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
84[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
85
86
87%preun
88if [ $1 = 0 ]; then
89        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
90        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
91        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
92        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
93        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
94        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
95        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
96        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
97fi
98
99
100%files
101%defattr(-,root,root)
102%license COPYING COPYING.LIB
103%doc README gdb/NEWS
104%{_bindir}/*
105%{_mandir}/*/*
106%dir %{_datadir}/gdb
107%{_datadir}/gdb/syscalls
108%dir %{_datadir}/gdb/python
109%{_datadir}/gdb/python/gdb
110%dir %{_datadir}/gdb/system-gdbinit
111%{_datadir}/gdb/system-gdbinit/elinos.py
112%{_datadir}/gdb/system-gdbinit/wrs-linux.py
113%{_infodir}/annotate.info*
114%{_infodir}/gdb.info*
115%{_infodir}/stabs.info*
116%exclude %{_infodir}/dir
117%ifarch %{ix86} x86_64
118%{_libdir}/libinproctrace.so
119%endif
120## don't include the files in include, they are part of binutils
121#%{_includedir}/*
122#%{_infodir}/bfd.info*
123#%{_infodir}/configure.info*
124#%{_infodir}/standard.info*
125#%{_libdir}/*
126#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
127#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
128
129
130%changelog
131* Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.1-1
132- new upstream release.
133
134* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.2-1
135- new upstream release.
136
137* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.1-1
138- new upstream release.
139
140* Wed Jan 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
141- new upstream release.
142
143* Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11.1-1
144- new upstream release
145
146* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
147- new upstream release
148
149* Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
150- new upstream release
151
152* Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
153- new upstream release
154
155* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
156- new upstream release
157
158* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
159- new upstream release
160
161* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
162- new upstream release
163
164* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
165- new upstream release
166
167* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
168- new upstream release
169
170* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
171- new upstream release
172
173* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
174- new upstream release
175
176* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
177- add BuildRequires: python-devel, zlib-devel
178- fix %%files
179
180* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
181- updated gdb to 7.2
182
183* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
184- updated gdb to 7.0.1
185- rebuilt with new environment
186
187* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
188- applied new versioning policy, spec in utf-8
189
190* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
191- rebuild with expat-2.0.1
192- add BuildRequires: expat-devel
193
194* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
195- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
196
197* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
198- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
199
200* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
201- new upstream release
202
203* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
204- new upstream release
205
206* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
207- new upstream release
208
209* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
210- Oops, spec was written in Shift-JIS. Fixed.
211
212* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
213- based on 5.2.1-4 from Rawhide and built for Vine Linux
214
215* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
216- added mainframe patch from developerworks
217
218* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
219- Add changelogs to the previous patch
220
221* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
222- Add some patches from Elena Zannoni <ezannoni@redhat.com>
223
224* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
225- 5.2.1
226
227* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
228- compile on mainframe
229
230* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
231- Rebuild
232
233* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
234- Rebuild
235
236* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
237- 5.2
238
239* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
240- 5.1.92. Hopefully identical to 5.2 final
241
242* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
243- 5.1.91. 5.2 expected in a week
244
245* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
246- Update to current
247
248* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
249- Update to current
250
251* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
252- Update to current
253
254* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
255- Update to current
256
257* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
258- Update to current 5.2 branch
259
260* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
261- 5.1.1
262- add URL
263
264* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
265- automated rebuild
266
267* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
268- Fix some thread+fpu problems
269
270* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
271- 5.1
272
273* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
274- 5.0.94. Almost there....
275
276* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
277- Add patch from jakub@redhat.com to improve handling of DWARF
278
279* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
280- 5.0.93
281- handle missing info pages in post/pre scripts
282
283* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
284- 5.0.92
285
286* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
287- New snapshot
288- Use the 5.0.91 versioning from the snapshot
289
290* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
291- New snapshot
292
293* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
294- New snapshot
295
296* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
297- New snapshot
298
299* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
300- Don't buildrequire compat-glibc (#51690)
301
302* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
303- New snapshot, from the stable branch eventually leading to gdb 5.1
304
305* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
306- s/Copyright/License/
307- Add texinfo to BuildRequires
308
309* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
310- New snapshot
311
312* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
313- New snapshot
314- Add ncurses-devel to buildprereq
315- Remove perl from buildprereq, as gdb changed the way
316  version strings are generated
317
318* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
319- New snapshot
320
321* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
322- New snapshot - this had thread fixes for curing #39070
323- New way of specifying version
324
325* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
326- New tarball
327- Kevin's patch is now part of gdb
328
329* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
330- Add patch from kevinb@redhat.com to fix floating point + thread
331  problem (#24310)
332- remove old workarounds
333- new snapshot
334
335* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
336- New snapshot
337
338* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
339- on ia64, there are no old headers :)
340
341* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
342- build with old headers, new compiler
343
344* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
345- new snapshot
346
347* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
348- new snapshot which should fix some more IA64 problems (#29151)
349- remove IA64 patch, it's now integrated
350
351* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
352- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
353- use perl instead of patch for fixing the version string
354
355* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
356- don't use kgcc anymore
357- mark it as our own version
358- new snapshot
359
360* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
361- Link with ncurses 5.x even though we're using kgcc.
362  No need to drag in requirements on ncurses4 (Bug #24445)
363
364* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
365- new snapshot
366
367* Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
368- new snapshot
369
370* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
371- new snapshot
372- new alpha patch - it now compiles everywhere. Finally.
373
374* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
375- new snapshot
376
377* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
378- new CVS snapshot
379- disable the patches
380- don't use %%configure, as it confuses the autoconf script
381- enable SPARC, disable Alpha
382
383
384* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
385- added patch from GDB team for C++ symbol handling
386
387* Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
388- upgrade to CVS snapshot
389- excludearch SPARC, build on IA61
390
391* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
392- rebuild
393
394* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
395- automatic rebuild
396
397* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
398- rebuild
399
400* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
401- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
402  and %%{_tmppath}
403- the install scripts  for info are broken(they don't care about
404  you specify in the installstep), work around that.
405- don't build for IA64
406
407* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
408- upgraded to 5.0 - dump all patches. Reapply later if needed.
409- added the NEWS file to the %%doc files
410- don't delete files which doesn't get installed (readline, texinfo)
411- let build system handle stripping and gzipping
412- don't delete libmmalloc
413- apply patch from jakub@redhat.com to make it build on SPARC
414
415* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
416- rebuilt against new ncurses
417
418* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
419- rebuild for sparc baud rates > 38400.
420
421* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
422- fix core file handling on i386 with glibc 2.1.3 headers
423
424* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
425- fix reading registers from core on sparc.
426- hack around build problems on i386 with glibc 2.1.3 headers
427
428* Thu Oct 7 1999 Jim Kingdon
429- List files to install in /usr/info specifically (so we don't pick up
430things like info.info from GDB snapshots).
431
432* Thu Oct 7 1999 Jim Kingdon
433- Update GDB to 19991004 snapshot.  This eliminates the need for the
434sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
435
436* Mon Aug 23 1999 Jim Kingdon
437- Omit readline manpage.
438
439* Sat Aug 7 1999 Jim Kingdon
440- Remove H.J. Lu's patches (they had been commented out).
441- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
442from code fusion CD-ROM).
443
444* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
445- merge H.J. Lu's patches into 4.18.
446
447* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
448- updated the kern22 patch with stuff from davem
449
450* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
451- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
452
453* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
454- auto rebuild in the new build environment (release 3)
455
456* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
457- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.