source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 3731

Revision 3731, 12.8 KB checked in by owa, 13 years ago (diff)

rebuilt:chasen,gdb,nasm,spambayes

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 7.2
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12Requires: install-info
13
14%description
15GDB, the GNU debugger, allows you to debug programs written in C, C++,
16and other languages, by executing them in a controlled fashion and
17printing their data.
18
19%description -l ja
20GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
21使うツールです.プログラムの実行を制御し,データを出力することができます.
22
23%prep
24%setup -q
25
26%build
27export CFLAGS="$RPM_OPT_FLAGS"
28rm -fr dejagnu tcl expect
29./configure \
30        --prefix=%{_prefix} \
31        --sysconfdir=%{_sysconfdir} \
32        --mandir=%{_mandir} \
33    --infodir=%{_infodir} \
34        %{_target_platform}
35
36make
37make info
38cp gdb/NEWS .
39
40%install
41rm -rf $RPM_BUILD_ROOT
42%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
43
44# install the gcore script in /usr/bin
45install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
46
47# The above is broken, do this for now:
48#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
49#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
50
51# These are part of binutils
52#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
53#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
54rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
55rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
56rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
57rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
58rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
59rm -rf $RPM_BUILD_ROOT%{_includedir}
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64
65%post
66[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
67[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
68[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
69[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
70[ -f %{_infodir}/gdbint.info ]         && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
71[ -f %{_infodir}/gdbint.info.gz ]      && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
72[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
73[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
74
75
76%preun
77if [ $1 = 0 ]; then
78        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
79        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
80        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
81        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
82        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
83        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
84        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
85        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
86fi
87
88
89%files
90%defattr(-,root,root)
91%doc COPYING COPYING.LIB README NEWS
92%{_bindir}/*
93%{_mandir}/*/*
94%{_datadir}/gdb/syscalls
95%{_infodir}/annotate.info*
96%{_infodir}/gdb.info*
97%{_infodir}/gdbint.info*
98%{_infodir}/stabs.info*
99%exclude %{_infodir}/dir
100%ifarch x86_64
101%{_libdir}/libinproctrace.so
102%endif
103## don't include the files in include, they are part of binutils
104#%{_includedir}/*
105#%{_infodir}/bfd.info*
106#%{_infodir}/configure.info*
107#%{_infodir}/standard.info*
108#%{_libdir}/*
109#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
110#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
111
112
113%changelog
114* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
115- updated gdb to 7.2
116
117* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
118- updated gdb to 7.0.1
119- rebuilt with new environment
120
121* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
122- applied new versioning policy, spec in utf-8
123
124* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
125- rebuild with expat-2.0.1
126- add BuildRequires: expat-devel
127
128* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
129- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
130
131* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
132- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
133
134* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
135- new upstream release
136
137* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
138- new upstream release
139
140* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
141- new upstream release
142
143* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
144- Oops, spec was written in Shift-JIS. Fixed.
145
146* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
147- based on 5.2.1-4 from Rawhide and built for Vine Linux
148
149* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
150- added mainframe patch from developerworks
151
152* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
153- Add changelogs to the previous patch
154
155* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
156- Add some patches from Elena Zannoni <ezannoni@redhat.com>
157
158* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
159- 5.2.1
160
161* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
162- compile on mainframe
163
164* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
165- Rebuild
166
167* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
168- Rebuild
169
170* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
171- 5.2
172
173* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
174- 5.1.92. Hopefully identical to 5.2 final
175
176* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
177- 5.1.91. 5.2 expected in a week
178
179* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
180- Update to current
181
182* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
183- Update to current
184
185* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
186- Update to current
187
188* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
189- Update to current
190
191* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
192- Update to current 5.2 branch
193
194* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
195- 5.1.1
196- add URL
197
198* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
199- automated rebuild
200
201* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
202- Fix some thread+fpu problems
203
204* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
205- 5.1
206
207* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
208- 5.0.94. Almost there....
209
210* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
211- Add patch from jakub@redhat.com to improve handling of DWARF
212
213* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
214- 5.0.93
215- handle missing info pages in post/pre scripts
216
217* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
218- 5.0.92
219
220* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
221- New snapshot
222- Use the 5.0.91 versioning from the snapshot
223
224* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
225- New snapshot
226
227* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
228- New snapshot
229
230* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
231- New snapshot
232
233* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
234- Don't buildrequire compat-glibc (#51690)
235
236* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
237- New snapshot, from the stable branch eventually leading to gdb 5.1
238
239* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
240- s/Copyright/License/
241- Add texinfo to BuildRequires
242
243* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
244- New snapshot
245
246* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
247- New snapshot
248- Add ncurses-devel to buildprereq
249- Remove perl from buildprereq, as gdb changed the way
250  version strings are generated
251
252* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
253- New snapshot
254
255* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
256- New snapshot - this had thread fixes for curing #39070
257- New way of specifying version
258
259* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
260- New tarball
261- Kevin's patch is now part of gdb
262
263* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
264- Add patch from kevinb@redhat.com to fix floating point + thread
265  problem (#24310)
266- remove old workarounds
267- new snapshot
268
269* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
270- New snapshot
271
272* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
273- on ia64, there are no old headers :)
274
275* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
276- build with old headers, new compiler
277
278* Wed Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
279- new snapshot
280
281* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
282- new snapshot which should fix some more IA64 problems (#29151)
283- remove IA64 patch, it's now integrated
284
285* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
286- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
287- use perl instead of patch for fixing the version string
288
289* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
290- don't use kgcc anymore
291- mark it as our own version
292- new snapshot
293
294* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
295- Link with ncurses 5.x even though we're using kgcc.
296  No need to drag in requirements on ncurses4 (Bug #24445)
297
298* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
299- new snapshot
300
301* Thu Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
302- new snapshot
303
304* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
305- new snapshot
306- new alpha patch - it now compiles everywhere. Finally.
307
308* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
309- new snapshot
310
311* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
312- new CVS snapshot
313- disable the patches
314- don't use %%configure, as it confuses the autoconf script
315- enable SPARC, disable Alpha
316
317
318* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
319- added patch from GDB team for C++ symbol handling
320
321* Mon Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
322- upgrade to CVS snapshot
323- excludearch SPARC, build on IA61
324
325* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
326- rebuild
327
328* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
329- automatic rebuild
330
331* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
332- rebuild
333
334* Fri Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
335- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
336  and %%{_tmppath}
337- the install scripts  for info are broken(they don't care about
338  you specify in the installstep), work around that.
339- don't build for IA64
340
341* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
342- upgraded to 5.0 - dump all patches. Reapply later if needed.
343- added the NEWS file to the %%doc files
344- don't delete files which doesn't get installed (readline, texinfo)
345- let build system handle stripping and gzipping
346- don't delete libmmalloc
347- apply patch from jakub@redhat.com to make it build on SPARC
348
349* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
350- rebuilt against new ncurses
351
352* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
353- rebuild for sparc baud rates > 38400.
354
355* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
356- fix core file handling on i386 with glibc 2.1.3 headers
357
358* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
359- fix reading registers from core on sparc.
360- hack around build problems on i386 with glibc 2.1.3 headers
361
362* Thu Oct 7 1999 Jim Kingdon
363- List files to install in /usr/info specifically (so we don't pick up
364things like info.info from GDB snapshots).
365
366* Thu Oct 7 1999 Jim Kingdon
367- Update GDB to 19991004 snapshot.  This eliminates the need for the
368sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
369
370* Mon Aug 23 1999 Jim Kingdon
371- Omit readline manpage.
372
373* Tue Aug 7 1999 Jim Kingdon
374- Remove H.J. Lu's patches (they had been commented out).
375- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
376from code fusion CD-ROM).
377
378* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
379- merge H.J. Lu's patches into 4.18.
380
381* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
382- updated the kern22 patch with stuff from davem
383
384* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
385- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
386
387* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
388- auto rebuild in the new build environment (release 3)
389
390* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
391- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.