source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 12342

Revision 12342, 14.1 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

binutils-2.34-1

gcc-9.3.1-1

gdb-9.1-1

glibc-2.31-1

libtool-2.4.6-6

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 9.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: https://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.xz
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12BuildRequires: python3-devel python3-rpm-macros
13BuildRequires: zlib-devel
14Requires: install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20GDB, the GNU debugger, allows you to debug programs written in C, C++,
21and other languages, by executing them in a controlled fashion and
22printing their data.
23
24%description -l ja
25GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
26使うツールです.プログラムの実行を制御し,データを出力することができます.
27
28%prep
29%setup -q
30
31%build
32export CFLAGS="$RPM_OPT_FLAGS"
33rm -fr dejagnu tcl expect
34mkdir -p build
35cd build
36../configure \
37        --prefix=%{_prefix} \
38        --sysconfdir=%{_sysconfdir} \
39        --mandir=%{_mandir} \
40    --infodir=%{_infodir} \
41    --with-python=%{__python3} \
42        %{_target_platform}
43
44make %{?_smp_mflags}
45make %{?_smp_mflags} info
46
47%install
48rm -rf $RPM_BUILD_ROOT
49cd build
50%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
51
52# The above is broken, do this for now:
53#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
54#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
55
56# These are part of binutils
57#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
58#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
59rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
60rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
61rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
62rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
63rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
64rm -rf $RPM_BUILD_ROOT%{_includedir}
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69
70%post
71[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
72[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
73[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
74[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
75[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
76[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
77
78
79%preun
80if [ $1 = 0 ]; then
81        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
82        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
83        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
84        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
85        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
86        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
87        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
88        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
89fi
90
91
92%files
93%defattr(-,root,root)
94%license COPYING COPYING.LIB
95%doc README gdb/NEWS
96%{_bindir}/*
97%{_mandir}/*/*
98%dir %{_datadir}/gdb
99%{_datadir}/gdb/syscalls
100%dir %{_datadir}/gdb/python
101%{_datadir}/gdb/python/gdb
102%dir %{_datadir}/gdb/system-gdbinit
103%{_datadir}/gdb/system-gdbinit/elinos.py
104%{_datadir}/gdb/system-gdbinit/wrs-linux.py
105%{_infodir}/annotate.info*
106%{_infodir}/gdb.info*
107%{_infodir}/stabs.info*
108%exclude %{_infodir}/dir
109%ifarch %{ix86} x86_64
110%{_libdir}/libinproctrace.so
111%endif
112## don't include the files in include, they are part of binutils
113#%{_includedir}/*
114#%{_infodir}/bfd.info*
115#%{_infodir}/configure.info*
116#%{_infodir}/standard.info*
117#%{_libdir}/*
118#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
119#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
120
121
122%changelog
123* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.1-1
124- new upstream release.
125
126* Wed Jan 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
127- new upstream release.
128
129* Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11.1-1
130- new upstream release
131
132* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
133- new upstream release
134
135* Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
136- new upstream release
137
138* Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
139- new upstream release
140
141* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
142- new upstream release
143
144* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
145- new upstream release
146
147* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
148- new upstream release
149
150* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
151- new upstream release
152
153* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
154- new upstream release
155
156* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
157- new upstream release
158
159* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
160- new upstream release
161
162* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
163- add BuildRequires: python-devel, zlib-devel
164- fix %%files
165
166* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
167- updated gdb to 7.2
168
169* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
170- updated gdb to 7.0.1
171- rebuilt with new environment
172
173* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
174- applied new versioning policy, spec in utf-8
175
176* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
177- rebuild with expat-2.0.1
178- add BuildRequires: expat-devel
179
180* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
181- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
182
183* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
184- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
185
186* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
187- new upstream release
188
189* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
190- new upstream release
191
192* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
193- new upstream release
194
195* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
196- Oops, spec was written in Shift-JIS. Fixed.
197
198* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
199- based on 5.2.1-4 from Rawhide and built for Vine Linux
200
201* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
202- added mainframe patch from developerworks
203
204* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
205- Add changelogs to the previous patch
206
207* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
208- Add some patches from Elena Zannoni <ezannoni@redhat.com>
209
210* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
211- 5.2.1
212
213* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
214- compile on mainframe
215
216* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
217- Rebuild
218
219* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
220- Rebuild
221
222* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
223- 5.2
224
225* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
226- 5.1.92. Hopefully identical to 5.2 final
227
228* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
229- 5.1.91. 5.2 expected in a week
230
231* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
232- Update to current
233
234* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
235- Update to current
236
237* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
238- Update to current
239
240* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
241- Update to current
242
243* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
244- Update to current 5.2 branch
245
246* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
247- 5.1.1
248- add URL
249
250* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
251- automated rebuild
252
253* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
254- Fix some thread+fpu problems
255
256* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
257- 5.1
258
259* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
260- 5.0.94. Almost there....
261
262* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
263- Add patch from jakub@redhat.com to improve handling of DWARF
264
265* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
266- 5.0.93
267- handle missing info pages in post/pre scripts
268
269* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
270- 5.0.92
271
272* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
273- New snapshot
274- Use the 5.0.91 versioning from the snapshot
275
276* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
277- New snapshot
278
279* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
280- New snapshot
281
282* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
283- New snapshot
284
285* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
286- Don't buildrequire compat-glibc (#51690)
287
288* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
289- New snapshot, from the stable branch eventually leading to gdb 5.1
290
291* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
292- s/Copyright/License/
293- Add texinfo to BuildRequires
294
295* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
296- New snapshot
297
298* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
299- New snapshot
300- Add ncurses-devel to buildprereq
301- Remove perl from buildprereq, as gdb changed the way
302  version strings are generated
303
304* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
305- New snapshot
306
307* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
308- New snapshot - this had thread fixes for curing #39070
309- New way of specifying version
310
311* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
312- New tarball
313- Kevin's patch is now part of gdb
314
315* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
316- Add patch from kevinb@redhat.com to fix floating point + thread
317  problem (#24310)
318- remove old workarounds
319- new snapshot
320
321* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
322- New snapshot
323
324* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
325- on ia64, there are no old headers :)
326
327* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
328- build with old headers, new compiler
329
330* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
331- new snapshot
332
333* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
334- new snapshot which should fix some more IA64 problems (#29151)
335- remove IA64 patch, it's now integrated
336
337* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
338- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
339- use perl instead of patch for fixing the version string
340
341* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
342- don't use kgcc anymore
343- mark it as our own version
344- new snapshot
345
346* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
347- Link with ncurses 5.x even though we're using kgcc.
348  No need to drag in requirements on ncurses4 (Bug #24445)
349
350* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
351- new snapshot
352
353* Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
354- new snapshot
355
356* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
357- new snapshot
358- new alpha patch - it now compiles everywhere. Finally.
359
360* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
361- new snapshot
362
363* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
364- new CVS snapshot
365- disable the patches
366- don't use %%configure, as it confuses the autoconf script
367- enable SPARC, disable Alpha
368
369
370* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
371- added patch from GDB team for C++ symbol handling
372
373* Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
374- upgrade to CVS snapshot
375- excludearch SPARC, build on IA61
376
377* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
378- rebuild
379
380* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
381- automatic rebuild
382
383* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
384- rebuild
385
386* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
387- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
388  and %%{_tmppath}
389- the install scripts  for info are broken(they don't care about
390  you specify in the installstep), work around that.
391- don't build for IA64
392
393* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
394- upgraded to 5.0 - dump all patches. Reapply later if needed.
395- added the NEWS file to the %%doc files
396- don't delete files which doesn't get installed (readline, texinfo)
397- let build system handle stripping and gzipping
398- don't delete libmmalloc
399- apply patch from jakub@redhat.com to make it build on SPARC
400
401* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
402- rebuilt against new ncurses
403
404* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
405- rebuild for sparc baud rates > 38400.
406
407* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
408- fix core file handling on i386 with glibc 2.1.3 headers
409
410* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
411- fix reading registers from core on sparc.
412- hack around build problems on i386 with glibc 2.1.3 headers
413
414* Thu Oct 7 1999 Jim Kingdon
415- List files to install in /usr/info specifically (so we don't pick up
416things like info.info from GDB snapshots).
417
418* Thu Oct 7 1999 Jim Kingdon
419- Update GDB to 19991004 snapshot.  This eliminates the need for the
420sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
421
422* Mon Aug 23 1999 Jim Kingdon
423- Omit readline manpage.
424
425* Sat Aug 7 1999 Jim Kingdon
426- Remove H.J. Lu's patches (they had been commented out).
427- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
428from code fusion CD-ROM).
429
430* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
431- merge H.J. Lu's patches into 4.18.
432
433* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
434- updated the kern22 patch with stuff from davem
435
436* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
437- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
438
439* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
440- auto rebuild in the new build environment (release 3)
441
442* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
443- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.