source: projects/specs/trunk/g/gdb/gdb-vl.spec @ 12469

Revision 12469, 14.2 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 9.2
5Release: 1%{?_dist_release}
6Group: programming
7Vendor: Project Vine
8Distribution: Vine Linux
9
10License: GPL
11URL: https://www.gnu.org/software/gdb/
12Source: https://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.xz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
16BuildRequires: python3-devel python3-rpm-macros
17BuildRequires: zlib-devel
18Requires: install-info
19
20%description
21GDB, the GNU debugger, allows you to debug programs written in C, C++,
22and other languages, by executing them in a controlled fashion and
23printing their data.
24
25%description -l ja
26GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
27使うツールです.プログラムの実行を制御し,データを出力することができます.
28
29
30%prep
31%setup -q
32
33
34%build
35export CFLAGS="$RPM_OPT_FLAGS"
36rm -fr dejagnu tcl expect
37mkdir -p build
38cd build
39../configure \
40        --prefix=%{_prefix} \
41        --sysconfdir=%{_sysconfdir} \
42        --mandir=%{_mandir} \
43    --infodir=%{_infodir} \
44    --with-python=%{__python3} \
45        %{_target_platform}
46
47make %{?_smp_mflags}
48make %{?_smp_mflags} info
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53cd build
54%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
55
56# The above is broken, do this for now:
57#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
58#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
59
60# These are part of binutils
61#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
62#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
63rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
64rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
65rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
66rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*}
67rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
68rm -rf $RPM_BUILD_ROOT%{_includedir}
69
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74
75%post
76[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
77[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
78[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
79[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
80[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
81[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
82
83
84%preun
85if [ $1 = 0 ]; then
86        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
87        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
88        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
89        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
90        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
91        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
92        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
93        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
94fi
95
96
97%files
98%defattr(-,root,root)
99%license COPYING COPYING.LIB
100%doc README gdb/NEWS
101%{_bindir}/*
102%{_mandir}/*/*
103%dir %{_datadir}/gdb
104%{_datadir}/gdb/syscalls
105%dir %{_datadir}/gdb/python
106%{_datadir}/gdb/python/gdb
107%dir %{_datadir}/gdb/system-gdbinit
108%{_datadir}/gdb/system-gdbinit/elinos.py
109%{_datadir}/gdb/system-gdbinit/wrs-linux.py
110%{_infodir}/annotate.info*
111%{_infodir}/gdb.info*
112%{_infodir}/stabs.info*
113%exclude %{_infodir}/dir
114%ifarch %{ix86} x86_64
115%{_libdir}/libinproctrace.so
116%endif
117## don't include the files in include, they are part of binutils
118#%{_includedir}/*
119#%{_infodir}/bfd.info*
120#%{_infodir}/configure.info*
121#%{_infodir}/standard.info*
122#%{_libdir}/*
123#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
124#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
125
126
127%changelog
128* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.2-1
129- new upstream release.
130
131* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.1-1
132- new upstream release.
133
134* Wed Jan 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
135- new upstream release.
136
137* Fri Jul 22 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11.1-1
138- new upstream release
139
140* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.11-1
141- new upstream release
142
143* Sun Oct 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.10-1
144- new upstream release
145
146* Mon Jul 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9.1-1
147- new upstream release
148
149* Sun Feb 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.9-1
150- new upstream release
151
152* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8.1-1
153- new upstream release
154
155* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.8-1
156- new upstream release
157
158* Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6.1-1
159- new upstream release
160
161* Mon Oct 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-1
162- new upstream release
163
164* Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4.1-1
165- new upstream release
166
167* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.4-1
168- new upstream release
169
170* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
171- add BuildRequires: python-devel, zlib-devel
172- fix %%files
173
174* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
175- updated gdb to 7.2
176
177* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
178- updated gdb to 7.0.1
179- rebuilt with new environment
180
181* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
182- applied new versioning policy, spec in utf-8
183
184* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
185- rebuild with expat-2.0.1
186- add BuildRequires: expat-devel
187
188* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
189- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
190
191* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
192- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
193
194* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
195- new upstream release
196
197* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
198- new upstream release
199
200* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
201- new upstream release
202
203* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
204- Oops, spec was written in Shift-JIS. Fixed.
205
206* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
207- based on 5.2.1-4 from Rawhide and built for Vine Linux
208
209* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
210- added mainframe patch from developerworks
211
212* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
213- Add changelogs to the previous patch
214
215* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
216- Add some patches from Elena Zannoni <ezannoni@redhat.com>
217
218* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
219- 5.2.1
220
221* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
222- compile on mainframe
223
224* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
225- Rebuild
226
227* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
228- Rebuild
229
230* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
231- 5.2
232
233* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
234- 5.1.92. Hopefully identical to 5.2 final
235
236* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
237- 5.1.91. 5.2 expected in a week
238
239* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
240- Update to current
241
242* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
243- Update to current
244
245* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
246- Update to current
247
248* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
249- Update to current
250
251* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
252- Update to current 5.2 branch
253
254* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
255- 5.1.1
256- add URL
257
258* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
259- automated rebuild
260
261* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
262- Fix some thread+fpu problems
263
264* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
265- 5.1
266
267* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
268- 5.0.94. Almost there....
269
270* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
271- Add patch from jakub@redhat.com to improve handling of DWARF
272
273* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
274- 5.0.93
275- handle missing info pages in post/pre scripts
276
277* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
278- 5.0.92
279
280* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
281- New snapshot
282- Use the 5.0.91 versioning from the snapshot
283
284* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
285- New snapshot
286
287* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
288- New snapshot
289
290* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
291- New snapshot
292
293* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
294- Don't buildrequire compat-glibc (#51690)
295
296* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
297- New snapshot, from the stable branch eventually leading to gdb 5.1
298
299* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
300- s/Copyright/License/
301- Add texinfo to BuildRequires
302
303* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
304- New snapshot
305
306* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
307- New snapshot
308- Add ncurses-devel to buildprereq
309- Remove perl from buildprereq, as gdb changed the way
310  version strings are generated
311
312* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
313- New snapshot
314
315* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
316- New snapshot - this had thread fixes for curing #39070
317- New way of specifying version
318
319* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
320- New tarball
321- Kevin's patch is now part of gdb
322
323* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
324- Add patch from kevinb@redhat.com to fix floating point + thread
325  problem (#24310)
326- remove old workarounds
327- new snapshot
328
329* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
330- New snapshot
331
332* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
333- on ia64, there are no old headers :)
334
335* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
336- build with old headers, new compiler
337
338* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
339- new snapshot
340
341* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
342- new snapshot which should fix some more IA64 problems (#29151)
343- remove IA64 patch, it's now integrated
344
345* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
346- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
347- use perl instead of patch for fixing the version string
348
349* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
350- don't use kgcc anymore
351- mark it as our own version
352- new snapshot
353
354* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
355- Link with ncurses 5.x even though we're using kgcc.
356  No need to drag in requirements on ncurses4 (Bug #24445)
357
358* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
359- new snapshot
360
361* Wed Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
362- new snapshot
363
364* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
365- new snapshot
366- new alpha patch - it now compiles everywhere. Finally.
367
368* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
369- new snapshot
370
371* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
372- new CVS snapshot
373- disable the patches
374- don't use %%configure, as it confuses the autoconf script
375- enable SPARC, disable Alpha
376
377
378* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
379- added patch from GDB team for C++ symbol handling
380
381* Tue Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
382- upgrade to CVS snapshot
383- excludearch SPARC, build on IA61
384
385* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
386- rebuild
387
388* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
389- automatic rebuild
390
391* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
392- rebuild
393
394* Thu Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
395- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
396  and %%{_tmppath}
397- the install scripts  for info are broken(they don't care about
398  you specify in the installstep), work around that.
399- don't build for IA64
400
401* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
402- upgraded to 5.0 - dump all patches. Reapply later if needed.
403- added the NEWS file to the %%doc files
404- don't delete files which doesn't get installed (readline, texinfo)
405- let build system handle stripping and gzipping
406- don't delete libmmalloc
407- apply patch from jakub@redhat.com to make it build on SPARC
408
409* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
410- rebuilt against new ncurses
411
412* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
413- rebuild for sparc baud rates > 38400.
414
415* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
416- fix core file handling on i386 with glibc 2.1.3 headers
417
418* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
419- fix reading registers from core on sparc.
420- hack around build problems on i386 with glibc 2.1.3 headers
421
422* Thu Oct 7 1999 Jim Kingdon
423- List files to install in /usr/info specifically (so we don't pick up
424things like info.info from GDB snapshots).
425
426* Thu Oct 7 1999 Jim Kingdon
427- Update GDB to 19991004 snapshot.  This eliminates the need for the
428sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
429
430* Mon Aug 23 1999 Jim Kingdon
431- Omit readline manpage.
432
433* Sat Aug 7 1999 Jim Kingdon
434- Remove H.J. Lu's patches (they had been commented out).
435- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
436from code fusion CD-ROM).
437
438* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
439- merge H.J. Lu's patches into 4.18.
440
441* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
442- updated the kern22 patch with stuff from davem
443
444* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
445- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
446
447* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
448- auto rebuild in the new build environment (release 3)
449
450* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
451- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.