source: projects/specs/trunk/g/gd/gd-vl.spec @ 8594

Revision 8594, 10.4 KB checked in by tomop, 10 years ago (diff)

gd-2.1.0-2

Line 
1%bcond_with libvpx
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4Summary: A graphics library for drawing .png files.
5Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
6Name: gd
7Version: 2.1.0
8Release: 2%{_dist_release}
9Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
10Patch0:        gd-2.1.0-multilib.patch
11Patch1:        gd-fixautoconf.patch
12Patch100:      gd-2.1.0-fonts-vine.patch
13License: BSD-style
14URL: http://www.libgd.org/
15Group: System Environment/Libraries
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: freetype2-devel
19BuildRequires: fontconfig-devel
20BuildRequires: gettext-devel
21BuildRequires: libjpeg-turbo-devel
22BuildRequires: libpng-devel
23BuildRequires: libtiff-devel
24%if %{with libvpx}
25BuildRequires: libvpx-devel
26%endif
27BuildRequires: libX11-devel
28BuildRequires: libXpm-devel
29BuildRequires: zlib-devel
30BuildRequires: pkgconfig
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: daisuke
35
36%description
37Gd is a graphics library for drawing .png files.  Gd allows your code to
38quickly draw images (lines, arcs, text, multiple colors, cutting and
39pasting from other images, flood fills) and write out the result as a
40.png file. Gd is particularly useful in web applications, where .pngs
41are commonly used as inline images.  Note, however, that gd is not a
42paint program.
43
44Install gd if you are developing applications which need to draw .png
45files.  If you install gd, you'll also need to install the gd-devel
46package.
47
48%description -l ja
49GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
50画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
51簡単に描写して、PNGファイルへ結果を出力することができます。
52Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
53便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
54ん。
55
56PNGファイルを描写する必要のあるアプリケーションを開発する場合、
57Gdをインストールしてください。gdをインストールした場合、gd-devel
58パッケージも必要になります。
59
60%package progs
61Summary: Utility programs that use libgd.
62Summary(ja): libgd を用いたユーティリティプログラム
63Group: Applications/Graphics
64Requires: gd = %{version}, perl
65
66%description progs
67These are utility programs supplied with gd, the .png graphics library.
68If you install these, you must install gd.
69
70%description progs -l ja
71これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
72プログラムです。これをインストールするには, gdをインストールする必要
73があります。
74
75%package devel
76Summary: The development libraries and header files for gd.
77Summary(ja): gd用の開発ライブラリとヘッダファイル
78Group: Development/Libraries
79Requires: gd = %{version}
80Requires: freetype-devel
81Requires: fontconfig-devel
82Requires: libjpeg-turbo-devel
83Requires: libpng-devel
84Requires: libtiff-devel
85%if %{with libvpx}
86Requires: libvpx-devel
87%endif
88Requires: libX11-devel
89Requires: libXpm-devel
90Requires: zlib-devel
91
92%description devel
93These are the development libraries and header files for gd, the .png
94graphics library.
95
96If you're installing the gd graphics library, you must install gd-devel.
97
98%description devel -l ja
99これらは開発ライブラリです。
100PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
101です。
102
103gdをインストールした場合、gd-develパッケージも必要になります。
104
105
106## to build compat32 for x86_64 architecture support
107%package -n compat32-%{name}
108Summary: A graphics library for drawing .png files.
109Group: System Environment/Libraries
110%description -n compat32-%{name}
111Gd is a graphics library for drawing .png files.  Gd allows your code to
112quickly draw images (lines, arcs, text, multiple colors, cutting and
113pasting from other images, flood fills) and write out the result as a
114.png file. Gd is particularly useful in web applications, where .pngs
115are commonly used as inline images.  Note, however, that gd is not a
116paint program.
117
118Install gd if you are developing applications which need to draw .png
119files.  If you install gd, you'll also need to install the gd-devel
120package.
121
122%package -n compat32-%{name}-devel
123Summary: The development libraries and header files for gd.
124Group: Development/Libraries
125Requires: compat32-freetype-devel
126Requires: compat32-fontconfig-devel
127Requires: compat32-libjpeg-turbo-devel
128Requires: compat32-libpng-devel
129Requires: compat32-libtiff-devel
130%if %{with libvpx}
131Requires: compat32-libvpx-devel
132%endif
133Requires: compat32-libX11-devel
134Requires: compat32-libXpm-devel
135Requires: compat32-zlib-devel
136
137%description -n compat32-%{name}-devel
138These are the development libraries and header files for gd, the .png
139graphics library.
140
141If you're installing the gd graphics library, you must install gd-devel.
142
143
144%prep
145%setup -q -n libgd-%{version}
146%patch0 -p1 -b .mlib
147%patch1 -p1 -b .automake
148%patch100 -p1 -b .fonts-vine
149
150# https://bitbucket.org/libgd/gd-libgd/issue/77
151sed -e '/GD_VERSION_STRING/s/-alpha//' \
152    -e '/GD_EXTRA_VERSION/s/alpha//' \
153    -i src/gd.h
154grep VERSION src/gd.h
155
156: regenerate autotool stuff
157if [ -f configure ]; then
158   libtoolize --copy --force
159   autoreconf -vif
160else
161   ./bootstrap.sh
162fi
163
164
165%build
166# Provide a correct default font search path
167CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
168/usr/share/fonts/TrueType-vlgothic:\
169/usr/share/fonts/bitstream-vera:\
170/usr/share/fonts/dejavu:\
171/usr/share/fonts/default/Type1:\
172/usr/share/X11/fonts/Type1:\
173/usr/share/fonts/liberation\"'"
174
175%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
176    --with-tiff=%{_prefix} \
177%if %{with libvpx}
178    --with-vpx=%{_prefix} \
179%endif
180        --disable-rpath
181make %{?_smp_mflags}
182
183%install
184[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
185make DESTDIR=$RPM_BUILD_ROOT install
186## remove unuse files
187rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
188
189%clean
190[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
191
192%post -p /sbin/ldconfig
193%postun -p /sbin/ldconfig
194
195%if %{build_compat32}
196%post -n compat32-%{name} -p /sbin/ldconfig
197%postun -n compat32-%{name} -p /sbin/ldconfig
198%endif
199
200%files
201%defattr(-,root,root)
202%doc ChangeLog COPYING NEWS docs/*
203%{_libdir}/*.so.*
204
205%files progs
206%defattr(-,root,root)
207%{_bindir}/*
208%exclude %{_bindir}/gdlib-config
209
210%files devel
211%defattr(-,root,root)
212%{_bindir}/gdlib-config
213%{_includedir}/*
214%{_libdir}/*.so
215%{_libdir}/pkgconfig/*.pc
216
217%if %{build_compat32}
218%files -n compat32-%{name}
219%defattr(-,root,root)
220%{_libdir}/*.so.*
221%files -n compat32-%{name}-devel
222%defattr(-,root,root)
223%{_libdir}/*.so
224%endif
225
226%changelog
227* Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
228- fixed version in gd.h.
229- added fontconfig and tiff support.
230
231* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
232- new upstream release.
233- dropped unnecessary patches.
234
235* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
236- import patches from fedora package
237- modified font path patch for Vine Linux
238- drop static library
239- remove "-DJISX0208"
240- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
241
242* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
243- move gdlib-config from gd-progs subpackage to gd-devel subpackage
244
245* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
246- build on current VineSeed
247
248* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
249- fix build_compat32 if-endif sections
250
251* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
252- add patch2 for fix CVE-2009-3546 (_gdGetColors())
253
254* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
255- updated URL
256- changed progs Group to Applications/Graphics
257- added %%postun section
258
259* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
260- removed  *.la
261- spec in utf-8
262
263* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
264- add patch1 from centos5
265- new versioning policy
266
267* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
268- new upstream release with security fix (CVE-2007-2756)
269
270* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
271- new upstream release with security fix
272- change source tarball format gz -> bz2
273
274* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
275- added compat32-* packages for x86_64 architecture support
276
277* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
278- source upgrade
279
280* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
281- source update
282- added -DJISX0208 flag
283
284* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
285- source upgrade
286- BuildPrereq: XOrg-devel instead of XFree86-devel
287
288* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
289- source upgrade
290- remove patch0 (no need for freetype2-2.1.7)
291
292* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
293- add patch0 to build against freetype2-2.1.7
294
295* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
296- source upgrade
297- add URL
298- remove all patches
299- use %%configure script
300- add BuildPrereq: freetype2-devel XFree86-devel
301- remove BuildPrereq: VFlib-devel
302- update %%files
303- update Requires:
304- use License tag instead of Copyright
305
306* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
307- rebuild with libpng-devel-1.2.5-0vl1
308
309* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
310- rebuild with new toolchain
311
312* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
313- 1.8.3-0vl2
314- symlink to libgd.so.1 (for backward compatibility)
315
316* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
317- first gd 1.8.x release for Vine from rawhide.
318- enable freetype support and defined JISX208 macro.
319
320* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
321- break out a -progs subpackage
322- disable freetype support
323
324* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
325- update to latest version (1.8.2)
326- disable xpm support
327
328* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
329- auto rebuild in the new build environment (release 6)
330
331* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
332- auto rebuild in the new build environment (release 5)
333
334* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
335- buiuld for glibc 2.1
336
337* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
338- built for 5.2
Note: See TracBrowser for help on using the repository browser.