source: projects/specs/trunk/g/gd/gd-vl.spec @ 7856

Revision 7856, 8.8 KB checked in by tomop, 11 years ago (diff)

gd-2.1.0-1 and dependencies.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: A graphics library for drawing .png files.
3Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
4Name: gd
5Version: 2.1.0
6Release: 1%{_dist_release}
7Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
8Patch0:        gd-2.1.0-multilib.patch
9Patch1:        gd-2.1.0-fonts-vine.patch
10License: BSD-style
11URL: http://www.libgd.org/
12Group: System Environment/Libraries
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libjpeg-devel zlib-devel freetype2-devel
16BuildRequires: libpng-devel >= 2:1.2.5
17BuildRequires: libX11-devel libXpm-devel
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: daisuke
22
23%description
24Gd is a graphics library for drawing .png files.  Gd allows your code to
25quickly draw images (lines, arcs, text, multiple colors, cutting and
26pasting from other images, flood fills) and write out the result as a
27.png file. Gd is particularly useful in web applications, where .pngs
28are commonly used as inline images.  Note, however, that gd is not a
29paint program.
30
31Install gd if you are developing applications which need to draw .png
32files.  If you install gd, you'll also need to install the gd-devel
33package.
34
35%description -l ja
36GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
37画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
38簡単に描写して、PNGファイルへ結果を出力することができます。
39Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
40便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
41ん。
42
43PNGファイルを描写する必要のあるアプリケーションを開発する場合、
44Gdをインストールしてください。gdをインストールした場合、gd-devel
45パッケージも必要になります。
46
47%package progs
48Summary: Utility programs that use libgd.
49Summary(ja): libgd を用いたユーティリティプログラム
50Group: Applications/Graphics
51Requires: gd = %{version}, perl
52
53%description progs
54These are utility programs supplied with gd, the .png graphics library.
55If you install these, you must install gd.
56
57%description progs -l ja
58これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
59プログラムです。これをインストールするには, gdをインストールする必要
60があります。
61
62%package devel
63Requires: gd = %{version}
64Summary: The development libraries and header files for gd.
65Summary(ja): gd用の開発ライブラリとヘッダファイル
66Group: Development/Libraries
67
68%description devel
69These are the development libraries and header files for gd, the .png
70graphics library.
71
72If you're installing the gd graphics library, you must install gd-devel.
73
74%description devel -l ja
75これらは開発ライブラリです。
76PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
77です。
78
79gdをインストールした場合、gd-develパッケージも必要になります。
80
81
82## to build compat32 for x86_64 architecture support
83%package -n compat32-%{name}
84Summary: A graphics library for drawing .png files.
85Group: System Environment/Libraries
86%description -n compat32-%{name}
87Gd is a graphics library for drawing .png files.  Gd allows your code to
88quickly draw images (lines, arcs, text, multiple colors, cutting and
89pasting from other images, flood fills) and write out the result as a
90.png file. Gd is particularly useful in web applications, where .pngs
91are commonly used as inline images.  Note, however, that gd is not a
92paint program.
93
94Install gd if you are developing applications which need to draw .png
95files.  If you install gd, you'll also need to install the gd-devel
96package.
97
98%package -n compat32-%{name}-devel
99Summary: The development libraries and header files for gd.
100Group: Development/Libraries
101%description -n compat32-%{name}-devel
102These are the development libraries and header files for gd, the .png
103graphics library.
104
105If you're installing the gd graphics library, you must install gd-devel.
106
107
108%prep
109%setup -q -n libgd-%{version}
110%patch0 -p1 -b .mlib
111%patch1 -p1 -b .fonts-vine
112
113%build
114%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
115make %{?_smp_mflags}
116
117%install
118[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
119make DESTDIR=$RPM_BUILD_ROOT install
120## remove unuse files
121rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
122
123%clean
124[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
125
126%post -p /sbin/ldconfig
127%postun -p /sbin/ldconfig
128
129%if %{build_compat32}
130%post -n compat32-%{name} -p /sbin/ldconfig
131%postun -n compat32-%{name} -p /sbin/ldconfig
132%endif
133
134%files
135%defattr(-,root,root)
136%doc ChangeLog COPYING NEWS docs/*
137%{_libdir}/*.so.*
138
139%files progs
140%defattr(-,root,root)
141%{_bindir}/*
142%exclude %{_bindir}/gdlib-config
143
144%files devel
145%defattr(-,root,root)
146%{_bindir}/gdlib-config
147%{_includedir}/*
148%{_libdir}/*.so
149%{_libdir}/pkgconfig/*.pc
150
151%if %{build_compat32}
152%files -n compat32-%{name}
153%defattr(-,root,root)
154%{_libdir}/*.so.*
155%files -n compat32-%{name}-devel
156%defattr(-,root,root)
157%{_libdir}/*.so
158%endif
159
160%changelog
161* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
162- new upstream release.
163- dropped unnecessary patches.
164
165* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
166- import patches from fedora package
167- modified font path patch for Vine Linux
168- drop static library
169- remove "-DJISX0208"
170- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
171
172* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
173- move gdlib-config from gd-progs subpackage to gd-devel subpackage
174
175* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
176- build on current VineSeed
177
178* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
179- fix build_compat32 if-endif sections
180
181* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
182- add patch2 for fix CVE-2009-3546 (_gdGetColors())
183
184* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
185- updated URL
186- changed progs Group to Applications/Graphics
187- added %%postun section
188
189* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
190- removed  *.la
191- spec in utf-8
192
193* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
194- add patch1 from centos5
195- new versioning policy
196
197* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
198- new upstream release with security fix (CVE-2007-2756)
199
200* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
201- new upstream release with security fix
202- change source tarball format gz -> bz2
203
204* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
205- added compat32-* packages for x86_64 architecture support
206
207* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
208- source upgrade
209
210* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
211- source update
212- added -DJISX0208 flag
213
214* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
215- source upgrade
216- BuildPrereq: XOrg-devel instead of XFree86-devel
217
218* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
219- source upgrade
220- remove patch0 (no need for freetype2-2.1.7)
221
222* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
223- add patch0 to build against freetype2-2.1.7
224
225* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
226- source upgrade
227- add URL
228- remove all patches
229- use %%configure script
230- add BuildPrereq: freetype2-devel XFree86-devel
231- remove BuildPrereq: VFlib-devel
232- update %%files
233- update Requires:
234- use License tag instead of Copyright
235
236* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
237- rebuild with libpng-devel-1.2.5-0vl1
238
239* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
240- rebuild with new toolchain
241
242* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
243- 1.8.3-0vl2
244- symlink to libgd.so.1 (for backward compatibility)
245
246* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
247- first gd 1.8.x release for Vine from rawhide.
248- enable freetype support and defined JISX208 macro.
249
250* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
251- break out a -progs subpackage
252- disable freetype support
253
254* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
255- update to latest version (1.8.2)
256- disable xpm support
257
258* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
259- auto rebuild in the new build environment (release 6)
260
261* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
262- auto rebuild in the new build environment (release 5)
263
264* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
265- buiuld for glibc 2.1
266
267* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
268- built for 5.2
Note: See TracBrowser for help on using the repository browser.