source: projects/specs/trunk/g/gd/gd-vl.spec @ 12517

Revision 12517, 11.4 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

gd-2.3.0-2

zabbix-5.0.6-1

Line 
1%bcond_with libvpx
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4Summary: A graphics library for drawing .png files.
5Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
6Name: gd
7Version: 2.3.0
8Release: 2%{_dist_release}
9Group: system
10Vendor: Project Vine
11Distribution: Vine Linux
12Packager: daisuke
13
14License: BSD-style
15URL: http://www.libgd.org/
16Source0: https://github.com/libgd/libgd/releases/download/gd-%{version}/libgd-%{version}.tar.xz
17# https://github.com/libgd/libgd/issues/610
18Source1: https://raw.githubusercontent.com/libgd/libgd/master/config/getlib.sh
19Patch0: gd-2.1.0-multilib.patch
20# https://github.com/libgd/libgd/issues/615
21Patch1: gdImageStringFT.patch
22Patch2: textLayout.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: freetype2-devel
26BuildRequires: fontconfig-devel
27BuildRequires: gettext-devel
28BuildRequires: libjpeg-turbo-devel
29BuildRequires: libpng-devel
30BuildRequires: libtiff-devel
31%if %{with libvpx}
32BuildRequires: libvpx-devel
33%endif
34BuildRequires: libX11-devel
35BuildRequires: libXpm-devel
36BuildRequires: zlib-devel
37BuildRequires: pkgconfig
38# for test
39BuildRequires: TrueType-vlgothic
40
41%description
42Gd is a graphics library for drawing .png files.  Gd allows your code to
43quickly draw images (lines, arcs, text, multiple colors, cutting and
44pasting from other images, flood fills) and write out the result as a
45.png file. Gd is particularly useful in web applications, where .pngs
46are commonly used as inline images.  Note, however, that gd is not a
47paint program.
48
49Install gd if you are developing applications which need to draw .png
50files.  If you install gd, you'll also need to install the gd-devel
51package.
52
53%description -l ja
54GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
55画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
56簡単に描写して、PNGファイルへ結果を出力することができます。
57Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
58便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
59ん。
60
61PNGファイルを描写する必要のあるアプリケーションを開発する場合、
62Gdをインストールしてください。gdをインストールした場合、gd-devel
63パッケージも必要になります。
64
65
66%package progs
67Summary: Utility programs that use libgd.
68Summary(ja): libgd を用いたユーティリティプログラム
69Group: graphics
70Requires: gd = %{version}
71Requires: perl
72
73%description progs
74These are utility programs supplied with gd, the .png graphics library.
75If you install these, you must install gd.
76
77%description progs -l ja
78これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
79プログラムです。これをインストールするには, gdをインストールする必要
80があります。
81
82
83%package devel
84Summary: The development libraries and header files for gd.
85Summary(ja): Gd用の開発ライブラリとヘッダファイル
86Group: programming
87Requires: gd = %{version}
88Requires: freetype2-devel
89Requires: fontconfig-devel
90Requires: libjpeg-turbo-devel
91Requires: libpng-devel
92Requires: libtiff-devel
93%if %{with libvpx}
94Requires: libvpx-devel
95%endif
96Requires: libX11-devel
97Requires: libXpm-devel
98Requires: zlib-devel
99
100%description devel
101These are the development libraries and header files for gd, the .png
102graphics library.
103
104If you're installing the gd graphics library, you must install gd-devel.
105
106%description devel -l ja
107これらは開発ライブラリです。
108PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
109です。
110
111gdをインストールした場合、gd-develパッケージも必要になります。
112
113
114## to build compat32 for x86_64 architecture support
115%package -n compat32-%{name}
116Summary: A graphics library for drawing .png files.
117Group: system
118%description -n compat32-%{name}
119Gd is a graphics library for drawing .png files.  Gd allows your code to
120quickly draw images (lines, arcs, text, multiple colors, cutting and
121pasting from other images, flood fills) and write out the result as a
122.png file. Gd is particularly useful in web applications, where .pngs
123are commonly used as inline images.  Note, however, that gd is not a
124paint program.
125
126Install gd if you are developing applications which need to draw .png
127files.  If you install gd, you'll also need to install the gd-devel
128package.
129
130
131%package -n compat32-%{name}-devel
132Summary: The development libraries and header files for gd.
133Group: programming
134Requires: compat32-freetype2-devel
135Requires: compat32-fontconfig-devel
136Requires: compat32-libjpeg-turbo-devel
137Requires: compat32-libpng-devel
138Requires: compat32-libtiff-devel
139%if %{with libvpx}
140Requires: compat32-libvpx-devel
141%endif
142Requires: compat32-libX11-devel
143Requires: compat32-libXpm-devel
144Requires: compat32-zlib-devel
145
146%description -n compat32-%{name}-devel
147These are the development libraries and header files for gd, the .png
148graphics library.
149
150If you're installing the gd graphics library, you must install gd-devel.
151
152
153%debug_package
154
155
156%prep
157%setup -q -n libgd-%{version}
158#patch0 -p1 -b .mlib
159%patch1 -p1 -b .text1
160%patch2 -p1 -b .text2
161
162cp %{SOURCE1} ./config/
163chmod 755 ./config/getlib.sh
164autoreconf -vif
165
166
167%build
168# Provide a correct default font search path
169CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
170/usr/share/fonts/alias/TrueType/:\
171/usr/share/fonts/TrueType-vlgothic/:\
172/usr/share/fonts/bitstream-vera/:\
173/usr/share/fonts/TrueType-dejavu/:\
174/usr/share/fonts/TrueType-ipafont/:\
175/usr/share/fonts/TrueType-ipaexfont/:\
176/usr/share/fonts/default/Type1/:\
177/usr/share/X11/fonts/Type1/:\
178/usr/share/fonts/TrueType-linux-liberation/\
179\"'"
180
181%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
182    --with-freetype \
183    --with-tiff=%{_prefix} \
184%if %{with libvpx}
185    --with-vpx=%{_prefix} \
186%endif
187        --disable-rpath
188make %{?_smp_mflags}
189
190
191%install
192[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
193make DESTDIR=$RPM_BUILD_ROOT install
194## remove unuse files
195rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
196
197%check
198%ifarch x86_64
199make %{?_smp_mflags} check
200%endif
201
202
203%clean
204[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
205
206
207%post -p /sbin/ldconfig
208%postun -p /sbin/ldconfig
209
210%if %{build_compat32}
211%post -n compat32-%{name} -p /sbin/ldconfig
212%postun -n compat32-%{name} -p /sbin/ldconfig
213%endif
214
215
216%files
217%defattr(-,root,root)
218%license COPYING
219%doc README.md CHANGELOG.md docs/*
220%{_libdir}/*.so.*
221
222%files progs
223%defattr(-,root,root)
224%{_bindir}/*
225
226%files devel
227%defattr(-,root,root)
228%{_includedir}/*
229%{_libdir}/*.so
230%{_libdir}/pkgconfig/*.pc
231
232%if %{build_compat32}
233%files -n compat32-%{name}
234%defattr(-,root,root)
235%{_libdir}/*.so.*
236%files -n compat32-%{name}-devel
237%defattr(-,root,root)
238%{_libdir}/*.so
239%endif
240
241
242%changelog
243* Sun Dec 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-2
244- add Patch1 and 2 to fix drawing text.
245
246* Fri Apr 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.0-1
247- new upstream release.
248
249* Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.5-1
250- new upstream release.
251- dropped %%patch1 and 2: fixed in upstream.
252
253* Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
254- new upstream release.
255- made to skip %%check on i686.
256
257* Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
258- new upstream release.
259- removed Patch1000 (fixed in upstream).
260
261* Wed May  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
262- added Patch1000 to fix CVE-2016-3074.
263
264* Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
265- new upstream release.
266
267* Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
268- BR: freetype2-devel instead of freetype-devel on devel package
269
270* Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
271- fixed version in gd.h.
272- added fontconfig and tiff support.
273
274* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
275- new upstream release.
276- dropped unnecessary patches.
277
278* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
279- import patches from fedora package
280- modified font path patch for Vine Linux
281- drop static library
282- remove "-DJISX0208"
283- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
284
285* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
286- move gdlib-config from gd-progs subpackage to gd-devel subpackage
287
288* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
289- build on current VineSeed
290
291* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
292- fix build_compat32 if-endif sections
293
294* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
295- add patch2 for fix CVE-2009-3546 (_gdGetColors())
296
297* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
298- updated URL
299- changed progs Group to Applications/Graphics
300- added %%postun section
301
302* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
303- removed  *.la
304- spec in utf-8
305
306* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
307- add patch1 from centos5
308- new versioning policy
309
310* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
311- new upstream release with security fix (CVE-2007-2756)
312
313* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
314- new upstream release with security fix
315- change source tarball format gz -> bz2
316
317* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
318- added compat32-* packages for x86_64 architecture support
319
320* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
321- source upgrade
322
323* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
324- source update
325- added -DJISX0208 flag
326
327* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
328- source upgrade
329- BuildPrereq: XOrg-devel instead of XFree86-devel
330
331* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
332- source upgrade
333- remove patch0 (no need for freetype2-2.1.7)
334
335* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
336- add patch0 to build against freetype2-2.1.7
337
338* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
339- source upgrade
340- add URL
341- remove all patches
342- use %%configure script
343- add BuildPrereq: freetype2-devel XFree86-devel
344- remove BuildPrereq: VFlib-devel
345- update %%files
346- update Requires:
347- use License tag instead of Copyright
348
349* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
350- rebuild with libpng-devel-1.2.5-0vl1
351
352* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
353- rebuild with new toolchain
354
355* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
356- 1.8.3-0vl2
357- symlink to libgd.so.1 (for backward compatibility)
358
359* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
360- first gd 1.8.x release for Vine from rawhide.
361- enable freetype support and defined JISX208 macro.
362
363* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
364- break out a -progs subpackage
365- disable freetype support
366
367* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
368- update to latest version (1.8.2)
369- disable xpm support
370
371* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
372- auto rebuild in the new build environment (release 6)
373
374* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
375- auto rebuild in the new build environment (release 5)
376
377* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
378- buiuld for glibc 2.1
379
380* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
381- built for 5.2
Note: See TracBrowser for help on using the repository browser.