source: projects/specs/trunk/g/gd/gd-vl.spec @ 10334

Revision 10334, 10.8 KB checked in by tomop, 8 years ago (diff)

gd-2.2.1-1

Line 
1%bcond_with libvpx
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4Summary: A graphics library for drawing .png files.
5Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
6Name: gd
7Version: 2.2.1
8Release: 1%{_dist_release}
9Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
10Patch0: gd-2.1.0-multilib.patch
11License: BSD-style
12URL: http://www.libgd.org/
13Group: System Environment/Libraries
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: freetype2-devel
17BuildRequires: fontconfig-devel
18BuildRequires: gettext-devel
19BuildRequires: libjpeg-turbo-devel
20BuildRequires: libpng-devel
21BuildRequires: libtiff-devel
22%if %{with libvpx}
23BuildRequires: libvpx-devel
24%endif
25BuildRequires: libX11-devel
26BuildRequires: libXpm-devel
27BuildRequires: zlib-devel
28BuildRequires: pkgconfig
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: daisuke
33
34%description
35Gd is a graphics library for drawing .png files.  Gd allows your code to
36quickly draw images (lines, arcs, text, multiple colors, cutting and
37pasting from other images, flood fills) and write out the result as a
38.png file. Gd is particularly useful in web applications, where .pngs
39are commonly used as inline images.  Note, however, that gd is not a
40paint program.
41
42Install gd if you are developing applications which need to draw .png
43files.  If you install gd, you'll also need to install the gd-devel
44package.
45
46%description -l ja
47GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
48画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
49簡単に描写して、PNGファイルへ結果を出力することができます。
50Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
51便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
52ん。
53
54PNGファイルを描写する必要のあるアプリケーションを開発する場合、
55Gdをインストールしてください。gdをインストールした場合、gd-devel
56パッケージも必要になります。
57
58%package progs
59Summary: Utility programs that use libgd.
60Summary(ja): libgd を用いたユーティリティプログラム
61Group: Applications/Graphics
62Requires: gd = %{version}
63Requires: perl
64
65%description progs
66These are utility programs supplied with gd, the .png graphics library.
67If you install these, you must install gd.
68
69%description progs -l ja
70これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
71プログラムです。これをインストールするには, gdをインストールする必要
72があります。
73
74%package devel
75Summary: The development libraries and header files for gd.
76Summary(ja): Gd用の開発ライブラリとヘッダファイル
77Group: Development/Libraries
78Requires: gd = %{version}
79Requires: freetype2-devel
80Requires: fontconfig-devel
81Requires: libjpeg-turbo-devel
82Requires: libpng-devel
83Requires: libtiff-devel
84%if %{with libvpx}
85Requires: libvpx-devel
86%endif
87Requires: libX11-devel
88Requires: libXpm-devel
89Requires: zlib-devel
90
91%description devel
92These are the development libraries and header files for gd, the .png
93graphics library.
94
95If you're installing the gd graphics library, you must install gd-devel.
96
97%description devel -l ja
98これらは開発ライブラリです。
99PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
100です。
101
102gdをインストールした場合、gd-develパッケージも必要になります。
103
104
105## to build compat32 for x86_64 architecture support
106%package -n compat32-%{name}
107Summary: A graphics library for drawing .png files.
108Group: System Environment/Libraries
109%description -n compat32-%{name}
110Gd is a graphics library for drawing .png files.  Gd allows your code to
111quickly draw images (lines, arcs, text, multiple colors, cutting and
112pasting from other images, flood fills) and write out the result as a
113.png file. Gd is particularly useful in web applications, where .pngs
114are commonly used as inline images.  Note, however, that gd is not a
115paint program.
116
117Install gd if you are developing applications which need to draw .png
118files.  If you install gd, you'll also need to install the gd-devel
119package.
120
121%package -n compat32-%{name}-devel
122Summary: The development libraries and header files for gd.
123Group: Development/Libraries
124Requires: compat32-freetype2-devel
125Requires: compat32-fontconfig-devel
126Requires: compat32-libjpeg-turbo-devel
127Requires: compat32-libpng-devel
128Requires: compat32-libtiff-devel
129%if %{with libvpx}
130Requires: compat32-libvpx-devel
131%endif
132Requires: compat32-libX11-devel
133Requires: compat32-libXpm-devel
134Requires: compat32-zlib-devel
135
136%description -n compat32-%{name}-devel
137These are the development libraries and header files for gd, the .png
138graphics library.
139
140If you're installing the gd graphics library, you must install gd-devel.
141
142
143%prep
144%setup -q -n libgd-%{version}
145%patch0 -p1 -b .mlib
146
147: regenerate autotool stuff
148if [ -f configure ]; then
149   libtoolize --copy --force
150   autoreconf -vif
151else
152   ./bootstrap.sh
153fi
154
155
156%build
157# Provide a correct default font search path
158CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
159/usr/share/fonts/alias/TrueType/:\
160/usr/share/fonts/TrueType-vlgothic/:\
161/usr/share/fonts/bitstream-vera/:\
162/usr/share/fonts/TrueType-dejavu/:\
163/usr/share/fonts/TrueType-ipafont/:\
164/usr/share/fonts/TrueType-ipaexfont/:\
165/usr/share/fonts/default/Type1/:\
166/usr/share/X11/fonts/Type1/:\
167/usr/share/fonts/TrueType-linux-liberation/\
168\"'"
169
170%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
171    --with-freetype \
172    --with-tiff=%{_prefix} \
173%if %{with libvpx}
174    --with-vpx=%{_prefix} \
175%endif
176        --disable-rpath
177make %{?_smp_mflags}
178
179%install
180[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
181make DESTDIR=$RPM_BUILD_ROOT install
182## remove unuse files
183rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
184
185%check
186
187make %{?_smp_mflags} check
188
189%clean
190[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
191
192%post -p /sbin/ldconfig
193%postun -p /sbin/ldconfig
194
195%if %{build_compat32}
196%post -n compat32-%{name} -p /sbin/ldconfig
197%postun -n compat32-%{name} -p /sbin/ldconfig
198%endif
199
200%files
201%defattr(-,root,root)
202%doc ChangeLog COPYING NEWS docs/*
203%{_libdir}/*.so.*
204
205%files progs
206%defattr(-,root,root)
207%{_bindir}/*
208%exclude %{_bindir}/gdlib-config
209
210%files devel
211%defattr(-,root,root)
212%{_bindir}/gdlib-config
213%{_includedir}/*
214%{_libdir}/*.so
215%{_libdir}/pkgconfig/*.pc
216
217%if %{build_compat32}
218%files -n compat32-%{name}
219%defattr(-,root,root)
220%{_libdir}/*.so.*
221%files -n compat32-%{name}-devel
222%defattr(-,root,root)
223%{_libdir}/*.so
224%endif
225
226%changelog
227* Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
228- new upstream release.
229- removed Patch1000 (fixed in upstream).
230
231* Wed May  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
232- added Patch1000 to fix CVE-2016-3074.
233
234* Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
235- new upstream release.
236
237* Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
238- BR: freetype2-devel instead of freetype-devel on devel package
239
240* Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
241- fixed version in gd.h.
242- added fontconfig and tiff support.
243
244* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
245- new upstream release.
246- dropped unnecessary patches.
247
248* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
249- import patches from fedora package
250- modified font path patch for Vine Linux
251- drop static library
252- remove "-DJISX0208"
253- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
254
255* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
256- move gdlib-config from gd-progs subpackage to gd-devel subpackage
257
258* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
259- build on current VineSeed
260
261* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
262- fix build_compat32 if-endif sections
263
264* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
265- add patch2 for fix CVE-2009-3546 (_gdGetColors())
266
267* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
268- updated URL
269- changed progs Group to Applications/Graphics
270- added %%postun section
271
272* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
273- removed  *.la
274- spec in utf-8
275
276* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
277- add patch1 from centos5
278- new versioning policy
279
280* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
281- new upstream release with security fix (CVE-2007-2756)
282
283* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
284- new upstream release with security fix
285- change source tarball format gz -> bz2
286
287* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
288- added compat32-* packages for x86_64 architecture support
289
290* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
291- source upgrade
292
293* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
294- source update
295- added -DJISX0208 flag
296
297* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
298- source upgrade
299- BuildPrereq: XOrg-devel instead of XFree86-devel
300
301* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
302- source upgrade
303- remove patch0 (no need for freetype2-2.1.7)
304
305* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
306- add patch0 to build against freetype2-2.1.7
307
308* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
309- source upgrade
310- add URL
311- remove all patches
312- use %%configure script
313- add BuildPrereq: freetype2-devel XFree86-devel
314- remove BuildPrereq: VFlib-devel
315- update %%files
316- update Requires:
317- use License tag instead of Copyright
318
319* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
320- rebuild with libpng-devel-1.2.5-0vl1
321
322* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
323- rebuild with new toolchain
324
325* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
326- 1.8.3-0vl2
327- symlink to libgd.so.1 (for backward compatibility)
328
329* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
330- first gd 1.8.x release for Vine from rawhide.
331- enable freetype support and defined JISX208 macro.
332
333* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
334- break out a -progs subpackage
335- disable freetype support
336
337* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
338- update to latest version (1.8.2)
339- disable xpm support
340
341* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
342- auto rebuild in the new build environment (release 6)
343
344* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
345- auto rebuild in the new build environment (release 5)
346
347* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
348- buiuld for glibc 2.1
349
350* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
351- built for 5.2
Note: See TracBrowser for help on using the repository browser.