source: projects/specs/trunk/g/gd/gd-vl.spec @ 10247

Revision 10247, 10.8 KB checked in by tomop, 8 years ago (diff)

gd-2.1.1-2

Line 
1%bcond_with libvpx
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4Summary: A graphics library for drawing .png files.
5Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
6Name: gd
7Version: 2.1.1
8Release: 2%{_dist_release}
9Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
10Patch0: gd-2.1.0-multilib.patch
11#Patch1: gd-fixautoconf.patch
12Patch100: gd-2.1.0-fonts-vine.patch
13Patch1000: 2bb97f407c1145c850416a3bfbcc8cf124e68a19.patch
14License: BSD-style
15URL: http://www.libgd.org/
16Group: System Environment/Libraries
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: freetype2-devel
20BuildRequires: fontconfig-devel
21BuildRequires: gettext-devel
22BuildRequires: libjpeg-turbo-devel
23BuildRequires: libpng-devel
24BuildRequires: libtiff-devel
25%if %{with libvpx}
26BuildRequires: libvpx-devel
27%endif
28BuildRequires: libX11-devel
29BuildRequires: libXpm-devel
30BuildRequires: zlib-devel
31BuildRequires: pkgconfig
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: daisuke
36
37%description
38Gd is a graphics library for drawing .png files.  Gd allows your code to
39quickly draw images (lines, arcs, text, multiple colors, cutting and
40pasting from other images, flood fills) and write out the result as a
41.png file. Gd is particularly useful in web applications, where .pngs
42are commonly used as inline images.  Note, however, that gd is not a
43paint program.
44
45Install gd if you are developing applications which need to draw .png
46files.  If you install gd, you'll also need to install the gd-devel
47package.
48
49%description -l ja
50GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
51画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
52簡単に描写して、PNGファイルへ結果を出力することができます。
53Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
54便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
55ん。
56
57PNGファイルを描写する必要のあるアプリケーションを開発する場合、
58Gdをインストールしてください。gdをインストールした場合、gd-devel
59パッケージも必要になります。
60
61%package progs
62Summary: Utility programs that use libgd.
63Summary(ja): libgd を用いたユーティリティプログラム
64Group: Applications/Graphics
65Requires: gd = %{version}
66Requires: perl
67
68%description progs
69These are utility programs supplied with gd, the .png graphics library.
70If you install these, you must install gd.
71
72%description progs -l ja
73これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
74プログラムです。これをインストールするには, gdをインストールする必要
75があります。
76
77%package devel
78Summary: The development libraries and header files for gd.
79Summary(ja): Gd用の開発ライブラリとヘッダファイル
80Group: Development/Libraries
81Requires: gd = %{version}
82Requires: freetype2-devel
83Requires: fontconfig-devel
84Requires: libjpeg-turbo-devel
85Requires: libpng-devel
86Requires: libtiff-devel
87%if %{with libvpx}
88Requires: libvpx-devel
89%endif
90Requires: libX11-devel
91Requires: libXpm-devel
92Requires: zlib-devel
93
94%description devel
95These are the development libraries and header files for gd, the .png
96graphics library.
97
98If you're installing the gd graphics library, you must install gd-devel.
99
100%description devel -l ja
101これらは開発ライブラリです。
102PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
103です。
104
105gdをインストールした場合、gd-develパッケージも必要になります。
106
107
108## to build compat32 for x86_64 architecture support
109%package -n compat32-%{name}
110Summary: A graphics library for drawing .png files.
111Group: System Environment/Libraries
112%description -n compat32-%{name}
113Gd is a graphics library for drawing .png files.  Gd allows your code to
114quickly draw images (lines, arcs, text, multiple colors, cutting and
115pasting from other images, flood fills) and write out the result as a
116.png file. Gd is particularly useful in web applications, where .pngs
117are commonly used as inline images.  Note, however, that gd is not a
118paint program.
119
120Install gd if you are developing applications which need to draw .png
121files.  If you install gd, you'll also need to install the gd-devel
122package.
123
124%package -n compat32-%{name}-devel
125Summary: The development libraries and header files for gd.
126Group: Development/Libraries
127Requires: compat32-freetype2-devel
128Requires: compat32-fontconfig-devel
129Requires: compat32-libjpeg-turbo-devel
130Requires: compat32-libpng-devel
131Requires: compat32-libtiff-devel
132%if %{with libvpx}
133Requires: compat32-libvpx-devel
134%endif
135Requires: compat32-libX11-devel
136Requires: compat32-libXpm-devel
137Requires: compat32-zlib-devel
138
139%description -n compat32-%{name}-devel
140These are the development libraries and header files for gd, the .png
141graphics library.
142
143If you're installing the gd graphics library, you must install gd-devel.
144
145
146%prep
147%setup -q -n libgd-%{version}
148%patch0 -p1 -b .mlib
149#%patch1 -p1 -b .automake
150%patch100 -p1 -b .fonts-vine
151
152%patch1000 -p1 -b .CVE-2016-3074
153
154# https://bitbucket.org/libgd/gd-libgd/issue/77
155#sed -e '/GD_VERSION_STRING/s/-alpha//' \
156#    -e '/GD_EXTRA_VERSION/s/alpha//' \
157#    -i src/gd.h
158#grep VERSION src/gd.h
159
160: regenerate autotool stuff
161if [ -f configure ]; then
162   libtoolize --copy --force
163   autoreconf -vif
164else
165   ./bootstrap.sh
166fi
167
168
169%build
170# Provide a correct default font search path
171CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
172/usr/share/fonts/TrueType-vlgothic:\
173/usr/share/fonts/bitstream-vera:\
174/usr/share/fonts/dejavu:\
175/usr/share/fonts/default/Type1:\
176/usr/share/X11/fonts/Type1:\
177/usr/share/fonts/liberation\"'"
178
179%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
180    --with-tiff=%{_prefix} \
181%if %{with libvpx}
182    --with-vpx=%{_prefix} \
183%endif
184        --disable-rpath
185make %{?_smp_mflags}
186
187%install
188[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
189make DESTDIR=$RPM_BUILD_ROOT install
190## remove unuse files
191rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
192
193%clean
194[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
195
196%post -p /sbin/ldconfig
197%postun -p /sbin/ldconfig
198
199%if %{build_compat32}
200%post -n compat32-%{name} -p /sbin/ldconfig
201%postun -n compat32-%{name} -p /sbin/ldconfig
202%endif
203
204%files
205%defattr(-,root,root)
206%doc ChangeLog COPYING NEWS docs/*
207%{_libdir}/*.so.*
208
209%files progs
210%defattr(-,root,root)
211%{_bindir}/*
212%exclude %{_bindir}/gdlib-config
213
214%files devel
215%defattr(-,root,root)
216%{_bindir}/gdlib-config
217%{_includedir}/*
218%{_libdir}/*.so
219%{_libdir}/pkgconfig/*.pc
220
221%if %{build_compat32}
222%files -n compat32-%{name}
223%defattr(-,root,root)
224%{_libdir}/*.so.*
225%files -n compat32-%{name}-devel
226%defattr(-,root,root)
227%{_libdir}/*.so
228%endif
229
230%changelog
231* Wed May  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
232- added Patch1000 to fix CVE-2016-3074.
233
234* Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
235- new upstream release.
236
237* Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
238- BR: freetype2-devel instead of freetype-devel on devel package
239
240* Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
241- fixed version in gd.h.
242- added fontconfig and tiff support.
243
244* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
245- new upstream release.
246- dropped unnecessary patches.
247
248* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
249- import patches from fedora package
250- modified font path patch for Vine Linux
251- drop static library
252- remove "-DJISX0208"
253- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
254
255* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
256- move gdlib-config from gd-progs subpackage to gd-devel subpackage
257
258* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
259- build on current VineSeed
260
261* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
262- fix build_compat32 if-endif sections
263
264* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
265- add patch2 for fix CVE-2009-3546 (_gdGetColors())
266
267* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
268- updated URL
269- changed progs Group to Applications/Graphics
270- added %%postun section
271
272* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
273- removed  *.la
274- spec in utf-8
275
276* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
277- add patch1 from centos5
278- new versioning policy
279
280* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
281- new upstream release with security fix (CVE-2007-2756)
282
283* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
284- new upstream release with security fix
285- change source tarball format gz -> bz2
286
287* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
288- added compat32-* packages for x86_64 architecture support
289
290* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
291- source upgrade
292
293* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
294- source update
295- added -DJISX0208 flag
296
297* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
298- source upgrade
299- BuildPrereq: XOrg-devel instead of XFree86-devel
300
301* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
302- source upgrade
303- remove patch0 (no need for freetype2-2.1.7)
304
305* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
306- add patch0 to build against freetype2-2.1.7
307
308* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
309- source upgrade
310- add URL
311- remove all patches
312- use %%configure script
313- add BuildPrereq: freetype2-devel XFree86-devel
314- remove BuildPrereq: VFlib-devel
315- update %%files
316- update Requires:
317- use License tag instead of Copyright
318
319* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
320- rebuild with libpng-devel-1.2.5-0vl1
321
322* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
323- rebuild with new toolchain
324
325* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
326- 1.8.3-0vl2
327- symlink to libgd.so.1 (for backward compatibility)
328
329* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
330- first gd 1.8.x release for Vine from rawhide.
331- enable freetype support and defined JISX208 macro.
332
333* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
334- break out a -progs subpackage
335- disable freetype support
336
337* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
338- update to latest version (1.8.2)
339- disable xpm support
340
341* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
342- auto rebuild in the new build environment (release 6)
343
344* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
345- auto rebuild in the new build environment (release 5)
346
347* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
348- buiuld for glibc 2.1
349
350* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
351- built for 5.2
Note: See TracBrowser for help on using the repository browser.