source: projects/specs/trunk/g/gamin/gamin-vl.spec @ 8084

Revision 8084, 13.5 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define python_archlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
3Summary: Library providing the FAM File Alteration Monitor API
4Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
5Name: gamin
6Version: 0.1.10
7Release: 6%{?_dist_release}
8License: LGPLv2
9Group: System Environment/Daemons
10Source: gamin-%{version}.tar.bz2
11
12# patch from ubuntu
13#  https://bugs.launchpad.net/ubuntu/+source/gamin/+bug/829504
14Patch10: 21_no_g_const_return.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17URL: http://www.gnome.org/~veillard/gamin/
18Obsoletes: fam
19Provides: fam
20BuildRequires: glib2-devel, python, python-devel
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26The Gamin library provides an API and ABI compatible file alteration
27monitor mechanism compatible with FAM but not dependent on a system wide
28daemon.
29
30%description -l ja
31Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
32します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
33パープログラムをオンデマンドに起動します。
34
35%package devel
36Summary: Development files for the Gamin library
37Summary(ja): Gamin ライブラリの開発用ファイル
38Group: Development/Libraries
39Requires: gamin = %{version}-%{release}
40Obsoletes: fam-devel
41Provides: fam-devel
42
43%description devel
44The Gamin library provides an API and ABI compatible file alteration
45monitor mechanism compatible with FAM but not dependent on a system wide
46daemon.
47
48%description devel -l ja
49Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
50します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
51パープログラムをオンデマンドに起動します。
52
53%package python
54Summary: Python bindings for the Gamin library
55Summary(ja): Gamin ライブラリ用の Python バインディング
56Group: Development/Libraries
57Requires: gamin = %{version}-%{release}
58Requires: python
59#Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
60
61%description python
62The gamin-python package contains a module that allow monitoring of
63files and directories from the Python language based on the support
64of the gamin package.
65
66%description python -l ja
67gamin-python は gamin ライブラリを利用して Python 言語からファイルや
68ディレクトリのモニタリングを行うためのモジュールです。
69
70## to build compat32 for x86_64 architecture support
71%package -n compat32-%{name}
72Summary: Library providing the FAM File Alteration Monitor API
73Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
74Group: System Environment/Daemons
75Requires: gamin = %{version}-%{release}
76
77%description -n compat32-%{name}
78The Gamin library provides an API and ABI compatible file alteration
79monitor mechanism compatible with FAM but not dependent on a system wide
80daemon.
81
82%description -n compat32-%{name} -l ja
83Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
84します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
85パープログラムをオンデマンドに起動します。
86
87%package -n compat32-%{name}-devel
88Summary: Development files for the Gamin library
89Summary(ja): Gamin ライブラリの開発用ファイル
90Group: Development/Libraries
91Requires: compat32-gamin = %{version}-%{release}
92
93%description -n compat32-%{name}-devel
94The Gamin library provides an API and ABI compatible file alteration
95monitor mechanism compatible with FAM but not dependent on a system wide
96daemon.
97
98%description -n compat32-%{name}-devel -l ja
99Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
100します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
101
102%prep
103%setup -q
104%patch10 -p1
105find server/ -type f -exec sed -i 's/G_CONST_RETURN/const/' {} ';'
106
107%build
108%configure
109%__make %{?_smp_mflags}
110
111%install
112rm -fr %{buildroot}
113
114make install DESTDIR=$RPM_BUILD_ROOT
115
116## remove unuse files
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
118rm -f $RPM_BUILD_ROOT%{python_archlib}/*.la
119
120
121%clean
122rm -fr %{buildroot}
123
124%post -p /sbin/ldconfig
125
126%postun -p /sbin/ldconfig
127
128%post -n compat32-%{name} -p /sbin/ldconfig
129
130%postun -n compat32-%{name} -p /sbin/ldconfig
131
132%files
133%defattr(-, root, root)
134
135%doc AUTHORS ChangeLog NEWS README Copyright TODO
136%doc doc/*.html
137%doc doc/*.gif
138%doc doc/*.txt
139%{_libdir}/lib*.so.*
140%{_libexecdir}/gam_server
141
142%files devel
143%defattr(-, root, root)
144
145%{_libdir}/lib*.so
146%{_libdir}/*a
147%{_includedir}/fam.h
148%{_libdir}/pkgconfig/gamin.pc
149
150%files python
151%defattr(-, root, root)
152%doc AUTHORS ChangeLog NEWS README Copyright TODO
153%{_libdir}/python*/site-packages/gamin.py*
154%{_libdir}/python*/site-packages/_gamin*
155%doc python/tests/*.py
156%doc doc/python.html
157
158%if %{build_compat32}
159%files -n compat32-%{name}
160%defattr(-, root, root)
161%{_libdir}/lib*.so.*
162
163%files -n compat32-%{name}-devel
164%defattr(-, root, root)
165%{_libdir}/lib*.so
166%{_libdir}/*a
167%{_libdir}/pkgconfig/gamin.pc
168%endif
169
170%changelog
171* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-6
172- rebuild with VineSeed environment
173
174* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-5
175- rebuild with python-2.7.2
176- add Patch10 (21_no_g_const_return.patch)
177
178* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 0.1.10-4
179- update Requires for python subpackage
180 - drop directory dependency
181
182* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.10-3
183- build with rpm-4.8.1-1 for pkg-config file
184
185* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
186- rebuild with python-2.6
187
188* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
189- new upstream release
190
191* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
192- fix license tag to LGPLv2
193- import patches from Fedora development
194  - Patch0: don't poll for non-existant watched files
195  - Patch1: Fix a memory leak
196  - Patch2: workaround for missing struct ucred in glibc headers
197    (fixed x86_64/ppc compilation)
198
199* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
200- spec in utf-8
201- removed *.la
202
203* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
204- added compat32-* packages for x86_64 architecture support
205- applied new versioning policy
206
207* Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
208- new upstream release
209- Patch10 was included in upstream, dropped
210
211* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
212- added Patch10 (<BTS:507>) which should be fixed in the new upstream release
213
214* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
215- new upstream release
216
217* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
218- stop removing *.la
219
220* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
221- initial build for Vine Linux
222
223* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
224- bump again for double-long bug on ppc(64)
225
226* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
227- rebuilt for new gcc4.1 snapshot and glibc changes
228
229* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
230- rebuilt
231
232* Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
233- hopefully fixes gam_server crashes
234- some portability fixes
235- removed a minor leak
236* Thu Sep  8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
237- revamp of the inotify back-end
238- memory leak fix
239- various fixes and cleanups
240* Tue Aug  9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
241- Improvement of configuration, system wide configuration files and
242  per filesystem type default
243- Rewrite of the inotify back-end, reduce resources usage, tuning in
244  case of busy resources
245- Documentation updates
246- Changes to compile inotify back-end on various architectures
247- Debugging output improvements
248* Tue Aug  2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
249- Fix to compile on older gcc versions
250- Inotify back-end changes and optimizations
251- Debug ouput cleanup, pid and process name reports
252- Dropped kernel monitor bugfix
253- Removed the old glist copy used for debugging
254- Maintain mounted filesystems knowledge, and per fstype preferences
255* Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
256- inotify back end patches, ready for the new inotify support in kernel
257- lot of server code cleanup patches
258- fixed an authentication problem
259* Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
260- gamin_data_conn_event fix
261- crash from bug gnome #303932
262- Inotify and mounted media #171201
263- mounted media did not show up on Desktop #159748
264- write may not be atomic
265- Monitoring a directory when it is a file
266- Portability to Hurd/Mach and various code cleanups
267- Added support for ~ as user home alias in .gaminrc
268* Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
269- Close inherited file descriptors on exec of gam_server
270- Cancelling a monitor send back a FAMAcknowledge
271- Fixed for big files > 2GB
272- Bug when monitoring a non existing directory
273- Make client side thread safe
274- Unreadable directory fixes
275- Better flow control handling
276- Updated to latest inotify version: 0.23-6
277* Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
278- Fix an include problem showing up with gcc4</li>
279- Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
280- removed an incompatibility with SGI FAM #149822
281* Tue Mar  1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
282- Fix a configure problem reported by Martin Schlemmer
283- Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
284- Fix the monitoring of directory using poll and not kernel
285* Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
286- more documentation
287- lot of serious bug fixes including Gnome Desktop refresh bug
288- extending the framework for more debug (configure --enable-debug-api)
289- extending the python bindings for watching the same resource multiple times
290  and adding debug framework support
291- growing the regression tests a lot based on python bindings
292- inotify-0.19 patch from John McCutchan
293- renamed python private module to _gamin to follow Python PEP 8
294
295* Tue Feb  8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
296- memory corruption fix from Mark on the client side
297- extending the protocol and API to allow skipping Exists and EndExists
298  events to avoid deadlock on reconnect or when they are not used.
299
300* Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
301- bit of python bindings improvements, added test
302- fixed 3 bugs
303
304* Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
305- Added Python support
306- Updated for inotify-0.18
307
308* Thu Jan  6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
309- Frederic Crozat seems to have found the GList corruption which may fix
310  #132354 and related problems
311- Frederic Crozat also fixed poll only mode
312
313* Fri Dec  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
314- still chasing the loop bug, made another pass at checking GList,
315  added own copy with memory poisonning of GList implementation.
316- fixed a compile issue when compiling without debug
317
318* Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
319- still chasing the loop bug, checked and cleaned up all GList use
320- patch from markmc to minimize load on busy apps
321
322* Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
323- chasing #132354, lot of debugging, checking and testing and a bit
324  of refactoring
325
326* Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
327- workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
328
329* Sun Oct  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
330- Found and fixed the annoying bug where update were not received
331  should fix bugs ##132429, #133665 and #134413
332- new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
333- Added documentation about internals
334
335* Fri Oct  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
336- applied portability fixes
337- hardened the code while chasing a segfault
338
339* Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
340- potential fix for a hard to reproduce looping problem.
341
342* Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
343- update to the latest version of inotify
344- inotify support compiled in by default
345- fix ABI FAM compatibility problems #133162
346
347* Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
348- more documentation
349- Added support for a configuration file $HOME/.gaminrc
350- fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
351
352* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
353- fix crash with konqueror #130967
354- exclude kernel (dnotify) monitoring for /mnt//* /media//*
355
356* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
357- Fixes crashes of the gam_server
358- try to correct the kernel/poll switching mode
359
360* Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
361- add support for both polling and dnotify simultaneously
362- fixes monitoring of initially missing files
363- load control on very busy resources #124361, desactivating
364  dnotify and falling back to polling for CPU drain
365
366* Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
367- fixes simple file monitoring should close RH #129974
368- relocate gam_server in $(libexec)
369
370* Thu Aug  5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
371- Fix a crash when the client binary forks the gam_server and an
372  atexit handler is run.
373
374* Wed Aug  4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
375- should fix KDE build problems
Note: See TracBrowser for help on using the repository browser.