source: projects/specs/trunk/g/gamin/gamin-vl.spec @ 5701

Revision 5701, 13.3 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define python_archlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
3Summary: Library providing the FAM File Alteration Monitor API
4Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
5Name: gamin
6Version: 0.1.10
7Release: 5%{?_dist_release}
8License: LGPLv2
9Group: System Environment/Daemons
10Source: gamin-%{version}.tar.bz2
11
12# patch from ubuntu
13#  https://bugs.launchpad.net/ubuntu/+source/gamin/+bug/829504
14Patch10: 21_no_g_const_return.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17URL: http://www.gnome.org/~veillard/gamin/
18Obsoletes: fam
19Provides: fam
20BuildRequires: glib2-devel, python, python-devel
21
22
23%description
24The Gamin library provides an API and ABI compatible file alteration
25monitor mechanism compatible with FAM but not dependent on a system wide
26daemon.
27
28%description -l ja
29Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
30します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
31パープログラムをオンデマンドに起動します。
32
33%package devel
34Summary: Development files for the Gamin library
35Summary(ja): Gamin ライブラリの開発用ファイル
36Group: Development/Libraries
37Requires: gamin = %{version}-%{release}
38Obsoletes: fam-devel
39Provides: fam-devel
40
41%description devel
42The Gamin library provides an API and ABI compatible file alteration
43monitor mechanism compatible with FAM but not dependent on a system wide
44daemon.
45
46%description devel -l ja
47Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
48します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
49パープログラムをオンデマンドに起動します。
50
51%package python
52Summary: Python bindings for the Gamin library
53Summary(ja): Gamin ライブラリ用の Python バインディング
54Group: Development/Libraries
55Requires: gamin = %{version}-%{release}
56Requires: python
57#Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
58
59%description python
60The gamin-python package contains a module that allow monitoring of
61files and directories from the Python language based on the support
62of the gamin package.
63
64%description python -l ja
65gamin-python は gamin ライブラリを利用して Python 言語からファイルや
66ディレクトリのモニタリングを行うためのモジュールです。
67
68## to build compat32 for x86_64 architecture support
69%package -n compat32-%{name}
70Summary: Library providing the FAM File Alteration Monitor API
71Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
72Group: System Environment/Daemons
73Requires: gamin = %{version}-%{release}
74
75%description -n compat32-%{name}
76The Gamin library provides an API and ABI compatible file alteration
77monitor mechanism compatible with FAM but not dependent on a system wide
78daemon.
79
80%description -n compat32-%{name} -l ja
81Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
82します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
83パープログラムをオンデマンドに起動します。
84
85%package -n compat32-%{name}-devel
86Summary: Development files for the Gamin library
87Summary(ja): Gamin ライブラリの開発用ファイル
88Group: Development/Libraries
89Requires: compat32-gamin = %{version}-%{release}
90
91%description -n compat32-%{name}-devel
92The Gamin library provides an API and ABI compatible file alteration
93monitor mechanism compatible with FAM but not dependent on a system wide
94daemon.
95
96%description -n compat32-%{name}-devel -l ja
97Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
98します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
99
100%prep
101%setup -q
102%patch10 -p1
103find server/ -type f -exec sed -i 's/G_CONST_RETURN/const/' {} ';'
104
105%build
106%configure
107%__make %{?_smp_mflags}
108
109%install
110rm -fr %{buildroot}
111
112%makeinstall
113
114## remove unuse files
115rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
116rm -f $RPM_BUILD_ROOT%{python_archlib}/*.la
117
118
119%clean
120rm -fr %{buildroot}
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%post -n compat32-%{name} -p /sbin/ldconfig
127
128%postun -n compat32-%{name} -p /sbin/ldconfig
129
130%files
131%defattr(-, root, root)
132
133%doc AUTHORS ChangeLog NEWS README Copyright TODO
134%doc doc/*.html
135%doc doc/*.gif
136%doc doc/*.txt
137%{_libdir}/lib*.so.*
138%{_libexecdir}/gam_server
139
140%files devel
141%defattr(-, root, root)
142
143%{_libdir}/lib*.so
144%{_libdir}/*a
145%{_includedir}/fam.h
146%{_libdir}/pkgconfig/gamin.pc
147
148%files python
149%defattr(-, root, root)
150%doc AUTHORS ChangeLog NEWS README Copyright TODO
151%{_libdir}/python*/site-packages/gamin.py*
152%{_libdir}/python*/site-packages/_gamin*
153%doc python/tests/*.py
154%doc doc/python.html
155
156%if %{build_compat32}
157%files -n compat32-%{name}
158%defattr(-, root, root)
159%{_libdir}/lib*.so.*
160
161%files -n compat32-%{name}-devel
162%defattr(-, root, root)
163%{_libdir}/lib*.so
164%{_libdir}/*a
165%{_libdir}/pkgconfig/gamin.pc
166%endif
167
168%changelog
169* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-5
170- rebuild with python-2.7.2
171- add Patch10 (21_no_g_const_return.patch)
172
173* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 0.1.10-4
174- update Requires for python subpackage
175 - drop directory dependency
176
177* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.10-3
178- build with rpm-4.8.1-1 for pkg-config file
179
180* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
181- rebuild with python-2.6
182
183* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
184- new upstream release
185
186* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
187- fix license tag to LGPLv2
188- import patches from Fedora development
189  - Patch0: don't poll for non-existant watched files
190  - Patch1: Fix a memory leak
191  - Patch2: workaround for missing struct ucred in glibc headers
192    (fixed x86_64/ppc compilation)
193
194* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
195- spec in utf-8
196- removed *.la
197
198* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
199- added compat32-* packages for x86_64 architecture support
200- applied new versioning policy
201
202* Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
203- new upstream release
204- Patch10 was included in upstream, dropped
205
206* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
207- added Patch10 (<BTS:507>) which should be fixed in the new upstream release
208
209* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
210- new upstream release
211
212* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
213- stop removing *.la
214
215* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
216- initial build for Vine Linux
217
218* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
219- bump again for double-long bug on ppc(64)
220
221* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
222- rebuilt for new gcc4.1 snapshot and glibc changes
223
224* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
225- rebuilt
226
227* Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
228- hopefully fixes gam_server crashes
229- some portability fixes
230- removed a minor leak
231* Thu Sep  8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
232- revamp of the inotify back-end
233- memory leak fix
234- various fixes and cleanups
235* Tue Aug  9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
236- Improvement of configuration, system wide configuration files and
237  per filesystem type default
238- Rewrite of the inotify back-end, reduce resources usage, tuning in
239  case of busy resources
240- Documentation updates
241- Changes to compile inotify back-end on various architectures
242- Debugging output improvements
243* Tue Aug  2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
244- Fix to compile on older gcc versions
245- Inotify back-end changes and optimizations
246- Debug ouput cleanup, pid and process name reports
247- Dropped kernel monitor bugfix
248- Removed the old glist copy used for debugging
249- Maintain mounted filesystems knowledge, and per fstype preferences
250* Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
251- inotify back end patches, ready for the new inotify support in kernel
252- lot of server code cleanup patches
253- fixed an authentication problem
254* Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
255- gamin_data_conn_event fix
256- crash from bug gnome #303932
257- Inotify and mounted media #171201
258- mounted media did not show up on Desktop #159748
259- write may not be atomic
260- Monitoring a directory when it is a file
261- Portability to Hurd/Mach and various code cleanups
262- Added support for ~ as user home alias in .gaminrc
263* Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
264- Close inherited file descriptors on exec of gam_server
265- Cancelling a monitor send back a FAMAcknowledge
266- Fixed for big files > 2GB
267- Bug when monitoring a non existing directory
268- Make client side thread safe
269- Unreadable directory fixes
270- Better flow control handling
271- Updated to latest inotify version: 0.23-6
272* Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
273- Fix an include problem showing up with gcc4</li>
274- Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
275- removed an incompatibility with SGI FAM #149822
276* Tue Mar  1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
277- Fix a configure problem reported by Martin Schlemmer
278- Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
279- Fix the monitoring of directory using poll and not kernel
280* Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
281- more documentation
282- lot of serious bug fixes including Gnome Desktop refresh bug
283- extending the framework for more debug (configure --enable-debug-api)
284- extending the python bindings for watching the same resource multiple times
285  and adding debug framework support
286- growing the regression tests a lot based on python bindings
287- inotify-0.19 patch from John McCutchan
288- renamed python private module to _gamin to follow Python PEP 8
289
290* Tue Feb  8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
291- memory corruption fix from Mark on the client side
292- extending the protocol and API to allow skipping Exists and EndExists
293  events to avoid deadlock on reconnect or when they are not used.
294
295* Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
296- bit of python bindings improvements, added test
297- fixed 3 bugs
298
299* Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
300- Added Python support
301- Updated for inotify-0.18
302
303* Thu Jan  6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
304- Frederic Crozat seems to have found the GList corruption which may fix
305  #132354 and related problems
306- Frederic Crozat also fixed poll only mode
307
308* Fri Dec  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
309- still chasing the loop bug, made another pass at checking GList,
310  added own copy with memory poisonning of GList implementation.
311- fixed a compile issue when compiling without debug
312
313* Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
314- still chasing the loop bug, checked and cleaned up all GList use
315- patch from markmc to minimize load on busy apps
316
317* Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
318- chasing #132354, lot of debugging, checking and testing and a bit
319  of refactoring
320
321* Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
322- workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
323
324* Sun Oct  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
325- Found and fixed the annoying bug where update were not received
326  should fix bugs ##132429, #133665 and #134413
327- new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
328- Added documentation about internals
329
330* Fri Oct  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
331- applied portability fixes
332- hardened the code while chasing a segfault
333
334* Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
335- potential fix for a hard to reproduce looping problem.
336
337* Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
338- update to the latest version of inotify
339- inotify support compiled in by default
340- fix ABI FAM compatibility problems #133162
341
342* Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
343- more documentation
344- Added support for a configuration file $HOME/.gaminrc
345- fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
346
347* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
348- fix crash with konqueror #130967
349- exclude kernel (dnotify) monitoring for /mnt//* /media//*
350
351* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
352- Fixes crashes of the gam_server
353- try to correct the kernel/poll switching mode
354
355* Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
356- add support for both polling and dnotify simultaneously
357- fixes monitoring of initially missing files
358- load control on very busy resources #124361, desactivating
359  dnotify and falling back to polling for CPU drain
360
361* Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
362- fixes simple file monitoring should close RH #129974
363- relocate gam_server in $(libexec)
364
365* Thu Aug  5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
366- Fix a crash when the client binary forks the gam_server and an
367  atexit handler is run.
368
369* Wed Aug  4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
370- should fix KDE build problems
Note: See TracBrowser for help on using the repository browser.