source: projects/specs/trunk/g/gamin/gamin-vl.spec @ 12082

Revision 12082, 15.1 KB checked in by tomop, 5 years ago (diff)

gamin-0.1.10-7

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library providing the FAM File Alteration Monitor API
4Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
5Name: gamin
6Version: 0.1.10
7Release: 7%{?_dist_release}
8License: LGPLv2
9Group: System Environment/Daemons
10Source: gamin-%{version}.tar.bz2
11# sample config file
12Source1: gaminrc
13
14# The patch declares HAVE_LINUX in case of linux-gnueabi as well.
15# Patch by Kedar Sovani <kedars@marvell.com>
16Patch1: gamin-0.1.10-gnueabi.patch
17
18# Don't try to build with -DG_DISABLE_DEPRECATED - glib has moved on
19Patch2: gamin-manape.patch
20
21# upstream fixes
22Patch4: 0001-Poll-files-on-nfs4.patch
23Patch5: 0002-Fix-compilation-of-recent-glib-removing-G_CONST_RETU.patch
24# gam_server deadlocks, leading to all KDE applications hanging at start
25# https://bugzilla.redhat.com/show_bug.cgi?id=786170
26# https://bugzilla.gnome.org/show_bug.cgi?id=667120
27Patch7: 0004-fix-possible-server-deadlock-in-ih_sub_cancel.patch
28
29# patch from ubuntu
30#  https://bugs.launchpad.net/ubuntu/+source/gamin/+bug/829504
31Patch10: 21_no_g_const_return.patch
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34URL: http://www.gnome.org/~veillard/gamin/
35Obsoletes: fam
36Provides: fam
37BuildRequires: glib2-devel, python, python-devel, python-rpm-macros
38BuildRequires: libxcrypt-devel
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44The Gamin library provides an API and ABI compatible file alteration
45monitor mechanism compatible with FAM but not dependent on a system wide
46daemon.
47
48%description -l ja
49Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
50します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
51パープログラムをオンデマンドに起動します。
52
53%package devel
54Summary: Development files for the Gamin library
55Summary(ja): Gamin ライブラリの開発用ファイル
56Group: Development/Libraries
57Requires: gamin = %{version}-%{release}
58Obsoletes: fam-devel
59Provides: fam-devel
60
61%description devel
62The Gamin library provides an API and ABI compatible file alteration
63monitor mechanism compatible with FAM but not dependent on a system wide
64daemon.
65
66%description devel -l ja
67Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
68します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
69パープログラムをオンデマンドに起動します。
70
71%package python
72Summary: Python bindings for the Gamin library
73Summary(ja): Gamin ライブラリ用の Python バインディング
74Group: Development/Libraries
75Requires: gamin = %{version}-%{release}
76Requires: python
77
78%description python
79The gamin-python package contains a module that allow monitoring of
80files and directories from the Python language based on the support
81of the gamin package.
82
83%description python -l ja
84gamin-python は gamin ライブラリを利用して Python 言語からファイルや
85ディレクトリのモニタリングを行うためのモジュールです。
86
87## to build compat32 for x86_64 architecture support
88%package -n compat32-%{name}
89Summary: Library providing the FAM File Alteration Monitor API
90Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
91Group: System Environment/Daemons
92Requires: gamin = %{version}-%{release}
93
94%description -n compat32-%{name}
95The Gamin library provides an API and ABI compatible file alteration
96monitor mechanism compatible with FAM but not dependent on a system wide
97daemon.
98
99%description -n compat32-%{name} -l ja
100Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
101します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
102パープログラムをオンデマンドに起動します。
103
104%package -n compat32-%{name}-devel
105Summary: Development files for the Gamin library
106Summary(ja): Gamin ライブラリの開発用ファイル
107Group: Development/Libraries
108Requires: compat32-gamin = %{version}-%{release}
109
110%description -n compat32-%{name}-devel
111The Gamin library provides an API and ABI compatible file alteration
112monitor mechanism compatible with FAM but not dependent on a system wide
113daemon.
114
115%description -n compat32-%{name}-devel -l ja
116Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
117します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
118
119%prep
120%setup -q
121%patch1 -p1 -b .gnueabi
122%patch2 -p1 -b .manape
123%patch4 -p1 -b .nfs4
124%patch5 -p1 -b .const
125%patch7 -p1 -b .double-lock
126%patch10 -p1
127
128# recode docs into UTF-8
129for i in ChangeLog NEWS ; do
130   iconv -f iso-8859-1 -t utf-8 < $i > XXX
131   touch -r $i XXX
132   mv XXX $i
133done
134
135# https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython
136
137# replace "/usr/bin/env python" with "/usr/bin/python2"
138for i in `find -name '*.py'`; do
139   sed -i.bak "s|^#!/usr/bin/env python|#!%{__python2}|g" $i
140   touch -r ${i}.bak $i
141   rm ${i}.bak
142done
143
144find server/ -type f -exec sed -i 's/G_CONST_RETURN/const/' {} ';'
145
146%build
147autoreconf -vif
148%configure \
149  --disable-static
150
151%__make %{?_smp_mflags}
152
153%install
154rm -fr %{buildroot}
155
156make install DESTDIR=%{buildroot} INSTALL="install -p"
157
158install -D -p -m644 %{SOURCE1} %{buildroot}%{_sysconfdir}/gamin/gaminrc
159touch %{buildroot}%{_sysconfdir}/gamin/mandatory_gaminrc
160
161rm -fv %{buildroot}%{_libdir}/lib*.la
162# gamin server links this, it gets installed even in --disable-static mode,
163# but continue to omit from packaging as has been done for a long time -- rex
164rm -fv %{buildroot}%{_libdir}/libgamin_shared.a
165
166%clean
167rm -fr %{buildroot}
168
169%post -p /sbin/ldconfig
170
171%postun -p /sbin/ldconfig
172
173%post -n compat32-%{name} -p /sbin/ldconfig
174
175%postun -n compat32-%{name} -p /sbin/ldconfig
176
177%files
178%defattr(-, root, root)
179
180%license COPYING
181%doc AUTHORS ChangeLog NEWS README TODO
182%doc doc/*.html
183%doc doc/*.gif
184%doc doc/*.txt
185%dir %{_sysconfdir}/gamin/
186%config(noreplace) %{_sysconfdir}/gamin/gaminrc
187%config(noreplace) %{_sysconfdir}/gamin/mandatory_gaminrc
188%{_libdir}/libfam.so.0*
189%{_libdir}/libgamin-1.so.0*
190%{_libexecdir}/gam_server
191
192%files devel
193%defattr(-, root, root)
194
195%{_libdir}/libfam.so
196%{_libdir}/libgamin-1.so
197%{_includedir}/fam.h
198%{_libdir}/pkgconfig/gamin.pc
199
200%files python
201%defattr(-, root, root)
202%doc AUTHORS ChangeLog NEWS README Copyright TODO
203%{_libdir}/python*/site-packages/gamin.py*
204%{_libdir}/python*/site-packages/_gamin*
205%doc python/tests/*.py
206%doc doc/python.html
207
208%if %{build_compat32}
209%files -n compat32-%{name}
210%defattr(-, root, root)
211%{_libdir}/libfam.so.0*
212%{_libdir}/libgamin-1.so.0*
213
214%files -n compat32-%{name}-devel
215%defattr(-, root, root)
216%{_libdir}/libfam.so
217%{_libdir}/libgamin-1.so
218%{_libdir}/pkgconfig/gamin.pc
219%endif
220
221%changelog
222* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.1.10-7
223- rebuilt with current environment.
224
225* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-6
226- rebuild with VineSeed environment
227
228* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-5
229- rebuild with python-2.7.2
230- add Patch10 (21_no_g_const_return.patch)
231
232* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 0.1.10-4
233- update Requires for python subpackage
234 - drop directory dependency
235
236* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.10-3
237- build with rpm-4.8.1-1 for pkg-config file
238
239* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
240- rebuild with python-2.6
241
242* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
243- new upstream release
244
245* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
246- fix license tag to LGPLv2
247- import patches from Fedora development
248  - Patch0: don't poll for non-existant watched files
249  - Patch1: Fix a memory leak
250  - Patch2: workaround for missing struct ucred in glibc headers
251    (fixed x86_64/ppc compilation)
252
253* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
254- spec in utf-8
255- removed *.la
256
257* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
258- added compat32-* packages for x86_64 architecture support
259- applied new versioning policy
260
261* Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
262- new upstream release
263- Patch10 was included in upstream, dropped
264
265* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
266- added Patch10 (<BTS:507>) which should be fixed in the new upstream release
267
268* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
269- new upstream release
270
271* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
272- stop removing *.la
273
274* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
275- initial build for Vine Linux
276
277* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
278- bump again for double-long bug on ppc(64)
279
280* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
281- rebuilt for new gcc4.1 snapshot and glibc changes
282
283* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
284- rebuilt
285
286* Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
287- hopefully fixes gam_server crashes
288- some portability fixes
289- removed a minor leak
290* Thu Sep  8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
291- revamp of the inotify back-end
292- memory leak fix
293- various fixes and cleanups
294* Tue Aug  9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
295- Improvement of configuration, system wide configuration files and
296  per filesystem type default
297- Rewrite of the inotify back-end, reduce resources usage, tuning in
298  case of busy resources
299- Documentation updates
300- Changes to compile inotify back-end on various architectures
301- Debugging output improvements
302* Tue Aug  2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
303- Fix to compile on older gcc versions
304- Inotify back-end changes and optimizations
305- Debug ouput cleanup, pid and process name reports
306- Dropped kernel monitor bugfix
307- Removed the old glist copy used for debugging
308- Maintain mounted filesystems knowledge, and per fstype preferences
309* Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
310- inotify back end patches, ready for the new inotify support in kernel
311- lot of server code cleanup patches
312- fixed an authentication problem
313* Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
314- gamin_data_conn_event fix
315- crash from bug gnome #303932
316- Inotify and mounted media #171201
317- mounted media did not show up on Desktop #159748
318- write may not be atomic
319- Monitoring a directory when it is a file
320- Portability to Hurd/Mach and various code cleanups
321- Added support for ~ as user home alias in .gaminrc
322* Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
323- Close inherited file descriptors on exec of gam_server
324- Cancelling a monitor send back a FAMAcknowledge
325- Fixed for big files > 2GB
326- Bug when monitoring a non existing directory
327- Make client side thread safe
328- Unreadable directory fixes
329- Better flow control handling
330- Updated to latest inotify version: 0.23-6
331* Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
332- Fix an include problem showing up with gcc4</li>
333- Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
334- removed an incompatibility with SGI FAM #149822
335* Tue Mar  1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
336- Fix a configure problem reported by Martin Schlemmer
337- Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
338- Fix the monitoring of directory using poll and not kernel
339* Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
340- more documentation
341- lot of serious bug fixes including Gnome Desktop refresh bug
342- extending the framework for more debug (configure --enable-debug-api)
343- extending the python bindings for watching the same resource multiple times
344  and adding debug framework support
345- growing the regression tests a lot based on python bindings
346- inotify-0.19 patch from John McCutchan
347- renamed python private module to _gamin to follow Python PEP 8
348
349* Tue Feb  8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
350- memory corruption fix from Mark on the client side
351- extending the protocol and API to allow skipping Exists and EndExists
352  events to avoid deadlock on reconnect or when they are not used.
353
354* Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
355- bit of python bindings improvements, added test
356- fixed 3 bugs
357
358* Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
359- Added Python support
360- Updated for inotify-0.18
361
362* Thu Jan  6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
363- Frederic Crozat seems to have found the GList corruption which may fix
364  #132354 and related problems
365- Frederic Crozat also fixed poll only mode
366
367* Fri Dec  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
368- still chasing the loop bug, made another pass at checking GList,
369  added own copy with memory poisonning of GList implementation.
370- fixed a compile issue when compiling without debug
371
372* Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
373- still chasing the loop bug, checked and cleaned up all GList use
374- patch from markmc to minimize load on busy apps
375
376* Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
377- chasing #132354, lot of debugging, checking and testing and a bit
378  of refactoring
379
380* Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
381- workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
382
383* Sun Oct  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
384- Found and fixed the annoying bug where update were not received
385  should fix bugs ##132429, #133665 and #134413
386- new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
387- Added documentation about internals
388
389* Fri Oct  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
390- applied portability fixes
391- hardened the code while chasing a segfault
392
393* Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
394- potential fix for a hard to reproduce looping problem.
395
396* Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
397- update to the latest version of inotify
398- inotify support compiled in by default
399- fix ABI FAM compatibility problems #133162
400
401* Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
402- more documentation
403- Added support for a configuration file $HOME/.gaminrc
404- fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
405
406* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
407- fix crash with konqueror #130967
408- exclude kernel (dnotify) monitoring for /mnt//* /media//*
409
410* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
411- Fixes crashes of the gam_server
412- try to correct the kernel/poll switching mode
413
414* Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
415- add support for both polling and dnotify simultaneously
416- fixes monitoring of initially missing files
417- load control on very busy resources #124361, desactivating
418  dnotify and falling back to polling for CPU drain
419
420* Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
421- fixes simple file monitoring should close RH #129974
422- relocate gam_server in $(libexec)
423
424* Thu Aug  5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
425- Fix a crash when the client binary forks the gam_server and an
426  atexit handler is run.
427
428* Wed Aug  4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
429- should fix KDE build problems
Note: See TracBrowser for help on using the repository browser.