source: projects/specs/trunk/f/fontconfig/fontconfig-vl.spec @ 5318

Revision 5318, 23.2 KB checked in by Takemikaduchi, 12 years ago (diff)

fontconfig: add R:expat-devel

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define freetype_version 2.4.8
3
4Summary: Font configuration and customization library
5Summary(ja): フォント設定/カスタマイズライブラリ
6Name: fontconfig
7Version: 2.8.0
8Release: 3%{?_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://fontconfig.org/
12
13Source: http://fontconfig.org/release/fontconfig-%{version}.tar.gz
14Source10: 70-prefer-ja-font.conf
15Source11: 59-morisawa-font-alias.conf
16
17Patch1: fontconfig-2.2.1-AppleRoman-DynaFont.patch
18Patch4: fontconfig-2.3.2-subst-ja-font.patch
19Patch10: fontconfig-2.6.0-vine.patch
20
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: gawk
24BuildRequires: expat-devel
25BuildRequires: freetype2-devel >= %{freetype_version}
26BuildRequires: perl
27
28Requires(pre): freetype2 >= %{freetype_version}, coreutils
29Conflicts: XOrg-libs <= 6.9.0
30Obsoletes: XOrg-libs <= 6.9.0
31Conflicts: XOrg-font-utils <= 6.9.0
32Obsoletes: XOrg-font-utils <= 6.9.0
33
34%description
35Fontconfig is designed to locate fonts within the
36system and select them according to requirements specified by
37applications.
38
39%description -l ja
40Fontconfig は、システム内のフォントを把握し、アプリケーション
41が指定した要求に応じてそれらを選択するためのライブラリです。
42
43%package devel
44Summary: Development files for %{name}
45Summary(ja): Fontconfig の開発ファイル
46Group: Development/Libraries
47Requires: fontconfig = %{version}-%{release}
48Requires: freetype2-devel >= %{freetype_version}
49Requires: expat-devel
50Requires: pkgconfig
51Conflicts: XOrg-devel <= 6.9.0
52Obsoletes: XOrg-devel <= 6.9.0
53
54%description devel
55The fontconfig-devel package includes the header files,
56and developer docs for the fontconfig package.
57
58%description -l ja devel
59fontconfig-devel パッケージには fontconfig を使ったソフトウエア
60を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
61ントが含まれています。
62
63# compat32
64%package -n compat32-%{name}
65Summary: Font configuration and customization library
66Summary(ja): フォント設定/カスタマイズライブラリ
67Group: System Environment/Libraries
68
69%description -n compat32-%{name}
70Fontconfig is designed to locate fonts within the
71system and select them according to requirements specified by
72applications.
73
74%description -l ja -n compat32-%{name}
75Fontconfig は、システム内のフォントを把握し、アプリケーション
76が指定した要求に応じてそれらを選択するためのライブラリです。
77
78%package -n compat32-%{name}-devel
79Summary: Font configuration and customization library
80Group: Development/Libraries
81Requires: compat32-%{name} = %{version}-%{release}
82Requires: %{name}-devel = %{version}-%{release}
83Requires: compat32-freetype2-devel >= %{freetype_version}
84Requires: compat32-expat-devel
85
86%description -n compat32-%{name}-devel
87The fontconfig-devel package includes the header files,
88and developer docs for the fontconfig package.
89
90%description -l ja -n compat32-%{name}-devel
91fontconfig-devel パッケージには fontconfig を使ったソフトウエア
92を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
93ントが含まれています。
94
95%prep
96%setup -q
97%patch1 -p1 -b .fontconfig-AppleRoman-DynaFont
98%patch4 -p1 -b .subst-ja-font
99%patch10 -p1 -b .vine
100
101%build
102
103# We don't want to rebuild the docs, but we want to install the included ones.
104export HASDOCBOOK=no
105
106%configure \
107  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
108
109%__make %{?_smp_mflags}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%__make install DESTDIR=$RPM_BUILD_ROOT
115
116ln -s ../conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
117
118install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
119for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
120do
121  ln -sf ../conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
122done
123
124# move installed doc files back to build directory to package themm
125# in the right place
126mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
127rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
128
129# All font packages depend on this package, so we create
130# and own /usr/share/fonts
131mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
132
133# Remove unpackaged files
134rm $RPM_BUILD_ROOT%{_libdir}/*.la
135rm $RPM_BUILD_ROOT%{_libdir}/*.a
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post
141/sbin/ldconfig
142umask 0022
143# Remove stale caches
144rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
145HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
146
147
148%postun -p /sbin/ldconfig
149
150%post -n compat32-%{name} -p /sbin/ldconfig
151
152%postun -n compat32-%{name} -p /sbin/ldconfig
153
154%files
155%defattr(-, root, root)
156%doc README AUTHORS COPYING
157%doc fontconfig-user.txt fontconfig-user.html
158%{_libdir}/libfontconfig.so.*
159%{_bindir}/fc-cache
160%{_bindir}/fc-list
161%{_bindir}/fc-match
162%{_bindir}/fc-cat
163%{_bindir}/fc-query
164%{_bindir}/fc-scan
165%dir %{_sysconfdir}/fonts/conf.avail
166%dir %{_datadir}/fonts
167%{_sysconfdir}/fonts/fonts.dtd
168%config %{_sysconfdir}/fonts/fonts.conf
169%doc %{_sysconfdir}/fonts/conf.d/README
170%config %{_sysconfdir}/fonts/conf.avail/*.conf
171%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
172%dir %{_localstatedir}/cache/fontconfig
173
174%{_mandir}/man1/*
175%{_mandir}/man5/*
176
177%files devel
178%defattr(-, root, root)
179%doc fontconfig-devel.txt fontconfig-devel
180%{_libdir}/libfontconfig.so
181%{_libdir}/pkgconfig/*
182%{_includedir}/fontconfig
183%{_mandir}/man3/*
184
185# compat32
186%if %{build_compat32}
187%files -n compat32-%{name}
188%defattr(-, root, root)
189%{_libdir}/libfontconfig.so.*
190
191%files -n compat32-%{name}-devel
192%defattr(-, root, root)
193%{_libdir}/libfontconfig.so
194%{_libdir}/pkgconfig/*
195%endif
196
197%changelog
198* Sat Dec 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
199- rebuild with freetype2-2.4.8
200- add Requires: expat-devel (-devel package)
201
202* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.0-2
203- build with rpm-4.8.1-1 for pkg-config file
204
205* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
206- new upstream release
207- remove static libs
208
209* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
210- update %%post
211
212* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
213- add translated summary and description
214
215* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
216- new upstream release
217
218* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
219- add fc-query and fc-scan to %%files
220
221* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
222- new upstream release
223- update 59-morisawa-font-alias.conf
224
225* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
226- added compat32 package for x86_64 arch support
227
228* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
229- update 59-morisawa-font-alias.conf
230  - add FutoMin, FutoGo, Jun alias
231
232* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
233- new upstream release
234- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
235
236* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
237- add 10-prefer-ja-font.conf to prefer Japanese fonts.
238- add 59-morisawa-font-alias.conf
239  - bind Ryumin to serif and GothicBBB to sans-serif
240
241* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
242- add legacy font path for compatibility
243
244* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
245- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
246
247* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
248- initial build for Vine Linux
249  - splitted from XOrg package.
250
251* Thu Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
252- Update to 2.5.0.
253
254* Thu Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
255- Update to 2.4.92.
256- Mark /etc/fonts/conf.d/* as config(noreplace).
257- Remove most of our conf file, all upstreamed except for
258  75-blacklist-fedora.conf that I'm happily dropping.  Who has
259  Hershey fonts these days...
260- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
261- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
262  of conf that didn't end up upstream.  Can get rid of it in the
263  future, but not just yet.
264
265* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
266- Update to 2.4.91.
267- Add /usr/local/share/fonts to default config. (#147004)
268- Don't rebuild docs, to fix multilib conflicts. (#313011)
269- Remove docbook and elinks BuildRequires and stuff as we don't
270  rebuild docs.
271
272* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
273- Rebuild for PPC toolchain bug
274- Add BuildRequires: gawk
275
276* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
277- /etc/fonts/conf.d is now owned by filesystem
278
279* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
280- Add Liberation fonts to 30-aliases-fedora.conf
281
282* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
283- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
284- Resolves: #220809
285
286* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
287- Update to 2.4.2
288
289* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
290- Fix a multilib upgrade problem (#208151)
291
292* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
293- rebuilt for unwind info generation, broken in gcc-4.1.1-21
294
295* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
296- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
297  fonts. (#207460)
298
299* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
300- Update to 2.4.1, a public API was dropped from 2.4.0
301- Remove upstreamed patch
302
303* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
304- Update to 2.4.0
305- Rename/order our configuration stuff to match the new scheme.
306  Breaks expected :-(
307
308* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
309- Add missing file.  Previous update didn't go through
310
311* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
312- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
313
314* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
315- update to 2.3.97
316- Drop upstreamed patches
317- Regenerate defaultconfig patch
318- Don't touch stamp as it was not ever needed
319
320* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
321- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
322
323* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
324- use "%5x" instead of " %4x" to support 64k instead of
325  clamping.  Idea from Behdad.
326
327* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
328- tweak last patch to give a more reasonable page size
329  value if 64k page size is in effect.
330
331* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
332- maybe fix buffer overflow (bug 202152).
333
334* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
335- Update configs to provide better openoffice/staroffice
336  compatibility (bug 200723)
337
338* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
339- Do umask 0022 in post
340- Update configs to reflect addition of new Indic fonts (#200381, #200397)
341
342* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
343- Plug a small memory leak
344
345* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
346- rebuild
347
348* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
349- rebuild
350
351* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
352- Fix the handling of TTF font collections
353
354* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
355- Apply a patch by David Turner to speed up cache generation
356
357* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
358- fix fonts.conf typo
359
360* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
361- Update to 2.3.95
362
363* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
364- Update to 2.3.94
365
366* Wed Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
367- Newer cvs snapshot
368
369* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
370- bump again for double-long bug on ppc(64)
371
372* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
373- Newer cvs snapshot
374
375* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
376- Newer cvs snapshot
377- Drop upstreamed patches, pick up some new ones
378
379* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
380- rebuilt for new gcc4.1 snapshot and glibc changes
381
382* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
383- Move user cache to a subdirectory (bug 160275)
384
385* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
386- Accumulated patches
387
388* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
389- Newer cvs snapshot
390
391* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
392- Newer cvs snapshot
393
394* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
395- apply patch from Tim Mayberry to correct aliasing and disable
396  hinting for the two Chinese font names AR PL ShanHeiSun Uni
397  and AR PL Zenkai Uni
398
399* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
400- prereq coreutils for mkdir/touch in %%post
401
402* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
403- Fix to create /var/cache/fontconfig/stamp in the post install stage.
404
405* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
406- New upstream version.
407
408* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
409- Disable hinting for Lohit Gujarati
410
411* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
412- Add two new Chinese font names to the default fonts.conf file:
413        AR PL ShanHeiSun Uni
414        AR PL Zenkai Uni
415
416* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
417- rebuilt
418
419* Sat Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
420- Update to a newer cvs snapshot
421
422* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
423- Update to a newer cvs snapshot
424
425* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
426- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
427  /usr/share/X11/fonts, adjust %%configure accordingly and
428  conflict with older font packages
429
430* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
431- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
432  Fixes #172437
433
434* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
435- Update to 2.3.92
436
437* Fri Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
438- Update to a newer cvs snapshot
439- Add a patch which should help to understand broken cache problems
440
441* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
442- Add new Chinese fonts
443- Fix the 40-blacklist-fonts.conf file to use the documented
444  fonts.conf syntax, and exclude the Hershey fonts by family
445  name.
446
447* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
448- Update to the mmap branch of fontconfig
449
450* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
451- Update to fontconfig-2.3.2.  Drop
452
453        fontconfig-2.1-slighthint.patch,
454        fontconfig-2.2.3-timestamp.patch,
455        fontconfig-2.2.3-names.patch,
456        fontconfig-2.2.3-ta-pa-orth.patch, and
457        fontconfig-2.2.3-timestamp.patch,
458
459  as they are now merged upstream.
460
461- Fold fontconfig-2.2.3-add-sazanami.patch into
462  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
463  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
464
465- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
466  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
467
468- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
469  .rpmsave files.
470
471- Renable s390 documentation now that #97079 has been fixed and add
472  BuildRequires: for docbook-utils and docbook-utils-pdf.
473
474- Drop code to iconv and custom install man pages, upstream does the
475  right thing now.
476
477- Add workaround from hell to make elinks cooperate so we can build
478  txt documentation.
479
480* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
481- Add another font family name Sazanami Gothic/Mincho (#148748)
482
483* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
484- Rebuild
485
486* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
487- Rebuild
488
489* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
490- Rebuild
491
492* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
493- Disable docs for s390 for now
494
495* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
496- Rebuild
497
498* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
499- Sleep a second before the exit of fc-cache to fix problems with fast
500  serial installs of fonts (#140335)
501- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
502
503* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
504- Add Lohit fonts for Indic languages (#134492)
505- Add Punjabi converage, fix Tamil coverage
506
507* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
508- Update fonts-hebrew names to include CLM suffix
509
510* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
511- Backport code from head branch of fontconfig CVS to parse names
512  for postscript fonts (fixes #127500, J. J. Ramsey)
513- Own /usr/share/fonts (#110956, David K. Levine)
514- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
515
516* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
517- Don't run fc-cache if the binary isn't there (#128072, tracked
518  down by Jay Turner)
519
520* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
521- Upgrade to 2.2.3
522- Convert man pages to UTF-8 (#108730, Peter van Egdom)
523- Renable docs on s390
524
525* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
526- Rebuild for RHEL
527- Back freetype required version down to 2.1.4
528
529* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
530- rebuilt
531
532* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
533- Require recent freetype (#109592, Peter Oliver)
534- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
535- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
536
537* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
538- Rebuild
539
540* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
541- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
542  as non-preferred alternatives for Sans/Serif/Monospace
543- Fix FreeType includes for recent FreeType
544
545* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
546- rebuilt
547
548* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
549- rebuilt
550
551* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
552- Should have been passing --with-add-fonts, not --with-add-dirs to
553  configure ... caused wrong version of Luxi to be used. (#100862)
554
555* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
556- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
557
558* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
559- handle null config->cache correctly
560
561* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
562- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
563
564* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
565- As a workaround disable doc builds on s390
566
567* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
568- Version 2.2.1
569
570* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
571- rebuilt
572
573* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
574- debuginfo rebuild
575
576* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
577- Fix segfault in fc-cache from .dircache patch
578
579* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
580- Back out patch that wrote fonts.conf entries that crash RH-8.0
581  gnome-terminal, go with patch from fontconfig CVS instead.
582  (#84863)
583
584* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
585- Move fontconfig man page to main package, since it contains non-devel
586  information (#76189)
587- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
588  so we find Syriac fonts (#82627)
589
590* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
591- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
592  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
593  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
594
595* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
596- rebuilt
597
598* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
599- Try a different tack when fixing cache problem
600
601* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
602- Try to fix bug where empty cache entries would be found in
603  ~/.fonts.cache-1 during scanning (#81335)
604
605* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
606- Updated to version 2.1
607- Updated slighthint patch to fontconfig-2.1-slighthint.patch
608- Updated freetype version required to 2.1.2-7
609
610* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
611- Version 2.0
612- Correct capitalization/spacing for ZYSong18030 name (#73272)
613
614* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
615- Blacklist fonts from ghostscript-fonts that don't render correctly
616
617* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
618- Upgrade to fcpackage rc3
619- Fix bug in comparisons for xx_XX language tags
620- Compensate for a minor config file change in rc3
621
622* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
623- Add an explicit PreReq for freetype
624- Move fonts we don't ship to the end of the fonts.conf aliases so
625  installing them doesn't change the look.
626
627* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
628- Memory leak fix when parsing config files
629- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
630- Fix some groff warnings for fontconfig.man (#72138)
631
632* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
633- Try once more to get the right default Sans-serif font :-(
634- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
635
636* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
637- Fix %%post
638
639* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
640- Fix lost Luxi Sans default
641
642* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
643- Upgrade to rc2
644- Turn off hinting for all CJK fonts
645- Fix typo in %%post
646- Remove the custom language tag stuff in favor of Keith's standard
647  solution.
648
649* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
650- Prefer Luxi Sans to Nimbus Sans again
651
652* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
653- Add FC_HINT_STYLE to FcBaseObjectTypes
654- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
655- Add ZYSong18030 to aliases (#68428)
656
657* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
658- Fix a typo in the langtag patch (caught by Erik van der Poel)
659
660* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
661- Add FC_HINT_STYLE tag
662
663* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
664- New upstream version, with fix for problems with
665  ghostscript-fonts (Fonts don't work for Qt+CJK,
666  etc.)
667
668* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
669- New upstream version, fixing locale problem
670
671* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
672- Add a hack where we set the "language" fontconfig property based on the locale, then
673  we conditionalize base on that in the fonts.conf file.
674
675* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
676- New upstream version
677
678* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
679- Fix crash from FcObjectSetAdd
680
681* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
682- make fonts.conf %%config, not %%config(noreplace)
683- Another try at the CJK aliases
684- Add some CJK fonts to the config
685- Prefer Luxi Mono to Nimbus Mono
686
687* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
688- New upstream version
689- Fix matching for bitmap fonts
690
691* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
692- New version, new upstream mega-tarball
693
694* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
695- Fix problem with FcConfigSort
696
697* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
698- Initial specfile
699
Note: See TracBrowser for help on using the repository browser.