source: projects/specs/trunk/f/fontconfig/fontconfig-vl.spec @ 5316

Revision 5316, 23.1 KB checked in by Takemikaduchi, 12 years ago (diff)

mate: change category
fontconfig: rebuild
others: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define freetype_version 2.4.8
3
4Summary: Font configuration and customization library
5Summary(ja): フォント設定/カスタマイズライブラリ
6Name: fontconfig
7Version: 2.8.0
8Release: 3%{?_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://fontconfig.org/
12
13Source: http://fontconfig.org/release/fontconfig-%{version}.tar.gz
14Source10: 70-prefer-ja-font.conf
15Source11: 59-morisawa-font-alias.conf
16
17Patch1: fontconfig-2.2.1-AppleRoman-DynaFont.patch
18Patch4: fontconfig-2.3.2-subst-ja-font.patch
19Patch10: fontconfig-2.6.0-vine.patch
20
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: gawk
24BuildRequires: expat-devel
25BuildRequires: freetype2-devel >= %{freetype_version}
26BuildRequires: perl
27
28Requires(pre): freetype2 >= %{freetype_version}, coreutils
29Conflicts: XOrg-libs <= 6.9.0
30Obsoletes: XOrg-libs <= 6.9.0
31Conflicts: XOrg-font-utils <= 6.9.0
32Obsoletes: XOrg-font-utils <= 6.9.0
33
34%description
35Fontconfig is designed to locate fonts within the
36system and select them according to requirements specified by
37applications.
38
39%description -l ja
40Fontconfig は、システム内のフォントを把握し、アプリケーション
41が指定した要求に応じてそれらを選択するためのライブラリです。
42
43%package devel
44Summary: Development files for %{name}
45Summary(ja): Fontconfig の開発ファイル
46Group: Development/Libraries
47Requires: fontconfig = %{version}-%{release}
48Requires: freetype2-devel >= %{freetype_version}
49Requires: pkgconfig
50Conflicts: XOrg-devel <= 6.9.0
51Obsoletes: XOrg-devel <= 6.9.0
52
53%description devel
54The fontconfig-devel package includes the header files,
55and developer docs for the fontconfig package.
56
57%description -l ja devel
58fontconfig-devel パッケージには fontconfig を使ったソフトウエア
59を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
60ントが含まれています。
61
62# compat32
63%package -n compat32-%{name}
64Summary: Font configuration and customization library
65Summary(ja): フォント設定/カスタマイズライブラリ
66Group: System Environment/Libraries
67
68%description -n compat32-%{name}
69Fontconfig is designed to locate fonts within the
70system and select them according to requirements specified by
71applications.
72
73%description -l ja -n compat32-%{name}
74Fontconfig は、システム内のフォントを把握し、アプリケーション
75が指定した要求に応じてそれらを選択するためのライブラリです。
76
77%package -n compat32-%{name}-devel
78Summary: Font configuration and customization library
79Group: Development/Libraries
80Requires: compat32-%{name} = %{version}-%{release}
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-freetype2-devel >= %{freetype_version}
83
84%description -n compat32-%{name}-devel
85The fontconfig-devel package includes the header files,
86and developer docs for the fontconfig package.
87
88%description -l ja -n compat32-%{name}-devel
89fontconfig-devel パッケージには fontconfig を使ったソフトウエア
90を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
91ントが含まれています。
92
93%prep
94%setup -q
95%patch1 -p1 -b .fontconfig-AppleRoman-DynaFont
96%patch4 -p1 -b .subst-ja-font
97%patch10 -p1 -b .vine
98
99%build
100
101# We don't want to rebuild the docs, but we want to install the included ones.
102export HASDOCBOOK=no
103
104%configure \
105  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
106
107%__make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%__make install DESTDIR=$RPM_BUILD_ROOT
113
114ln -s ../conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
115
116install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
117for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
118do
119  ln -sf ../conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
120done
121
122# move installed doc files back to build directory to package themm
123# in the right place
124mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
125rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
126
127# All font packages depend on this package, so we create
128# and own /usr/share/fonts
129mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
130
131# Remove unpackaged files
132rm $RPM_BUILD_ROOT%{_libdir}/*.la
133rm $RPM_BUILD_ROOT%{_libdir}/*.a
134
135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%post
139/sbin/ldconfig
140umask 0022
141# Remove stale caches
142rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
143HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
144
145
146%postun -p /sbin/ldconfig
147
148%post -n compat32-%{name} -p /sbin/ldconfig
149
150%postun -n compat32-%{name} -p /sbin/ldconfig
151
152%files
153%defattr(-, root, root)
154%doc README AUTHORS COPYING
155%doc fontconfig-user.txt fontconfig-user.html
156%{_libdir}/libfontconfig.so.*
157%{_bindir}/fc-cache
158%{_bindir}/fc-list
159%{_bindir}/fc-match
160%{_bindir}/fc-cat
161%{_bindir}/fc-query
162%{_bindir}/fc-scan
163%dir %{_sysconfdir}/fonts/conf.avail
164%dir %{_datadir}/fonts
165%{_sysconfdir}/fonts/fonts.dtd
166%config %{_sysconfdir}/fonts/fonts.conf
167%doc %{_sysconfdir}/fonts/conf.d/README
168%config %{_sysconfdir}/fonts/conf.avail/*.conf
169%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
170%dir %{_localstatedir}/cache/fontconfig
171
172%{_mandir}/man1/*
173%{_mandir}/man5/*
174
175%files devel
176%defattr(-, root, root)
177%doc fontconfig-devel.txt fontconfig-devel
178%{_libdir}/libfontconfig.so
179%{_libdir}/pkgconfig/*
180%{_includedir}/fontconfig
181%{_mandir}/man3/*
182
183# compat32
184%if %{build_compat32}
185%files -n compat32-%{name}
186%defattr(-, root, root)
187%{_libdir}/libfontconfig.so.*
188
189%files -n compat32-%{name}-devel
190%defattr(-, root, root)
191%{_libdir}/libfontconfig.so
192%{_libdir}/pkgconfig/*
193%endif
194
195%changelog
196* Sat Dec 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
197- rebuild with freetype2-2.4.8
198
199* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.0-2
200- build with rpm-4.8.1-1 for pkg-config file
201
202* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
203- new upstream release
204- remove static libs
205
206* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
207- update %%post
208
209* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
210- add translated summary and description
211
212* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
213- new upstream release
214
215* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
216- add fc-query and fc-scan to %%files
217
218* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
219- new upstream release
220- update 59-morisawa-font-alias.conf
221
222* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
223- added compat32 package for x86_64 arch support
224
225* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
226- update 59-morisawa-font-alias.conf
227  - add FutoMin, FutoGo, Jun alias
228
229* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
230- new upstream release
231- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
232
233* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
234- add 10-prefer-ja-font.conf to prefer Japanese fonts.
235- add 59-morisawa-font-alias.conf
236  - bind Ryumin to serif and GothicBBB to sans-serif
237
238* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
239- add legacy font path for compatibility
240
241* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
242- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
243
244* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
245- initial build for Vine Linux
246  - splitted from XOrg package.
247
248* Thu Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
249- Update to 2.5.0.
250
251* Thu Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
252- Update to 2.4.92.
253- Mark /etc/fonts/conf.d/* as config(noreplace).
254- Remove most of our conf file, all upstreamed except for
255  75-blacklist-fedora.conf that I'm happily dropping.  Who has
256  Hershey fonts these days...
257- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
258- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
259  of conf that didn't end up upstream.  Can get rid of it in the
260  future, but not just yet.
261
262* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
263- Update to 2.4.91.
264- Add /usr/local/share/fonts to default config. (#147004)
265- Don't rebuild docs, to fix multilib conflicts. (#313011)
266- Remove docbook and elinks BuildRequires and stuff as we don't
267  rebuild docs.
268
269* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
270- Rebuild for PPC toolchain bug
271- Add BuildRequires: gawk
272
273* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
274- /etc/fonts/conf.d is now owned by filesystem
275
276* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
277- Add Liberation fonts to 30-aliases-fedora.conf
278
279* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
280- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
281- Resolves: #220809
282
283* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
284- Update to 2.4.2
285
286* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
287- Fix a multilib upgrade problem (#208151)
288
289* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
290- rebuilt for unwind info generation, broken in gcc-4.1.1-21
291
292* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
293- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
294  fonts. (#207460)
295
296* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
297- Update to 2.4.1, a public API was dropped from 2.4.0
298- Remove upstreamed patch
299
300* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
301- Update to 2.4.0
302- Rename/order our configuration stuff to match the new scheme.
303  Breaks expected :-(
304
305* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
306- Add missing file.  Previous update didn't go through
307
308* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
309- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
310
311* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
312- update to 2.3.97
313- Drop upstreamed patches
314- Regenerate defaultconfig patch
315- Don't touch stamp as it was not ever needed
316
317* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
318- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
319
320* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
321- use "%5x" instead of " %4x" to support 64k instead of
322  clamping.  Idea from Behdad.
323
324* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
325- tweak last patch to give a more reasonable page size
326  value if 64k page size is in effect.
327
328* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
329- maybe fix buffer overflow (bug 202152).
330
331* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
332- Update configs to provide better openoffice/staroffice
333  compatibility (bug 200723)
334
335* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
336- Do umask 0022 in post
337- Update configs to reflect addition of new Indic fonts (#200381, #200397)
338
339* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
340- Plug a small memory leak
341
342* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
343- rebuild
344
345* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
346- rebuild
347
348* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
349- Fix the handling of TTF font collections
350
351* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
352- Apply a patch by David Turner to speed up cache generation
353
354* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
355- fix fonts.conf typo
356
357* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
358- Update to 2.3.95
359
360* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
361- Update to 2.3.94
362
363* Wed Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
364- Newer cvs snapshot
365
366* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
367- bump again for double-long bug on ppc(64)
368
369* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
370- Newer cvs snapshot
371
372* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
373- Newer cvs snapshot
374- Drop upstreamed patches, pick up some new ones
375
376* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
377- rebuilt for new gcc4.1 snapshot and glibc changes
378
379* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
380- Move user cache to a subdirectory (bug 160275)
381
382* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
383- Accumulated patches
384
385* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
386- Newer cvs snapshot
387
388* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
389- Newer cvs snapshot
390
391* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
392- apply patch from Tim Mayberry to correct aliasing and disable
393  hinting for the two Chinese font names AR PL ShanHeiSun Uni
394  and AR PL Zenkai Uni
395
396* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
397- prereq coreutils for mkdir/touch in %%post
398
399* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
400- Fix to create /var/cache/fontconfig/stamp in the post install stage.
401
402* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
403- New upstream version.
404
405* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
406- Disable hinting for Lohit Gujarati
407
408* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
409- Add two new Chinese font names to the default fonts.conf file:
410        AR PL ShanHeiSun Uni
411        AR PL Zenkai Uni
412
413* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
414- rebuilt
415
416* Sat Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
417- Update to a newer cvs snapshot
418
419* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
420- Update to a newer cvs snapshot
421
422* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
423- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
424  /usr/share/X11/fonts, adjust %%configure accordingly and
425  conflict with older font packages
426
427* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
428- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
429  Fixes #172437
430
431* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
432- Update to 2.3.92
433
434* Fri Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
435- Update to a newer cvs snapshot
436- Add a patch which should help to understand broken cache problems
437
438* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
439- Add new Chinese fonts
440- Fix the 40-blacklist-fonts.conf file to use the documented
441  fonts.conf syntax, and exclude the Hershey fonts by family
442  name.
443
444* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
445- Update to the mmap branch of fontconfig
446
447* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
448- Update to fontconfig-2.3.2.  Drop
449
450        fontconfig-2.1-slighthint.patch,
451        fontconfig-2.2.3-timestamp.patch,
452        fontconfig-2.2.3-names.patch,
453        fontconfig-2.2.3-ta-pa-orth.patch, and
454        fontconfig-2.2.3-timestamp.patch,
455
456  as they are now merged upstream.
457
458- Fold fontconfig-2.2.3-add-sazanami.patch into
459  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
460  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
461
462- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
463  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
464
465- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
466  .rpmsave files.
467
468- Renable s390 documentation now that #97079 has been fixed and add
469  BuildRequires: for docbook-utils and docbook-utils-pdf.
470
471- Drop code to iconv and custom install man pages, upstream does the
472  right thing now.
473
474- Add workaround from hell to make elinks cooperate so we can build
475  txt documentation.
476
477* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
478- Add another font family name Sazanami Gothic/Mincho (#148748)
479
480* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
481- Rebuild
482
483* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
484- Rebuild
485
486* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
487- Rebuild
488
489* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
490- Disable docs for s390 for now
491
492* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
493- Rebuild
494
495* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
496- Sleep a second before the exit of fc-cache to fix problems with fast
497  serial installs of fonts (#140335)
498- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
499
500* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
501- Add Lohit fonts for Indic languages (#134492)
502- Add Punjabi converage, fix Tamil coverage
503
504* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
505- Update fonts-hebrew names to include CLM suffix
506
507* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
508- Backport code from head branch of fontconfig CVS to parse names
509  for postscript fonts (fixes #127500, J. J. Ramsey)
510- Own /usr/share/fonts (#110956, David K. Levine)
511- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
512
513* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
514- Don't run fc-cache if the binary isn't there (#128072, tracked
515  down by Jay Turner)
516
517* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
518- Upgrade to 2.2.3
519- Convert man pages to UTF-8 (#108730, Peter van Egdom)
520- Renable docs on s390
521
522* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
523- Rebuild for RHEL
524- Back freetype required version down to 2.1.4
525
526* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
527- rebuilt
528
529* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
530- Require recent freetype (#109592, Peter Oliver)
531- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
532- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
533
534* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
535- Rebuild
536
537* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
538- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
539  as non-preferred alternatives for Sans/Serif/Monospace
540- Fix FreeType includes for recent FreeType
541
542* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
543- rebuilt
544
545* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
546- rebuilt
547
548* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
549- Should have been passing --with-add-fonts, not --with-add-dirs to
550  configure ... caused wrong version of Luxi to be used. (#100862)
551
552* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
553- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
554
555* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
556- handle null config->cache correctly
557
558* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
559- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
560
561* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
562- As a workaround disable doc builds on s390
563
564* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
565- Version 2.2.1
566
567* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
568- rebuilt
569
570* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
571- debuginfo rebuild
572
573* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
574- Fix segfault in fc-cache from .dircache patch
575
576* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
577- Back out patch that wrote fonts.conf entries that crash RH-8.0
578  gnome-terminal, go with patch from fontconfig CVS instead.
579  (#84863)
580
581* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
582- Move fontconfig man page to main package, since it contains non-devel
583  information (#76189)
584- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
585  so we find Syriac fonts (#82627)
586
587* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
588- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
589  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
590  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
591
592* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
593- rebuilt
594
595* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
596- Try a different tack when fixing cache problem
597
598* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
599- Try to fix bug where empty cache entries would be found in
600  ~/.fonts.cache-1 during scanning (#81335)
601
602* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
603- Updated to version 2.1
604- Updated slighthint patch to fontconfig-2.1-slighthint.patch
605- Updated freetype version required to 2.1.2-7
606
607* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
608- Version 2.0
609- Correct capitalization/spacing for ZYSong18030 name (#73272)
610
611* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
612- Blacklist fonts from ghostscript-fonts that don't render correctly
613
614* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
615- Upgrade to fcpackage rc3
616- Fix bug in comparisons for xx_XX language tags
617- Compensate for a minor config file change in rc3
618
619* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
620- Add an explicit PreReq for freetype
621- Move fonts we don't ship to the end of the fonts.conf aliases so
622  installing them doesn't change the look.
623
624* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
625- Memory leak fix when parsing config files
626- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
627- Fix some groff warnings for fontconfig.man (#72138)
628
629* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
630- Try once more to get the right default Sans-serif font :-(
631- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
632
633* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
634- Fix %%post
635
636* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
637- Fix lost Luxi Sans default
638
639* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
640- Upgrade to rc2
641- Turn off hinting for all CJK fonts
642- Fix typo in %%post
643- Remove the custom language tag stuff in favor of Keith's standard
644  solution.
645
646* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
647- Prefer Luxi Sans to Nimbus Sans again
648
649* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
650- Add FC_HINT_STYLE to FcBaseObjectTypes
651- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
652- Add ZYSong18030 to aliases (#68428)
653
654* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
655- Fix a typo in the langtag patch (caught by Erik van der Poel)
656
657* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
658- Add FC_HINT_STYLE tag
659
660* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
661- New upstream version, with fix for problems with
662  ghostscript-fonts (Fonts don't work for Qt+CJK,
663  etc.)
664
665* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
666- New upstream version, fixing locale problem
667
668* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
669- Add a hack where we set the "language" fontconfig property based on the locale, then
670  we conditionalize base on that in the fonts.conf file.
671
672* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
673- New upstream version
674
675* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
676- Fix crash from FcObjectSetAdd
677
678* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
679- make fonts.conf %%config, not %%config(noreplace)
680- Another try at the CJK aliases
681- Add some CJK fonts to the config
682- Prefer Luxi Mono to Nimbus Mono
683
684* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
685- New upstream version
686- Fix matching for bitmap fonts
687
688* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
689- New version, new upstream mega-tarball
690
691* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
692- Fix problem with FcConfigSort
693
694* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
695- Initial specfile
696
Note: See TracBrowser for help on using the repository browser.