source: projects/specs/trunk/f/fontconfig/fontconfig-vl.spec @ 7633

Revision 7633, 23.2 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define freetype_version 2.4.11
3
4Summary: Font configuration and customization library
5Summary(ja): フォント設定/カスタマイズライブラリ
6Name: fontconfig
7Version: 2.10.92
8Release: 1%{?_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://fontconfig.org/
12
13Source: http://fontconfig.org/release/fontconfig-%{version}.tar.bz2
14Source10: 70-prefer-ja-font.conf
15Source11: 59-morisawa-font-alias.conf
16
17Patch4: fontconfig-2.3.2-subst-ja-font.patch
18Patch10: fontconfig-2.6.0-vine.patch
19
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: gawk
23BuildRequires: expat-devel
24BuildRequires: freetype2-devel >= %{freetype_version}
25BuildRequires: perl
26
27Requires(pre): freetype2 >= %{freetype_version}, coreutils
28Conflicts: XOrg-libs <= 6.9.0
29Obsoletes: XOrg-libs <= 6.9.0
30Conflicts: XOrg-font-utils <= 6.9.0
31Obsoletes: XOrg-font-utils <= 6.9.0
32
33%description
34Fontconfig is designed to locate fonts within the
35system and select them according to requirements specified by
36applications.
37
38%description -l ja
39Fontconfig は、システム内のフォントを把握し、アプリケーション
40が指定した要求に応じてそれらを選択するためのライブラリです。
41
42%package devel
43Summary: Development files for %{name}
44Summary(ja): Fontconfig の開発ファイル
45Group: Development/Libraries
46Requires: fontconfig = %{version}-%{release}
47Requires: freetype2-devel >= %{freetype_version}
48Requires: expat-devel
49Requires: pkgconfig
50Conflicts: XOrg-devel <= 6.9.0
51Obsoletes: XOrg-devel <= 6.9.0
52
53%description devel
54The fontconfig-devel package includes the header files,
55and developer docs for the fontconfig package.
56
57%description -l ja devel
58fontconfig-devel パッケージには fontconfig を使ったソフトウエア
59を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
60ントが含まれています。
61
62# compat32
63%package -n compat32-%{name}
64Summary: Font configuration and customization library
65Summary(ja): フォント設定/カスタマイズライブラリ
66Group: System Environment/Libraries
67
68%description -n compat32-%{name}
69Fontconfig is designed to locate fonts within the
70system and select them according to requirements specified by
71applications.
72
73%description -l ja -n compat32-%{name}
74Fontconfig は、システム内のフォントを把握し、アプリケーション
75が指定した要求に応じてそれらを選択するためのライブラリです。
76
77%package -n compat32-%{name}-devel
78Summary: Font configuration and customization library
79Group: Development/Libraries
80Requires: compat32-%{name} = %{version}-%{release}
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-freetype2-devel >= %{freetype_version}
83Requires: compat32-expat-devel
84
85%description -n compat32-%{name}-devel
86The fontconfig-devel package includes the header files,
87and developer docs for the fontconfig package.
88
89%description -l ja -n compat32-%{name}-devel
90fontconfig-devel パッケージには fontconfig を使ったソフトウエア
91を開発するために必要なヘッダファイルやライブラリ、開発用ドキュメ
92ントが含まれています。
93
94%prep
95%setup -q
96%patch4 -p1 -b .subst-ja-font
97%patch10 -p1 -b .vine
98
99%build
100
101# We don't want to rebuild the docs, but we want to install the included ones.
102export HASDOCBOOK=no
103
104%configure \
105  --with-add-fonts=/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/TTF,/usr/local/share/fonts
106
107%__make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111
112%__make install DESTDIR=$RPM_BUILD_ROOT
113
114#ln -s ../conf.avail/25-unhint-nonlatin.conf $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.d
115#install -m664 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
116for i in 70-prefer-ja-font.conf 59-morisawa-font-alias.conf
117do
118  ln -sf ../conf.avail/$i $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
119done
120
121# move installed doc files back to build directory to package themm
122# in the right place
123mv $RPM_BUILD_ROOT%{_docdir}/fontconfig/* .
124rmdir $RPM_BUILD_ROOT%{_docdir}/fontconfig/
125
126# All font packages depend on this package, so we create
127# and own /usr/share/fonts
128mkdir -p $RPM_BUILD_ROOT%{_datadir}/fonts
129
130# Remove unpackaged files
131rm $RPM_BUILD_ROOT%{_libdir}/*.la
132rm $RPM_BUILD_ROOT%{_libdir}/*.a
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post
138/sbin/ldconfig
139umask 0022
140# Remove stale caches
141rm -f %{_localstatedir}/cache/fontconfig/????????????????????????????????-*.cache-2
142HOME=/root /usr/bin/fc-cache -f -s >& /dev/null
143
144
145%postun -p /sbin/ldconfig
146
147%post -n compat32-%{name} -p /sbin/ldconfig
148
149%postun -n compat32-%{name} -p /sbin/ldconfig
150
151%files
152%defattr(-, root, root)
153%doc README AUTHORS COPYING
154%doc fontconfig-user.txt fontconfig-user.html
155%doc %{_sysconfdir}/fonts/conf.d/README
156%{_libdir}/libfontconfig.so.*
157%{_bindir}/fc-cache
158%{_bindir}/fc-list
159%{_bindir}/fc-match
160%{_bindir}/fc-cat
161%{_bindir}/fc-query
162%{_bindir}/fc-scan
163%{_bindir}/fc-pattern
164%{_bindir}/fc-validate
165%dir %{_datadir}/fonts
166%{_datadir}/%{name}
167%{_datadir}/xml/%{name}/fonts.dtd
168%config %{_sysconfdir}/fonts/fonts.conf
169%config(noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
170%dir %{_localstatedir}/cache/fontconfig
171
172%{_mandir}/man1/*
173%{_mandir}/man5/*
174
175%files devel
176%defattr(-, root, root)
177%doc fontconfig-devel.txt fontconfig-devel
178%{_libdir}/libfontconfig.so
179%{_libdir}/pkgconfig/*
180%{_includedir}/fontconfig
181%{_mandir}/man3/*
182
183# compat32
184%if %{build_compat32}
185%files -n compat32-%{name}
186%defattr(-, root, root)
187%{_libdir}/libfontconfig.so.*
188
189%files -n compat32-%{name}-devel
190%defattr(-, root, root)
191%{_libdir}/libfontconfig.so
192%{_libdir}/pkgconfig/*
193%endif
194
195%changelog
196* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.10.92-1
197- new upstream release
198- remove Patch1 (fontconfig-2.2.1-AppleRoman-DynaFont.patch)
199
200* Fri Dec 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
201- rebuild with freetype2-2.4.8
202- add Requires: expat-devel (-devel package)
203
204* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.0-2
205- build with rpm-4.8.1-1 for pkg-config file
206
207* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
208- new upstream release
209- remove static libs
210
211* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-3
212- update %%post
213
214* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-2
215- add translated summary and description
216
217* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.1-1
218- new upstream release
219
220* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-2
221- add fc-query and fc-scan to %%files
222
223* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
224- new upstream release
225- update 59-morisawa-font-alias.conf
226
227* Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.0-3
228- added compat32 package for x86_64 arch support
229
230* Tue Jan 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-2
231- update 59-morisawa-font-alias.conf
232  - add FutoMin, FutoGo, Jun alias
233
234* Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-1
235- new upstream release
236- rename 10-prefer-ja-font.conf to 70-prefer-ja-font.conf
237
238* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-3
239- add 10-prefer-ja-font.conf to prefer Japanese fonts.
240- add 59-morisawa-font-alias.conf
241  - bind Ryumin to serif and GothicBBB to sans-serif
242
243* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
244- add legacy font path for compatibility
245
246* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
247- add Conflits/Obsoletes: XOrg-font-utils <= 6.9.0
248
249* Mon Dec 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
250- initial build for Vine Linux
251  - splitted from XOrg package.
252
253* Tue Nov 13 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.5.0-1
254- Update to 2.5.0.
255
256* Tue Nov 06 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.92-1
257- Update to 2.4.92.
258- Mark /etc/fonts/conf.d/* as config(noreplace).
259- Remove most of our conf file, all upstreamed except for
260  75-blacklist-fedora.conf that I'm happily dropping.  Who has
261  Hershey fonts these days...
262- ln upstream'ed 25-unhint-nonlatin.conf from conf.avail in conf.d
263- Add 25-no-bitmap-fedora.conf which is the tiny remaining bit
264  of conf that didn't end up upstream.  Can get rid of it in the
265  future, but not just yet.
266
267* Thu Oct 25 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.91-1
268- Update to 2.4.91.
269- Add /usr/local/share/fonts to default config. (#147004)
270- Don't rebuild docs, to fix multilib conflicts. (#313011)
271- Remove docbook and elinks BuildRequires and stuff as we don't
272  rebuild docs.
273
274* Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 2.4.2-5
275- Rebuild for PPC toolchain bug
276- Add BuildRequires: gawk
277
278* Sun Jun 17 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-4
279- /etc/fonts/conf.d is now owned by filesystem
280
281* Fri May 11 2007 Matthias Clasen <mclasen@redhat.com> - 2.4.2-3
282- Add Liberation fonts to 30-aliases-fedora.conf
283
284* Fri Jan 12 2007 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.2-2
285- Change /usr/share/X11/fonts/OTF to /usr/share/X11/fonts/TTF
286- Resolves: #220809
287
288* Tue Dec  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.2-1
289- Update to 2.4.2
290
291* Wed Oct  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.4.1-4
292- Fix a multilib upgrade problem (#208151)
293
294* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-3
295- rebuilt for unwind info generation, broken in gcc-4.1.1-21
296
297* Fri Sep 22 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-2
298- Update 30-aliases-fedora.conf to correctly alias MS and StarOffice
299  fonts. (#207460)
300
301* Fri Sep 15 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.1-1
302- Update to 2.4.1, a public API was dropped from 2.4.0
303- Remove upstreamed patch
304
305* Mon Sep 11 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.4.0-1
306- Update to 2.4.0
307- Rename/order our configuration stuff to match the new scheme.
308  Breaks expected :-(
309
310* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-3
311- Add missing file.  Previous update didn't go through
312
313* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-2
314- Add fontconfig-2.3.97-ppc64.patch, for ppc64 arch signature
315
316* Thu Sep 07 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.97-1
317- update to 2.3.97
318- Drop upstreamed patches
319- Regenerate defaultconfig patch
320- Don't touch stamp as it was not ever needed
321
322* Thu Aug 17 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-11
323- inclusion of zhong yi font and rearranged font prefer list. (bug# 201300)
324
325* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-10
326- use "%5x" instead of " %4x" to support 64k instead of
327  clamping.  Idea from Behdad.
328
329* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-9
330- tweak last patch to give a more reasonable page size
331  value if 64k page size is in effect.
332
333* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-8
334- maybe fix buffer overflow (bug 202152).
335
336* Fri Aug 11 2006 Ray Strode <rstrode@redhat.com> - 2.3.95-7
337- Update configs to provide better openoffice/staroffice
338  compatibility (bug 200723)
339
340* Thu Jul 27 2006 Behdad Esfahbod <besfahbo@redhat.com> - 2.3.95-6
341- Do umask 0022 in post
342- Update configs to reflect addition of new Indic fonts (#200381, #200397)
343
344* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-5
345- Plug a small memory leak
346
347* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1.1
348- rebuild
349
350* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.3.95-4.1
351- rebuild
352
353* Fri Jun  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-4
354- Fix the handling of TTF font collections
355
356* Thu May 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-3
357- Apply a patch by David Turner to speed up cache generation
358
359* Wed Apr 26 2006 Bill Nottingham <notting@redhat.com> - 2.3.95-2
360- fix fonts.conf typo
361
362* Wed Apr 26 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.95-1
363- Update to 2.3.95
364
365* Fri Feb 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.94-1
366- Update to 2.3.94
367
368* Sat Feb 11 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060211-1
369- Newer cvs snapshot
370
371* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060208-1.1
372- bump again for double-long bug on ppc(64)
373
374* Wed Feb  8 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060208-1
375- Newer cvs snapshot
376
377* Tue Feb  7 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060207-1
378- Newer cvs snapshot
379- Drop upstreamed patches, pick up some new ones
380
381* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3.93.cvs20060131-3.1
382- rebuilt for new gcc4.1 snapshot and glibc changes
383
384* Thu Feb  2 2006 Ray Strode <rstrode@redhat.com> - 2.3.93.cvs20060131-3
385- Move user cache to a subdirectory (bug 160275)
386
387* Thu Feb  2 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-2
388- Accumulated patches
389
390* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060131-1
391- Newer cvs snapshot
392
393* Tue Jan 24 2006 Matthias Clasen <mclasen@redhat.com> - 2.3.93.cvs20060124-1
394- Newer cvs snapshot
395
396* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 2.3.93-4
397- apply patch from Tim Mayberry to correct aliasing and disable
398  hinting for the two Chinese font names AR PL ShanHeiSun Uni
399  and AR PL Zenkai Uni
400
401* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> - 2.3.93-3
402- prereq coreutils for mkdir/touch in %%post
403
404* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-2
405- Fix to create /var/cache/fontconfig/stamp in the post install stage.
406
407* Wed Dec 21 2005 Carl Worth <cworth@redhat.com> - 2.3.93-1
408- New upstream version.
409
410* Tue Dec 13 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-3
411- Disable hinting for Lohit Gujarati
412
413* Fri Dec  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92.cvs20051129-2
414- Add two new Chinese font names to the default fonts.conf file:
415        AR PL ShanHeiSun Uni
416        AR PL Zenkai Uni
417
418* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
419- rebuilt
420
421* Mon Nov 28 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051129-1
422- Update to a newer cvs snapshot
423
424* Sat Nov 19 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92.cvs20051119-1
425- Update to a newer cvs snapshot
426
427* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 2.3.93-3
428- modular X moved fonts from /usr/X11R6/lib/X11/fonts to
429  /usr/share/X11/fonts, adjust %%configure accordingly and
430  conflict with older font packages
431
432* Wed Nov  9 2005 Carl Worth <cworth@redhat.com> - 2.3.92-2
433- Remove inadvertent rejection of Luxi Mono from 40-blacklist-fonts.conf.
434  Fixes #172437
435
436* Fri Nov  4 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.92-1
437- Update to 2.3.92
438
439* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051031-1
440- Update to a newer cvs snapshot
441- Add a patch which should help to understand broken cache problems
442
443* Fri Oct 21 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-2
444- Add new Chinese fonts
445- Fix the 40-blacklist-fonts.conf file to use the documented
446  fonts.conf syntax, and exclude the Hershey fonts by family
447  name.
448
449* Fri Oct 14 2005 Matthias Clasen <mclasen@redhat.com> - 2.3.91.cvs20051017-1
450- Update to the mmap branch of fontconfig
451
452* Fri Jul 22 2005 Kristian H淡gsberg <krh@redhat.com> - 2.3.2-1
453- Update to fontconfig-2.3.2.  Drop
454
455        fontconfig-2.1-slighthint.patch,
456        fontconfig-2.2.3-timestamp.patch,
457        fontconfig-2.2.3-names.patch,
458        fontconfig-2.2.3-ta-pa-orth.patch, and
459        fontconfig-2.2.3-timestamp.patch,
460
461  as they are now merged upstream.
462
463- Fold fontconfig-2.2.3-add-sazanami.patch into
464  fontconfig-2.3.2-defaultconfig.patch and split rules to disable CJK
465  hinting out into /etc/fonts/conf.d/50-no-hint-fonts.conf.
466
467- Drop fontconfig-0.0.1.020826.1330-blacklist.patch and use the new
468  rejectfont directive to reject those fonts in 40-blacklist-fonts.conf.
469
470- Add fontconfig-2.3.2-only-parse-conf-files.patch to avoid parsing
471  .rpmsave files.
472
473- Renable s390 documentation now that #97079 has been fixed and add
474  BuildRequires: for docbook-utils and docbook-utils-pdf.
475
476- Drop code to iconv and custom install man pages, upstream does the
477  right thing now.
478
479- Add workaround from hell to make elinks cooperate so we can build
480  txt documentation.
481
482* Tue Apr 19 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-13
483- Add another font family name Sazanami Gothic/Mincho (#148748)
484
485* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-12
486- Rebuild
487
488* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-11
489- Rebuild
490
491* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-10
492- Rebuild
493
494* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-9
495- Disable docs for s390 for now
496
497* Fri Mar  4 2005 David Zeuthen <davidz@redhat.com> - 2.2.3-8
498- Rebuild
499
500* Wed Dec  1 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-6
501- Sleep a second before the exit of fc-cache to fix problems with fast
502  serial installs of fonts (#140335)
503- Turn off hinting for Lohit Hindi/Bengali/Punjabi (#139816)
504
505* Tue Oct 19 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-5
506- Add Lohit fonts for Indic languages (#134492)
507- Add Punjabi converage, fix Tamil coverage
508
509* Wed Sep 22 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-4
510- Update fonts-hebrew names to include CLM suffix
511
512* Thu Sep  2 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-3
513- Backport code from head branch of fontconfig CVS to parse names
514  for postscript fonts (fixes #127500, J. J. Ramsey)
515- Own /usr/share/fonts (#110956, David K. Levine)
516- Add KacstQura to serif/sans-serif/monospace aliases (#101182)
517
518* Mon Aug 16 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-2
519- Don't run fc-cache if the binary isn't there (#128072, tracked
520  down by Jay Turner)
521
522* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
523- Upgrade to 2.2.3
524- Convert man pages to UTF-8 (#108730, Peter van Egdom)
525- Renable docs on s390
526
527* Mon Jul 26 2004 Owen Taylor <otaylor@redhat.com> - 2.2.1-12
528- Rebuild for RHEL
529- Back freetype required version down to 2.1.4
530
531* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
532- rebuilt
533
534* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-10
535- Require recent freetype (#109592, Peter Oliver)
536- Remove fonts.conf timestamp to fix multiarch conflict (#118182)
537- Disable hinting for Mukti Narrow (#120915, Sayamindu Dasgupta)
538
539* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.1
540- Rebuild
541
542* Wed Mar 10 2004 Owen Taylor <otaylor@redhat.com> 2.2.1-8.0
543- Add Albany/Cumberland/Thorndale as fallbacks for Microsoft core fonts and
544  as non-preferred alternatives for Sans/Serif/Monospace
545- Fix FreeType includes for recent FreeType
546
547* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
548- rebuilt
549
550* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
551- rebuilt
552
553* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
554- Should have been passing --with-add-fonts, not --with-add-dirs to
555  configure ... caused wrong version of Luxi to be used. (#100862)
556
557* Fri Sep 19 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-5.0
558- Tweak fonts.conf to get right hinting for CJK fonts (#97337)
559
560* Tue Jun 17 2003 Bill Nottingham <notting@redhat.com> 2.2.1-3
561- handle null config->cache correctly
562
563* Thu Jun 12 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
564- Update default config to include Hebrew fonts (#90501, Dov Grobgeld)
565
566* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-2
567- As a workaround disable doc builds on s390
568
569* Mon Jun  9 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-1
570- Version 2.2.1
571
572* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
573- rebuilt
574
575* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
576- debuginfo rebuild
577
578* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com> 2.1-8
579- Fix segfault in fc-cache from .dircache patch
580
581* Mon Feb 24 2003 Owen Taylor <otaylor@redhat.com>
582- Back out patch that wrote fonts.conf entries that crash RH-8.0
583  gnome-terminal, go with patch from fontconfig CVS instead.
584  (#84863)
585
586* Tue Feb 11 2003 Owen Taylor <otaylor@redhat.com>
587- Move fontconfig man page to main package, since it contains non-devel
588  information (#76189)
589- Look in the OTF subdirectory of /usr/X11R6/lib/fonts as well
590  so we find Syriac fonts (#82627)
591
592* Thu Feb  6 2003 Matt Wilson <msw@redhat.com> 2.1-5
593- modified fontconfig-0.0.1.020626.1517-fontdir.patch to hard code
594  /usr/X11R6/lib/X11/fonts instead of using $(X_FONT_DIR).  This is
595  because on lib64 machines, fonts are not in /usr/X11R6/lib64/....
596
597* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
598- rebuilt
599
600* Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com>
601- Try a different tack when fixing cache problem
602
603* Tue Jan 14 2003 Owen Taylor <otaylor@redhat.com>
604- Try to fix bug where empty cache entries would be found in
605  ~/.fonts.cache-1 during scanning (#81335)
606
607* Thu Nov 21 2002 Mike A. Harris <mharris@redhat.com> 2.1-1
608- Updated to version 2.1
609- Updated slighthint patch to fontconfig-2.1-slighthint.patch
610- Updated freetype version required to 2.1.2-7
611
612* Mon Sep  2 2002 Owen Taylor <otaylor@redhat.com>
613- Version 2.0
614- Correct capitalization/spacing for ZYSong18030 name (#73272)
615
616* Fri Aug 30 2002 Owen Taylor <otaylor@redhat.com>
617- Blacklist fonts from ghostscript-fonts that don't render correctly
618
619* Mon Aug 26 2002 Owen Taylor <otaylor@redhat.com>
620- Upgrade to fcpackage rc3
621- Fix bug in comparisons for xx_XX language tags
622- Compensate for a minor config file change in rc3
623
624* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
625- Add an explicit PreReq for freetype
626- Move fonts we don't ship to the end of the fonts.conf aliases so
627  installing them doesn't change the look.
628
629* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
630- Memory leak fix when parsing config files
631- Set rh_prefer_bitmaps for .ja fonts to key off of in Xft
632- Fix some groff warnings for fontconfig.man (#72138)
633
634* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
635- Try once more to get the right default Sans-serif font :-(
636- Switch the Sans/Monospace aliases for Korean to Gulim, not Dotum
637
638* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
639- Fix %%post
640
641* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
642- Fix lost Luxi Sans default
643
644* Mon Aug 12 2002 Owen Taylor <otaylor@redhat.com>
645- Upgrade to rc2
646- Turn off hinting for all CJK fonts
647- Fix typo in %%post
648- Remove the custom language tag stuff in favor of Keith's standard
649  solution.
650
651* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
652- Prefer Luxi Sans to Nimbus Sans again
653
654* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
655- Add FC_HINT_STYLE to FcBaseObjectTypes
656- Switch Chinese fonts to always using Sung-ti / Ming-ti, and never Kai-ti
657- Add ZYSong18030 to aliases (#68428)
658
659* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
660- Fix a typo in the langtag patch (caught by Erik van der Poel)
661
662* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
663- Add FC_HINT_STYLE tag
664
665* Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
666- New upstream version, with fix for problems with
667  ghostscript-fonts (Fonts don't work for Qt+CJK,
668  etc.)
669
670* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
671- New upstream version, fixing locale problem
672
673* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
674- Add a hack where we set the "language" fontconfig property based on the locale, then
675  we conditionalize base on that in the fonts.conf file.
676
677* Sun Jun 23 2002 Owen Taylor <otaylor@redhat.com>
678- New upstream version
679
680* Tue Jun 18 2002 Owen Taylor <otaylor@redhat.com>
681- Fix crash from FcObjectSetAdd
682
683* Tue Jun 11 2002 Owen Taylor <otaylor@redhat.com>
684- make fonts.conf %%config, not %%config(noreplace)
685- Another try at the CJK aliases
686- Add some CJK fonts to the config
687- Prefer Luxi Mono to Nimbus Mono
688
689* Mon Jun 10 2002 Owen Taylor <otaylor@redhat.com>
690- New upstream version
691- Fix matching for bitmap fonts
692
693* Mon Jun  3 2002 Owen Taylor <otaylor@redhat.com>
694- New version, new upstream mega-tarball
695
696* Tue May 28 2002 Owen Taylor <otaylor@redhat.com>
697- Fix problem with FcConfigSort
698
699* Fri May 24 2002 Owen Taylor <otaylor@redhat.com>
700- Initial specfile
701
Note: See TracBrowser for help on using the repository browser.