source: projects/specs/trunk/e/expect/expect-vl.spec @ 9210

Revision 9210, 11.7 KB checked in by inagaki, 9 years ago (diff)

2015-01-01 Ryoichi INAGAKI <ryo1@…>

  • cjs, gjs: changed Group
  • expect, tclx, thread: updated
  • pclock, tix: rebuilt


Line 
1%{!?tcl_version: %define tcl_version %(echo 'puts $tcl_version' | tclsh)}
2%{!?tcl_sitearch: %define tcl_sitearch %{_libdir}/tcl%{tcl_version}}
3
4%define tcl_major 8.4
5%define majorver 5.45
6
7Summary: A Tcl/Tk development environment: expect
8Summary(ja): Tcl/Tk 開発環境: expect
9Name: expect
10Version: %{majorver}
11Release: 1%{?_dist_release}
12License: Public Domain
13Group: Development/Languages
14# URL: probably more useful is http://sourceforge.net/projects/expect/
15URL: http://expect.nist.gov/
16
17Source: http://downloads.sourceforge.net/%{name}/%{name}%{version}.tar.gz
18# Patch0: fixes change log file permissions
19Patch0: expect-5.43.0-log_file.patch
20# Patch1: fixes install location, change pkgIndex
21Patch1: expect-5.43.0-pkgpath.patch
22# Patch2: fixes minor man page formatting issue
23Patch2: expect-5.45-man-page.patch
24# Patch3: fixes segmentation fault during matching characters
25Patch3: expect-5.45-match-gt-numchars-segfault.patch
26# Patch4: fixes memory leak when using -re, http://sourceforge.net/p/expect/patches/13/
27Patch4: expect-5.45-re-memleak.patch
28# Patch5: use vsnprintf instead of vsprintf to avoid buffer overflow
29Patch5: expect-5.45-exp-log-buf-overflow.patch
30# Patch6: fixes segfaults if Tcl is built with stubs and Expect is used directly
31#   from C program rhbz#1091060
32Patch6: expect-5.45-segfault-with-stubs.patch
33# Patch7: fixes leaked fd, patch by Matej Mužila, rhbz#1001220
34Patch7: expect-5.45-fd-leak.patch
35# examples patches
36# Patch100: changes random function
37Patch100: expect-5.32.2-random.patch
38# Patch101: fixes bz674184 - mkpasswd fails randomly
39Patch101: expect-5.45-mkpasswd-dash.patch
40# Patch102: fixes bz703702 - let user know that telnet is needed for
41# running some examples
42Patch102: expect-5.45-check-telnet.patch
43# Patch103: use full path to 'su', it's safer
44Patch103: expect-5.45-passmass-su-full-path.patch
45# Patch104: rhbz 963889, fixes inaccuracy in mkpasswd man page
46Patch104: expect-5.45-mkpasswd-man.patch
47
48Buildroot: %{_tmppath}/%{name}-%{version}-root
49BuildRequires: tcl >= %{tcl_major}
50BuildRequires: tk >= %{tcl_major}
51BuildRequires: autoconf
52BuildRequires: chrpath
53BuildRequires: libX11-devel
54BuildRequires: libXft-devel
55
56Vendor: Project Vine
57Distribution: Vine Linux
58
59%description -n expect
60Expect is a tcl extension for automating interactive applications such
61as telnet, ftp, passwd, fsck, rlogin, tip, etc.  Expect is also useful
62for testing the named applications.  Expect makes it easy for a script
63to control another program and interact with it.
64
65Install the expect package if you'd like to develop scripts which interact
66with interactive applications.  You'll also need to install the tcl
67package.
68
69%package devel
70Summary: Development files for expect library.
71Summary(ja): expect ライブラリの開発用ファイル
72Group: Development/Libraries
73Requires: expect = %{version}-%{release}
74Obsoletes: expect <= 5.43-0vl4
75
76%description devel
77This package contains development files for the expect library.
78
79%package -n expectk
80Summary: A program-script interaction and testing utility
81Group: Development/Tools
82Requires: expect = %{version}-%{release}
83Obsoletes: expect <= 5.43-0vl4
84
85%description -n expectk
86This package originally contained expectk and some scripts
87that used it. As expectk was removed from upstream tarball
88in expect-5.45, now the package contains just these scripts.
89Please use tclsh with package require Tk and Expect instead
90of expectk.
91
92%prep
93%setup -q -n expect%{version}
94%patch0 -p1 -b .log_file
95%patch1 -p1 -b .pkgpath
96%patch2 -p1 -b .man-page
97%patch3 -p1 -b .match-gt-numchars-segfault
98%patch4 -p1 -b .re-memleak
99%patch5 -p1 -b .exp-log-buf-overflow
100%patch6 -p1 -b .segfault-with-stubs
101%patch7 -p1 -b .fd-leak
102# examples fixes
103%patch100 -p1 -b .random
104%patch101 -p1 -b .mkpasswd-dash
105%patch102 -p1 -b .check-telnet
106%patch103 -p1 -b .passmass-su-full-path
107%patch104 -p1 -b .mkpasswd-man
108# -pkgpath.patch touch configure.in
109aclocal
110autoconf
111( cd testsuite
112  autoconf -I.. )
113
114%build
115%configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
116        --with-tclinclude=%{_includedir}/tcl-private/generic
117make %{?_smp_mflags}
118
119%check
120make test
121
122%install
123rm -rf ${RPM_BUILD_ROOT}
124make install DESTDIR="$RPM_BUILD_ROOT"
125
126# move
127mv "$RPM_BUILD_ROOT"%{tcl_sitearch}/expect%{version}/libexpect%{version}.so "$RPM_BUILD_ROOT"%{_libdir}
128
129# for linking with -lexpect
130ln -s libexpect%{majorver}.1.15.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
131
132# remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
133rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
134rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
135rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
136
137# remove rpath
138chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libexpect%{version}.so
139
140
141%post -p /sbin/ldconfig -n expect
142
143%postun -p /sbin/ldconfig -n expect
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%files
149%%defattr(-,root,root)
150%doc FAQ HISTORY NEWS README
151%{_bindir}/expect
152%{_bindir}/autoexpect
153%{_bindir}/dislocate
154%{_bindir}/ftp-rfc
155%{_bindir}/kibitz
156%{_bindir}/lpunlock
157%{_bindir}/mkpasswd
158%{_bindir}/passmass
159%{_bindir}/rftp
160%{_bindir}/rlogin-cwd
161%{_bindir}/timed-read
162%{_bindir}/timed-run
163%{_bindir}/unbuffer
164%{_bindir}/weather
165%{_bindir}/xkibitz
166%dir %{tcl_sitearch}/expect%{version}
167%{tcl_sitearch}/expect%{version}/pkgIndex.tcl
168%{_libdir}/libexpect%{version}.so
169%{_mandir}/man1/autoexpect.1.gz
170%{_mandir}/man1/dislocate.1.gz
171%{_mandir}/man1/expect.1.gz
172%{_mandir}/man1/kibitz.1.gz
173%{_mandir}/man1/mkpasswd.1.gz
174%{_mandir}/man1/passmass.1.gz
175%{_mandir}/man1/tknewsbiff.1.gz
176%{_mandir}/man1/unbuffer.1.gz
177%{_mandir}/man1/xkibitz.1.gz
178
179%files devel
180%defattr(-,root,root,-)
181%{_libdir}/libexpect.so
182%{_mandir}/man3/libexpect.3*
183%{_includedir}/*
184
185%files -n expectk
186%defattr(-,root,root,-)
187%{_bindir}/multixterm
188%{_bindir}/tknewsbiff
189%{_bindir}/tkpasswd
190%{_bindir}/xpstat
191%{_mandir}/man1/multixterm.1*
192%{_mandir}/man1/tknewsbiff.1*
193
194
195%changelog
196* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.45-1
197- updated to 5.45
198- rebuilt with tcl/tk 8.5.15
199
200* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 5.44.1.15-1
201- update to 5.44.1.15:sync ed Hat Enterprise Linux 6 expect-5.44.1.15-4.el6
202- add BuildRequires: tk, chrpath
203- update License: Public Domain
204- drop obsolete patches
205 - random patch (Patch0)
206 - spawn-43310 patch (Patch6)
207 - setpgrp patch (Patch8)
208 - lib spec patch (Patch10)
209 - libdir patch (Patch11)
210- add some patches from RHEL expect-5.44.1.15-4.el6
211 - fixes log file permissions patch (Patch500)
212 - fixes install location patch (Patch501)
213 - tk init patch (Patch502)
214 - match gt numchars segfault patch (Patch503)
215 - man page patch (Patch504)
216 - random patch (Patch600)
217 - unbuffer exit code patch (Patch601)
218 - passmass su full path Patch (Patch602)
219- update build and install section: sync RHEL expect-5.44.1.15-4.el6
220- add Vendor and Distribution tags
221
222* Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
223- add missing BuildRequires: libX11-devel
224
225* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
226- rebuilt with rpm-4.8.1-3
227
228* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
229- rebuilt with tcl/tk-8.4.19-2
230
231* Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
232- rebuilt with new toolchain
233- changed devel Group to Development/Libraries
234
235* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
236- applied new versioning policy and spec in utf-8
237
238* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
239- rebuilt with tcl/tk-8.4.18
240
241* Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
242- split to expect-devel and expectk sub package.
243- add libexpect.so to expect-devel (<BTS:wishes:0136>)
244
245* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
246- rebuilt with tcl/tk-8.4.16
247
248* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
249- rebuilt with new toolchain
250
251* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
252- rebuild for tcl/tk-8.4.12
253- added --enable-64bit to configure's option
254
255* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
256- updated expect to 5.43.0
257- dropped expect-5.39.0-64bit-82547.patch (for fixed)
258- dropped expect-5.32.2-kibitz.patch (for fixed)
259- dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
260- rebuilt with tcl/tk 8.4.11
261
262* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
263- rebuild for tcl/tk-8.4.6
264
265* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
266- update based on fedora
267
268* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
269- update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
270
271* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
272- splite source package
273- add include files
274
275* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
276- expand some macros.. (FIXME)
277
278* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
279- use %configure macros
280- add Patch 47,50
281
282* Thu May 31 2001 <sagami@vinelinux.org>
283- 8.0.5_jp-10
284- unexpand old %%{configure}, new one causes build failure
285- fixed missing libtkx.so libtclx.so symlink in /usr/lib
286- install manpages into %%{_mandir} and mode 644
287
288* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
289- 8.0.5_jp-9
290- modified %install section to handle compressed man pages
291- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
292
293* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
294- changed default fonts
295
296* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
297- added defattr
298
299* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
300- added some symlinks, such as libtcl8.0.so.
301- obsoletes version number using _jp, now 8.0.5-31vl1
302
303* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
304- Apply Tcl/Tk 8.0 Japanese Patch 1.7
305
306* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
307- fix tclX symlinks.
308- compile on systems where SIGPWR == SIGLOST.
309
310* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
311- update tcl/tk to 8.0.5.
312- avoid "containing" in Tix (#2332).
313
314* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
315- use /usr/bin/write in kibitz (#1320).
316- use cirrus.sprl.umich.edu in weather (#1926).
317
318* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
319- auto rebuild in the new build environment (release 28)
320
321* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
322- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
323
324* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
325- expect does unaligned access on alpha (#989)
326- upgrade tcl/tk/tclX to 8.0.4
327- upgrade expect to 5.28.
328- add itcl 3.0.1
329
330* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
331- call libtoolize to allow building on the arm
332- build for glibc 2.1
333- strip binaries
334
335* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
336- update tcl/tk/tclX to 8.0.3, expect is updated also.
337
338* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
339- expect: mkpasswd needs delay before sending password (problem #576)
340
341* Thu May 07 1998 Prospector System <bugs@redhat.com>
342- translations modified for de, fr, tr
343
344* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
345- fixed expect binaries exec permissions
346
347* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
348- updated to Tix 4.1.0.006
349- updated version numbers of tcl/tk to relflect includsion of p2
350
351* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
352- updated tcl/tk to patch level 2
353- updated tclX to 8.0.2
354
355* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
356- fixed filelist for tix... replacing path to the expect binary in scripts
357  was leaving junk files around.
358
359* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
360- added patch to remove libieee test in configure.in for tcl and tk.
361  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
362  solution for all systems
363- fixed src urls
364
365* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
366- removed version numbers from descriptions
367
368* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
369- updated to tcl/tk 8.0 and related versions of packages
370
371* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
372- built against glibc
373- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.