source: projects/specs/trunk/e/expect/expect-vl.spec @ 9859

Revision 9859, 11.7 KB checked in by tomop, 8 years ago (diff)

expect-5.45-2

Line 
1%{!?tcl_version: %define tcl_version %(echo 'puts $tcl_version' | tclsh)}
2%{!?tcl_sitearch: %define tcl_sitearch %{_libdir}/tcl%{tcl_version}}
3
4%define tcl_major 8.4
5%define majorver 5.45
6
7Summary: A Tcl/Tk development environment: expect
8Summary(ja): Tcl/Tk 開発環境: expect
9Name: expect
10Version: %{majorver}
11Release: 2%{?_dist_release}
12License: Public Domain
13Group: Development/Languages
14# URL: probably more useful is http://sourceforge.net/projects/expect/
15URL: http://expect.nist.gov/
16
17Source: http://downloads.sourceforge.net/%{name}/%{name}%{version}.tar.gz
18# Patch0: fixes change log file permissions
19Patch0: expect-5.43.0-log_file.patch
20# Patch1: fixes install location, change pkgIndex
21Patch1: expect-5.43.0-pkgpath.patch
22# Patch2: fixes minor man page formatting issue
23Patch2: expect-5.45-man-page.patch
24# Patch3: fixes segmentation fault during matching characters
25Patch3: expect-5.45-match-gt-numchars-segfault.patch
26# Patch4: fixes memory leak when using -re, http://sourceforge.net/p/expect/patches/13/
27Patch4: expect-5.45-re-memleak.patch
28# Patch5: use vsnprintf instead of vsprintf to avoid buffer overflow
29Patch5: expect-5.45-exp-log-buf-overflow.patch
30# Patch6: fixes segfaults if Tcl is built with stubs and Expect is used directly
31#   from C program rhbz#1091060
32Patch6: expect-5.45-segfault-with-stubs.patch
33# Patch7: fixes leaked fd, patch by Matej Mužila, rhbz#1001220
34Patch7: expect-5.45-fd-leak.patch
35# examples patches
36# Patch100: changes random function
37Patch100: expect-5.32.2-random.patch
38# Patch101: fixes bz674184 - mkpasswd fails randomly
39Patch101: expect-5.45-mkpasswd-dash.patch
40# Patch102: fixes bz703702 - let user know that telnet is needed for
41# running some examples
42Patch102: expect-5.45-check-telnet.patch
43# Patch103: use full path to 'su', it's safer
44Patch103: expect-5.45-passmass-su-full-path.patch
45# Patch104: rhbz 963889, fixes inaccuracy in mkpasswd man page
46Patch104: expect-5.45-mkpasswd-man.patch
47
48Buildroot: %{_tmppath}/%{name}-%{version}-root
49BuildRequires: tk-devel >= %{tcl_major}
50BuildRequires: autoconf
51BuildRequires: chrpath
52BuildRequires: libX11-devel
53BuildRequires: libXft-devel
54
55Vendor: Project Vine
56Distribution: Vine Linux
57
58%description -n expect
59Expect is a tcl extension for automating interactive applications such
60as telnet, ftp, passwd, fsck, rlogin, tip, etc.  Expect is also useful
61for testing the named applications.  Expect makes it easy for a script
62to control another program and interact with it.
63
64Install the expect package if you'd like to develop scripts which interact
65with interactive applications.  You'll also need to install the tcl
66package.
67
68%package devel
69Summary: Development files for expect library.
70Summary(ja): expect ライブラリの開発用ファイル
71Group: Development/Libraries
72Requires: expect = %{version}-%{release}
73Obsoletes: expect <= 5.43-0vl4
74
75%description devel
76This package contains development files for the expect library.
77
78%package -n expectk
79Summary: A program-script interaction and testing utility
80Group: Development/Tools
81Requires: expect = %{version}-%{release}
82Obsoletes: expect <= 5.43-0vl4
83
84%description -n expectk
85This package originally contained expectk and some scripts
86that used it. As expectk was removed from upstream tarball
87in expect-5.45, now the package contains just these scripts.
88Please use tclsh with package require Tk and Expect instead
89of expectk.
90
91%prep
92%setup -q -n expect%{version}
93%patch0 -p1 -b .log_file
94%patch1 -p1 -b .pkgpath
95%patch2 -p1 -b .man-page
96%patch3 -p1 -b .match-gt-numchars-segfault
97%patch4 -p1 -b .re-memleak
98%patch5 -p1 -b .exp-log-buf-overflow
99%patch6 -p1 -b .segfault-with-stubs
100%patch7 -p1 -b .fd-leak
101# examples fixes
102%patch100 -p1 -b .random
103%patch101 -p1 -b .mkpasswd-dash
104%patch102 -p1 -b .check-telnet
105%patch103 -p1 -b .passmass-su-full-path
106%patch104 -p1 -b .mkpasswd-man
107# -pkgpath.patch touch configure.in
108aclocal
109autoconf
110( cd testsuite
111  autoconf -I.. )
112
113%build
114%configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
115        --with-tclinclude=%{_includedir}/tcl-private/generic
116make %{?_smp_mflags}
117
118%check
119make test
120
121%install
122rm -rf ${RPM_BUILD_ROOT}
123make install DESTDIR="$RPM_BUILD_ROOT"
124
125# move
126mv "$RPM_BUILD_ROOT"%{tcl_sitearch}/expect%{version}/libexpect%{version}.so "$RPM_BUILD_ROOT"%{_libdir}
127
128# for linking with -lexpect
129ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
130
131# remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
132rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
133rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
134rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
135
136# remove rpath
137chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libexpect%{version}.so
138
139
140%post -p /sbin/ldconfig -n expect
141
142%postun -p /sbin/ldconfig -n expect
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%files
148%%defattr(-,root,root)
149%doc FAQ HISTORY NEWS README
150%{_bindir}/expect
151%{_bindir}/autoexpect
152%{_bindir}/dislocate
153%{_bindir}/ftp-rfc
154%{_bindir}/kibitz
155%{_bindir}/lpunlock
156%{_bindir}/mkpasswd
157%{_bindir}/passmass
158%{_bindir}/rftp
159%{_bindir}/rlogin-cwd
160%{_bindir}/timed-read
161%{_bindir}/timed-run
162%{_bindir}/unbuffer
163%{_bindir}/weather
164%{_bindir}/xkibitz
165%dir %{tcl_sitearch}/expect%{version}
166%{tcl_sitearch}/expect%{version}/pkgIndex.tcl
167%{_libdir}/libexpect%{version}.so
168%{_mandir}/man1/autoexpect.1.gz
169%{_mandir}/man1/dislocate.1.gz
170%{_mandir}/man1/expect.1.gz
171%{_mandir}/man1/kibitz.1.gz
172%{_mandir}/man1/mkpasswd.1.gz
173%{_mandir}/man1/passmass.1.gz
174%{_mandir}/man1/tknewsbiff.1.gz
175%{_mandir}/man1/unbuffer.1.gz
176%{_mandir}/man1/xkibitz.1.gz
177
178%files devel
179%defattr(-,root,root,-)
180%{_libdir}/libexpect.so
181%{_mandir}/man3/libexpect.3*
182%{_includedir}/*
183
184%files -n expectk
185%defattr(-,root,root,-)
186%{_bindir}/multixterm
187%{_bindir}/tknewsbiff
188%{_bindir}/tkpasswd
189%{_bindir}/xpstat
190%{_mandir}/man1/multixterm.1*
191%{_mandir}/man1/tknewsbiff.1*
192
193
194%changelog
195* Sat Dec 5 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.45-2
196- fixed a symlink.
197- fixed BR:.
198
199* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.45-1
200- updated to 5.45
201- rebuilt with tcl/tk 8.5.15
202
203* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 5.44.1.15-1
204- update to 5.44.1.15:sync ed Hat Enterprise Linux 6 expect-5.44.1.15-4.el6
205- add BuildRequires: tk, chrpath
206- update License: Public Domain
207- drop obsolete patches
208 - random patch (Patch0)
209 - spawn-43310 patch (Patch6)
210 - setpgrp patch (Patch8)
211 - lib spec patch (Patch10)
212 - libdir patch (Patch11)
213- add some patches from RHEL expect-5.44.1.15-4.el6
214 - fixes log file permissions patch (Patch500)
215 - fixes install location patch (Patch501)
216 - tk init patch (Patch502)
217 - match gt numchars segfault patch (Patch503)
218 - man page patch (Patch504)
219 - random patch (Patch600)
220 - unbuffer exit code patch (Patch601)
221 - passmass su full path Patch (Patch602)
222- update build and install section: sync RHEL expect-5.44.1.15-4.el6
223- add Vendor and Distribution tags
224
225* Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
226- add missing BuildRequires: libX11-devel
227
228* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
229- rebuilt with rpm-4.8.1-3
230
231* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
232- rebuilt with tcl/tk-8.4.19-2
233
234* Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
235- rebuilt with new toolchain
236- changed devel Group to Development/Libraries
237
238* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
239- applied new versioning policy and spec in utf-8
240
241* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
242- rebuilt with tcl/tk-8.4.18
243
244* Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
245- split to expect-devel and expectk sub package.
246- add libexpect.so to expect-devel (<BTS:wishes:0136>)
247
248* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
249- rebuilt with tcl/tk-8.4.16
250
251* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
252- rebuilt with new toolchain
253
254* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
255- rebuild for tcl/tk-8.4.12
256- added --enable-64bit to configure's option
257
258* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
259- updated expect to 5.43.0
260- dropped expect-5.39.0-64bit-82547.patch (for fixed)
261- dropped expect-5.32.2-kibitz.patch (for fixed)
262- dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
263- rebuilt with tcl/tk 8.4.11
264
265* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
266- rebuild for tcl/tk-8.4.6
267
268* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
269- update based on fedora
270
271* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
272- update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
273
274* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
275- splite source package
276- add include files
277
278* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
279- expand some macros.. (FIXME)
280
281* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
282- use %configure macros
283- add Patch 47,50
284
285* Thu May 31 2001 <sagami@vinelinux.org>
286- 8.0.5_jp-10
287- unexpand old %%{configure}, new one causes build failure
288- fixed missing libtkx.so libtclx.so symlink in /usr/lib
289- install manpages into %%{_mandir} and mode 644
290
291* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
292- 8.0.5_jp-9
293- modified %install section to handle compressed man pages
294- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
295
296* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
297- changed default fonts
298
299* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
300- added defattr
301
302* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
303- added some symlinks, such as libtcl8.0.so.
304- obsoletes version number using _jp, now 8.0.5-31vl1
305
306* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
307- Apply Tcl/Tk 8.0 Japanese Patch 1.7
308
309* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
310- fix tclX symlinks.
311- compile on systems where SIGPWR == SIGLOST.
312
313* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
314- update tcl/tk to 8.0.5.
315- avoid "containing" in Tix (#2332).
316
317* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
318- use /usr/bin/write in kibitz (#1320).
319- use cirrus.sprl.umich.edu in weather (#1926).
320
321* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
322- auto rebuild in the new build environment (release 28)
323
324* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
325- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
326
327* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
328- expect does unaligned access on alpha (#989)
329- upgrade tcl/tk/tclX to 8.0.4
330- upgrade expect to 5.28.
331- add itcl 3.0.1
332
333* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
334- call libtoolize to allow building on the arm
335- build for glibc 2.1
336- strip binaries
337
338* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
339- update tcl/tk/tclX to 8.0.3, expect is updated also.
340
341* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
342- expect: mkpasswd needs delay before sending password (problem #576)
343
344* Thu May 07 1998 Prospector System <bugs@redhat.com>
345- translations modified for de, fr, tr
346
347* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
348- fixed expect binaries exec permissions
349
350* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
351- updated to Tix 4.1.0.006
352- updated version numbers of tcl/tk to relflect includsion of p2
353
354* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
355- updated tcl/tk to patch level 2
356- updated tclX to 8.0.2
357
358* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
359- fixed filelist for tix... replacing path to the expect binary in scripts
360  was leaving junk files around.
361
362* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
363- added patch to remove libieee test in configure.in for tcl and tk.
364  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
365  solution for all systems
366- fixed src urls
367
368* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
369- removed version numbers from descriptions
370
371* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
372- updated to tcl/tk 8.0 and related versions of packages
373
374* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
375- built against glibc
376- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.