source: projects/specs/trunk/e/expect/expect-vl.spec @ 7290

Revision 7290, 10.8 KB checked in by iwaim, 11 years ago (diff)

expect 5.44.1.15-1

Line 
1%{!?tcl_version: %define tcl_version %(echo 'puts $tcl_version' | tclsh)}
2%{!?tcl_sitearch: %define tcl_sitearch %{_libdir}/tcl%{tcl_version}}
3
4%define tcl_major 8.4
5%define thread_major 2.5
6%define majorver 5.44
7
8Summary: A Tcl/Tk development environment: expect
9Summary(ja): Tcl/Tk 開発環境: expect
10Name: expect
11Version: %{majorver}.1.15
12Release: 1%{?_dist_release}
13Group: Development/Languages
14URL: http://expect.nist.gov/
15License: Public Domain
16Source0: http://expect.nist.gov/src/%{name}-%{version}.tar.bz2
17# Patch500: fixes change log file permissions
18Patch500: expect-5.43.0-log_file.patch
19# Patch501: fixes install location, change pkgIndex
20Patch501: expect-5.43.0-pkgpath.patch
21# Patch502: fixes bz456738, expectk is unsupported by upstream actually,
22#       but the patch is under discussion (patch by Sergei Golovan)
23Patch502: expect-5.44.1.15-tk-init.patch
24# Patch503: fixes bz742911
25Patch503: expect-5.44.1.15-match-gt-numchars-segfault.patch
26# Patch504: bz674866, proposed upstream, not accepted yet
27# https://sourceforge.net/tracker/?func=detail&aid=3404934&group_id=13179&atid=113179
28Patch504: expect-5.45-man-page.patch
29# examples patches
30# Patch600: changes random function
31Patch600: expect-5.32.2-random.patch
32# Patch601: bz547686, no response from upstream
33Patch601: expect-5.44.1.15-unbuffer-exit-code.patch
34# Patch602: bz735962, proposed to upstream, not accepted yet
35# https://sourceforge.net/tracker/?func=detail&aid=3404914&group_id=13179&atid=113179
36Patch602: expect-5.45-passmass-su-full-path.patch
37
38Buildroot: %{_tmppath}/%{name}-%{version}-root
39BuildRequires: tcl >= %{tcl_major}
40BuildRequires: tk >= %{tcl_major}
41BuildRequires: thread >= %{thread_major}
42BuildRequires: autoconf
43BuildRequires: libX11-devel
44BuildRequires: chrpath
45
46Vendor: Project Vine
47Distribution: Vine Linux
48
49%description -n expect
50Expect is a tcl extension for automating interactive applications such
51as telnet, ftp, passwd, fsck, rlogin, tip, etc.  Expect is also useful
52for testing the named applications.  Expect makes it easy for a script
53to control another program and interact with it.
54
55Install the expect package if you'd like to develop scripts which interact
56with interactive applications.  You'll also need to install the tcl
57package.
58
59%package devel
60Summary: Development files for expect library.
61Group: Development/Libraries
62Requires: expect = %{version}-%{release}
63Obsoletes: expect <= 5.43-0vl4
64
65%description devel
66This package contains development files for the expect library.
67
68%package -n expectk
69Summary: expectk and some scripts
70Group: Development/Languages
71Requires: expect = %{version}-%{release}
72Obsoletes: expect <= 5.43-0vl4
73
74%description -n expectk
75This package contains expectk and some scripts that use it.
76
77%prep
78%setup -q
79%patch500 -p1 -b .log_file
80%patch501 -p1 -b .pkgpath
81%patch502 -p1 -b .tk-init
82%patch503 -p1 -b .match-gt-numchars-segfault
83%patch504 -p1 -b .man-page
84# examples fixes
85%patch600 -p1 -b .random
86%patch601 -p1 -b .unbuffer-exit-code
87%patch602 -p1 -b .passmass-su-full-path
88# -pkgpath.patch touch configure.in
89aclocal
90autoconf
91( cd testsuite
92  autoconf -I.. )
93
94%build
95%configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
96        --with-tclinclude=%{_includedir}/tcl-private
97make %{?_smp_mflags}
98
99%check
100make test
101
102%install
103rm -rf ${RPM_BUILD_ROOT}
104make install DESTDIR="$RPM_BUILD_ROOT"
105
106# move
107mv "$RPM_BUILD_ROOT"%{tcl_sitearch}/expect%{version}/libexpect%{version}.so "$RPM_BUILD_ROOT"%{_libdir}
108
109# for linking with -lexpect
110ln -s libexpect%{majorver}.1.15.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
111
112# remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
113rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
114rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
115rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
116
117# remove rpath
118chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libexpect%{version}.so
119
120
121%post -p /sbin/ldconfig -n expect
122
123%postun -p /sbin/ldconfig -n expect
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%files
129%%defattr(-,root,root)
130%doc FAQ HISTORY NEWS README
131%{_bindir}/expect
132%{_bindir}/autoexpect
133%{_bindir}/dislocate
134%{_bindir}/ftp-rfc
135%{_bindir}/kibitz
136%{_bindir}/lpunlock
137%{_bindir}/mkpasswd
138%{_bindir}/passmass
139%{_bindir}/rftp
140%{_bindir}/rlogin-cwd
141%{_bindir}/timed-read
142%{_bindir}/timed-run
143%{_bindir}/unbuffer
144%{_bindir}/weather
145%{_bindir}/xkibitz
146%dir %{tcl_sitearch}/expect%{version}
147%{tcl_sitearch}/expect%{version}/pkgIndex.tcl
148%{_libdir}/libexpect%{version}.so
149%{_mandir}/man1/autoexpect.1.gz
150%{_mandir}/man1/dislocate.1.gz
151%{_mandir}/man1/expect.1.gz
152%{_mandir}/man1/kibitz.1.gz
153%{_mandir}/man1/mkpasswd.1.gz
154%{_mandir}/man1/passmass.1.gz
155%{_mandir}/man1/tknewsbiff.1.gz
156%{_mandir}/man1/unbuffer.1.gz
157%{_mandir}/man1/xkibitz.1.gz
158
159%files devel
160%defattr(-,root,root,-)
161%{_libdir}/libexpect.so
162%{_mandir}/man3/libexpect.3*
163%{_includedir}/*
164
165%files -n expectk
166%defattr(-,root,root,-)
167%{_bindir}/expectk
168%{_bindir}/multixterm
169%{_bindir}/tknewsbiff
170%{_bindir}/tkpasswd
171%{_bindir}/xpstat
172%{_mandir}/man1/expectk.1*
173%{_mandir}/man1/multixterm.1*
174%{_mandir}/man1/tknewsbiff.1*
175
176
177%changelog
178* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 5.44.1.15-1
179- update to 5.44.1.15:sync ed Hat Enterprise Linux 6 expect-5.44.1.15-4.el6
180- add BuildRequires: tk, chrpath
181- update License: Public Domain
182- drop obsolete patches
183 - random patch (Patch0)
184 - spawn-43310 patch (Patch6)
185 - setpgrp patch (Patch8)
186 - lib spec patch (Patch10)
187 - libdir patch (Patch11)
188- add some patches from RHEL expect-5.44.1.15-4.el6
189 - fixes log file permissions patch (Patch500)
190 - fixes install location patch (Patch501)
191 - tk init patch (Patch502)
192 - match gt numchars segfault patch (Patch503)
193 - man page patch (Patch504)
194 - random patch (Patch600)
195 - unbuffer exit code patch (Patch601)
196 - passmass su full path Patch (Patch602)
197- update build and install section: sync RHEL expect-5.44.1.15-4.el6
198- add Vendor and Distribution tags
199
200* Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
201- add missing BuildRequires: libX11-devel
202
203* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
204- rebuilt with rpm-4.8.1-3
205
206* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
207- rebuilt with tcl/tk-8.4.19-2
208
209* Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
210- rebuilt with new toolchain
211- changed devel Group to Development/Libraries
212
213* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
214- applied new versioning policy and spec in utf-8
215
216* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
217- rebuilt with tcl/tk-8.4.18
218
219* Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
220- split to expect-devel and expectk sub package.
221- add libexpect.so to expect-devel (<BTS:wishes:0136>)
222
223* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
224- rebuilt with tcl/tk-8.4.16
225
226* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
227- rebuilt with new toolchain
228
229* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
230- rebuild for tcl/tk-8.4.12
231- added --enable-64bit to configure's option
232
233* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
234- updated expect to 5.43.0
235- dropped expect-5.39.0-64bit-82547.patch (for fixed)
236- dropped expect-5.32.2-kibitz.patch (for fixed)
237- dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
238- rebuilt with tcl/tk 8.4.11
239
240* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
241- rebuild for tcl/tk-8.4.6
242
243* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
244- update based on fedora
245
246* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
247- update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
248
249* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
250- splite source package
251- add include files
252
253* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
254- expand some macros.. (FIXME)
255
256* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
257- use %configure macros
258- add Patch 47,50
259
260* Thu May 31 2001 <sagami@vinelinux.org>
261- 8.0.5_jp-10
262- unexpand old %%{configure}, new one causes build failure
263- fixed missing libtkx.so libtclx.so symlink in /usr/lib
264- install manpages into %%{_mandir} and mode 644
265
266* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
267- 8.0.5_jp-9
268- modified %install section to handle compressed man pages
269- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
270
271* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
272- changed default fonts
273
274* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
275- added defattr
276
277* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
278- added some symlinks, such as libtcl8.0.so.
279- obsoletes version number using _jp, now 8.0.5-31vl1
280
281* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
282- Apply Tcl/Tk 8.0 Japanese Patch 1.7
283
284* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
285- fix tclX symlinks.
286- compile on systems where SIGPWR == SIGLOST.
287
288* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
289- update tcl/tk to 8.0.5.
290- avoid "containing" in Tix (#2332).
291
292* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
293- use /usr/bin/write in kibitz (#1320).
294- use cirrus.sprl.umich.edu in weather (#1926).
295
296* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
297- auto rebuild in the new build environment (release 28)
298
299* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
300- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
301
302* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
303- expect does unaligned access on alpha (#989)
304- upgrade tcl/tk/tclX to 8.0.4
305- upgrade expect to 5.28.
306- add itcl 3.0.1
307
308* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
309- call libtoolize to allow building on the arm
310- build for glibc 2.1
311- strip binaries
312
313* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
314- update tcl/tk/tclX to 8.0.3, expect is updated also.
315
316* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
317- expect: mkpasswd needs delay before sending password (problem #576)
318
319* Thu May 07 1998 Prospector System <bugs@redhat.com>
320- translations modified for de, fr, tr
321
322* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
323- fixed expect binaries exec permissions
324
325* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
326- updated to Tix 4.1.0.006
327- updated version numbers of tcl/tk to relflect includsion of p2
328
329* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
330- updated tcl/tk to patch level 2
331- updated tclX to 8.0.2
332
333* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
334- fixed filelist for tix... replacing path to the expect binary in scripts
335  was leaving junk files around.
336
337* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
338- added patch to remove libieee test in configure.in for tcl and tk.
339  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
340  solution for all systems
341- fixed src urls
342
343* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
344- removed version numbers from descriptions
345
346* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
347- updated to tcl/tk 8.0 and related versions of packages
348
349* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
350- built against glibc
351- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.