source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 1250

Revision 1250, 14.6 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with evolution-data-server-2.30.2

Line 
1%define major_ver 2.30
2%define minor_ver 0.1
3%define rel       3
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk2_min_version        2.14
10%global glib2_min_version       2.22.0
11%global tp_mc_min_version       5.3.2
12%global tp_glib_min_version     0.9.2
13#global enchant_version         1.4.0
14%global aspell_version          0.50
15%global libcanberra_version     0.4
16%global gnome_keyring_version   2.22
17%global libnotify_version       0.4.4
18
19Summary:        GNOME Instant Messaging Client
20Summary(ja):    GNOME インスタントメッセージクラアイント
21
22Name:           empathy
23Version:        %{major_ver}.%{minor_ver}
24Release:        %{rel}%{?_dist_release}
25
26Group:          Applications/Communications
27License:        GPLv2+
28URL:            http://live.gnome.org/Empathy
29
30Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.bz2
31Source1:        %{name}-README.ConnectionManagers
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34
35#BuildRequires: enchant-devel >= %{enchant_version}
36BuildRequires:  aspell-devel >= %{aspell_version}
37BuildRequires:  iso-codes
38BuildRequires:  desktop-file-utils
39BuildRequires:  evolution-data-server-devel
40BuildRequires:  GConf2-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gnome-doc-utils >= 0.17.3
44BuildRequires:  gnome-panel
45BuildRequires:  gtk2-devel >= %{gtk2_min_version}
46BuildRequires:  intltool
47BuildRequires:  libxml2-devel
48BuildRequires:  perl(XML::Parser)
49BuildRequires:  pygtk2-devel
50BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
51BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
52BuildRequires:  farsight2-devel
53BuildRequires:  telepathy-farsight-devel
54BuildRequires:  libcanberra-devel >= %{libcanberra_version}
55BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
56BuildRequires:  unique-devel
57BuildRequires:  libnotify-devel >= %{libnotify_version}
58BuildRequires:  libtelepathy-devel
59BuildRequires:  libgnomecanvas-devel
60BuildRequires:  libbonoboui-devel
61
62Requires:       telepathy-filesystem
63## Empathy is useless without a proper Telepathy connection manager installed.
64## We hardcode dependencies on Salut and Gabble to support XMPP on a default
65## install, in both the link-local and Jabber/GoogleTalk incarnations.
66## (RHBZ: 308871 and 334221)
67## TODO: Perhaps we can configure these to be installed "on demand" with
68##       PackageKit and friends?
69Requires:       telepathy-gabble
70Requires:       telepathy-salut
71## Also hardcode Haze dependency since Empathy is the default IM client in F10+
72## and I'd hate for people to simply disregard it for lack of the "out of the
73## box" protocol support that Pidgin has. (RHBZ: 458935)
74BuildRequires:  telepathy-haze
75# Require this for VOIP support
76Requires:       telepathy-stream-engine
77
78Requires(pre):  GConf2
79
80Requires(post): GConf2
81Requires(post): scrollkeeper
82
83Requires(preun):        GConf2
84
85Requires(postun):       scrollkeeper
86
87## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
88Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
89Provides:       telepathy-haze-mission-control = 0.2.0-3
90## upstream 2.29.1 removed shared libraries: #599086
91Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
92## upstream 2.29.1 removed python bindings' #599039
93Obsoletes: empathy-python < 2.29.1
94
95%description
96Empathy provides a powerful multiple protocol instant messaging
97client using the Telepathy framework.
98
99
100%package -n     nautilus-sendto-empathy
101License:        GPLv2+
102Summary:        Nautilus-sendto plugin for empathy
103Summary(ja):    empathy 用 nautilus-sendto プラグイン
104Group:          User Interface/Desktop
105
106Requires:       %{name} = %{version}-%{release}
107Requires:       nautilus-sendto
108BuildRequires:  nautilus-sendto-devel
109
110%description -n nautilus-sendto-empathy
111This package contains nautilus-sendto plugin for the Empathy IM application.
112
113
114%prep
115%setup -q
116
117
118%build
119## GCC complains about some unused functions, so we forcibly show those as
120## simple warnings instead of build-halting errors.
121%configure --with-compile-warnings=yes --disable-static --enable-nautilus-sendto=yes
122## RPATHs are yucky.
123sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
124sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
125
126##make %{?_smp_mflags}
127## don't use _smp_mflags at empathy-2.18.1
128make
129
130install -m 0644 %{SOURCE1} ./README.ConnectionManagers
131
132
133%install
134rm -rf $RPM_BUILD_ROOT
135make install DESTDIR=$RPM_BUILD_ROOT
136find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
137
138%find_lang %{name}
139
140desktop-file-install --vendor "" --delete-original      \
141        --dir %{buildroot}%{_datadir}/applications      \
142        %{buildroot}%{_datadir}/applications/%{name}.desktop
143
144
145%clean
146rm -rf %{buildroot}
147
148
149%pre
150if [ "$1" -gt 1 ]; then
151        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
152        gconftool-2 --makefile-uninstall-rule   \
153                %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
154fi
155
156
157%post
158export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
159## for empathy =< 2.28.2-1's schemas
160if [ -e %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas ]; then
161        gconftool-2 --makefile-uninstall-rule   \
162                %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas > /dev/null ||:
163fi
164gconftool-2 --makefile-install-rule     \
165        %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
166scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
167touch --no-create %{_datadir}/icons/hicolor ||:
168%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
169
170
171%preun
172if [ "$1" -eq 0 ]; then
173        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
174        gconftool-2 --makefile-uninstall-rule   \
175                %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
176fi
177
178
179%postun
180scrollkeeper-update -q || :
181touch --no-create %{_datadir}/icons/hicolor || :
182if [ -x %{_bindir}/gtk-update-icon-cache ]; then
183        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
184fi
185
186
187%files -f %{name}.lang
188%defattr(-,root,root,-)
189%doc AUTHORS COPYING README README.ConnectionManagers NEWS
190%{_sysconfdir}/gconf/schemas/%{name}.schemas
191%{_bindir}/empathy
192%{_bindir}/empathy-accounts
193%{_bindir}/empathy-debugger
194%{_datadir}/dbus-1/services/*
195%{_datadir}/empathy
196%{_datadir}/applications/*.desktop
197%{_datadir}/gnome/help/%{name}/
198#{_datadir}/omf/%{name}/
199%{_datadir}/icons/hicolor/*/apps/%{name}*
200#{_datadir}/mission-control/profiles/*.profile
201%{_datadir}/telepathy/clients/Empathy.client
202%{_mandir}/man1/empathy*.1*
203
204%files -n nautilus-sendto-empathy
205%defattr(-,root,root,-)
206%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
207
208
209%changelog
210* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
211- rebuild with evolution-data-server-2.30.2
212- add nautilus-sendto-empathy package
213  - add configure option (--enable-nautilus-sendto=yes)
214  - add BuildRequires: nautilus-sendto-devel
215
216* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
217- add Obsoletes: empathy-python < 2.29.1
218
219* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
220- new upstream release
221- add new files: %%{_bindir}/empathy-{accounts,debugger}
222- drop -libs, -devel, -python sub packages: upstream removed
223  - Obsoletes: empathy-{libs,devel} < 2.29.1
224  - drop BuildRequires: python-devel
225- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
226- drop applet files in %%files: upstream removed the panel applets
227  - update %%post, %pre and %%preun
228- update BuildRequires version for glib2 and tp_glib
229- defined major_ver, minor_ver and rel
230- fix BuildRequires for gnome-keyring
231
232* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
233- new upstream release
234- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
235
236* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
237- rebuilt with python-2.6.4
238
239* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
240- unuse %%{?_smp_mflags} option to make
241
242* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
243- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
244
245* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
246- new upstream release
247
248* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
249- new upstream release
250
251* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
252- initial build for Vine Linux
253
254* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
255- Update to 2.23.92
256
257* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
258- Update to 2.23.91
259
260* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
261- Now that Empathy will be the default IM client in F10+, hardcode a dependency
262  on telepathy-haze to keep the same protocol functionality across upgrades,
263  for a much improved "out of the box" experience.
264- Reference: bug 458935.
265
266* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
267- Update to new upstream release (2.23.90)
268
269* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
270- Apply patch from Colin Walters to automagically update profile namings for
271  the switch to using Empathy's provided profiles.
272- Drop the upgrade script (no longer needed since it's automatically done).
273  - upgrade-haze-profiles.sh
274
275* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
276- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
277  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
278  horribly stale...). This makes for better automagic functionality (if Haze is
279  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
280  + upgrade-haze-profiles.sh
281
282* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
283- Update to new upstream release (2.23.6)
284- Use the in-tarball libtool scripts instead of the system copy to workaround
285  'make install' errors.
286
287* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
288- Update to 0.23.4.
289- Update source url.
290
291* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
292- Update to 0.23.3.
293- Remove reference to stream-engine in connections managers readme.
294
295* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
296- Update to 0.23.2.
297- Add man pages.
298- Use enchant-devel, instead of aspell-devel.
299
300* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
301- Rebuild for new e-d-s.
302
303* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
304- Drop multiple copies of COPYING file.
305- Drop BR on gnome-vfs2-devel.
306- Require telepathy-stream-engine for VOIP support.
307- Add BR on iso-codes-devel, so spell-checking is enabled.
308
309* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
310- Update to new upstream release (0.23.1)
311- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
312
313* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
314- Update to new upstream release (0.22.1)
315
316* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
317- Update to new upstream release (0.22.0)
318
319* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
320- Update to new upstream release (0.21.91)
321
322* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
323- Update to new upstream release (0.21.90)
324
325* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
326- Autorebuild for GCC 4.3
327
328* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
329- Update to new upstream release (0.21.4)
330
331* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
332- Update to new upstream release (0.21.2)
333- Drop backported drag-and-drop patch (fixed upstream):
334    - svn380-fix-contact-DnD.patch
335- Update README.ConnectionManagers: Include Haze package note, remove Galago
336  note (a feed-only connection manager isn't useful for instant messaging),
337  and fix some wording.
338
339* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
340- Backport upstream patch to fixes crashes when using drag-and-drop of a
341  contact from the buddy list to the current conversation window to initiate a
342  conversation:
343    + svn380-fix-contact-DnD.patch
344- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
345  dragged a contact ...)
346
347* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
348- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
349  is essentially useless due to the need to install an external connection
350  manager. Also, add a README.ConnectionManagers to the installed
351  documentation which lists other possibilities.
352- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
353  and bug 334221 (Default empathy install is useless).
354
355* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
356- Enable VoIP support for those brave enough to test/break/debug it (F9+
357  only). Though it is functional, it is still deemed rather unstable by
358  upstream. Use it at your own risk. :)
359
360* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
361- Disable VoIP support at this time, since it is deemed unstable by upstream
362  for now. (Thanks to Brian Pepple for the notice.)
363 
364* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
365- Update to new upstream release (0.14).
366
367* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
368- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
369  and python bindings.
370- Split shared libraries into a libs subpackage for easier handling
371  in multi-lib environments.
372
373* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
374- Add ldconfig invocations to %%post and %%postun scriptlets.
375
376* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
377- Update to new upstream release (0.12).
378- Build against new mission-control stack.
379- Update License tag (GPLv2+).
380- Alphabetize BuildRequires list (aesthetic-only change).
381
382* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
383- Rebuild for selinux ppc32 issue.
384
385* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
386- Update to new upstream release (0.11)
387
388* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
389- bump to 0.8
390- Now with aspell support (deat to teh speeling mistaks)
391
392* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
393- bump to 0.7
394
395* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
396- Add telepathy-filesystem to Requires
397- Move .desktop from autostart to applications
398- Nasty hackery to make empathy launch from the menu
399
400* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
401- Add gettext to BuildRequires
402
403* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
404- Bump to 0.6
405
406* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
407- Let Empathy own the directory and not just the files in it
408
409* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
410- Initial package
Note: See TracBrowser for help on using the repository browser.