source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 1191

Revision 1191, 13.8 KB checked in by iwaim, 14 years ago (diff)

empathy 2.30.0.1-2

Line 
1%define major_ver 2.30
2%define minor_ver 0.1
3%define rel       2
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk2_min_version        2.14
10%global glib2_min_version       2.22.0
11%global tp_mc_min_version       5.3.2
12%global tp_glib_min_version     0.9.2
13#global enchant_version         1.4.0
14%global aspell_version          0.50
15%global libcanberra_version     0.4
16%global gnome_keyring_version   2.22
17%global libnotify_version       0.4.4
18
19Summary:        GNOME Instant Messaging Client
20Summary(ja):    GNOME インスタントメッセージクラアイント
21
22Name:           empathy
23Version:        %{major_ver}.%{minor_ver}
24Release:        %{rel}%{?_dist_release}
25
26Group:          Applications/Communications
27License:        GPLv2+
28URL:            http://live.gnome.org/Empathy
29
30Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.bz2
31Source1:        %{name}-README.ConnectionManagers
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34
35#BuildRequires: enchant-devel >= %{enchant_version}
36BuildRequires:  aspell-devel >= %{aspell_version}
37BuildRequires:  iso-codes
38BuildRequires:  desktop-file-utils
39BuildRequires:  evolution-data-server-devel
40BuildRequires:  GConf2-devel
41BuildRequires:  gettext
42BuildRequires:  glib2-devel >= %{glib2_min_version}
43BuildRequires:  gnome-doc-utils >= 0.17.3
44BuildRequires:  gnome-panel
45BuildRequires:  gtk2-devel >= %{gtk2_min_version}
46BuildRequires:  intltool
47BuildRequires:  libxml2-devel
48BuildRequires:  perl(XML::Parser)
49BuildRequires:  pygtk2-devel
50BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
51BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
52BuildRequires:  farsight2-devel
53BuildRequires:  telepathy-farsight-devel
54BuildRequires:  libcanberra-devel >= %{libcanberra_version}
55BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
56BuildRequires:  unique-devel
57BuildRequires:  libnotify-devel >= %{libnotify_version}
58BuildRequires:  libtelepathy-devel
59BuildRequires:  libgnomecanvas-devel
60BuildRequires:  libbonoboui-devel
61
62Requires:       telepathy-filesystem
63## Empathy is useless without a proper Telepathy connection manager installed.
64## We hardcode dependencies on Salut and Gabble to support XMPP on a default
65## install, in both the link-local and Jabber/GoogleTalk incarnations.
66## (RHBZ: 308871 and 334221)
67## TODO: Perhaps we can configure these to be installed "on demand" with
68##       PackageKit and friends?
69Requires:       telepathy-gabble
70Requires:       telepathy-salut
71## Also hardcode Haze dependency since Empathy is the default IM client in F10+
72## and I'd hate for people to simply disregard it for lack of the "out of the
73## box" protocol support that Pidgin has. (RHBZ: 458935)
74BuildRequires:  telepathy-haze
75# Require this for VOIP support
76Requires:       telepathy-stream-engine
77
78Requires(pre):  GConf2
79
80Requires(post): GConf2
81Requires(post): scrollkeeper
82
83Requires(preun):        GConf2
84
85Requires(postun):       scrollkeeper
86
87## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
88Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
89Provides:       telepathy-haze-mission-control = 0.2.0-3
90## upstream 2.29.1 removed shared libraries: #599086
91Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
92## upstream 2.29.1 removed python bindings' #599039
93Obsoletes: empathy-python < 2.29.1
94
95%description
96Empathy provides a powerful multiple protocol instant messaging
97client using the Telepathy framework.
98
99
100%prep
101%setup -q
102
103
104%build
105## GCC complains about some unused functions, so we forcibly show those as
106## simple warnings instead of build-halting errors.
107%configure --with-compile-warnings=yes --disable-static
108## RPATHs are yucky.
109sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
110sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
111
112##make %{?_smp_mflags}
113## don't use _smp_mflags at empathy-2.18.1
114make
115
116install -m 0644 %{SOURCE1} ./README.ConnectionManagers
117
118
119%install
120rm -rf $RPM_BUILD_ROOT
121make install DESTDIR=$RPM_BUILD_ROOT
122find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
123
124%find_lang %{name}
125
126desktop-file-install --vendor "" --delete-original      \
127        --dir %{buildroot}%{_datadir}/applications      \
128        %{buildroot}%{_datadir}/applications/%{name}.desktop
129
130
131%clean
132rm -rf %{buildroot}
133
134
135%pre
136if [ "$1" -gt 1 ]; then
137        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
138        gconftool-2 --makefile-uninstall-rule   \
139                %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
140fi
141
142
143%post
144export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
145## for empathy =< 2.28.2-1's schemas
146if [ -e %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas ]; then
147        gconftool-2 --makefile-uninstall-rule   \
148                %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas > /dev/null ||:
149fi
150gconftool-2 --makefile-install-rule     \
151        %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
152scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
153touch --no-create %{_datadir}/icons/hicolor ||:
154%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
155
156
157%preun
158if [ "$1" -eq 0 ]; then
159        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
160        gconftool-2 --makefile-uninstall-rule   \
161                %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
162fi
163
164
165%postun
166scrollkeeper-update -q || :
167touch --no-create %{_datadir}/icons/hicolor || :
168if [ -x %{_bindir}/gtk-update-icon-cache ]; then
169        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
170fi
171
172
173%files -f %{name}.lang
174%defattr(-,root,root,-)
175%doc AUTHORS COPYING README README.ConnectionManagers NEWS
176%{_sysconfdir}/gconf/schemas/%{name}.schemas
177%{_bindir}/empathy
178%{_bindir}/empathy-accounts
179%{_bindir}/empathy-debugger
180%{_datadir}/dbus-1/services/*
181%{_datadir}/empathy
182%{_datadir}/applications/*.desktop
183%{_datadir}/gnome/help/%{name}/
184#{_datadir}/omf/%{name}/
185%{_datadir}/icons/hicolor/*/apps/%{name}*
186#{_datadir}/mission-control/profiles/*.profile
187%{_datadir}/telepathy/clients/Empathy.client
188%{_mandir}/man1/empathy*.1*
189
190
191%changelog
192* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
193- add Obsoletes: empathy-python < 2.29.1
194
195* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
196- new upstream release
197- add new files: %%{_bindir}/empathy-{accounts,debugger}
198- drop -libs, -devel, -python sub packages: upstream removed
199  - Obsoletes: empathy-{libs,devel} < 2.29.1
200  - drop BuildRequires: python-devel
201- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
202- drop applet files in %%files: upstream removed the panel applets
203  - update %%post, %pre and %%preun
204- update BuildRequires version for glib2 and tp_glib
205- defined major_ver, minor_ver and rel
206- fix BuildRequires for gnome-keyring
207
208* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
209- new upstream release
210- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
211
212* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
213- rebuilt with python-2.6.4
214
215* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
216- unuse %%{?_smp_mflags} option to make
217
218* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
219- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
220
221* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
222- new upstream release
223
224* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
225- new upstream release
226
227* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
228- initial build for Vine Linux
229
230* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
231- Update to 2.23.92
232
233* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
234- Update to 2.23.91
235
236* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
237- Now that Empathy will be the default IM client in F10+, hardcode a dependency
238  on telepathy-haze to keep the same protocol functionality across upgrades,
239  for a much improved "out of the box" experience.
240- Reference: bug 458935.
241
242* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
243- Update to new upstream release (2.23.90)
244
245* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
246- Apply patch from Colin Walters to automagically update profile namings for
247  the switch to using Empathy's provided profiles.
248- Drop the upgrade script (no longer needed since it's automatically done).
249  - upgrade-haze-profiles.sh
250
251* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
252- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
253  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
254  horribly stale...). This makes for better automagic functionality (if Haze is
255  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
256  + upgrade-haze-profiles.sh
257
258* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
259- Update to new upstream release (2.23.6)
260- Use the in-tarball libtool scripts instead of the system copy to workaround
261  'make install' errors.
262
263* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
264- Update to 0.23.4.
265- Update source url.
266
267* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
268- Update to 0.23.3.
269- Remove reference to stream-engine in connections managers readme.
270
271* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
272- Update to 0.23.2.
273- Add man pages.
274- Use enchant-devel, instead of aspell-devel.
275
276* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
277- Rebuild for new e-d-s.
278
279* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
280- Drop multiple copies of COPYING file.
281- Drop BR on gnome-vfs2-devel.
282- Require telepathy-stream-engine for VOIP support.
283- Add BR on iso-codes-devel, so spell-checking is enabled.
284
285* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
286- Update to new upstream release (0.23.1)
287- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
288
289* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
290- Update to new upstream release (0.22.1)
291
292* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
293- Update to new upstream release (0.22.0)
294
295* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
296- Update to new upstream release (0.21.91)
297
298* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
299- Update to new upstream release (0.21.90)
300
301* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
302- Autorebuild for GCC 4.3
303
304* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
305- Update to new upstream release (0.21.4)
306
307* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
308- Update to new upstream release (0.21.2)
309- Drop backported drag-and-drop patch (fixed upstream):
310    - svn380-fix-contact-DnD.patch
311- Update README.ConnectionManagers: Include Haze package note, remove Galago
312  note (a feed-only connection manager isn't useful for instant messaging),
313  and fix some wording.
314
315* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
316- Backport upstream patch to fixes crashes when using drag-and-drop of a
317  contact from the buddy list to the current conversation window to initiate a
318  conversation:
319    + svn380-fix-contact-DnD.patch
320- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
321  dragged a contact ...)
322
323* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
324- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
325  is essentially useless due to the need to install an external connection
326  manager. Also, add a README.ConnectionManagers to the installed
327  documentation which lists other possibilities.
328- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
329  and bug 334221 (Default empathy install is useless).
330
331* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
332- Enable VoIP support for those brave enough to test/break/debug it (F9+
333  only). Though it is functional, it is still deemed rather unstable by
334  upstream. Use it at your own risk. :)
335
336* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
337- Disable VoIP support at this time, since it is deemed unstable by upstream
338  for now. (Thanks to Brian Pepple for the notice.)
339 
340* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
341- Update to new upstream release (0.14).
342
343* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
344- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
345  and python bindings.
346- Split shared libraries into a libs subpackage for easier handling
347  in multi-lib environments.
348
349* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
350- Add ldconfig invocations to %%post and %%postun scriptlets.
351
352* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
353- Update to new upstream release (0.12).
354- Build against new mission-control stack.
355- Update License tag (GPLv2+).
356- Alphabetize BuildRequires list (aesthetic-only change).
357
358* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
359- Rebuild for selinux ppc32 issue.
360
361* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
362- Update to new upstream release (0.11)
363
364* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
365- bump to 0.8
366- Now with aspell support (deat to teh speeling mistaks)
367
368* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
369- bump to 0.7
370
371* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
372- Add telepathy-filesystem to Requires
373- Move .desktop from autostart to applications
374- Nasty hackery to make empathy launch from the menu
375
376* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
377- Add gettext to BuildRequires
378
379* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
380- Bump to 0.6
381
382* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
383- Let Empathy own the directory and not just the files in it
384
385* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
386- Initial package
Note: See TracBrowser for help on using the repository browser.