source: projects/specs/trunk/e/empathy/empathy-vl.spec @ 2041

Revision 2041, 14.4 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define major_ver 2.32
2%define minor_ver 0.1
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk2_min_version        2.22
10%global glib2_min_version       2.26.0
11%global tp_mc_min_version       5.6.0
12%global tp_glib_min_version     0.13.0
13%global tp_logger_min_version   0.1.5
14#global enchant_version         1.4.0
15%global aspell_version          0.50
16%global libcanberra_version     0.4
17%global gnome_keyring_version   2.32
18%global libnotify_version       0.4.4
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.bz2
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  GConf2-devel
42BuildRequires:  gettext
43BuildRequires:  glib2-devel >= %{glib2_min_version}
44BuildRequires:  gnome-doc-utils >= 0.17.3
45BuildRequires:  gnome-panel
46BuildRequires:  gtk2-devel >= %{gtk2_min_version}
47BuildRequires:  intltool
48BuildRequires:  libxml2-devel
49BuildRequires:  perl(XML::Parser)
50BuildRequires:  pygtk2-devel
51BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
52BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
53BuildRequires:  farsight2-devel
54BuildRequires:  telepathy-farsight-devel
55BuildRequires:  libcanberra-devel >= %{libcanberra_version}
56BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
57BuildRequires:  unique-devel
58BuildRequires:  libnotify-devel >= %{libnotify_version}
59BuildRequires:  libtelepathy-devel
60BuildRequires:  libgnomecanvas-devel
61BuildRequires:  libbonoboui-devel
62BuildRequires:  folks-devel
63BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
64BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
65
66Requires:       telepathy-filesystem
67## Empathy is useless without a proper Telepathy connection manager installed.
68## We hardcode dependencies on Salut and Gabble to support XMPP on a default
69## install, in both the link-local and Jabber/GoogleTalk incarnations.
70## (RHBZ: 308871 and 334221)
71## TODO: Perhaps we can configure these to be installed "on demand" with
72##       PackageKit and friends?
73Requires:       telepathy-gabble
74Requires:       telepathy-salut
75## Also hardcode Haze dependency since Empathy is the default IM client in F10+
76## and I'd hate for people to simply disregard it for lack of the "out of the
77## box" protocol support that Pidgin has. (RHBZ: 458935)
78BuildRequires:  telepathy-haze
79# Require this for VOIP support
80Requires:       telepathy-stream-engine
81
82
83Requires(post): GConf2
84Requires(post): scrollkeeper
85
86Requires(postun):       scrollkeeper
87
88## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
89Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
90Provides:       telepathy-haze-mission-control = 0.2.0-3
91## upstream 2.29.1 removed shared libraries: #599086
92Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
93## upstream 2.29.1 removed python bindings' #599039
94Obsoletes: empathy-python < 2.29.1
95
96%description
97Empathy provides a powerful multiple protocol instant messaging
98client using the Telepathy framework.
99
100
101%package -n     nautilus-sendto-empathy
102License:        GPLv2+
103Summary:        Nautilus-sendto plugin for empathy
104Summary(ja):    empathy 用 nautilus-sendto プラグイン
105Group:          User Interface/Desktop
106
107Requires:       %{name} = %{version}-%{release}
108Requires:       nautilus-sendto
109BuildRequires:  nautilus-sendto-devel
110
111%description -n nautilus-sendto-empathy
112This package contains nautilus-sendto plugin for the Empathy IM application.
113
114
115%prep
116%setup -q
117
118
119%build
120## GCC complains about some unused functions, so we forcibly show those as
121## simple warnings instead of build-halting errors.
122%configure --with-compile-warnings=yes --disable-static --enable-nautilus-sendto=yes
123## RPATHs are yucky.
124sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
125sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
126
127##make %{?_smp_mflags}
128## don't use _smp_mflags at empathy-2.18.1
129make
130
131install -m 0644 %{SOURCE1} ./README.ConnectionManagers
132
133
134%install
135rm -rf $RPM_BUILD_ROOT
136make install DESTDIR=$RPM_BUILD_ROOT
137find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
138
139%find_lang %{name}
140
141desktop-file-install --vendor "" --delete-original      \
142        --dir %{buildroot}%{_datadir}/applications      \
143        %{buildroot}%{_datadir}/applications/%{name}.desktop
144
145
146%clean
147rm -rf %{buildroot}
148
149
150%post
151scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
152touch --no-create %{_datadir}/icons/hicolor ||:
153%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
154
155%postun
156scrollkeeper-update -q || :
157touch --no-create %{_datadir}/icons/hicolor || :
158if [ -x %{_bindir}/gtk-update-icon-cache ]; then
159        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
160        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
161fi
162
163%posttrans
164gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
165glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
166
167
168%files -f %{name}.lang
169%defattr(-,root,root,-)
170%doc AUTHORS COPYING README README.ConnectionManagers NEWS
171%{_bindir}/empathy
172%{_bindir}/empathy-accounts
173%{_bindir}/empathy-debugger
174%{_libexecdir}/empathy-auth-client
175%{_libexecdir}/empathy-av
176%{_datadir}/dbus-1/services/*
177%{_datadir}/empathy
178%{_datadir}/glib-2.0/schemas/*.xml
179%{_datadir}/GConf/gsettings/*
180%{_datadir}/applications/*.desktop
181%{_datadir}/gnome/help/%{name}/
182#{_datadir}/omf/%{name}/
183%{_datadir}/icons/hicolor/*/apps/%{name}*
184#{_datadir}/mission-control/profiles/*.profile
185%{_datadir}/telepathy/clients/*.client
186%{_mandir}/man1/empathy*.1*
187
188%files -n nautilus-sendto-empathy
189%defattr(-,root,root,-)
190%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
191
192
193%changelog
194* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
195- new upstream release
196- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
197- fix %files
198- fix %post, %postun
199- drop %pre, %preun
200
201* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
202- rebuild with evolution-data-server-2.30.2
203- add nautilus-sendto-empathy package
204  - add configure option (--enable-nautilus-sendto=yes)
205  - add BuildRequires: nautilus-sendto-devel
206
207* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
208- add Obsoletes: empathy-python < 2.29.1
209
210* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
211- new upstream release
212- add new files: %%{_bindir}/empathy-{accounts,debugger}
213- drop -libs, -devel, -python sub packages: upstream removed
214  - Obsoletes: empathy-{libs,devel} < 2.29.1
215  - drop BuildRequires: python-devel
216- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
217- drop applet files in %%files: upstream removed the panel applets
218  - update %%post, %pre and %%preun
219- update BuildRequires version for glib2 and tp_glib
220- defined major_ver, minor_ver and rel
221- fix BuildRequires for gnome-keyring
222
223* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
224- new upstream release
225- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
226
227* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
228- rebuilt with python-2.6.4
229
230* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
231- unuse %%{?_smp_mflags} option to make
232
233* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
234- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
235
236* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
237- new upstream release
238
239* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
240- new upstream release
241
242* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
243- initial build for Vine Linux
244
245* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
246- Update to 2.23.92
247
248* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
249- Update to 2.23.91
250
251* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
252- Now that Empathy will be the default IM client in F10+, hardcode a dependency
253  on telepathy-haze to keep the same protocol functionality across upgrades,
254  for a much improved "out of the box" experience.
255- Reference: bug 458935.
256
257* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
258- Update to new upstream release (2.23.90)
259
260* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
261- Apply patch from Colin Walters to automagically update profile namings for
262  the switch to using Empathy's provided profiles.
263- Drop the upgrade script (no longer needed since it's automatically done).
264  - upgrade-haze-profiles.sh
265
266* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
267- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
268  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
269  horribly stale...). This makes for better automagic functionality (if Haze is
270  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
271  + upgrade-haze-profiles.sh
272
273* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
274- Update to new upstream release (2.23.6)
275- Use the in-tarball libtool scripts instead of the system copy to workaround
276  'make install' errors.
277
278* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
279- Update to 0.23.4.
280- Update source url.
281
282* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
283- Update to 0.23.3.
284- Remove reference to stream-engine in connections managers readme.
285
286* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
287- Update to 0.23.2.
288- Add man pages.
289- Use enchant-devel, instead of aspell-devel.
290
291* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
292- Rebuild for new e-d-s.
293
294* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
295- Drop multiple copies of COPYING file.
296- Drop BR on gnome-vfs2-devel.
297- Require telepathy-stream-engine for VOIP support.
298- Add BR on iso-codes-devel, so spell-checking is enabled.
299
300* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
301- Update to new upstream release (0.23.1)
302- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
303
304* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
305- Update to new upstream release (0.22.1)
306
307* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
308- Update to new upstream release (0.22.0)
309
310* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
311- Update to new upstream release (0.21.91)
312
313* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
314- Update to new upstream release (0.21.90)
315
316* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
317- Autorebuild for GCC 4.3
318
319* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
320- Update to new upstream release (0.21.4)
321
322* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
323- Update to new upstream release (0.21.2)
324- Drop backported drag-and-drop patch (fixed upstream):
325    - svn380-fix-contact-DnD.patch
326- Update README.ConnectionManagers: Include Haze package note, remove Galago
327  note (a feed-only connection manager isn't useful for instant messaging),
328  and fix some wording.
329
330* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
331- Backport upstream patch to fixes crashes when using drag-and-drop of a
332  contact from the buddy list to the current conversation window to initiate a
333  conversation:
334    + svn380-fix-contact-DnD.patch
335- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
336  dragged a contact ...)
337
338* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
339- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
340  is essentially useless due to the need to install an external connection
341  manager. Also, add a README.ConnectionManagers to the installed
342  documentation which lists other possibilities.
343- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
344  and bug 334221 (Default empathy install is useless).
345
346* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
347- Enable VoIP support for those brave enough to test/break/debug it (F9+
348  only). Though it is functional, it is still deemed rather unstable by
349  upstream. Use it at your own risk. :)
350
351* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
352- Disable VoIP support at this time, since it is deemed unstable by upstream
353  for now. (Thanks to Brian Pepple for the notice.)
354 
355* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
356- Update to new upstream release (0.14).
357
358* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
359- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
360  and python bindings.
361- Split shared libraries into a libs subpackage for easier handling
362  in multi-lib environments.
363
364* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
365- Add ldconfig invocations to %%post and %%postun scriptlets.
366
367* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
368- Update to new upstream release (0.12).
369- Build against new mission-control stack.
370- Update License tag (GPLv2+).
371- Alphabetize BuildRequires list (aesthetic-only change).
372
373* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
374- Rebuild for selinux ppc32 issue.
375
376* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
377- Update to new upstream release (0.11)
378
379* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
380- bump to 0.8
381- Now with aspell support (deat to teh speeling mistaks)
382
383* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
384- bump to 0.7
385
386* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
387- Add telepathy-filesystem to Requires
388- Move .desktop from autostart to applications
389- Nasty hackery to make empathy launch from the menu
390
391* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
392- Add gettext to BuildRequires
393
394* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
395- Bump to 0.6
396
397* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
398- Let Empathy own the directory and not just the files in it
399
400* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
401- Initial package
Note: See TracBrowser for help on using the repository browser.