source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 3327

Revision 3327, 24.2 KB checked in by daisuke, 13 years ago (diff)

efutils: add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext

Line 
1%define eu_version 0.152
2%define eu_release 2
3
4Summary: A collection of utilities and DSOs to handle compiled objects
5Name: elfutils
6Version: %{eu_version}
7Release: %{eu_release}%{?_dist_release}
8License: GPLv2 with exceptions
9Group: Development/Tools
10URL: https://fedorahosted.org/elfutils/
11Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
12##VINE##
13Patch10: elfutils-0.131-readelf_c.patch
14
15Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
16Requires: elfutils-libs-%{_arch} = %{version}-%{release}
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19BuildRequires: bison >= 1.875
20BuildRequires: flex >= 2.5.4a
21BuildRequires: bzip2
22BuildRequires: bzip2-devel
23BuildRequires: zlib-devel
24BuildRequires: xz-devel
25BuildRequires: gettext
26BuildRequires: m4
27BuildRequires: gcc >= 3.4
28# Need <byteswap.h> that gives unsigned bswap_16 etc.
29BuildRequires: glibc-headers >= 2.3.4-11
30
31%define _gnu %{nil}
32%define _program_prefix eu-
33
34%description
35Elfutils is a collection of utilities, including ld (a linker),
36nm (for listing symbols from object files), size (for listing the
37section sizes of an object or archive file), strip (for discarding
38symbols), readelf (to see the raw ELF file structures), and elflint
39(to check for well-formed ELF files).
40
41
42%package libs
43Summary: Libraries to handle compiled objects
44Group: System Environment/Libraries
45Provides: elfutils-libs-%{_arch} = %{version}-%{release}
46Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
47Conflicts: elfutils < %{version}-%{release}
48Conflicts: elfutils > %{version}-%{release}
49Conflicts: elfutils-devel < %{version}-%{release}
50Conflicts: elfutils-devel > %{version}-%{release}
51
52%description libs
53The elfutils-libs package contains libraries which implement DWARF, ELF,
54and machine-specific ELF handling.  These libraries are used by the programs
55in the elfutils package.  The elfutils-devel package enables building
56other programs using these libraries.
57
58
59%package devel
60Summary: Development libraries to handle compiled objects
61Group: Development/Libraries
62Provides: elfutils-devel-%{_arch} = %{version}-%{release}
63Requires: elfutils-libs-%{_arch} = %{version}-%{release}
64Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
65Conflicts: elfutils-libelf-devel < %{version}-%{release}
66Conflicts: elfutils-libelf-devel > %{version}-%{release}
67
68%description devel
69The elfutils-devel package contains the libraries to create
70applications for handling compiled objects.  libebl provides some
71higher-level ELF access functionality.  libdw provides access to
72the DWARF debugging information.  libasm provides a programmable
73assembler interface.
74
75
76%package devel-static
77Summary: Static archives to handle compiled objects
78Group: Development/Libraries
79Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
80Requires: elfutils-devel-%{_arch} = %{version}-%{release}
81Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
82Conflicts: elfutils-libelf-devel < %{version}-%{release}
83Conflicts: elfutils-libelf-devel > %{version}-%{release}
84
85%description devel-static
86The elfutils-devel-static package contains the static archives
87with the code to handle compiled objects.
88
89
90%package libelf
91Summary: Library to read and write ELF files
92Group: System Environment/Libraries
93Provides: libelf = %{version}-%{release}
94Obsoletes: libelf <= 0.8.2-2
95Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
96Conflicts: elfutils < %{version}-%{release}
97Conflicts: elfutils > %{version}-%{release}
98Conflicts: elfutils-libs < %{version}-%{release}
99Conflicts: elfutils-libs > %{version}-%{release}
100Conflicts: elfutils-libelf-devel < %{version}-%{release}
101Conflicts: elfutils-libelf-devel > %{version}-%{release}
102
103%description libelf
104The elfutils-libelf package provides a DSO which allows reading and
105writing ELF files on a high level.  Third party programs depend on
106this package to read internals of ELF files.  The programs of the
107elfutils package use it also to generate new ELF files.
108
109
110%package libelf-devel
111Summary: Development support for libelf
112Group: Development/Libraries
113Provides: libelf-devel = %{version}-%{release}
114Obsoletes: libelf-devel <= 0.8.2-2
115Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
116Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
117Conflicts: libelf-devel < %{version}-%{release}
118
119%description libelf-devel
120The elfutils-libelf-devel package contains the libraries to create
121applications for handling compiled objects.  libelf allows you to
122access the internals of the ELF object file format, so you can see the
123different sections of an ELF file.
124
125
126%package libelf-devel-static
127Summary: Static archive of libelf
128Group: Development/Libraries
129Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
130Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
131
132%description libelf-devel-static
133The elfutils-libelf-static package contains the static archive
134for libelf.
135
136
137%prep
138%setup -q
139
140%patch10 -p0 -b .readelf_c
141
142find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
143
144
145%build
146# Remove -Wall from default flags.  The makefiles enable enough warnings
147# themselves, and they use -Werror.  Appending -Wall defeats the cases where
148# the makefiles disable some specific warnings for specific code.
149RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
150
151%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
152make -s %{?_smp_mflags}
153
154
155%install
156rm -rf ${RPM_BUILD_ROOT}
157make -s install DESTDIR=${RPM_BUILD_ROOT}
158
159chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
160chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
161
162%find_lang %{name}
163
164# XXX Nuke unpackaged files
165{ cd ${RPM_BUILD_ROOT}
166  rm -f .%{_bindir}/eu-ld
167}
168
169
170
171%check
172make -s check
173
174
175%clean
176rm -rf ${RPM_BUILD_ROOT}
177
178
179%post libs -p /sbin/ldconfig
180
181%postun libs -p /sbin/ldconfig
182
183%post libelf -p /sbin/ldconfig
184
185%postun libelf -p /sbin/ldconfig
186
187
188%files -f %{name}.lang
189%defattr(-,root,root)
190%doc README TODO
191%{_bindir}/eu-addr2line
192%{_bindir}/eu-ar
193%{_bindir}/eu-elfcmp
194%{_bindir}/eu-elflint
195%{_bindir}/eu-findtextrel
196%{_bindir}/eu-nm
197%{_bindir}/eu-objdump
198%{_bindir}/eu-ranlib
199%{_bindir}/eu-readelf
200%{_bindir}/eu-size
201%{_bindir}/eu-strings
202%{_bindir}/eu-strip
203#%{_bindir}/eu-ld
204%{_bindir}/eu-unstrip
205%{_bindir}/eu-make-debug-archive
206
207
208%files libs
209%defattr(-,root,root)
210%{_libdir}/libasm-%{version}.so
211%{_libdir}/libasm.so.*
212%{_libdir}/libdw-%{version}.so
213%{_libdir}/libdw.so.*
214%dir %{_libdir}/elfutils
215%{_libdir}/elfutils/lib*.so
216
217
218%files devel
219%defattr(-,root,root)
220%{_includedir}/dwarf.h
221%dir %{_includedir}/elfutils
222%{_includedir}/elfutils/elf-knowledge.h
223%{_includedir}/elfutils/libasm.h
224%{_includedir}/elfutils/libebl.h
225%{_includedir}/elfutils/libdw.h
226%{_includedir}/elfutils/libdwfl.h
227%{_includedir}/elfutils/version.h
228%{_libdir}/libebl.a
229%{_libdir}/libasm.so
230%{_libdir}/libdw.so
231
232
233%files devel-static
234%defattr(-,root,root)
235%{_libdir}/libasm.a
236%{_libdir}/libdw.a
237
238
239%files libelf
240%defattr(-,root,root)
241%{_libdir}/libelf-%{version}.so
242%{_libdir}/libelf.so.*
243
244
245%files libelf-devel
246%defattr(-,root,root)
247%{_includedir}/libelf.h
248%{_includedir}/gelf.h
249%{_includedir}/nlist.h
250%{_libdir}/libelf.so
251
252
253%files libelf-devel-static
254%defattr(-,root,root)
255%{_libdir}/libelf.a
256
257
258%changelog
259* Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
260- add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
261
262* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
263- update to 0.152
264
265* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
266- elfutils-libs: changed Group to System Environment/Libraries
267- elfutils-libelf: changed Group to System Environment/Libraries
268- elfutils-devel: changed Group to Development/Libraries
269- elfutils-devel-static: changed Group to Development/Libraries
270- elfutils-libelf-devel: changed Group to Development/Libraries
271- elfutils-libelf-devel-static: changed Group to Development/Libraries
272
273* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
274- merged with Fedora 9 0.135-1
275
276  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
277  - applied new versioning policy
278  - added elfutils-0.131-readelf_c.patch
279
280  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
281  - new upstream release
282  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
283    - remove Obsoletes: libelf, libelf-devel from elfutils
284    - add Obsoletes: libelf to elfutils-libelf
285    - add Obsoletes: libelf-devel to elfutils-libelf-devel
286
287* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
288- Update to 0.135
289  - libdwfl: bug fixes
290  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
291
292* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
293- Update to 0.134
294  - elflint: backend improvements for sparc, alpha (#204170)
295  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
296- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
297
298* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
299- Update to 0.133
300  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
301  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
302  - libdwfl: bug fixes and optimization in relocation handling
303  - elfcmp: bug fix for non-allocated section handling
304  - ld: implement newer features of binutils linker.
305- Install eu-objdump and libasm, now has limited disassembler support.
306
307* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
308- Update to 0.132
309  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
310  - eu-readelf: Fix handling of ET_REL files in archives.
311  - libcpu: Implement x86 and x86-64 disassembler.
312  - libasm: Add interface for disassembler.
313  - all programs: add debugging of branch prediction.
314  - libelf: new function elf_scnshndx.
315
316* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
317- Update to 0.131
318  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
319           bug fixes for oddly-formatted DWARF
320  - libdwfl: bug fixes in offline archive support, symbol table handling;
321             apply partial relocations for dwfl_module_address_section on ET_REL
322  - libebl: powerpc backend support for Altivec registers
323
324* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
325- Fix ET_REL support.
326- Fix odd indentation in eu-readelf -x output.
327
328* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
329- Update to 0.130
330  - eu-readelf -p option can take an argument like -x for one section
331  - eu-readelf --archive-index (or -c)
332  - eu-readelf -n improved output for core dumps
333  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
334  - eu-elflint: ditto
335  - eu-elflint: stricter checks on debug sections
336  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
337  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
338            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
339  - libebl: backend improvements (#324031)
340  - libdwfl: build_id support, new functions for it
341  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
342  - libdwfl offline archive support, new script eu-make-debug-archive
343
344* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
345- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
346
347* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
348- Update to 0.129
349  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
350  - addr2line: new option --symbols (or -S)
351  - libdw: dwarf_getscopes fixes (#230235)
352  - libdwfl: dwfl_module_addrsym fixes (#249490)
353
354* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
355- Update to 0.128
356  - new program: unstrip
357  - elfcmp: new option --hash-inexact
358- Replace Conflicts: with Provides/Requires using -arch
359
360* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
361- Update to 0.127
362  - libdw: new function dwarf_getsrcdirs
363  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
364             dwfl_module_address_section
365
366* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
367- Update to 0.126
368  - New program eu-ar.
369  - libdw: fix missing dwarf_getelf (#227206)
370  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
371- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
372
373* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
374- Fix overeager warn_unused_result build failures.
375
376* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
377- Update to 0.125
378  - elflint: Compare DT_GNU_HASH tests.
379  - move archives into -static RPMs
380  - libelf, elflint: better support for core file handling
381  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
382- Resolves: RHBZ #220817, RHBZ #213792
383
384* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
385- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
386- Update to 0.124
387  - libebl: fix ia64 reloc support (#206981)
388  - libebl: sparc backend support for return value location
389  - libebl, libdwfl: backend register name support extended with more info
390  - libelf, libdw: bug fixes for unaligned accesses on machines that care
391  - readelf, elflint: trivial bugs fixed
392
393* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
394- Update to 0.123
395  - libebl: Backend build fixes, thanks to Stepan Kasal.
396  - libebl: ia64 backend support for register names, return value location
397  - libdwfl: Handle truncated linux kernel module section names.
398  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
399  - elflint: Fix checks to permit --hash-style=gnu format.
400
401* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
402- Fix warnings in elflint compilation.
403
404* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
405- Update to 0.122
406  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
407  - libebl: add function to test for relative relocation
408  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
409  - elflint, readelf: add support for DT_GNU_HASH
410  - libelf: add elf_gnu_hash
411  - elflint, readelf: add support for 64-bit SysV-style hash tables
412  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
413
414* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
415- Update to 0.121
416  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
417  - make all installed headers usable in C++ code (#193153).
418  - eu-readelf: better output format.
419  - eu-elflint: fix tests of dynamic section content.
420  - libdw, libdwfl: handle files without aranges info.
421
422* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
423- rebuild to pick up -devel deps
424
425* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
426- Update to 0.120
427  - License changed to GPL, with some exceptions for using
428    the libelf, libebl, libdw, and libdwfl library interfaces.
429    Red Hat elfutils is an included package of the Open Invention Network.
430  - dwarf.h updated for DWARF 3.0 final specification.
431  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
432  - libdwfl: New function dwfl_version; fixes for offline.
433
434* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
435- bump again for double-long bug on ppc(64)
436
437* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
438- rebuilt for new gcc4.1 snapshot and glibc changes
439
440* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
441- update to 0.119
442
443* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
444- rebuilt
445
446* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
447- update to 0.118
448  - elflint: more tests.
449  - libdwfl: New function dwfl_module_register_names.
450  - libebl: New backend hook for register names.
451- Make sure -fexceptions is always in CFLAGS.
452
453* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
454- update to 0.117
455  - libdwfl: New function dwfl_module_return_value_location (#166118)
456  - libebl: Backend improvements for several CPUs
457
458* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
459- update to 0.116
460  - libdw fixes, API changes and additions
461  - libdwfl fixes (#169672)
462  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
463
464* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
465- Update requires/conflicts for better biarch update behavior.
466
467* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
468- update to 0.115
469  - New program eu-strings.
470  - libdw: New function dwarf_getscopes_die.
471  - libelf: speed-ups of non-mmap reading.
472  - Implement --enable-gcov option for configure.
473
474* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
475- update to 0.114
476  - new program eu-ranlib
477  - libdw: new calls for inlines
478  - libdwfl: new calls for offline modules
479
480* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
481- update to 0.113
482  - elflint: relax a bit.  Allow version definitions for defined symbols
483    against DSO versions also for symbols in nobits sections.
484    Allow .rodata section to have STRINGS and MERGE flag set.
485  - strip: add some more compatibility with binutils.
486  - libdwfl: bug fixes.
487- Separate libdw et al into elfutils-libs subpackage.
488
489* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
490- update to 0.112
491  - elfcmp: some more relaxation.
492  - elflint: many more tests, especially regarding to symbol versioning.
493  - libelf: Add elfXX_offscn and gelf_offscn.
494  - libasm: asm_begin interface changes.
495  - libebl: Add three new interfaces to directly access machine, class,
496    and data encoding information.
497
498* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
499- update portability patch
500
501* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
502- update to 0.111
503  - libdwfl library now merged into libdw
504
505* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
506- update to 0.110
507
508* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
509- update to 0.109
510  - verify that libebl modules are from the same build
511  - new eu-elflint checks on copy relocations
512  - new program eu-elfcmp
513  - new experimental libdwfl library
514
515* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
516- robustification of eu-strip and eu-readelf
517
518* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
519- more robustification
520
521* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
522- robustification
523
524* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
525- update to 0.108
526  - merge strip fixes
527  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
528  - update elf.h from glibc
529
530* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
531- fix strip -f byte-swapping bug
532
533* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
534- update to 0.107
535  - readelf: improve DWARF output format
536  - elflint: -d option to support checking separate debuginfo files
537  - strip: fix ET_REL debuginfo files (#156341)
538
539* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
540- fix some bugs in new code, reenable make check
541
542* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
543- disable make check for most arches, for now
544
545* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
546- update to 0.106
547
548* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
549- update to 0.104
550
551* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
552- update to 0.103
553
554* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
555- update to 0.101.
556- use %%configure macro to get CFLAGS etc. right
557
558* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
559- upgrade to 0.99.
560
561* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
562- upgrade to 0.97.
563
564* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
565- upgrade to 0.96.
566
567* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
568- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
569  warning
570
571* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
572- rebuilt
573
574* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
575- upgrade to 0.95.
576
577* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
578- rebuilt
579
580* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
581- rebuilt
582
583* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
584- upgrade to 0.94
585
586* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
587- upgrade to 0.93
588
589* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
590- full version
591- macroized spec file for GPL or OSL builds
592- include only libelf under GPL plus wrapper scripts
593
594* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
595- macroized spec file for GPL or OSL builds
596
597* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
598- split elfutils-devel into two packages.
599
600* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
601- include only libelf under GPL plus wrapper scripts
602
603* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
604- readelf, not readline, in %%description (#111214).
605
606* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
607- update to 0.89 (fix eu-strip)
608
609* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
610- update to 0.86 (fix eu-strip on s390x/alpha)
611- libebl is an archive now; remove references to DSO
612
613* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
614- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
615
616* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
617- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
618
619* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
620- upgrade to 0.82 (strip tests fixed on big-endian).
621
622* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
623- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
624
625* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
626- upgrade to 0.80 (debugedit changes for kernel in progress).
627
628* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
629- rebuilt
630
631* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
632- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
633
634* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
635- upgrade to 0.78 (libdwarf bugfix, libdw additions).
636
637* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
638- debuginfo rebuild
639
640* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
641- use the correct way of identifying the section via the sh_info link.
642
643* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
644- update to 0.75 (eu-strip -g fix)
645
646* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
647- update to 0.74 (fix for writing with some non-dirty sections)
648
649* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
650- another -0.73 update (with sparc fixes).
651- do "make check" in %%check, not %%install, section.
652
653* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
654- update to 0.73 (with s390 fixes).
655
656* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
657- rebuilt
658
659* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
660- fix arguments to gelf_getsymshndx and elf_getshstrndx
661- fix other warnings
662- reenable checks on s390x
663
664* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
665- temporarily disable checks on s390x, until someone has
666  time to look at it
667
668* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
669- update to 0.72
670
671* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
672- update to 0.71
673
674* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
675- update to 0.69.
676- add "make check" and segfault avoidance patch.
677- elfutils-libelf needs to run ldconfig.
678
679* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
680- update to 0.68.
681
682* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
683- update to 0.67.
684
685* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
686- update to 0.65.
687
688* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
689- update to 0.64.
690
691* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
692- split packages further into elfutils-libelf
693
694* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
695- update to 0.63.
696
697* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
698- Adjust for dropping libtool
699
700* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
701- update to 0.59
702
703* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
704- update to 0.56
705
706* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
707- update to 0.54
708
709* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
710- update to 0.53
711- drop x86_64 hack, ICE fixed in gcc-3.2-11.
712
713* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
714- get beehive to punch a rhpkg generated package.
715
716* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
717- build in 8.0.1.
718- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
719
720* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
721- Add libelf-devel to conflicts for elfutils-devel
722
723* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
724- Split into runtime and devel package
725
726* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
727- integrate into official sources
728
729* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
730- Swaddle.
Note: See TracBrowser for help on using the repository browser.