source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 3306

Revision 3306, 24.0 KB checked in by daisuke, 13 years ago (diff)

elfutils: update to 0.152

Line 
1%define eu_version 0.152
2%define eu_release 1
3
4Summary: A collection of utilities and DSOs to handle compiled objects
5Name: elfutils
6Version: %{eu_version}
7Release: %{eu_release}%{?_dist_release}
8License: GPLv2 with exceptions
9Group: Development/Tools
10URL: https://fedorahosted.org/elfutils/
11Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
12##VINE##
13Patch10: elfutils-0.131-readelf_c.patch
14
15Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
16Requires: elfutils-libs-%{_arch} = %{version}-%{release}
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19BuildRequires: bison >= 1.875
20BuildRequires: flex >= 2.5.4a
21BuildRequires: bzip2
22BuildRequires: gcc >= 3.4
23# Need <byteswap.h> that gives unsigned bswap_16 etc.
24BuildRequires: glibc-headers >= 2.3.4-11
25
26%define _gnu %{nil}
27%define _program_prefix eu-
28
29%description
30Elfutils is a collection of utilities, including ld (a linker),
31nm (for listing symbols from object files), size (for listing the
32section sizes of an object or archive file), strip (for discarding
33symbols), readelf (to see the raw ELF file structures), and elflint
34(to check for well-formed ELF files).
35
36
37%package libs
38Summary: Libraries to handle compiled objects
39Group: System Environment/Libraries
40Provides: elfutils-libs-%{_arch} = %{version}-%{release}
41Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
42Conflicts: elfutils < %{version}-%{release}
43Conflicts: elfutils > %{version}-%{release}
44Conflicts: elfutils-devel < %{version}-%{release}
45Conflicts: elfutils-devel > %{version}-%{release}
46
47%description libs
48The elfutils-libs package contains libraries which implement DWARF, ELF,
49and machine-specific ELF handling.  These libraries are used by the programs
50in the elfutils package.  The elfutils-devel package enables building
51other programs using these libraries.
52
53
54%package devel
55Summary: Development libraries to handle compiled objects
56Group: Development/Libraries
57Provides: elfutils-devel-%{_arch} = %{version}-%{release}
58Requires: elfutils-libs-%{_arch} = %{version}-%{release}
59Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
60Conflicts: elfutils-libelf-devel < %{version}-%{release}
61Conflicts: elfutils-libelf-devel > %{version}-%{release}
62
63%description devel
64The elfutils-devel package contains the libraries to create
65applications for handling compiled objects.  libebl provides some
66higher-level ELF access functionality.  libdw provides access to
67the DWARF debugging information.  libasm provides a programmable
68assembler interface.
69
70
71%package devel-static
72Summary: Static archives to handle compiled objects
73Group: Development/Libraries
74Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
75Requires: elfutils-devel-%{_arch} = %{version}-%{release}
76Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
77Conflicts: elfutils-libelf-devel < %{version}-%{release}
78Conflicts: elfutils-libelf-devel > %{version}-%{release}
79
80%description devel-static
81The elfutils-devel-static package contains the static archives
82with the code to handle compiled objects.
83
84
85%package libelf
86Summary: Library to read and write ELF files
87Group: System Environment/Libraries
88Provides: libelf = %{version}-%{release}
89Obsoletes: libelf <= 0.8.2-2
90Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
91Conflicts: elfutils < %{version}-%{release}
92Conflicts: elfutils > %{version}-%{release}
93Conflicts: elfutils-libs < %{version}-%{release}
94Conflicts: elfutils-libs > %{version}-%{release}
95Conflicts: elfutils-libelf-devel < %{version}-%{release}
96Conflicts: elfutils-libelf-devel > %{version}-%{release}
97
98%description libelf
99The elfutils-libelf package provides a DSO which allows reading and
100writing ELF files on a high level.  Third party programs depend on
101this package to read internals of ELF files.  The programs of the
102elfutils package use it also to generate new ELF files.
103
104
105%package libelf-devel
106Summary: Development support for libelf
107Group: Development/Libraries
108Provides: libelf-devel = %{version}-%{release}
109Obsoletes: libelf-devel <= 0.8.2-2
110Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
111Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
112Conflicts: libelf-devel < %{version}-%{release}
113
114%description libelf-devel
115The elfutils-libelf-devel package contains the libraries to create
116applications for handling compiled objects.  libelf allows you to
117access the internals of the ELF object file format, so you can see the
118different sections of an ELF file.
119
120
121%package libelf-devel-static
122Summary: Static archive of libelf
123Group: Development/Libraries
124Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
125Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
126
127%description libelf-devel-static
128The elfutils-libelf-static package contains the static archive
129for libelf.
130
131
132%prep
133%setup -q
134
135%patch10 -p0 -b .readelf_c
136
137find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
138
139
140%build
141# Remove -Wall from default flags.  The makefiles enable enough warnings
142# themselves, and they use -Werror.  Appending -Wall defeats the cases where
143# the makefiles disable some specific warnings for specific code.
144RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
145
146%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
147make -s %{?_smp_mflags}
148
149
150%install
151rm -rf ${RPM_BUILD_ROOT}
152make -s install DESTDIR=${RPM_BUILD_ROOT}
153
154chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
155chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
156
157%find_lang %{name}
158
159# XXX Nuke unpackaged files
160{ cd ${RPM_BUILD_ROOT}
161  rm -f .%{_bindir}/eu-ld
162}
163
164
165
166%check
167make -s check
168
169
170%clean
171rm -rf ${RPM_BUILD_ROOT}
172
173
174%post libs -p /sbin/ldconfig
175
176%postun libs -p /sbin/ldconfig
177
178%post libelf -p /sbin/ldconfig
179
180%postun libelf -p /sbin/ldconfig
181
182
183%files -f %{name}.lang
184%defattr(-,root,root)
185%doc README TODO
186%{_bindir}/eu-addr2line
187%{_bindir}/eu-ar
188%{_bindir}/eu-elfcmp
189%{_bindir}/eu-elflint
190%{_bindir}/eu-findtextrel
191%{_bindir}/eu-nm
192%{_bindir}/eu-objdump
193%{_bindir}/eu-ranlib
194%{_bindir}/eu-readelf
195%{_bindir}/eu-size
196%{_bindir}/eu-strings
197%{_bindir}/eu-strip
198#%{_bindir}/eu-ld
199%{_bindir}/eu-unstrip
200%{_bindir}/eu-make-debug-archive
201
202
203%files libs
204%defattr(-,root,root)
205%{_libdir}/libasm-%{version}.so
206%{_libdir}/libasm.so.*
207%{_libdir}/libdw-%{version}.so
208%{_libdir}/libdw.so.*
209%dir %{_libdir}/elfutils
210%{_libdir}/elfutils/lib*.so
211
212
213%files devel
214%defattr(-,root,root)
215%{_includedir}/dwarf.h
216%dir %{_includedir}/elfutils
217%{_includedir}/elfutils/elf-knowledge.h
218%{_includedir}/elfutils/libasm.h
219%{_includedir}/elfutils/libebl.h
220%{_includedir}/elfutils/libdw.h
221%{_includedir}/elfutils/libdwfl.h
222%{_includedir}/elfutils/version.h
223%{_libdir}/libebl.a
224%{_libdir}/libasm.so
225%{_libdir}/libdw.so
226
227
228%files devel-static
229%defattr(-,root,root)
230%{_libdir}/libasm.a
231%{_libdir}/libdw.a
232
233
234%files libelf
235%defattr(-,root,root)
236%{_libdir}/libelf-%{version}.so
237%{_libdir}/libelf.so.*
238
239
240%files libelf-devel
241%defattr(-,root,root)
242%{_includedir}/libelf.h
243%{_includedir}/gelf.h
244%{_includedir}/nlist.h
245%{_libdir}/libelf.so
246
247
248%files libelf-devel-static
249%defattr(-,root,root)
250%{_libdir}/libelf.a
251
252
253%changelog
254* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
255- update to 0.152
256
257* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
258- elfutils-libs: changed Group to System Environment/Libraries
259- elfutils-libelf: changed Group to System Environment/Libraries
260- elfutils-devel: changed Group to Development/Libraries
261- elfutils-devel-static: changed Group to Development/Libraries
262- elfutils-libelf-devel: changed Group to Development/Libraries
263- elfutils-libelf-devel-static: changed Group to Development/Libraries
264
265* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
266- merged with Fedora 9 0.135-1
267
268  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
269  - applied new versioning policy
270  - added elfutils-0.131-readelf_c.patch
271
272  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
273  - new upstream release
274  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
275    - remove Obsoletes: libelf, libelf-devel from elfutils
276    - add Obsoletes: libelf to elfutils-libelf
277    - add Obsoletes: libelf-devel to elfutils-libelf-devel
278
279* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
280- Update to 0.135
281  - libdwfl: bug fixes
282  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
283
284* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
285- Update to 0.134
286  - elflint: backend improvements for sparc, alpha (#204170)
287  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
288- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
289
290* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
291- Update to 0.133
292  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
293  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
294  - libdwfl: bug fixes and optimization in relocation handling
295  - elfcmp: bug fix for non-allocated section handling
296  - ld: implement newer features of binutils linker.
297- Install eu-objdump and libasm, now has limited disassembler support.
298
299* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
300- Update to 0.132
301  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
302  - eu-readelf: Fix handling of ET_REL files in archives.
303  - libcpu: Implement x86 and x86-64 disassembler.
304  - libasm: Add interface for disassembler.
305  - all programs: add debugging of branch prediction.
306  - libelf: new function elf_scnshndx.
307
308* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
309- Update to 0.131
310  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
311           bug fixes for oddly-formatted DWARF
312  - libdwfl: bug fixes in offline archive support, symbol table handling;
313             apply partial relocations for dwfl_module_address_section on ET_REL
314  - libebl: powerpc backend support for Altivec registers
315
316* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
317- Fix ET_REL support.
318- Fix odd indentation in eu-readelf -x output.
319
320* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
321- Update to 0.130
322  - eu-readelf -p option can take an argument like -x for one section
323  - eu-readelf --archive-index (or -c)
324  - eu-readelf -n improved output for core dumps
325  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
326  - eu-elflint: ditto
327  - eu-elflint: stricter checks on debug sections
328  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
329  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
330            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
331  - libebl: backend improvements (#324031)
332  - libdwfl: build_id support, new functions for it
333  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
334  - libdwfl offline archive support, new script eu-make-debug-archive
335
336* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
337- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
338
339* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
340- Update to 0.129
341  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
342  - addr2line: new option --symbols (or -S)
343  - libdw: dwarf_getscopes fixes (#230235)
344  - libdwfl: dwfl_module_addrsym fixes (#249490)
345
346* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
347- Update to 0.128
348  - new program: unstrip
349  - elfcmp: new option --hash-inexact
350- Replace Conflicts: with Provides/Requires using -arch
351
352* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
353- Update to 0.127
354  - libdw: new function dwarf_getsrcdirs
355  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
356             dwfl_module_address_section
357
358* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
359- Update to 0.126
360  - New program eu-ar.
361  - libdw: fix missing dwarf_getelf (#227206)
362  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
363- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
364
365* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
366- Fix overeager warn_unused_result build failures.
367
368* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
369- Update to 0.125
370  - elflint: Compare DT_GNU_HASH tests.
371  - move archives into -static RPMs
372  - libelf, elflint: better support for core file handling
373  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
374- Resolves: RHBZ #220817, RHBZ #213792
375
376* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
377- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
378- Update to 0.124
379  - libebl: fix ia64 reloc support (#206981)
380  - libebl: sparc backend support for return value location
381  - libebl, libdwfl: backend register name support extended with more info
382  - libelf, libdw: bug fixes for unaligned accesses on machines that care
383  - readelf, elflint: trivial bugs fixed
384
385* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
386- Update to 0.123
387  - libebl: Backend build fixes, thanks to Stepan Kasal.
388  - libebl: ia64 backend support for register names, return value location
389  - libdwfl: Handle truncated linux kernel module section names.
390  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
391  - elflint: Fix checks to permit --hash-style=gnu format.
392
393* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
394- Fix warnings in elflint compilation.
395
396* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
397- Update to 0.122
398  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
399  - libebl: add function to test for relative relocation
400  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
401  - elflint, readelf: add support for DT_GNU_HASH
402  - libelf: add elf_gnu_hash
403  - elflint, readelf: add support for 64-bit SysV-style hash tables
404  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
405
406* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
407- Update to 0.121
408  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
409  - make all installed headers usable in C++ code (#193153).
410  - eu-readelf: better output format.
411  - eu-elflint: fix tests of dynamic section content.
412  - libdw, libdwfl: handle files without aranges info.
413
414* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
415- rebuild to pick up -devel deps
416
417* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
418- Update to 0.120
419  - License changed to GPL, with some exceptions for using
420    the libelf, libebl, libdw, and libdwfl library interfaces.
421    Red Hat elfutils is an included package of the Open Invention Network.
422  - dwarf.h updated for DWARF 3.0 final specification.
423  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
424  - libdwfl: New function dwfl_version; fixes for offline.
425
426* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
427- bump again for double-long bug on ppc(64)
428
429* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
430- rebuilt for new gcc4.1 snapshot and glibc changes
431
432* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
433- update to 0.119
434
435* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
436- rebuilt
437
438* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
439- update to 0.118
440  - elflint: more tests.
441  - libdwfl: New function dwfl_module_register_names.
442  - libebl: New backend hook for register names.
443- Make sure -fexceptions is always in CFLAGS.
444
445* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
446- update to 0.117
447  - libdwfl: New function dwfl_module_return_value_location (#166118)
448  - libebl: Backend improvements for several CPUs
449
450* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
451- update to 0.116
452  - libdw fixes, API changes and additions
453  - libdwfl fixes (#169672)
454  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
455
456* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
457- Update requires/conflicts for better biarch update behavior.
458
459* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
460- update to 0.115
461  - New program eu-strings.
462  - libdw: New function dwarf_getscopes_die.
463  - libelf: speed-ups of non-mmap reading.
464  - Implement --enable-gcov option for configure.
465
466* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
467- update to 0.114
468  - new program eu-ranlib
469  - libdw: new calls for inlines
470  - libdwfl: new calls for offline modules
471
472* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
473- update to 0.113
474  - elflint: relax a bit.  Allow version definitions for defined symbols
475    against DSO versions also for symbols in nobits sections.
476    Allow .rodata section to have STRINGS and MERGE flag set.
477  - strip: add some more compatibility with binutils.
478  - libdwfl: bug fixes.
479- Separate libdw et al into elfutils-libs subpackage.
480
481* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
482- update to 0.112
483  - elfcmp: some more relaxation.
484  - elflint: many more tests, especially regarding to symbol versioning.
485  - libelf: Add elfXX_offscn and gelf_offscn.
486  - libasm: asm_begin interface changes.
487  - libebl: Add three new interfaces to directly access machine, class,
488    and data encoding information.
489
490* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
491- update portability patch
492
493* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
494- update to 0.111
495  - libdwfl library now merged into libdw
496
497* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
498- update to 0.110
499
500* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
501- update to 0.109
502  - verify that libebl modules are from the same build
503  - new eu-elflint checks on copy relocations
504  - new program eu-elfcmp
505  - new experimental libdwfl library
506
507* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
508- robustification of eu-strip and eu-readelf
509
510* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
511- more robustification
512
513* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
514- robustification
515
516* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
517- update to 0.108
518  - merge strip fixes
519  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
520  - update elf.h from glibc
521
522* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
523- fix strip -f byte-swapping bug
524
525* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
526- update to 0.107
527  - readelf: improve DWARF output format
528  - elflint: -d option to support checking separate debuginfo files
529  - strip: fix ET_REL debuginfo files (#156341)
530
531* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
532- fix some bugs in new code, reenable make check
533
534* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
535- disable make check for most arches, for now
536
537* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
538- update to 0.106
539
540* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
541- update to 0.104
542
543* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
544- update to 0.103
545
546* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
547- update to 0.101.
548- use %%configure macro to get CFLAGS etc. right
549
550* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
551- upgrade to 0.99.
552
553* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
554- upgrade to 0.97.
555
556* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
557- upgrade to 0.96.
558
559* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
560- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
561  warning
562
563* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
564- rebuilt
565
566* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
567- upgrade to 0.95.
568
569* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
570- rebuilt
571
572* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
573- rebuilt
574
575* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
576- upgrade to 0.94
577
578* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
579- upgrade to 0.93
580
581* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
582- full version
583- macroized spec file for GPL or OSL builds
584- include only libelf under GPL plus wrapper scripts
585
586* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
587- macroized spec file for GPL or OSL builds
588
589* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
590- split elfutils-devel into two packages.
591
592* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
593- include only libelf under GPL plus wrapper scripts
594
595* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
596- readelf, not readline, in %%description (#111214).
597
598* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
599- update to 0.89 (fix eu-strip)
600
601* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
602- update to 0.86 (fix eu-strip on s390x/alpha)
603- libebl is an archive now; remove references to DSO
604
605* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
606- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
607
608* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
609- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
610
611* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
612- upgrade to 0.82 (strip tests fixed on big-endian).
613
614* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
615- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
616
617* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
618- upgrade to 0.80 (debugedit changes for kernel in progress).
619
620* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
621- rebuilt
622
623* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
624- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
625
626* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
627- upgrade to 0.78 (libdwarf bugfix, libdw additions).
628
629* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
630- debuginfo rebuild
631
632* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
633- use the correct way of identifying the section via the sh_info link.
634
635* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
636- update to 0.75 (eu-strip -g fix)
637
638* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
639- update to 0.74 (fix for writing with some non-dirty sections)
640
641* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
642- another -0.73 update (with sparc fixes).
643- do "make check" in %%check, not %%install, section.
644
645* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
646- update to 0.73 (with s390 fixes).
647
648* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
649- rebuilt
650
651* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
652- fix arguments to gelf_getsymshndx and elf_getshstrndx
653- fix other warnings
654- reenable checks on s390x
655
656* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
657- temporarily disable checks on s390x, until someone has
658  time to look at it
659
660* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
661- update to 0.72
662
663* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
664- update to 0.71
665
666* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
667- update to 0.69.
668- add "make check" and segfault avoidance patch.
669- elfutils-libelf needs to run ldconfig.
670
671* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
672- update to 0.68.
673
674* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
675- update to 0.67.
676
677* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
678- update to 0.65.
679
680* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
681- update to 0.64.
682
683* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
684- split packages further into elfutils-libelf
685
686* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
687- update to 0.63.
688
689* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
690- Adjust for dropping libtool
691
692* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
693- update to 0.59
694
695* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
696- update to 0.56
697
698* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
699- update to 0.54
700
701* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
702- update to 0.53
703- drop x86_64 hack, ICE fixed in gcc-3.2-11.
704
705* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
706- get beehive to punch a rhpkg generated package.
707
708* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
709- build in 8.0.1.
710- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
711
712* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
713- Add libelf-devel to conflicts for elfutils-devel
714
715* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
716- Split into runtime and devel package
717
718* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
719- integrate into official sources
720
721* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
722- Swaddle.
Note: See TracBrowser for help on using the repository browser.