source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 12525

Revision 12525, 26.9 KB checked in by tomop, 3 years ago (diff)

updated 10 packages

binutils-2.36.1-1

elfutils-0.183-1

gcc-10.2.1-1

gdb-10.1-1

glibc-2.33-1

isl-0.23-1

libtirpc-1.3.1-1

libtool-2.4.6-7

libxcrypt-4.4.17-1

valgrind-3.16.1-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%global nocheck true
4
5Summary: A collection of utilities and DSOs to handle compiled objects
6Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
7Name: elfutils
8Version:        0.183
9Release:        1%{?_dist_release}
10Group:          programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        GPLv3+ and (GPLv2+ or LGPLv3+)
15URL:            https://sourceware.org/elfutils/
16Source:         https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
17
18Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
19Requires: elfutils-libs-%{_arch} = %{version}-%{release}
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: bison >= 1.875
23BuildRequires: bzip2
24BuildRequires: bzip2-devel
25BuildRequires: flex >= 2.5.4a
26BuildRequires: gcc >= 9.0.0
27BuildRequires: gettext
28BuildRequires: libzstd-devel
29BuildRequires: m4
30BuildRequires: xz-devel
31BuildRequires: zlib-devel
32BuildRequires: zstd
33# Need <byteswap.h> that gives unsigned bswap_16 etc.
34BuildRequires: glibc-headers >= 2.3.4-11
35
36%define _gnu %{nil}
37%define _program_prefix eu-
38
39%description
40Elfutils is a collection of utilities, including ld (a linker),
41nm (for listing symbols from object files), size (for listing the
42section sizes of an object or archive file), strip (for discarding
43symbols), readelf (to see the raw ELF file structures), and elflint
44(to check for well-formed ELF files).
45
46
47%package libs
48Summary: Libraries to handle compiled objects
49Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
50License: GPLv2+ or LGPLv3+
51Group: system
52Provides: elfutils-libs-%{_arch} = %{version}-%{release}
53Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
54Conflicts: elfutils < %{version}-%{release}
55Conflicts: elfutils > %{version}-%{release}
56Conflicts: elfutils-devel < %{version}-%{release}
57Conflicts: elfutils-devel > %{version}-%{release}
58
59%description libs
60The elfutils-libs package contains libraries which implement DWARF, ELF,
61and machine-specific ELF handling.  These libraries are used by the programs
62in the elfutils package.  The elfutils-devel package enables building
63other programs using these libraries.
64
65
66%package devel
67Summary: Development libraries to handle compiled objects
68Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
69License: GPLv2+ or LGPLv3+
70Group: programming
71Provides: elfutils-devel-%{_arch} = %{version}-%{release}
72Requires: elfutils-libs-%{_arch} = %{version}-%{release}
73Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
74Conflicts: elfutils-libelf-devel < %{version}-%{release}
75Conflicts: elfutils-libelf-devel > %{version}-%{release}
76
77%description devel
78The elfutils-devel package contains the libraries to create
79applications for handling compiled objects.  libebl provides some
80higher-level ELF access functionality.  libdw provides access to
81the DWARF debugging information.  libasm provides a programmable
82assembler interface.
83
84
85%package devel-static
86Summary: Static archives to handle compiled objects
87Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
88License: GPLv2+ or LGPLv3+
89Group: programming
90Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
91Requires: elfutils-devel-%{_arch} = %{version}-%{release}
92Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
93Conflicts: elfutils-libelf-devel < %{version}-%{release}
94Conflicts: elfutils-libelf-devel > %{version}-%{release}
95
96%description devel-static
97The elfutils-devel-static package contains the static archives
98with the code to handle compiled objects.
99
100
101%package libelf
102Summary: Library to read and write ELF files
103Summary(ja): ELF ファイルを読み書きするためのライブラリ
104License: GPLv2+ or LGPLv3+
105Group: system
106Provides: libelf = %{version}-%{release}
107Obsoletes: libelf <= 0.8.2-2
108Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
109Conflicts: elfutils < %{version}-%{release}
110Conflicts: elfutils > %{version}-%{release}
111Conflicts: elfutils-libs < %{version}-%{release}
112Conflicts: elfutils-libs > %{version}-%{release}
113Conflicts: elfutils-libelf-devel < %{version}-%{release}
114Conflicts: elfutils-libelf-devel > %{version}-%{release}
115
116%description libelf
117The elfutils-libelf package provides a DSO which allows reading and
118writing ELF files on a high level.  Third party programs depend on
119this package to read internals of ELF files.  The programs of the
120elfutils package use it also to generate new ELF files.
121
122
123%package libelf-devel
124Summary: Development support for libelf
125Summary(ja): libelf の開発用ライブラリ
126License: GPLv2+ or LGPLv3+
127Group: programming
128Provides: libelf-devel = %{version}-%{release}
129Obsoletes: libelf-devel <= 0.8.2-2
130Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
131Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
132Conflicts: libelf-devel < %{version}-%{release}
133
134%description libelf-devel
135The elfutils-libelf-devel package contains the libraries to create
136applications for handling compiled objects.  libelf allows you to
137access the internals of the ELF object file format, so you can see the
138different sections of an ELF file.
139
140
141%package libelf-devel-static
142Summary: Static archive of libelf
143Summary(ja): libelf の静的ライブラリ
144License: GPLv2+ or LGPLv3+
145Group: programming
146Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
147Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
148
149%description libelf-devel-static
150The elfutils-libelf-static package contains the static archive
151for libelf.
152
153
154# compat32
155%package -n compat32-%{name}-libelf
156Summary: Library to read and write ELF files
157Summary(ja): ELF ファイルを読み書きするためのライブラリ
158License: GPLv2+ or LGPLv3+
159Group: system
160Provides: compat32-libelf = %{version}-%{release}
161
162%description -n compat32-%{name}-libelf
163The elfutils-libelf package provides a DSO which allows reading and
164writing ELF files on a high level.  Third party programs depend on
165this package to read internals of ELF files.  The programs of the
166elfutils package use it also to generate new ELF files.
167
168
169%debug_package
170
171
172%prep
173%setup -q
174
175autoreconf -f -v -i
176
177find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
178
179
180%build
181# Remove -Wall from default flags.  The makefiles enable enough warnings
182# themselves, and they use -Werror.  Appending -Wall defeats the cases where
183# the makefiles disable some specific warnings for specific code.
184# But add -Wformat explicitly for use with -Werror=format-security which
185# doesn't work without -Wformat (enabled by -Wall).
186RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
187RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
188
189%configure \
190        CFLAGS="$RPM_OPT_FLAGS -fexceptions" \
191        --disable-debuginfod \
192        --disable-libdebuginfod
193make -s %{?_smp_mflags}
194
195
196%install
197rm -rf ${RPM_BUILD_ROOT}
198make -s install DESTDIR=${RPM_BUILD_ROOT}
199
200chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
201
202%find_lang %{name}
203
204# XXX Nuke unpackaged files
205{ cd ${RPM_BUILD_ROOT}
206  rm -f .%{_bindir}/eu-ld
207}
208
209
210%check
211make -s check || (cat tests/test-suite.log; %{nocheck})
212
213
214%clean
215rm -rf ${RPM_BUILD_ROOT}
216
217
218%post libs -p /sbin/ldconfig
219%postun libs -p /sbin/ldconfig
220
221%post libelf -p /sbin/ldconfig
222%postun libelf -p /sbin/ldconfig
223
224%post -n compat32-%{name}-libelf -p /sbin/ldconfig
225%postun -n compat32-%{name}-libelf -p /sbin/ldconfig
226
227
228%files -f %{name}.lang
229%defattr(-,root,root)
230%doc README TODO
231%{_bindir}/eu-addr2line
232%{_bindir}/eu-ar
233%{_bindir}/eu-elfclassify
234%{_bindir}/eu-elfcmp
235%{_bindir}/eu-elflint
236%{_bindir}/eu-findtextrel
237%{_bindir}/eu-nm
238%{_bindir}/eu-objdump
239%{_bindir}/eu-ranlib
240%{_bindir}/eu-readelf
241%{_bindir}/eu-size
242%{_bindir}/eu-stack
243%{_bindir}/eu-strings
244%{_bindir}/eu-strip
245#%{_bindir}/eu-ld
246%{_bindir}/eu-unstrip
247%{_bindir}/eu-make-debug-archive
248%{_bindir}/eu-elfcompress
249%{_mandir}/man1/eu-*
250
251%files libs
252%defattr(-,root,root)
253%{_libdir}/libasm-%{version}.so
254%{_libdir}/libasm.so.*
255%{_libdir}/libdw-%{version}.so
256%{_libdir}/libdw.so.*
257
258%files devel
259%defattr(-,root,root)
260%{_includedir}/dwarf.h
261%dir %{_includedir}/elfutils
262%{_includedir}/elfutils/elf-knowledge.h
263%{_includedir}/elfutils/known-dwarf.h
264%{_includedir}/elfutils/libasm.h
265%{_includedir}/elfutils/libdw.h
266%{_includedir}/elfutils/libdwelf.h
267%{_includedir}/elfutils/libdwfl.h
268%{_includedir}/elfutils/version.h
269%{_libdir}/libasm.so
270%{_libdir}/libdw.so
271%{_libdir}/pkgconfig/libdw.pc
272
273
274%files devel-static
275%defattr(-,root,root)
276%{_libdir}/libasm.a
277%{_libdir}/libdw.a
278
279
280%files libelf
281%defattr(-,root,root)
282%{_libdir}/libelf-%{version}.so
283%{_libdir}/libelf.so.*
284
285
286%files libelf-devel
287%defattr(-,root,root)
288%{_includedir}/libelf.h
289%{_includedir}/gelf.h
290%{_includedir}/nlist.h
291%{_libdir}/libelf.so
292%{_libdir}/pkgconfig/libelf.pc
293%{_mandir}/man3/elf_*
294
295
296%files libelf-devel-static
297%defattr(-,root,root)
298%{_libdir}/libelf.a
299
300%if %{build_compat32}
301%files -n compat32-%{name}-libelf
302%defattr(-,root,root)
303%{_libdir}/libelf-%{version}.so
304%{_libdir}/libelf.so.*
305%endif
306
307
308%changelog
309* Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-1
310- new upstream release.
311
312* Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.177-1
313- new upstream release.
314
315* Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-3
316- rebuilt
317- 2vl7 was skipped (used for vl6)
318
319* Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
320- updated to 0.170.
321- dropped all patches.
322
323* Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
324- rebuild with gcc-5.4.0
325
326* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
327- create compat32-elfutils-libelf subpackage
328
329* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
330- update to 0.161
331- added Japanese summary
332
333* Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
334- update to 0.157
335
336* Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
337- add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
338
339* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
340- update to 0.152
341
342* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
343- elfutils-libs: changed Group to System Environment/Libraries
344- elfutils-libelf: changed Group to System Environment/Libraries
345- elfutils-devel: changed Group to Development/Libraries
346- elfutils-devel-static: changed Group to Development/Libraries
347- elfutils-libelf-devel: changed Group to Development/Libraries
348- elfutils-libelf-devel-static: changed Group to Development/Libraries
349
350* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
351- merged with Fedora 9 0.135-1
352
353  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
354  - applied new versioning policy
355  - added elfutils-0.131-readelf_c.patch
356
357  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
358  - new upstream release
359  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
360    - remove Obsoletes: libelf, libelf-devel from elfutils
361    - add Obsoletes: libelf to elfutils-libelf
362    - add Obsoletes: libelf-devel to elfutils-libelf-devel
363
364* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
365- Update to 0.135
366  - libdwfl: bug fixes
367  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
368
369* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
370- Update to 0.134
371  - elflint: backend improvements for sparc, alpha (#204170)
372  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
373- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
374
375* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
376- Update to 0.133
377  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
378  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
379  - libdwfl: bug fixes and optimization in relocation handling
380  - elfcmp: bug fix for non-allocated section handling
381  - ld: implement newer features of binutils linker.
382- Install eu-objdump and libasm, now has limited disassembler support.
383
384* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
385- Update to 0.132
386  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
387  - eu-readelf: Fix handling of ET_REL files in archives.
388  - libcpu: Implement x86 and x86-64 disassembler.
389  - libasm: Add interface for disassembler.
390  - all programs: add debugging of branch prediction.
391  - libelf: new function elf_scnshndx.
392
393* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
394- Update to 0.131
395  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
396           bug fixes for oddly-formatted DWARF
397  - libdwfl: bug fixes in offline archive support, symbol table handling;
398             apply partial relocations for dwfl_module_address_section on ET_REL
399  - libebl: powerpc backend support for Altivec registers
400
401* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
402- Fix ET_REL support.
403- Fix odd indentation in eu-readelf -x output.
404
405* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
406- Update to 0.130
407  - eu-readelf -p option can take an argument like -x for one section
408  - eu-readelf --archive-index (or -c)
409  - eu-readelf -n improved output for core dumps
410  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
411  - eu-elflint: ditto
412  - eu-elflint: stricter checks on debug sections
413  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
414  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
415            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
416  - libebl: backend improvements (#324031)
417  - libdwfl: build_id support, new functions for it
418  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
419  - libdwfl offline archive support, new script eu-make-debug-archive
420
421* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
422- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
423
424* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
425- Update to 0.129
426  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
427  - addr2line: new option --symbols (or -S)
428  - libdw: dwarf_getscopes fixes (#230235)
429  - libdwfl: dwfl_module_addrsym fixes (#249490)
430
431* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
432- Update to 0.128
433  - new program: unstrip
434  - elfcmp: new option --hash-inexact
435- Replace Conflicts: with Provides/Requires using -arch
436
437* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
438- Update to 0.127
439  - libdw: new function dwarf_getsrcdirs
440  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
441             dwfl_module_address_section
442
443* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
444- Update to 0.126
445  - New program eu-ar.
446  - libdw: fix missing dwarf_getelf (#227206)
447  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
448- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
449
450* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
451- Fix overeager warn_unused_result build failures.
452
453* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
454- Update to 0.125
455  - elflint: Compare DT_GNU_HASH tests.
456  - move archives into -static RPMs
457  - libelf, elflint: better support for core file handling
458  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
459- Resolves: RHBZ #220817, RHBZ #213792
460
461* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
462- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
463- Update to 0.124
464  - libebl: fix ia64 reloc support (#206981)
465  - libebl: sparc backend support for return value location
466  - libebl, libdwfl: backend register name support extended with more info
467  - libelf, libdw: bug fixes for unaligned accesses on machines that care
468  - readelf, elflint: trivial bugs fixed
469
470* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
471- Update to 0.123
472  - libebl: Backend build fixes, thanks to Stepan Kasal.
473  - libebl: ia64 backend support for register names, return value location
474  - libdwfl: Handle truncated linux kernel module section names.
475  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
476  - elflint: Fix checks to permit --hash-style=gnu format.
477
478* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
479- Fix warnings in elflint compilation.
480
481* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
482- Update to 0.122
483  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
484  - libebl: add function to test for relative relocation
485  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
486  - elflint, readelf: add support for DT_GNU_HASH
487  - libelf: add elf_gnu_hash
488  - elflint, readelf: add support for 64-bit SysV-style hash tables
489  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
490
491* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
492- Update to 0.121
493  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
494  - make all installed headers usable in C++ code (#193153).
495  - eu-readelf: better output format.
496  - eu-elflint: fix tests of dynamic section content.
497  - libdw, libdwfl: handle files without aranges info.
498
499* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
500- rebuild to pick up -devel deps
501
502* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
503- Update to 0.120
504  - License changed to GPL, with some exceptions for using
505    the libelf, libebl, libdw, and libdwfl library interfaces.
506    Red Hat elfutils is an included package of the Open Invention Network.
507  - dwarf.h updated for DWARF 3.0 final specification.
508  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
509  - libdwfl: New function dwfl_version; fixes for offline.
510
511* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
512- bump again for double-long bug on ppc(64)
513
514* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
515- rebuilt for new gcc4.1 snapshot and glibc changes
516
517* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
518- update to 0.119
519
520* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
521- rebuilt
522
523* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
524- update to 0.118
525  - elflint: more tests.
526  - libdwfl: New function dwfl_module_register_names.
527  - libebl: New backend hook for register names.
528- Make sure -fexceptions is always in CFLAGS.
529
530* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
531- update to 0.117
532  - libdwfl: New function dwfl_module_return_value_location (#166118)
533  - libebl: Backend improvements for several CPUs
534
535* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
536- update to 0.116
537  - libdw fixes, API changes and additions
538  - libdwfl fixes (#169672)
539  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
540
541* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
542- Update requires/conflicts for better biarch update behavior.
543
544* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
545- update to 0.115
546  - New program eu-strings.
547  - libdw: New function dwarf_getscopes_die.
548  - libelf: speed-ups of non-mmap reading.
549  - Implement --enable-gcov option for configure.
550
551* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
552- update to 0.114
553  - new program eu-ranlib
554  - libdw: new calls for inlines
555  - libdwfl: new calls for offline modules
556
557* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
558- update to 0.113
559  - elflint: relax a bit.  Allow version definitions for defined symbols
560    against DSO versions also for symbols in nobits sections.
561    Allow .rodata section to have STRINGS and MERGE flag set.
562  - strip: add some more compatibility with binutils.
563  - libdwfl: bug fixes.
564- Separate libdw et al into elfutils-libs subpackage.
565
566* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
567- update to 0.112
568  - elfcmp: some more relaxation.
569  - elflint: many more tests, especially regarding to symbol versioning.
570  - libelf: Add elfXX_offscn and gelf_offscn.
571  - libasm: asm_begin interface changes.
572  - libebl: Add three new interfaces to directly access machine, class,
573    and data encoding information.
574
575* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
576- update portability patch
577
578* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
579- update to 0.111
580  - libdwfl library now merged into libdw
581
582* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
583- update to 0.110
584
585* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
586- update to 0.109
587  - verify that libebl modules are from the same build
588  - new eu-elflint checks on copy relocations
589  - new program eu-elfcmp
590  - new experimental libdwfl library
591
592* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
593- robustification of eu-strip and eu-readelf
594
595* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
596- more robustification
597
598* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
599- robustification
600
601* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
602- update to 0.108
603  - merge strip fixes
604  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
605  - update elf.h from glibc
606
607* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
608- fix strip -f byte-swapping bug
609
610* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
611- update to 0.107
612  - readelf: improve DWARF output format
613  - elflint: -d option to support checking separate debuginfo files
614  - strip: fix ET_REL debuginfo files (#156341)
615
616* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
617- fix some bugs in new code, reenable make check
618
619* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
620- disable make check for most arches, for now
621
622* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
623- update to 0.106
624
625* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
626- update to 0.104
627
628* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
629- update to 0.103
630
631* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
632- update to 0.101.
633- use %%configure macro to get CFLAGS etc. right
634
635* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
636- upgrade to 0.99.
637
638* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
639- upgrade to 0.97.
640
641* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
642- upgrade to 0.96.
643
644* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
645- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
646  warning
647
648* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
649- rebuilt
650
651* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
652- upgrade to 0.95.
653
654* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
655- rebuilt
656
657* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
658- rebuilt
659
660* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
661- upgrade to 0.94
662
663* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
664- upgrade to 0.93
665
666* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
667- full version
668- macroized spec file for GPL or OSL builds
669- include only libelf under GPL plus wrapper scripts
670
671* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
672- macroized spec file for GPL or OSL builds
673
674* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
675- split elfutils-devel into two packages.
676
677* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
678- include only libelf under GPL plus wrapper scripts
679
680* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
681- readelf, not readline, in %%description (#111214).
682
683* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
684- update to 0.89 (fix eu-strip)
685
686* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
687- update to 0.86 (fix eu-strip on s390x/alpha)
688- libebl is an archive now; remove references to DSO
689
690* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
691- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
692
693* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
694- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
695
696* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
697- upgrade to 0.82 (strip tests fixed on big-endian).
698
699* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
700- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
701
702* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
703- upgrade to 0.80 (debugedit changes for kernel in progress).
704
705* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
706- rebuilt
707
708* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
709- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
710
711* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
712- upgrade to 0.78 (libdwarf bugfix, libdw additions).
713
714* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
715- debuginfo rebuild
716
717* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
718- use the correct way of identifying the section via the sh_info link.
719
720* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
721- update to 0.75 (eu-strip -g fix)
722
723* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
724- update to 0.74 (fix for writing with some non-dirty sections)
725
726* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
727- another -0.73 update (with sparc fixes).
728- do "make check" in %%check, not %%install, section.
729
730* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
731- update to 0.73 (with s390 fixes).
732
733* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
734- rebuilt
735
736* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
737- fix arguments to gelf_getsymshndx and elf_getshstrndx
738- fix other warnings
739- reenable checks on s390x
740
741* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
742- temporarily disable checks on s390x, until someone has
743  time to look at it
744
745* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
746- update to 0.72
747
748* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
749- update to 0.71
750
751* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
752- update to 0.69.
753- add "make check" and segfault avoidance patch.
754- elfutils-libelf needs to run ldconfig.
755
756* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
757- update to 0.68.
758
759* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
760- update to 0.67.
761
762* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
763- update to 0.65.
764
765* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
766- update to 0.64.
767
768* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
769- split packages further into elfutils-libelf
770
771* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
772- update to 0.63.
773
774* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
775- Adjust for dropping libtool
776
777* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
778- update to 0.59
779
780* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
781- update to 0.56
782
783* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
784- update to 0.54
785
786* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
787- update to 0.53
788- drop x86_64 hack, ICE fixed in gcc-3.2-11.
789
790* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
791- get beehive to punch a rhpkg generated package.
792
793* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
794- build in 8.0.1.
795- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
796
797* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
798- Add libelf-devel to conflicts for elfutils-devel
799
800* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
801- Split into runtime and devel package
802
803* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
804- integrate into official sources
805
806* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
807- Swaddle.
Note: See TracBrowser for help on using the repository browser.