source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 521

Revision 521, 23.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define eu_version 0.135
2%define eu_release 2
3
4Summary: A collection of utilities and DSOs to handle compiled objects
5Name: elfutils
6Version: %{eu_version}
7Release: %{eu_release}%{?_dist_release}
8License: GPLv2 with exceptions
9Group: Development/Tools
10URL: https://fedorahosted.org/elfutils/
11Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.gz
12Patch1: elfutils-portability.patch
13Patch2: elfutils-robustify.patch
14##VINE##
15Patch10: elfutils-0.131-readelf_c.patch
16
17Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
18Requires: elfutils-libs-%{_arch} = %{version}-%{release}
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21BuildRequires: bison >= 1.875
22BuildRequires: flex >= 2.5.4a
23BuildRequires: bzip2
24BuildRequires: gcc >= 3.4
25# Need <byteswap.h> that gives unsigned bswap_16 etc.
26BuildRequires: glibc-headers >= 2.3.4-11
27
28%define _gnu %{nil}
29%define _program_prefix eu-
30
31%description
32Elfutils is a collection of utilities, including ld (a linker),
33nm (for listing symbols from object files), size (for listing the
34section sizes of an object or archive file), strip (for discarding
35symbols), readelf (to see the raw ELF file structures), and elflint
36(to check for well-formed ELF files).
37
38
39%package libs
40Summary: Libraries to handle compiled objects
41Group: System Environment/Libraries
42Provides: elfutils-libs-%{_arch} = %{version}-%{release}
43Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
44Conflicts: elfutils < %{version}-%{release}
45Conflicts: elfutils > %{version}-%{release}
46Conflicts: elfutils-devel < %{version}-%{release}
47Conflicts: elfutils-devel > %{version}-%{release}
48
49%description libs
50The elfutils-libs package contains libraries which implement DWARF, ELF,
51and machine-specific ELF handling.  These libraries are used by the programs
52in the elfutils package.  The elfutils-devel package enables building
53other programs using these libraries.
54
55
56%package devel
57Summary: Development libraries to handle compiled objects
58Group: Development/Libraries
59Provides: elfutils-devel-%{_arch} = %{version}-%{release}
60Requires: elfutils-libs-%{_arch} = %{version}-%{release}
61Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
62Conflicts: elfutils-libelf-devel < %{version}-%{release}
63Conflicts: elfutils-libelf-devel > %{version}-%{release}
64
65%description devel
66The elfutils-devel package contains the libraries to create
67applications for handling compiled objects.  libebl provides some
68higher-level ELF access functionality.  libdw provides access to
69the DWARF debugging information.  libasm provides a programmable
70assembler interface.
71
72
73%package devel-static
74Summary: Static archives to handle compiled objects
75Group: Development/Libraries
76Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
77Requires: elfutils-devel-%{_arch} = %{version}-%{release}
78Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
79Conflicts: elfutils-libelf-devel < %{version}-%{release}
80Conflicts: elfutils-libelf-devel > %{version}-%{release}
81
82%description devel-static
83The elfutils-devel-static package contains the static archives
84with the code to handle compiled objects.
85
86
87%package libelf
88Summary: Library to read and write ELF files
89Group: System Environment/Libraries
90Provides: libelf = %{version}-%{release}
91Obsoletes: libelf <= 0.8.2-2
92Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
93Conflicts: elfutils < %{version}-%{release}
94Conflicts: elfutils > %{version}-%{release}
95Conflicts: elfutils-libs < %{version}-%{release}
96Conflicts: elfutils-libs > %{version}-%{release}
97Conflicts: elfutils-libelf-devel < %{version}-%{release}
98Conflicts: elfutils-libelf-devel > %{version}-%{release}
99
100%description libelf
101The elfutils-libelf package provides a DSO which allows reading and
102writing ELF files on a high level.  Third party programs depend on
103this package to read internals of ELF files.  The programs of the
104elfutils package use it also to generate new ELF files.
105
106
107%package libelf-devel
108Summary: Development support for libelf
109Group: Development/Libraries
110Provides: libelf-devel = %{version}-%{release}
111Obsoletes: libelf-devel <= 0.8.2-2
112Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
113Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
114Conflicts: libelf-devel < %{version}-%{release}
115
116%description libelf-devel
117The elfutils-libelf-devel package contains the libraries to create
118applications for handling compiled objects.  libelf allows you to
119access the internals of the ELF object file format, so you can see the
120different sections of an ELF file.
121
122
123%package libelf-devel-static
124Summary: Static archive of libelf
125Group: Development/Libraries
126Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
127Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
128
129%description libelf-devel-static
130The elfutils-libelf-static package contains the static archive
131for libelf.
132
133
134%prep
135%setup -q
136
137%patch2 -p1 -b .robustify
138
139%patch10 -p0 -b .readelf_c
140
141find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
142
143
144%build
145# Remove -Wall from default flags.  The makefiles enable enough warnings
146# themselves, and they use -Werror.  Appending -Wall defeats the cases where
147# the makefiles disable some specific warnings for specific code.
148RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
149
150%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
151make -s %{?_smp_mflags}
152
153
154%install
155rm -rf ${RPM_BUILD_ROOT}
156make -s install DESTDIR=${RPM_BUILD_ROOT}
157
158chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
159chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
160
161# XXX Nuke unpackaged files
162{ cd ${RPM_BUILD_ROOT}
163  rm -f .%{_bindir}/eu-ld
164}
165
166
167%check
168make -s check
169
170
171%clean
172rm -rf ${RPM_BUILD_ROOT}
173
174
175%post libs -p /sbin/ldconfig
176
177%postun libs -p /sbin/ldconfig
178
179%post libelf -p /sbin/ldconfig
180
181%postun libelf -p /sbin/ldconfig
182
183
184%files
185%defattr(-,root,root)
186%doc README TODO
187%{_bindir}/eu-addr2line
188%{_bindir}/eu-ar
189%{_bindir}/eu-elfcmp
190%{_bindir}/eu-elflint
191%{_bindir}/eu-findtextrel
192%{_bindir}/eu-nm
193%{_bindir}/eu-objdump
194%{_bindir}/eu-ranlib
195%{_bindir}/eu-readelf
196%{_bindir}/eu-size
197%{_bindir}/eu-strings
198%{_bindir}/eu-strip
199#%{_bindir}/eu-ld
200%{_bindir}/eu-unstrip
201%{_bindir}/eu-make-debug-archive
202
203
204%files libs
205%defattr(-,root,root)
206%{_libdir}/libasm-%{version}.so
207%{_libdir}/libasm.so.*
208%{_libdir}/libdw-%{version}.so
209%{_libdir}/libdw.so.*
210%dir %{_libdir}/elfutils
211%{_libdir}/elfutils/lib*.so
212
213
214%files devel
215%defattr(-,root,root)
216%{_includedir}/dwarf.h
217%dir %{_includedir}/elfutils
218%{_includedir}/elfutils/elf-knowledge.h
219%{_includedir}/elfutils/libasm.h
220%{_includedir}/elfutils/libebl.h
221%{_includedir}/elfutils/libdw.h
222%{_includedir}/elfutils/libdwfl.h
223%{_libdir}/libebl.a
224%{_libdir}/libasm.so
225%{_libdir}/libdw.so
226
227
228%files devel-static
229%defattr(-,root,root)
230%{_libdir}/libasm.a
231%{_libdir}/libdw.a
232
233
234%files libelf
235%defattr(-,root,root)
236%{_libdir}/libelf-%{version}.so
237%{_libdir}/libelf.so.*
238
239
240%files libelf-devel
241%defattr(-,root,root)
242%{_includedir}/libelf.h
243%{_includedir}/gelf.h
244%{_includedir}/nlist.h
245%{_libdir}/libelf.so
246
247
248%files libelf-devel-static
249%defattr(-,root,root)
250%{_libdir}/libelf.a
251
252
253%changelog
254* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
255- elfutils-libs: changed Group to System Environment/Libraries
256- elfutils-libelf: changed Group to System Environment/Libraries
257- elfutils-devel: changed Group to Development/Libraries
258- elfutils-devel-static: changed Group to Development/Libraries
259- elfutils-libelf-devel: changed Group to Development/Libraries
260- elfutils-libelf-devel-static: changed Group to Development/Libraries
261
262* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
263- merged with Fedora 9 0.135-1
264
265  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
266  - applied new versioning policy
267  - added elfutils-0.131-readelf_c.patch
268
269  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
270  - new upstream release
271  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
272    - remove Obsoletes: libelf, libelf-devel from elfutils
273    - add Obsoletes: libelf to elfutils-libelf
274    - add Obsoletes: libelf-devel to elfutils-libelf-devel
275
276* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
277- Update to 0.135
278  - libdwfl: bug fixes
279  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
280
281* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
282- Update to 0.134
283  - elflint: backend improvements for sparc, alpha (#204170)
284  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
285- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
286
287* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
288- Update to 0.133
289  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
290  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
291  - libdwfl: bug fixes and optimization in relocation handling
292  - elfcmp: bug fix for non-allocated section handling
293  - ld: implement newer features of binutils linker.
294- Install eu-objdump and libasm, now has limited disassembler support.
295
296* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
297- Update to 0.132
298  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
299  - eu-readelf: Fix handling of ET_REL files in archives.
300  - libcpu: Implement x86 and x86-64 disassembler.
301  - libasm: Add interface for disassembler.
302  - all programs: add debugging of branch prediction.
303  - libelf: new function elf_scnshndx.
304
305* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
306- Update to 0.131
307  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
308           bug fixes for oddly-formatted DWARF
309  - libdwfl: bug fixes in offline archive support, symbol table handling;
310             apply partial relocations for dwfl_module_address_section on ET_REL
311  - libebl: powerpc backend support for Altivec registers
312
313* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
314- Fix ET_REL support.
315- Fix odd indentation in eu-readelf -x output.
316
317* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
318- Update to 0.130
319  - eu-readelf -p option can take an argument like -x for one section
320  - eu-readelf --archive-index (or -c)
321  - eu-readelf -n improved output for core dumps
322  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
323  - eu-elflint: ditto
324  - eu-elflint: stricter checks on debug sections
325  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
326  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
327            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
328  - libebl: backend improvements (#324031)
329  - libdwfl: build_id support, new functions for it
330  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
331  - libdwfl offline archive support, new script eu-make-debug-archive
332
333* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
334- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
335
336* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
337- Update to 0.129
338  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
339  - addr2line: new option --symbols (or -S)
340  - libdw: dwarf_getscopes fixes (#230235)
341  - libdwfl: dwfl_module_addrsym fixes (#249490)
342
343* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
344- Update to 0.128
345  - new program: unstrip
346  - elfcmp: new option --hash-inexact
347- Replace Conflicts: with Provides/Requires using -arch
348
349* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
350- Update to 0.127
351  - libdw: new function dwarf_getsrcdirs
352  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
353             dwfl_module_address_section
354
355* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
356- Update to 0.126
357  - New program eu-ar.
358  - libdw: fix missing dwarf_getelf (#227206)
359  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
360- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
361
362* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
363- Fix overeager warn_unused_result build failures.
364
365* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
366- Update to 0.125
367  - elflint: Compare DT_GNU_HASH tests.
368  - move archives into -static RPMs
369  - libelf, elflint: better support for core file handling
370  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
371- Resolves: RHBZ #220817, RHBZ #213792
372
373* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
374- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
375- Update to 0.124
376  - libebl: fix ia64 reloc support (#206981)
377  - libebl: sparc backend support for return value location
378  - libebl, libdwfl: backend register name support extended with more info
379  - libelf, libdw: bug fixes for unaligned accesses on machines that care
380  - readelf, elflint: trivial bugs fixed
381
382* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
383- Update to 0.123
384  - libebl: Backend build fixes, thanks to Stepan Kasal.
385  - libebl: ia64 backend support for register names, return value location
386  - libdwfl: Handle truncated linux kernel module section names.
387  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
388  - elflint: Fix checks to permit --hash-style=gnu format.
389
390* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
391- Fix warnings in elflint compilation.
392
393* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
394- Update to 0.122
395  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
396  - libebl: add function to test for relative relocation
397  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
398  - elflint, readelf: add support for DT_GNU_HASH
399  - libelf: add elf_gnu_hash
400  - elflint, readelf: add support for 64-bit SysV-style hash tables
401  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
402
403* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
404- Update to 0.121
405  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
406  - make all installed headers usable in C++ code (#193153).
407  - eu-readelf: better output format.
408  - eu-elflint: fix tests of dynamic section content.
409  - libdw, libdwfl: handle files without aranges info.
410
411* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
412- rebuild to pick up -devel deps
413
414* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
415- Update to 0.120
416  - License changed to GPL, with some exceptions for using
417    the libelf, libebl, libdw, and libdwfl library interfaces.
418    Red Hat elfutils is an included package of the Open Invention Network.
419  - dwarf.h updated for DWARF 3.0 final specification.
420  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
421  - libdwfl: New function dwfl_version; fixes for offline.
422
423* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
424- bump again for double-long bug on ppc(64)
425
426* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
427- rebuilt for new gcc4.1 snapshot and glibc changes
428
429* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
430- update to 0.119
431
432* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
433- rebuilt
434
435* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
436- update to 0.118
437  - elflint: more tests.
438  - libdwfl: New function dwfl_module_register_names.
439  - libebl: New backend hook for register names.
440- Make sure -fexceptions is always in CFLAGS.
441
442* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
443- update to 0.117
444  - libdwfl: New function dwfl_module_return_value_location (#166118)
445  - libebl: Backend improvements for several CPUs
446
447* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
448- update to 0.116
449  - libdw fixes, API changes and additions
450  - libdwfl fixes (#169672)
451  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
452
453* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
454- Update requires/conflicts for better biarch update behavior.
455
456* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
457- update to 0.115
458  - New program eu-strings.
459  - libdw: New function dwarf_getscopes_die.
460  - libelf: speed-ups of non-mmap reading.
461  - Implement --enable-gcov option for configure.
462
463* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
464- update to 0.114
465  - new program eu-ranlib
466  - libdw: new calls for inlines
467  - libdwfl: new calls for offline modules
468
469* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
470- update to 0.113
471  - elflint: relax a bit.  Allow version definitions for defined symbols
472    against DSO versions also for symbols in nobits sections.
473    Allow .rodata section to have STRINGS and MERGE flag set.
474  - strip: add some more compatibility with binutils.
475  - libdwfl: bug fixes.
476- Separate libdw et al into elfutils-libs subpackage.
477
478* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
479- update to 0.112
480  - elfcmp: some more relaxation.
481  - elflint: many more tests, especially regarding to symbol versioning.
482  - libelf: Add elfXX_offscn and gelf_offscn.
483  - libasm: asm_begin interface changes.
484  - libebl: Add three new interfaces to directly access machine, class,
485    and data encoding information.
486
487* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
488- update portability patch
489
490* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
491- update to 0.111
492  - libdwfl library now merged into libdw
493
494* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
495- update to 0.110
496
497* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
498- update to 0.109
499  - verify that libebl modules are from the same build
500  - new eu-elflint checks on copy relocations
501  - new program eu-elfcmp
502  - new experimental libdwfl library
503
504* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
505- robustification of eu-strip and eu-readelf
506
507* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
508- more robustification
509
510* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
511- robustification
512
513* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
514- update to 0.108
515  - merge strip fixes
516  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
517  - update elf.h from glibc
518
519* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
520- fix strip -f byte-swapping bug
521
522* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
523- update to 0.107
524  - readelf: improve DWARF output format
525  - elflint: -d option to support checking separate debuginfo files
526  - strip: fix ET_REL debuginfo files (#156341)
527
528* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
529- fix some bugs in new code, reenable make check
530
531* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
532- disable make check for most arches, for now
533
534* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
535- update to 0.106
536
537* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
538- update to 0.104
539
540* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
541- update to 0.103
542
543* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
544- update to 0.101.
545- use %%configure macro to get CFLAGS etc. right
546
547* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
548- upgrade to 0.99.
549
550* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
551- upgrade to 0.97.
552
553* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
554- upgrade to 0.96.
555
556* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
557- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
558  warning
559
560* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
561- rebuilt
562
563* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
564- upgrade to 0.95.
565
566* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
567- rebuilt
568
569* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
570- rebuilt
571
572* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
573- upgrade to 0.94
574
575* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
576- upgrade to 0.93
577
578* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
579- full version
580- macroized spec file for GPL or OSL builds
581- include only libelf under GPL plus wrapper scripts
582
583* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
584- macroized spec file for GPL or OSL builds
585
586* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
587- split elfutils-devel into two packages.
588
589* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
590- include only libelf under GPL plus wrapper scripts
591
592* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
593- readelf, not readline, in %%description (#111214).
594
595* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
596- update to 0.89 (fix eu-strip)
597
598* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
599- update to 0.86 (fix eu-strip on s390x/alpha)
600- libebl is an archive now; remove references to DSO
601
602* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
603- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
604
605* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
606- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
607
608* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
609- upgrade to 0.82 (strip tests fixed on big-endian).
610
611* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
612- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
613
614* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
615- upgrade to 0.80 (debugedit changes for kernel in progress).
616
617* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
618- rebuilt
619
620* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
621- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
622
623* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
624- upgrade to 0.78 (libdwarf bugfix, libdw additions).
625
626* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
627- debuginfo rebuild
628
629* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
630- use the correct way of identifying the section via the sh_info link.
631
632* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
633- update to 0.75 (eu-strip -g fix)
634
635* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
636- update to 0.74 (fix for writing with some non-dirty sections)
637
638* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
639- another -0.73 update (with sparc fixes).
640- do "make check" in %%check, not %%install, section.
641
642* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
643- update to 0.73 (with s390 fixes).
644
645* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
646- rebuilt
647
648* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
649- fix arguments to gelf_getsymshndx and elf_getshstrndx
650- fix other warnings
651- reenable checks on s390x
652
653* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
654- temporarily disable checks on s390x, until someone has
655  time to look at it
656
657* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
658- update to 0.72
659
660* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
661- update to 0.71
662
663* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
664- update to 0.69.
665- add "make check" and segfault avoidance patch.
666- elfutils-libelf needs to run ldconfig.
667
668* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
669- update to 0.68.
670
671* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
672- update to 0.67.
673
674* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
675- update to 0.65.
676
677* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
678- update to 0.64.
679
680* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
681- split packages further into elfutils-libelf
682
683* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
684- update to 0.63.
685
686* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
687- Adjust for dropping libtool
688
689* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
690- update to 0.59
691
692* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
693- update to 0.56
694
695* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
696- update to 0.54
697
698* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
699- update to 0.53
700- drop x86_64 hack, ICE fixed in gcc-3.2-11.
701
702* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
703- get beehive to punch a rhpkg generated package.
704
705* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
706- build in 8.0.1.
707- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
708
709* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
710- Add libelf-devel to conflicts for elfutils-devel
711
712* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
713- Split into runtime and devel package
714
715* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
716- integrate into official sources
717
718* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
719- Swaddle.
Note: See TracBrowser for help on using the repository browser.